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1 RedPAD 使用手册 

1.1 RedPAD 设计界面 

打开软件 Redpad，进入 PadDesigner 设计界面。 
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1.2 焊盘参数设置介绍 

Units 区域用以指定焊盘的尺寸单位和精度。 

Padstack layers: Single layer mode (在创建表贴焊盘时需要勾选此项；而在

创建通孔焊盘时则不需要勾选)。 

Start Layer/End Layer: 分别表示 TOP 层及 BOTTOM 层的焊盘； 

Internal Layer: 表示多层板内层的焊盘（设计通孔时需要设置该项）； 

Soldrmask_top/soldermask_bottom: 表示阻焊的大小，即绿油开窗的大小，

有阻焊的区域将不覆盖绿油。 

Pastemask_top/pasemask_bottom: 表示表贴器件焊盘回流焊刷锡膏时，钢

网开窗的大小。 

ACT Pad、Thermal Relief、Anti Pad 三个区域用以设置相关 Pad 的详细参

数: 

Act Pad: 常规焊盘。 

Thermal Relief : 热风盘（也叫花焊盘），仅在负片光绘中有效；用于描述负

片中焊盘与旁边同名网络敷铜的连接方式。 

Anti Pad : 反焊盘（也叫隔离焊盘），默认仅在负片光绘中有效；用于描述

负片中焊盘与旁边不同网络敷铜之间的避让间距。 

Geometry:选择焊盘的形状（Null: 空，Circle:圆形，Square:正方形，Oblong: 

椭圆形，Rectangle: 矩形，Oceagon:八角形，Shape:Copper Sym，） 

Shape: 选择 Copper Sym（建不规则焊盘才需要选择，需先建一个 Copper 

Sym，然后将它调入） 

Flash: 选择 Flash Sym（需建一个 Flash Sym，是在建通孔焊盘才需要选择，

表贴的不用） 

Width:宽度，Height:高度 
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Drill/Slot hole:在 Hole Type 下拉框中可以选择钻孔的形状类型，有如下 3

种选择。 

Circle Drill: 圆形钻孔 

Oval Slot : 椭圆形钻孔 

Rectangle Slot : 矩形钻孔 

在 Plating 下拉菜单中可以选择钻孔的电镀类型，有如下 2 种选择。 

Plated : 金属化孔，有电气连接关系的元件引脚焊盘需要选择 Plated。 

Non-Plated: 非金属化孔，元件的安装孔或者定位孔需要选择 Non-Plated 

Drill diameter:孔的直径 

Views 窗口可以预览焊盘 
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2 创建表贴器件封装 

2.1 DIE 封装 

1）用 EXCE 建封 DIE，表格需要下图的规范， 

Footprint Name:输入封装名 

Bump size X: 

Bump size Y: 

Padstack:焊盘名 

Pin Number:从第 10 行开始 

Padstack:焊盘名 

X Coord,Y Coord:X 和 Y 坐标 

Rotation:焊盘角度 
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2）打开软件 RedPKG,进入 PKG 设计界面 

 

 

3）点击菜单 File -> New ，弹出对话窗口，File Name 输入新建的封装名称

“DIE1”，Mode 选择“editfootprint”，点击 Browse 可以选择存盘路径。最后

点击“OK”。 

 

 

4）点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中,Design

中选择操作单位。 
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5）点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 Library 

设定库路径：点击 Footprint 后方...图标，跳出对话框，选择 Browse,选择需

要的路径。 

设定焊盘的路径：点击 Footprint Pad 后方...图标，跳出对话框，选择 Browse,

选择需要的路径 

 

 

6）点击 Tools->Grid 

Value(输入需要的格点大小）， 

Type（格点类型）：Dots（点状网格），off（隐藏网格），Lines（线型网格） 

 

设置层叠，点击 Modules->LayerManager,或点击图标 ,弹出对话框： 

在 Layer 属性 TOP 栏右键，选择 Add Layer Above，在 TOP 层增加 Layer 

Name:DIE 等 DIE 层，Type 设置为 DIE。 
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7）点击 Draw->Footprintpad 

在右侧 Selection 面板中 Pad 栏选择需要的 PAD:P62X44-die1 

 

8）在右侧 Selection 面板中 Pad 栏选择,点击 Import Excel 选择 Excel 文件所

在的路径 
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选择 Excel 文件所在的路径 

 

9）DIE1 的封装 Pad 就放置出来了 

 

10）添加器件 Assembly Outline 

点击图标 Line 或 Draw->Line,选择层面 Layers/Assembly_Top,选择角度 90

度，选择线宽 0.01mm，点击到 PKG 里面开始绘制，完成后单击右键选择 Done，

至此绘制 Assembly 外形完成 
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11）添加器件 Silkscreen Outline 

点击图标 Line 或 Draw->Line,选择层面 Layers/Silkscreen_Top,选择角度 90

度，选择线宽 0.01mm，点击到 PKG 里面开始绘制，完成后单击右键选择 Done，

至此绘制 Silkscreen 外形完成。 

 

12）添加 Refdes 标签 

点击 Draw->Text 或点击 图标，弹出 Text 面板 
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Size(选择字体的大小）， 

Font（选择字体的类型）， 

选择层面 Ref_Des/Assembly_top（装配层）,Ref_Des/Silkscreen_top（丝印

层）输入需要的文字，点击到器件中心 

        

 

Notes：放置的“REF#”分别是装配层及丝印层的器件位号占位标识符，当在

PKG 中导入网表或 SIP Excel 数据后，占位符将被实际器件位号所替代。 

13） 点击菜单 File -> Save 进行保存。则在相应路径中生成一个 DIE1.redpic

文件及一个 DIE1.redfp 文件。 

 

2.2  BGA 封装 

1）点击 Draw -> Footprintpad 

在右侧 Selection 面板中 Pad 栏选择需要的 PAD:BGAPAD_470 
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PAD#输入：A1 

Quantity  X 输入：14    Y 输入：1 

Space  X 输入：800    Y 输入：800 

Order  X 选择 Left 

Place Pos: 5200  -5200 

点击 Create 图标 

 

 

这 样 14 个 Pad 就 放 置 出 来 了 ， 后 面 依 次 从

B1/C1/D1/E1/F1/G1/H1/J1/K1/L1/M1/N1/P1 开始，每行分别放置 14 个 Pad。放置

完毕后，右键选择 Done,结束 Pad 的放置。 
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2）删除不需要的 Pad 
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3）添加器件 Assembly Outline 

点击图标Line或Draw->Line,选择层面Layers/Assembly_Top,选择角度90度，

选择线宽 100um，点击到 PKG 里面开始绘制，完成后单击右键选择 Done，至此

绘制 Assembly 外形完成 

 

 

4）添加器件 Silkscreen Outline 

点击图标 Line 或 Draw->Line,选择层面 Layers/Silkscreen_Top,选择角度 90

度，选择线宽 100um，点击到 PKG 里面开始绘制，完成后单击右键选择 Done，

至此绘制 Silkscreen 外形完成。 

 

 

5）添加 Refdes 标签 

点击 Draw->Text 或点击 图标，弹出 Text 面板 
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Size(选择字体的大小） 

Font（选择字体的类型） 

选择层面 Ref_Des/Assembly_top（装配层）,Ref_Des/Silkscreen_top（丝印层）

输入需要的文字，点击到器件中心。 

   

 

Notes：放置的“REF#”分别是装配层及丝印层的器件位号占位标识符，当在

PKG中导入网表或 SIP Excel数据后，占位符将被实际器件位号所替代。 

 

 

6）点击菜单 File -> Save 进行保存。则在相应路径中生成一个

BGA14x14.redpic 文件及一个 BGA14x14.redfp 文件。 
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3 设计参数设定 

3.1 新建 PKG 

打开软件 RedPKG,进入 PKG 设计界面 

 

在 Redpkg 窗口中，点击菜单 File -> New，File Name 输入新建的 PKG 名称

“WB-DDR-netlist-DEMO”，点击Browse 可以选择存盘路径。Mode 选择“Editpkg”，

最后点击“OK”，确认创建 PKG。 

 

3.2 设置网格单位与网格距离 

点击菜单 File ->settings 在弹出的“Design Parameter”窗口中，Design 中选

择操作单位。 

.

 



0 3 设计参数设定 

16 

 

点击 Tools->Grid->Value(输入需要的格点大小），type（格点类型）: Dots（点

状网格），off（隐藏网格），Lines（线型网格）。 

 

     

Dots（点状网格）         Lines（线的形态）        off（隐藏网格） 

3.3 设定库路径 

点击菜单 File ->settings 在弹出的“Design Parameter ”窗口中，点击 Library。 

设定库路径: 点击 Footprint 后方...图标，跳出对话框，选择 Browse，选择需

要的路径。 

设定焊盘的路径: 点击 Footprint Pad 后方...图标，跳出对话框，选择 Browse，

选择需要的路径。 
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Delete: 可以将之前设定的路径删除 

Up: 多路径时可以将重要的路径点击后选择 Up，选择的路径就会上升一位 

Dow: 多路径时可以将路径点击后选择 Dow，选择的路径就会下降一位 

软件调取库的时候，路径比较多的时候，会根据从上到下的优先顺序来调取。 

 

3.4 自动保存设置 

点击菜单 File ->Settings 在弹出的“Design Parameter”窗口中，点击 Autosave，

Save interval 输入需要的时间。 
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3.5 显示设置 

点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 Display。 

Display Mode（显示设置）:勾选需要的选项 

Filled Pad: 焊盘填充（勾选后焊盘会显示实心，不勾选焊盘显示空心） 

Filled Track: 走线填充（勾选后走线会显示实心，不勾选走线显示空心） 

Filled Copper: 铜皮填充（勾选后走线会铜皮实心，不勾选铜皮显示空心） 

 

Net Name（网络名显示）: 勾选需要的选项 

Visibility(可见度） 
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3.6 主题设置 

点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 Theme,选择

喜欢的颜色主题 

 

 

3.7 语言设置 

点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 Language,选

择需要的语言 
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3.8 快捷键设定 

点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 Shortcuts,设

定快捷键 
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3.9 DRC 大小设置 

点击菜单 File ->Settings 在弹出的“Design Parameter ”窗口中，点击 DRC,设

定大小 

 

 

4  设置叠层 

4.1 点击 Modules->LayerManager,或点击图标 ,弹出对话框： 
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4.2 在 Layer 属性 TOP 栏右键，选择 Add Layer Above 

 

4.3 在 TOP 层上分别依次增加 Layer Name:DIE1,DIE2,DIE3,DIE4 等 DIE 层，

Type 设置为 DIE。DIE 层叠的可根据实际的工程项目需求设置。 

 

4.4 点击 OK 图标，保存增加的 DIE 层参数。 
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5  导入 SIP 和 Netlist 

5.1 导入 SIP 

5.1.1 准备 SIP 文件，SIP 文件规范如下图, 

     表格第一页：BGA 的网络列表 

Footprint Name:输入封装名 

RefDes:输入位号 

Ball Size X: BGA X 向尺寸 

Ball Size Y: BGA Y 向尺寸 

Ball Count:球的数量,可以不填写 

Ball Pitch:球的尺寸 

Padstack:焊盘名字 

Coordinate:坐标 

Pin Number:输入 PIN Number 

Padstack:输入每一个焊盘的焊盘名 

X Coord:焊盘的 X 坐标 

Y Coord:焊盘的 Y 坐标 

Rotation:焊盘的旋转角度 

Net Name:焊盘连接的信号名 

Pin Use:Pin 的类型 

Voltage:电压 
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表格第二页：为 DIE 的网络列表 

Footprint Name:输入 DIE 的封装名 

RefDes:输入位号 

Bump Size X: DIE X 向尺寸 

Bump Size Y: DIE Y 向尺寸 

Bump Count:DIE 的数量,可以不填写 

Bump Pitch:DIE 的尺寸 

Padstack:焊盘名字 

Coordinate:坐标 

Pin Number:输入 PIN Number 

Padstack:输入每一个焊盘的焊盘名 

X Coord:焊盘的 X 坐标 

Y Coord:焊盘的 Y 坐标 

Rotation:焊盘的旋转角度 

Net Name:焊盘连接的信号名 
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Pin Use:Pin 的类型 

Voltage:电压 

 

 

 

两个 DIE 需要在表格后方点击+，命名为 Bump2 Net List,格式与 Bump1 的格式

一样 
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5.1.2 在新建的 RedPKG里,点击 File->Import->SIP。 

 

5.1.3 弹出 ImportSIP 对话框，已建好封装的，不用勾选 Bump 和 Ball,没建

封装，必须要有焊盘，勾选 Bump 和 Ball 可以自动建封装并导入网表 
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5.1.4 点击 ChooseFile图标，选择 SIP数据文件放置的路径 

 

5.1.5 在 ImportSIP 对话框里，点击 Import 图标 
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5.1.6 数据就导进来了，Footprint 已放置在画布上 

 

 

5.1.7 点击菜单 File -> Save 进行保存。 

 

5.2 导入网表 

5.2.1 在新建的 RedPKG里,点击 File->Import->Netlist 
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5.2.2 弹出 Netlist 对话框 

 

ImportMode: 

勾选 Always：表示对于在 PKG 中已放置的器件，无论其在原理图中的连接

关系或其属性发生任何改变，更新网表后都不改变器件的位置。该项为建议默认

设置。(一般情况下，都会勾选 Always) 
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勾选 Never：表示只要器件在原理图中有任何更新，更新网表后就在 PKG 中

将相应器件将变为 unplaced状态，也就是我们俗称的将器件飞掉。 

勾选 same fp：表示如果器件在原理图中有所更新，但其封装（ Footprint）、

Value 值、Tolerance 精度没有发生变化，更新网表后将不改变器件的位置；但

是如果以上三个属性中任何一个发生变化，更新网表后将相应器件飞掉。 

PlaceMode: 

勾选 Auto:自动放置 

勾选 Manual:手动放置 

 

 

 

 

5.2.3 点击 ChooseFile图标，选择 Netlist 数据文件放置的路径 

 



弘快电子自动化设计软件 使用手册 V1.0 

31 

 

 

5.2.4 自动放置 

ImportMode:勾选 Always ，PlaceMode:勾选 Auto，点击 Import,所有器件

就已经调进 PKG 里面了 
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5.2.5 手动放置：ImportMode:勾选 Always ，PlaceMode:勾选 Manual，点

击 Import,板子上没有器件，但是器件已经在 PKG后台了 

 

将后台的器件调入 PKG 板里面，点击 Draw->Netlist Footprint,跳出对话
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框，选择需要的器件，点击 Place,器件就调入 PKG 里面了（不小心删除器件也

是在这里面调入进来）。 

 

 

5.2.6 点击菜单 File -> Save 进行保存。 

 

6 Finger 设置和放置 

6.1Finger 设置 

1)点击 Draw->EditFinger 
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2）弹出 EditFinger 对话框 

 

3)点击 Add 图标，弹出 Add Bond Wire对话框，在 Bond Wire 后面的数据框

输入：1，点击 OK。 

 

 

）在 EditFinger 对话框里，在 Finger Name 下的方框里，双击需要的 Finger,

双击后，所需要的 Finger就移动到右边的方框里。 

(说明：Finger 焊盘的创建在 RedPAD 里同普通的贴片焊盘一样操作，可在

命名 Finger 焊盘的名称时，前缀加上 Finger，方边后续的辩识和操作） 
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点击 Edit 图标，弹出 Edit Bond Wire 对话框 

 

在 Finger下的下拉列表里，选择所增加的 Finger焊盘，点击 OK。这样 Finger

就设置好了 
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6.2 Finger 放置 

1)点击 图标放置 Bond Wire 和 Finger,弹出 Bond Wire 面板 

 

 

面板里显示：Bond Wire 的序号 

            Finger 的类型 

            Bond Wire Width 

根据个人习惯，可 Bond Wire Width 更改为：5 

 

 

2）根据鼠线显示的连接显示，点击 DIE 的焊盘，Finger 和 Bond Wire 就吸

附在鼠标上，移动鼠标，在合适的位置单击，Finger 和 Bond Wire 就放置在画布

上。 
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3）重复上面的 Finger 和 Bond Wire 的放置操作，把 DIE 的焊盘有网络连接

显示放置完成 Finger 和 Bond Wire。 

放置 Finger 和 Bond Wire 时，要按设置的格点布放，在多 DIE 封装层叠的

工程项目里，每个 DIE 的 Finger 要放在同一行或同一列。最底层的 Finger 距离

DIE 较近，最底层相邻的上一层的 Finger 要放置离 DIE 次之，其它 DIE 的 Finger

放置距离 DIE 依此类推。 

（在放置 Finger 和 Bond Wire 时，由于 PIN 较多，要养成操作一定时间就保

存文件的习惯。） 

 

4）点击菜单 File -> Save 进行保存。 

 

7 设计规则设置 

7.1 物理规则设置 

1）点击图标 或者点击 Modules->RulerManagers,跳出对话框，选择 Physical,

选择 Rule,点击 Default 
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在 Track 输入之需要的线宽， 

Track：Min (最小线宽），Max(最大线宽） 

2）设置电源线宽：点击在 Default 上右击选择 Create,新加规则，输入名字：

POWER 

设定线宽：最小线宽 70，最大线宽 200 
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将设定好的阻抗和信号匹配上，在下方 Net 框里，Nets：信号名，RuleName:

选择对应的阻抗，选好后，匹配的线宽会自动变更 
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7.2 差分线设置 

1）设置成差分对 

方法 1：点击 Function->Differential Pairs,跳出对话框，信号名前缀一样的，

在 Fileter+,Fileter-,输入信号名后缀，点击 Search，蓝框内就是生成的差分对， 

（一般差分对，命名一样，只是在最后会加一个 N 和 P,标识差分对的正和

负） 

 

点击 Create,所有差分队就显示在左上教，可以查找差分对，勾选差分对名，

点击 Delete,可以将差分队删除 
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方法二：按住 Ctrt 键，点击两根信号在 Diff pair name:输入差分对名，点击

Create,差分信号就添加完成 

 

2）设置差分信号的线宽和两根线之间的间距：在 Differential Pair Rule 界面

中，Track min(最小线宽），Track max（最大线宽），Track Gap(差分线之间的距

离） 
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3）在 Differential Pair 中就可以看到刚刚设的差分对，在 RuleName 选择之

前设的欧姆，线宽和线距就会自动变更 
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7.3 设置间距（Spacing）规则 

1)点击图标 或者点击 Modules->RulerManagers,跳出对话框，选择

Spacing,选择 Rule,点击 Default,设定各种的间距 

 

 

Track/Track: 走线与走线的间距 

Track/Thr Pad:走线与通孔焊盘的间距 

Track/SMD pad: 走线与贴片焊盘的间距 

Track/Via: 走线与过孔的间距 

Track/BB Via：走线与盲埋孔的间距 

Track/Copper：走线与铜皮的间距 

Thr Pad/Thr Pad:通孔焊盘与通孔焊盘的间距 

Thr Pad/SMD pad:通孔焊盘与贴片焊盘的间距 

Thr Pad/Via:通孔焊盘与过孔的间距 

Thr Pad/BB Via:通孔焊盘与盲埋孔的间距 

Thr Pad/Copper:通孔焊盘与铜皮的间距 

SMD pad/SMD pad: 贴片焊盘与贴片焊盘的间距 

SMD pad/Via: 贴片焊盘与过孔的间距 

SMD pad/BB Via: 贴片焊盘与盲埋孔的间距 

SMD pad/Copper: 贴片焊盘与铜皮的间距 
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Via/Via:过孔与过孔的间距 

Via/BB Via:过孔与盲埋孔的间距 

Via/Copper:过孔与铜皮的间距 

BB Via/BB Via：盲埋孔与盲埋孔的间距 

BB Via/Copper：盲埋孔与铜皮的间距 

Copper/Copper: 铜皮与铜皮的间距 

 

2）特殊信号为了防止与其它信号有干扰，我们可以线的距离设置的大一些 

点击在 Default 上右击选择 Create,新加规则，输入名字：20 ，所有间距改成

20，在 NET 那栏选中信号名，后面选 20，所有间距就会自动跳到 20 了 

 

 

7.4 添加过孔 

1）点击 Draw->VIA,跳出对话框，点击需要隔过孔焊盘，双击后，会跳到右

边，点击 Apply,过孔就加进来了 



弘快电子自动化设计软件 使用手册 V1.0 

45 

 

2）软件支持添加多种过孔焊盘，当添加的比较多时，我们点击最常用的 via，

点击 UP，让它排到第一位，打过孔的优先顺序是从上往下，不需要的 VIA 也可

以在 CurrentPcbVia 中，选中不需要的 VIA，双击后，就会回到左边，走线是就

打不了这个过孔了 

 

 

3）设定好后点击保存，将之前设定保存 
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8 PKG 布线 

8.1 布线 

在布局阶段我们将格点间距设置为 50um；布线阶段为了更加灵活地布线及

推挤走线，建议需要设置较小的格点间距。 

1）点击菜单 View -> Zoom In 或图标 放大局部区域，观察格点是否已

正确设置。 

2）点击  图标，激活 Track 命令。 

3）在 RedPKG 左边 Selection 面板中，相关布线参数如下图所示： 

 

 

4）点击任一待布线网络的 Finger，我们看到随光标的移动从该 Finger 焊盘

引出一根TOP层的走线，当前走线宽度如 Selection面板“Thack Width”所示为 50um

（这里是规则管理器中相应网络的约束值）；如果需要修改线宽、拐角等参数可

以在 Selection 面板里进行修改。 
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5）手动修改线宽在 Selection面板中，在 TrackWidth输入需要的线宽（20m）

勾选 Force(勾选后线宽根据 TrackWidth 的线宽走线，不勾选线宽根据规则管理

器里面设定的线宽走线） 

 

 

在 Work Area 用左键依次点击下图圈出的位置，直到走线连接到该网络在对

应的 PIN 脚，参考走线如下图所示。 

 

Notes：使用 Track 命令走线过程中，为了提高设计效率，经常需要使用右键
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的相关命令。 

常用右键命令的作用如下： 

Done：结束当前 Track 布线命令。 

Oops：取消最近的一次左键单击操作，回到上一步状态，并保证 Track 布线

命令仍然生效，用户可以继续走线。 

Cancel：撤销本次 Track 的所有操作。  

走线支持 45度角，90度角和任意角度 

   

 

6）走线时当和其它走线太近是会有走线警告，和其它走线交叉是也会有短

路实时警告。 

 

   

 

布线过程中，有时难免会需要删除部分或全部走线以进行修改，下面介绍如

何删除走线： 
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7）点击  图标，激活 Delete 命令 

8）查看并确定 RedPKG 左侧的 Selection 面板中仅勾选了“Track seg”对象

类型。 

9）点击信号的某一下段走线，如下图所示。 

 

 

10）删除后的效果如下图所示。 

 

 

11）点击  图标，激活 Delete 命令 

12）查看并确定 RedPKG 左侧的 Selection面板中仅勾选了“Track ”对象类

型。 

13）点击信号的任一下段走线，如下图所示。 
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14）删除后的效果如下图所示。 

 

Notes：从上面的例子可以看到对象类型“Track Segs”和“Track”分别表示“走

线线段”和“整段走线”。 

 

8.2 换层走线 

1）点击 图标，激活 Track 功能。 

2）点击 PIN 拖动光标在 TOP 层绘制一段走线，然后在任意处双击左键打一

个过孔。 

3)在 RedPKG 左侧的 Selection 面板中，Track 选择层：TOP。 
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4）在 RebPKG 中继续在 BOTTOM 层走线，当走线连接到 E7 焊盘时，信号

就连接上了。 

 

 

8.3 修改走线 

1)完成网络走线后，如下图所示：两根信号太近，需要推开。 
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2)点击图标 ，激活 Drag功能，点击走线，将上面的信号线往上推，推

完后如下图： 

将线往右边推 ： 推之前和推之后的对比图 

     

 

3）点击菜单 File -> Save 进行保存。 

 

 

 

9 电源处理 

9.1 铺铜 

1）点击  在 RedPKG 左侧的 Selection面板中,选择 Net 和 Pad,点击 Pad,

会出现这个 Pad 的 NET 信息，Net Name:POWER1 
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2) 点击图标 ，激活查找功能在 RedPcb 右侧的框内输入 Net 

Name:POWER1，下拉框选择 Net，就跳出查找的 NET（POWER1）。 

 

 

3)点击 Choose Color,选择颜色，点击 OK。 
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勾选 Net（POWER1）,点击 Apply，PKG 上的 NET 就变成黄色的：如下图
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5）铺铜皮方法一：点击图标 或者点击 Cooper->Complex,在 RedPKG 左

侧的 Selection 面板中，Cooper 框内，选择层面：Layers, 在 Layers 的层面里选

择 TOP 层， 

Type:选择 Cooper 的形态 （Cavity） 

下方是在 PKG 中常用的形态： 

Dynamic copper(动态 shape) 

Cavity(静态 shape) 

Static crosshatch(静态网格 shape) 

 

6)将同一种颜色的焊盘包起来 

 

铺好铜皮，点击图标 在 RedPKG 左侧的 Selection 面板中选择 Cooper，

点击刚铺的铜皮，显示 Net name是空的，标识这个铜皮没有连接到信号，为空。 
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8)现在给铜皮命名，点击图标 ，在点击铜皮，然后点击需要连接的 PAD,

铜皮的信号就变成了 POWER1 

 

9)铺铜皮方法二：点击图标 或者点击 Cooper->Complex,在 RedPKG左侧

的 Selection 面板中，Cooper框内，选择层面：Layers, 在 Layers的层面里选

择 TOP层，NET 下拉框选择需要的 Net 
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10）将要连接的焊盘包起来，这样信号就直接连上了 

 

 

9.2 铜皮掏空处理 

1）矩形铜皮掏空：点击图标 或者点击 Cooper-> Dig Rect,点击铜皮，框

选需要掏空的地方如下图 

 

2）不规则掏空：点击图标 或者点击 Cooper-> Dig Polygon,点击铜皮，按

照需求掏空的地方如下图： 
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3）圆形掏空：点击图标 或者点击 Cooper-> Dig Circle,点击铜皮，框选需

要掏空的地方如下图: 

 

 

4）自动避让过孔：点击 Copper 右击，点击 Dig ALL,Copper 会自动避让其

它信号的过孔 

 

5）点击菜单 File -> Save 进行保存。 

10. SUMMARY 功能和 DRC 功能 

10.1 SUMMARY 功能 

Summary 功能是检查 PKG 板上的信号是否都连通了，有多少没有连通，还

有器件是否都从后台调入，有多少没有调入 PKG 里。 

1)点击 Tools -> Summary,跳出对话框， 
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2）将后台的器件调入到 PKG 里面，点击 Draw->NetlistFootPrint,跳出对话

框，显示出后台的器件的位号和封装型号，框选点击 Place 

 

 

3）将器件就调入 PKG 里面了，根据原理图然后将器件放在特定的位置上 
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4）点击 Tools-> Summary,跳出对话框，确认器件是否都调入 

 

 

 

 

5）将所有层关闭，看一下飞线的位置，然后将层面打开，将飞线都连接起



弘快电子自动化设计软件 使用手册 V1.0 

61 

来 

 

 

6）然后再点击 Tools-> Summary,跳出对话框，确认信号都已经连接完成，

显示 100%表示所有信号都已经连接完成了 
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10.2 DRC 检查 

DRC 检查是方便查找一些短路短路的一些报警，是根据规则管理器生成 

1）点击图标 或点击 Modules->DrcCheck,跳出对话框，显示出 DRC 的基

本信息 

ErrorNumber:显示 DRC 的序号 

显示 DRC 的坐标：X92.160 Y101.520 

DRC 错误类型：TrackSeg And Shape(走线和铜皮靠的太近了） 

产生 DRC 的信号：Avdd1.8 和 GND 靠的太近 

所在的层面：TOP 

 

DRC 错误类型分别有：TrackSeg And Shape(走线和铜皮靠的太近了） 

                    Via And Shape (过孔和铜皮靠的太近了） 

                    TrackSeg And TrackSeg(走线和走线靠的太近了） 

                    TrackSeg And FootprintPad(走线和焊盘靠的太近了） 

 

2)PKG 所有层面关闭可以快速找到 DRC 的位置。 
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11 出光绘文件 

11.1 光绘输出 

本章将介绍如何生成 PKG 生产装配使用的工程制造数据文件；由于输出的

设计数据文件较多，为了方便整理，建议大家在输出光绘文件前，将 PKG 文件

放置到一个新建的文件夹中用来放置这些工程数据文件；当然用户也可以通过环

境变量指定工程数据文件的路径。 

1）点击菜单 File->Export->Gerber,弹出出对话框， 

 

2）点击 SelectAll 图标,点击 GenerateFile 图标,Gerber 文件及数据输出完成

（数据输出默认路径是和 PKG 在同一个文件夹内）。 
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运行完毕，弹出对话框，显示 Gerber文件已经生成完毕，没有出现问题 
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3）在文件夹里就自动生成了每一层后缀带着.redgrb 的光绘文件，每一层

光绘自动包含了下方这些层面 

布线层: 常规信号层，主要是布线 

Top:Track/Top Bottom:Track/Bottom 

Pad/Top Pad/Bottom 

Via/Top Via/Bottom 

Copper/Top Copper/Bottom 

Line/Top Line/Bottom 

Text/Top Text/Bottom 

平面层: 指 GND 及 POWER，是完整铜箔层 
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Gnd:Track/Gnd Vcc:Track/Vcc 

Pad/Gnd Pad/Vcc 

Via/Gnd Via/Vcc 

Copper/Gnd Copper/Vcc 

Line/Gnd Line/Vcc 

Text/Gnd Text/Vcc 

转孔层: 指设计文件中设计者手工添加包含 Pcb 加工信息的层面。命名为 Drill 

Drill: Pcb Geometry/Outline 

 Pcb Geometry/Dimension 

 Fabrication/Drill_Symbol 

 Fabrication/Drill_Table 

装配层: 指设计文件中为客户提供查看封装信息和器件位置的层面，命名为

Assembly_Top/Assembly_Bot 

Assembly_Top:Line/Assembly_Top Assembly_Bot:Line/Assembly_Bottom 

Res Des/Assembly_Top Res Des/Assembly_Bottom 

Pcb Geometry/Outline Pcb Geometry/Outline 

Pcb Geometry/Assembly_Top Pcb Geometry/Assembly_Bottom 

 

钢 网 层 : 指 设 计 文 件 中 为 锡 膏 涂 布 提 供 加 工 信 息 的 层 面 ， 命 名 为

astemask_Top/Pastemask_Bot 

Pastemask_Top:  

Via/Pastemask_Top Pastemask_Bot:Via/Pastemask_Bottom 

Pad/Pastemask_Top Pad/Pastemask_Bottom 

Copper/Pastemask_Top Copper/Pastemask_Bottom 
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Pcb Geometry/Pastemask_Top Pcb Geometry/Pastemask_Bottom 

丝 印 层 : 指 设 计 文 件 中 为 加 工 丝 印 提 供 信 息 的 层 面 ， 命 名 为

Silkscreen_Top/Silkscreen_Bot 

Silkscreen_Top:Copper/Silkscreen_Top Silkscreen_Bottom:Copper/Silkscreen_Bottom 

Line/Silkscreen_Top Line/Silkscreen_Bottom 

Text/Silkscreen_Top Text/Silkscreen_Bottom 

Res Des/Silkscreen_Top Res Des/Silkscreen_Bottom 

Pcb Geometry/Silkscreen_Top Pcb Geometry/Silkscreen_Bottom 

阻 焊 层 : 指 设 计 文 件 中 为 绿 油 涂 布 提 供 加 工 信 息 的 层 面 ， 命 名 为

Soldermask_Top/Soldermask_Bot 

Soldermask_Top:  

Via/Soldermask_Top Soldermask_Bot:Via/Soldermask_Bottom 

Pad/Soldermask_Top Pad/Soldermask_Bottom 

Copper/Soldermask_Top Copper/Soldermask_Bottom 

Pcb Geometry/Soldermask_Top Pcb Geometry/Soldermask_Bottom 

板框层: 指 Pcb 外形，命名为 Outline 

Outline:Pcb Geometry/Outline 
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11.2 钻孔文件输出 

1）点击菜单 File->Export->Drill 
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2）弹出对话框，选择文件输出路径，点击 OK 

 

 

3）弹出对话框，显示输出成功，点击 OK,文件夹中就有两个.Drl 文件，分

别是金属和非金属化孔的钻孔表 

 

 

 

11.3 DXF 文件导出 

点击菜单 File->Export->DXF,跳出对话框 ，选择路径，输入名字，Units:选择单

位，勾选 All Select,勾选 Auto Generate Dxflayer,点击 Map,点击 OK,跳出对话框 

显示导出成功 
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完成后文件夹中就有一个.DXF 文件 
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11.4 打包文件 

将之前转出来得文件按照公司要求打包发给板厂。 

 

 

 

 

 

 

 




