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1 安装 PCB-DESIGN 

本章节为您介绍如何安装 PCB-DESIGN 版图设计软件。 

操作步骤 

步骤 1 联系工程师获取 PCB-DESIGN 安装包。 

步骤 2 解压并打开安装包，在解压文件夹中找到“PCB-DESIGN_Setup.exe”，双击运行。 

步骤 3 在欢迎安装界面上单击“Next”。 
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图1-1 欢迎安装界面 

 

 

步骤 4 在软件用户声明界面，选择“I accept the user agreement”同意软件用户声明，再

单击“Next”。 
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图1-2 安装界面权限入口 

 

 

步骤 5 在软件服务声明界面，选择“I accept the terms of service”同意软件服务声明，再

单击“Next”。 
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图1-3 安装界面权限入口 

 

 

步骤 6 在选择功能页面，查看和勾选需要安装的功能，再单击“Next”。 

默认安装“PCB-DESIGN PCB Builder（PCB-DESIGN 版图编辑器）”、“PCB-

DESIGN Library Manager（PCB-DESIGN 封装库管理）”、“PCB-DESIGN Footprint 

Editor（PCB-DESIGN 封装编辑器）”、“PCB-DESIGN Padstacks Editor（PCB-

DESIGN 焊盘编辑器）”、“PCB-DESIGN Shape Editor（PCB-DESIGN 形状编辑

器）”，且不能取消勾选。 
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图1-4 选择安装工具界面 

 

 

步骤 7 在选择安装路径界面，单击“Browse...”，选择安装路径，安装路径不可包含中文路

径。单击“Next”，系统自动开始安装软件。 
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图1-5 安装路径界面 

 

 

 

如果在所选安装路径下，之前有安装过本产品，需选择是否要覆盖之前的安装文件。单击

“Yes”，覆盖之前的文件安装，单击“No”，需要重新选择安装路径。 

步骤 8 安装完成后，在安装完成界面选择“Open” ，打开 PCB-DESIGN PCB Builder。 



PCB版图设计 

用户指南 1 安装 PCB-DESIGN 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 7 

 

图1-6 安装完成界面 

 

----结束 
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2 License 授权操作 

2.1 浮动 license 授权操作 

2.2 固定 license 授权操作 

2.1 浮动 license 授权操作 

步骤 1 浮动 license 授权服务器激活： 打开浏览器，输入浮动 license 授权服务器网址，进

入激活页面，可以查看已激活的 license 信息： 

 

步骤 2 点击激活 license 按钮，上传 license 文件，点击确认按钮，激活浮动 license 授权服

务器： 

 

步骤 3 若 license 文件正确，则激活成功，后续客户端工具可连接至浮动 license 授权服务器

进行客户端激活操作： 
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否则弹出失败提示框，请更换正确的license文件后再次尝试激活： 

 

步骤 4 客户端激活： 首次安装完成后，在打开 PCB-DESIGN PCB Builder 启动客户端时，需

先激活 license，可以选择浮动 license 激活，在 Server address 栏输入浮动 license

授权服务器域名，点击 Activate 按钮进行激活，若浮动 license 认证成功，则成功激

活客户端进入软件使用界面，否则弹出 License Check Fail 弹窗。 
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⚫ 如果断开服务端或者浮动 License 过期，会弹出 License 过期提示并自动退出 PCB 

Builder。 

 

a. 单击“Test Connection”测试浮动 License 服务端的连通性。 

 

b. 单击“Activate”，激活 License。 

 

c. 激活完成后系统自动打开 PCB Builder。 
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2.2 固定 License 授权操作 

步骤 1 在弹出的“ License Activation”弹窗 页面，选 择“Fixed License ”页签 ，单击

选择本地的 License 文件。 

 

License 文件的保存路径不能有中文，且 License 文件名称也不能有中文。 

 

步骤 2 单击“Activate”，激活 License。 

 

步骤 3 激活完成后弹出激活成功的提示并打开 PCB Builder。 

----结束 
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3 PCB-DESIGN 版图编辑器 

3.1  新建版图工程 

3.2  打开版图工程 

3.3  编辑器界面介绍 

3.4  菜单栏 

3.5  顶部工具栏 

3.6  左侧流程设计窗口 

3.7  左侧工程文件窗口 

3.8  左侧对象查询窗口 

3.9  左侧网络查询窗口 

3.10  左侧器件查询窗口 

3.11  右侧图层窗口 

3.12  右侧配层选择窗口 

3.13  右侧配置窗口 

3.14  底部操作命令窗口 

3.15  底部信息窗口 

3.16  底部对象元素窗口 

3.17  底部局部放大视图窗口 

3.18  底部状态栏 
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3.19  快捷键配置和使用 

3.20  并行设计 

3.1 新建版图工程 

PCB-DESIGN 版图编辑器管理的版图工程由工程文件和单板文件两部分组成，新建版

图工程时，需要先创建工程文件再创建单板文件。 

3.1.1 新建工程文件 

本章节为您介绍如何创建一个版图工程文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“PCB_Builder”，打开 PCB-DESIGN 版图编辑

器。 

步骤 2 在弹出的页面单击“New”。 

步骤 3 在“New”页面中，选择工程保存路径，填写工程名，单击“保存”。 

 

版图工程的保存路径不能有中文。 
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图3-1 工程界面入口 

 

 

步骤 4 新建工程完成后，系统默认自动打开新建工程。 

图3-2 工程界面 

 

 

----结束 

 

工程文件创建完成后自动生成，所选的保存目录自动生成版图工程文件夹，其中.prj 文件为版图

工程文件。在工程下新建单板文件后，会默认保存到工程文件夹的 DesignFiles 文件夹。 
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3.1.2 新建单板文件 

新建工程文件后，还需要新建单板文件来绘制版图，本章节为您介绍如何创建一个版

图工程的单板文件。 

操作步骤 

步骤 1 3.2.1 打开工程文件。 

步骤 2 在“Project”窗口中，单击 图标，会在 DesignFiles 文件夹里自动新建一个空白单

板文件（.ddb 文件）。 

步骤 3 单击单板文件，修改单板文件名称。 

图3-3 新建单板文件 

 

 

步骤 4 名称修改完成后，按键盘“Enter”键自动保存新建的单板文件，直接在画布中显示新

建的单板文件。 

----结束 

 

新建单板文件（.ddb 文件）名称建议使用工程名称命名。 
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3.2 打开版图工程 

3.2.1 打开工程文件 

本章节为您介绍如何打开一个已有的版图工程文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“PCB_Builder”，打开 PCB-DESIGN 版图编辑

器。 

步骤 2 在弹出的页面，单击“Open”。 

步骤 3 在“Open”页面中，选择本地需要打开的工程文件（.Prj 文件），单击“打开”。 

图3-4 工程文件路径入口 

 

 

步骤 4 工程文件打开后，直接进入 PCB-DESIGN 版图编辑器页面。 
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图3-5 工程界面 

 

 

----结束 

3.2.2 打开单板文件 

本章节为您介绍如何打开一个版图工程单板文件。 

操作步骤 

步骤 1 3.2.1 打开工程文件。 

步骤 2 在“Project”窗口中，单击 或者选中“DesignFiles”右键选择“Add File”。 

图3-6 添加单板文件 

 

 

步骤 3 在“Add File”页面中，选择本地需要打开的单板文件（.ddb 文件），单击“打

开”。 
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图3-7 打开文件路径入口 

 

 

步骤 4 单板文件打开成功后，文件自动显示在“DesignFiles”文件夹下，且画布中自动打开

单板文件。 

 

----结束 
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3.2.3 切换单板文件 

一个工程文件只能同时打开一个单板文件，如需切换工程文件中的其他单板文件，需

要关闭当前打开的单板文件，才能打开新的单板文件。本章节为您介绍如何切换一个

版图工程的单板文件。 

操作步骤 

步骤 1 3.2.1 打开工程文件。 

步骤 2 关闭单板文件。 

1. 右键单击“DesignFiles”下的单板文件（.ddb 文件），单击“Close”。 

2. 在弹窗中，单击“Yes”，关闭单板文件。 

图3-8 关闭单板文件 

 

 

步骤 3 移除单板文件。 

1. 右键单击“DesignFiles”下的单板文件（.ddb 文件），单击“Remove”。 

2. 在弹窗中，单击“Yes”，移除单板文件。 
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图3-9 移除单板文件 

 

 

步骤 4 打开新的单板文件。 

1. 在“Project”窗口中，单击 或者选中“DesignFiles”右键选择“Add 

File”。 

 

2. 在“Add File”页面中，选择本地需要打开的另一个单板文件（.ddb 文件），单

击“打开”。 
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图3-10 添加单板文件 

 

 

----结束 

3.3 编辑器界面介绍 

版图编辑器界面由菜单栏、工具栏、流程设计窗口、工程文件窗口、对象查询窗口、

网络查询窗口、器件查询窗口、画布、图层窗口、配层选择窗口、配置窗口、操作命

令窗口、信息窗口、对象元素窗口、局部放大视图窗口、状态栏组成，如图 3-11 所

示。 

编辑器各个部分的相关操作请参见表 3-1。 
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图3-11 版图编辑器 

 

 

表3-1 编辑器界面操作 

编辑器界面 使用方法 

菜单栏 菜单栏提供了版图编辑器常用的功能，关于菜单栏的具体操

作请参见 3.4 菜单栏。 

工具栏 工具栏提供了设置及显示菜单栏对应的功能按钮，方便快捷

操作，关于工具栏的具体操作请参见 3.5 顶部工具栏。 

流程设计窗口 流程设计窗口提供了快速进入流程设置页面按钮，方便快捷

操作，关于流程设计窗口的具体操作请参见 3.6 左侧流程设

计窗口。 

工程文件窗口 工程文件窗口提供了新建和打开单板文件的功能，关于工程

文件窗口的具体操作请参见 3.7 左侧工程文件窗口。 

对象查询窗口 对象查询窗口提供了查询画布中任何对象的功能，关于对象

查询窗口的具体操作请参见 3.8 左侧对象查询窗口。 

网络查询窗口 网络查询窗口提供了查询所有器件网络的功能，关于网络查

询窗口的具体操作请参见 3.9 左侧网络查询窗口。 

器件查询窗口 器件查询窗口提供了查询所有器件的功能，关于器件查询窗

口的具体操作请参见 3.10 左侧器件查询窗口。 

画布 版图编辑器中，画布用于绘制版图，允许进行放置器件、布
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编辑器界面 使用方法 

局，布线等操作。 

图层窗口 图层窗口用于打开和选择版图绘制的层次，关于图层窗口的

具体操作请参见 3.11 右侧图层窗口。 

配层选择窗口 配层选择窗口用于打开和选择版图绘制的配层，关于配层窗

口的具体操作请参见 3.12 右侧配层选择窗口。 

配置窗口 配置窗口提供了操作命令的所有配置功能，关于配置窗口的

具体操作请参见 3.13 右侧配置窗口。 

操作命令窗口 操作命令窗口提供了输入操作命令，画布中的对象直接执行

操作的功能，关于操作命令窗口的具体操作请参见 3.14 底

部操作命令窗口。 

信息窗口 信息窗口提供了快速查看版图信息的功能，关于信息窗口的

具体操作请参见 3.15 底部信息窗口。 

对象元素窗口 对象元素窗口提供了查询对象所有元素的功能，关于对象元

素窗口的具体操作请参见 3.16 底部对象元素窗口。 

局部放大视图窗口 局部放大视图窗口便于在绘制版图过程中查看具体位置，关

于局部放大视图窗口的具体操作请参见 3.17 底部局部放大

视图窗口。 

状态栏 状态栏提供了版图编辑器中显示 DRC、坐标、格点及配置

功能按钮，方便快捷操作，关于状态栏的具体操作请参见

3.18 底部状态栏。 

 

3.4 菜单栏 

3.4.1 文件菜单（File） 

3.4.1.1 新建工程文件（New） 

本章节为您介绍如何在打开工程文件的状态下，新建一个新的版图工程文件。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>New...”。 

步骤 3 在弹出的“Question”页面中，单击“Yes”保存当前工程文件。 

图3-12 保存提示窗口 

 

 

步骤 4 选择完成后，在弹出的“New”页面中，填写工程文件名称、选择工程存放目录，单

击“保存”。 

 

版图工程的保存路径不能有中文。 

图3-13 新建工程 

 

 

步骤 5 单击“保存”后，新建工程结束，当前界面自动打开新建工程。 
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工程文件创建完成后自动生成，所选的保存目录自动生成版图工程文件夹，其中.prj 文件为版图

工程文件。在工程下新建单板文件后，会默认保存到工程文件夹的 DesignFiles 文件夹。 

----结束 

3.4.1.2 工程基础操作 

本章节为您介绍在编辑器中能对工程执行的基础操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在编辑器界面能对工程执行一些基础操作，操作方法请参见表 3-2。 

表3-2 工程基础操作 

操作名称 操作步骤 

打开工程（Open） 1. 在菜单栏选择“File>Open...”。 

2. 在“Open”弹窗中选择工程，单击

“打开”。打开工程成功后左侧工程文

件命令窗口展示当前打开工程文件，

并自动打开单板文件。 

保存（Save） 1. 在画布中修改单板文件信息。 

2. 在菜单栏选择“File>Save”，保存

单板文件信息。 

另存为(本地)（Save As） 将当前工程另存为一个.prj 格式文件到本

地。 

1. 在菜单栏选择“File>Save As...”。 

2. 在“Save As”弹窗中输入文件名

称，单击“保存”。在本地文件夹中

生成一个.prj 格式文件。 

近期工程（Recent Project） 近期工程展示最新创建的 8 个 PCB 版图

工程。 

在菜单栏选择“File>Recent 

Project”，在工程列表中单击工程名称
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操作名称 操作步骤 

可以打开工程。 

关闭全部（Close） 在菜单栏选择“File>close”，关闭版图

编辑器，返回编辑器主界面。 

 

----结束 

3.4.1.3 Client 端并行设计（Collaboration Client） 

本章节为您介绍如何在客户端（Client 端）进行版图连接使用。在进入客户端（Client

端）前需要先开启服务端（Server 端）。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Collaboration Client...”。 

步骤 3 在弹出的“Question”页面中，选择是否关闭当前工程文件。 

图3-14 关闭提示窗口 

 

 

步骤 4 根据端口号选择服务端（Server 端）进行版图同步。 

1. 先在服务端（Server 端）开启连接，开启连接操作请参见 3.20.1 Server 端发布

版图。 

2. 连接开启后在“Collaboration Client”页面中，单击“Query”。 

3. 在弹出的页面中输入服务端（Server 端）的 IP 地址。IP 地址可在服务端

（Server 端）“Owner”栏查看。 
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4. 根据端口号单击选择需要连接的服务端（Server 端），然后单击“Connect”进

行版图同步。端口号可在“Host”栏查看。 

图3-15 开启连接 

 

 

步骤 5 版图连接后直接进入工程文件界面，单击“Save Server Db”保存服务端（Server

端）单板文件。 

图3-16 保存单板文件 

 

 

步骤 6 单击“Disconnect”，在弹窗中单击“Yes”关闭连接，单击 关闭窗口。 
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图3-17 关闭连接 

 

 

----结束 

3.4.1.4 宏命令（Scripting） 

本章节为您介绍如何录制一个宏命令。宏命令可以快速的将您制作过程中所有的操作

命令转换成文本，方便下次使用。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Scripting”。 

步骤 3 在弹出的“Scripting”页面中，单击 选择录制脚本保存路径（存放路径和

文件名称不能包含中文），单击“Record”开始录制。 
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图3-18 开始录制 

 

 

步骤 4 录制完成后，在菜单栏选择“File>Scripting”。 

步骤 5 在弹出的“Scripting”页面中，单击“Stop”，即可停止录制。 

图3-19 结束录制 

 

 

步骤 6 打开录制脚本保存路径，查看录制脚本文件。录制后的脚本文件以 txt 格式保存。 
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图3-20 宏命令文件 

 

 

----结束 

3.4.1.5 导入（Import） 

3.4.1.5.1 导入网表文件（Netlist） 

本章节为您介绍如何导入网表文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>Netlist...”。 
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步骤 3 在弹出的“Import Netlist”页面中，单击 选择本地保存的网表文件（.tel

文件），单击“打开”。 

步骤 4 勾选网表文件需要的配置，参数说明请参见表 3-3，勾选完成后单击“Import”。 

图3-21 导入网表文件 

 

 

表3-3 网表文件配置参数说明表 

参数名称 说明 

lgnore FIXED  property 忽略锁定的器件。 

Allow etch removal ECO 允许铜箔和走线被删除。 

Compare all logical data with previous data 

and record the defference in the log 

和更新前的网表文件对比，并更

改文件。 

Parts From Library Settings 勾选导入 pEDA-Schematic 网

表.tel 文件，不勾导入普通网

表.txt 文件。 

 

 

在导入网表文件前需要连接对应的封装库。 

步骤 5 网表导入成功后，弹出“Import netlist report”页面，查看导入报告后单击 关闭

即可。 
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步骤 6 查看左下角“Components”命令窗口虚拟网表器件列表，若存在虚拟器件，说明网

表导入成功。 

图3-22 网表虚拟器件列表 

 

 

----结束 

3.4.1.5.2 导入结构图文件（DXF） 

本章节为您介绍如何导入结构图文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>DXF...”。 
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步骤 3 在弹出的“Import  DXF”页面中，配置导入 DXF 参数。 

1. 单击 DXF file 输入框后的 ，选择需要导入的结构图文件（.dxf 文

件）。 

2. 在 Units 后的下拉框选择单位，可选择 MM 和 MILS。 

3. 勾选 DXF layer 前的方框，选择所有结构图层文件。 

4. 在 Class 后的下拉框选择放置文件的“Layout”配层。在 SubClass 后的下拉框

选择放置结构图的“MCAD_Detail”配层。单击“Map”更新放置文件的配层。 

图3-23 导入结构图 

 

 

步骤 4 参数配置完成后，单击“Import”。 

步骤 5 结构图导入完成后，显示报告弹窗，查看报告后单击 关闭即可。导入的结构图可在

“MCAD_Detail”配层查看。 

 

MCAD_Detail 配层放置于 Selection 窗口的“Board Elements>Layout”。 

----结束 

3.4.1.5.3 导入 IDF 结构文件（IDF） 

本章节为您介绍如何导入 IDF 结构文件。IDF 结构文件支持.bdf 、.emn 和.out 这三

种文件格式。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>IDF...”。 

步骤 3 在弹出的“Import IDF”页面中，单击 选择本地保存的 IDF 文件，单击

“打开”。 

步骤 4 在页面中，单击“Import”。 

系统默认勾选“Check database after import idf”，导入 IDF 结构文件后检查数据

库。可取消勾选，导入 IDF 结构文件后不检查数据库。 

图3-24 导入 IDF 结构文件 

 

 

----结束 

3.4.1.5.4 导入跨板拷贝文件（Copy Reference Design） 

本章节为您介绍如何导入跨板拷贝文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>Copy Reference Design”。 

步骤 3 在弹出的“Copy Reference Design Filename”页面中选择本地保存的.crd 文件，单

击“打开”。 
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图3-25 导入跨板拷贝文件 

 

 

步骤 4 在画布中单击合适位置放置拷贝数据。 

----结束 

 

跨板拷贝文件不能有同位号的器件，文件需在导入前删除同位号器件。 

3.4.1.5.5 导入元器件（Placement） 

本章节为您介绍如何导入元器件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>Placement...”。 

步骤 3 在弹出的“Import Placement”页面中，单击 选择本地保存的元器件文件

（.txt 文件），单击“打开”。 

步骤 4 选择元器件配置，参数说明请参见表 3-4，单击“Import”。 
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图3-26 导入元器件 

 

 

表3-4 元器件配置参数说明表 

参数名称 说明 

Add and move 新增和移动器件 

lgnore FIXED  property 忽略锁定的器件 

 

----结束 

3.4.1.5.6 导入封装补偿文件（Pin Delay） 

本章节为您介绍如何导入封装补偿文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>Pin Delay...”。 

步骤 3 在弹出的“Pin Delay Import”页面，单击 选择本地保存的封装补偿文件

（.CVS 文件），单击“打开”。 
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步骤 4 选择文件后，单击“Import”。 

图3-27 导入封装补偿文件 

 

 

步骤 5 在属性管理器中查看导入的数据。 

1. 在菜单栏选择“Edit>Property...”。 

2. 在弹出的“Property”页面中选择“Manager”页签查看属性。 

3. 在页面左侧“Available Properties”下方的下拉框选择 Pins。 

4. 在页面左侧属性列表中单击“PIN_DELAY”。 

5. 右侧“Object Properties”下自动显示所有对象、属性及属性值。 
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图3-28 查看导入数据 

 

 

----结束 

3.4.1.5.7 导入 txt 文件（Design Data） 

本章节为您介绍如何导入 txt 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Import>Design Data...”。 

步骤 3 在弹出的“Design Data”页面中选择本地保存的 txt 文件，单击“打开”。 
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图3-29 导入 txt 文件 

 

 

----结束 

 

导入 txt 文件时工程不可存在单板文件。如果有单板文件，将无法导入，需关闭移除后，再导入

txt 文件。 

3.4.1.5.8 跨板拷贝支持旋转（Copy Reference Design） 

本章节为您介绍如何跨板拷贝后进行旋转。 

操作步骤 

步骤 1 功能菜单栏，点击 File-Import-Copy Reference Design 
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步骤 2 选择文件（.crd），点击打开 

 

步骤 3 编辑框右键，选择旋转命令（Rotate），导入报告完成 
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----结束 

3.4.1.6 导出（Export） 

3.4.1.6.1 导出网表文件（NetList） 

本章节为您介绍如何导出网表文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>NetList...”。 

步骤 3 在弹出的“Export Netlist”页面中，配置导出参数。 

1. 单击 Netlist 后的 选择需要导出的网表文件（.txt 文件）的存放路径

（存放路径和文件名称不能包含中文）。 

2. 选择是否勾选“Need property”。选择“Need property”需要属性。取消勾

选，则不需要属性。 
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图3-30 导出网表文件 

 

 

步骤 4 单击“Export”导出文件。 

----结束 

3.4.1.6.2 导出光绘文件（Gerber） 

本章节为您介绍如何导出光绘文件。光绘文件也叫 Gerber 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>Gerber...”。 

步骤 3 在弹出的“Gerber”页面，选择“Film Control”页签导出文件。 

1. 单击“Auto Gen”重置文件列表。 

2. 单击“Select All”选择所有导出的图层和配层。 

3. 单击“Apply”保存配置。 

4. 单击“Create Artwork”导出文件。 
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图3-31 导出光绘文件 

 

 

步骤 4 在弹出的页面中查看导出是否成功，查看完后单击页面右上角 关闭页面即可。 

步骤 5 打开 Output 文件夹查看导出的文件。 

图3-32 查看 Gerber 文件 

 

 

----结束 

3.4.1.6.3 导出 NC 文件（NC） 

本章节为您介绍如何导出 NC 文件。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>NC...”。 

步骤 3 在弹出的“Export NC Drill”页面中选择导出参数，参数说明请参见表 3-5，填写完

成后单击“Generate”导出文件。 

图3-33 导出 NC 文件 

 

 

表3-5 导出 NC 文件参数说明表 

参数名称 说明 

Root file name 导出文件名称，一般默认为当前文件名（存放路径

和文件名称不能包含中文）。 

Tool sequence 导出的孔表顺序，有递增和递减两种方式。 
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参数名称 说明 

Auto tool select 自动选择孔表。 

Separate files for 

plated/non-plated holes 

单独创建金属化孔表和非金属化孔表。 

Drilling Type 钻孔类型。 

NC route NC route 文件，即开槽口铣刀数据文件。 

 

步骤 4 单击“View Path”查看 NC 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.4 导出 ODB++文件（ODB++） 

本章节为您介绍如何导出 ODB++文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>ODB++...”。 

步骤 3 在弹出的“Export ODB++”页面中，选择“Film Control”页签。 

步骤 4 在 Archive Type 后的下拉框选择压缩格式。 
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图3-34 文件压缩界面 

 

 

步骤 5 单击“Auto Gen”重置文件列表，再单击“Select All”选择所有导出的图层和配

层。 

步骤 6 单击“Exprot”导出文件。 

步骤 7 打开存放 ODB++文件的文件夹，可查看导出的文件。 

----结束 

3.4.1.6.5 导出 IPC2581 文件（IPC2581） 

本章节为您介绍如何导出 IPC2581 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>IPC2581”。 

步骤 3 在弹出的“Export IPC2581”页面，选择“Film Control”页签，配置导出的图层和

配层。 

1. 单击“Auto Gen”重置文件列表。 

2. 单击“Select All”选择所有导出的图层和配层。 

3. 单击“Apply”保存配置。 
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图3-35 选择图层和配层 

 

 

步骤 4 在弹出的“Export IPC2581”页面，选择“IPC2581”页签，选择导出压缩包，单击

“Export”导出文件。 

图3-36 导出文件 

 

 

步骤 5 在弹出的页面中查看导出是否成功，查看完后单击页面右上角 关闭页面即可。 
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图3-37 文件导出报告 

 

 

步骤 6 单击“View Path”查看 IPC2581 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.6 导出 IPC356A 文件（IPC356A） 

本章节为您介绍如何导出 IPC356A 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>IPC356A...”。 

步骤 3 在弹出的“Export IPC356A”页面，在 Output file 后的输入框输入导出的文件名，

一般默认为当前文件名（存放路径和文件名称不能包含中文）。 
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图3-38 导出 IPC356A 文件 

 

 

步骤 4 单击“Export”导出文件。 

步骤 5 单击“View Path”查看 IPC356A 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.7 导出结构图文件（DXF） 

本章节为您介绍如何导出结构图文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>DXF...”。 

步骤 3 在弹出的“Export DXF”页面中，配置导出参数。 

1. 在 DXF output file 后的输入框输入导出的文件名，一般默认为当前文件名（存放

路径和文件名称不能包含中文）。 

2. 在 Output Units 后的下拉框，选择单位“MM”或者“MILS”。 

3. 勾选全部的“Class”结构图层文件，单击“Map”更新“DXF layer”。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 50 

 

图3-39 导出 DXF 文件 

 

 

步骤 4 配置完成后，单击“Export”导出文件。 

步骤 5 单击“View Path”查看结构图文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.8 导出 IDF 文件（IDF） 

本章节为您介绍如何导出 IDF 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>IDF...”。 
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步骤 3 在弹出的“IDF”页面，配置导出参数。 

1. 在 File Name Type 后的下拉框选择导出文件类型，文件类型有 PTC、IDF、

SDRC 三种格式。 

2. 在 Output file name 后的输入框输入导出的文件名，一般默认为当前文件名（存

放路径和文件名称不能包含中文）。 

3. 勾选“Use Filter”展开扩展框，在展开的扩展框勾选需要过滤的内容。 

图3-40 导出 IDF 文件 

 

 

步骤 4 配置完成后，单击“Export”导出文件。 

步骤 5 单击“View Path”查看 IDF 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.9 导出 Archiving 文件压缩包（Archiving） 

本章节为您介绍如何导出 Archiving 文件压缩包。Archiving 文件自动压缩导出有两种

模式，可将单个文件压缩后导出，也可将多个文件压缩后导出。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 先配置光绘文件。 

1. 在菜单栏选择“File>Export>Gerber...”。 

2. 在弹出的“Gerber”页面，选择“Film Control”页签。 

3. 单击“Auto Gen”重置文件列表。 

4. 单击“Select All”选择所有导出的图层和配层。 

5. 单击“Apply”保存配置。 

步骤 3 在菜单栏选择“File>Export>Archiving...”。 

步骤 4 在弹出的“Archiving”页面中，有两种方式选择背钻文件和塞孔文件。 

⚫ 单击“Auto_Add BackDrill and Filled Files”后的 ，在弹窗中手动

选择背钻文件和塞孔文件。 

a. 在 BackDrill Files 框内单击“All”，选择所有的背钻文件。 

b. 在 Filled Files 框内单击“All”，选择所有的塞孔文件。 

c. 单击“OK”。 

⚫ 勾选“Auto_Add BackDrill and Filled Files”前的方框，自动选择背钻文件和塞

孔文件。 

步骤 5 可在下拉框中选择 Terminal（终端）、Non-Terminal（非终端）。 

步骤 6 在 Select 框内勾选需要导出的文件，单击“Export”。 

可勾选“Check database before export”前的方框，选择在导出前检查数据库；取

消勾选，则不检查。 
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图3-41 导出 Archiving 文件压缩包 

 

 

步骤 7 单击“Viewlog”查看导出日志信息。 

----结束 

3.4.1.6.10 导出 PDF 文件（PDF） 

本章节为您介绍如何导出 PDF 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>PDF”。 

步骤 3 在弹出的“PDF Export”页面，配置导出参数。 

1. 在 Output file name 后的输入框输入导出的文件名，一般默认为当前文件名（存

放路径和文件名称不能包含中文）。 

2. 单击“Select All”选择所有导出的图层。 

3. 在 Export Options 框内勾选配置参数。参数说明请参见表 3-6。 
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图3-42 导出 PDF 文件 

 

 

表3-6 配置参数说明表 

参数名称 说明 

Export board/symbol outlines and 

refdes if pins exported 

勾选时，当输出的光绘文件有 Pin 时，

把板件/器件的板框/器件框显示出来，并

且把器件位号标注出来。取消勾选，不

做任何操作，保持原有输出。 

Filled pads 勾选时，填充输出的 PDF 中的盘。取消

勾选，则输出空心盘。 

Filled shapes 勾选时，填充输出的 PDF 中的铜箔。取

消勾选，则不填充铜箔。 

Filter holes 勾选时，输出的 PDF 不单独显示孔，只

显示孔的外框。取消勾选，则孔和孔的

外框都显示出来。 
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参数名称 说明 

Filter traces 勾选时，输出的 PDF 所有的 trace 都不

显示。取消勾选，则显示所有的 trace。 

Filter drawing origin 勾选时，输出的 PDF 左下角不显示版图

基准点。取消勾选，则显示版图基准

点。 

Filter header/footer 勾选时，输出的 PDF 头部和尾部不会输

出光绘文件名。取消勾选，输出的 PDF

头部和尾部会输出光绘文件名。 

ProPerty Options 勾选时，输出的 PDF 会携带勾选的选项

信息。可勾选的选项为 Comp Tree、

Net Tree、TestPoint Tree、Pin、

Via、Cline、Shape。 

Comp Tree 勾选时，器件的相关信息可以输出到

PDF 上。取消勾选，则不输出。 

Net Tree 勾选时，网络的相关信息可以输出到

PDF 上。取消勾选，则不输出。 

TestPoint Tree 勾选时，每个测试点的相关信息可以输

出到 PDF 上。取消勾选，则不输出。 

Pin 勾选时，输出的 PDF 上的 Pin 可单击，

单击后出现提示。取消勾选，则 PDF 上

的 Pin 不可单击。 

Via 勾选时，输出的 PDF 上的 Via 可单击，

单击后出现提示。取消勾选，则 PDF 上

的 Via 不可单击。 

Cline 勾选时，输出的 PDF 上的 Cline 可单

击，单击后出现提示。取消勾选，则

PDF 上的 Cline 不可单击。 

Shape 勾选时，输出的 PDF 上的 Shape 可单

击，单击后出现提示。取消勾选，则

PDF 上的 Shape 不可单击。 
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参数名称 说明 

Security 勾选时，可进行安全设置。取消勾选，

不进行安全设置。 

Document open password 输入设置打开文件需要的密码，打开

PDF 前输入密码才能打开。勾选

Security 时，才配置此项。 

Permissions password 输入密码设置加密，无法编辑、打印、

复制 PDF。勾选 Security 时，才配置此

项。 

Output PDF in black and white mode 勾选时，按照黑白模式输出 PDF。取消

勾选，按照彩色模式输出 PDF。 

Create separate PDF file for each art 

film 

勾选时，对每个光绘文件生成的 PDF 文

件分开输出，输出多个 PDF 文件。取消

勾选，多个光绘文件的 PDF 合成在一起

输出，输出多页的一个 PDF 文件。 

Create PDF optimized for print(no 

meta data but smaller files) 

勾选时，输出的 PDF 文件将会更小。 

Display Component by RefDes 

without the package name 

勾选时，通过位号显示没有名称的器

件。取消勾选，则不显示。 

 

步骤 4 配置完成后，单击“Export”导出文件。 

步骤 5 单击“View Path”查看 PDF 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.11 导出跨板拷贝文件（Copy Reference Design） 

本章节为您介绍如何导出跨板拷贝文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在菜单栏选择“File>Export>Copy Reference Design”。 

步骤 3 在编辑器右侧“Options”窗口页面选择参数，参数说明请参见表 3-7。 

图3-43 目标参数 

 

 

表3-7 目标参数说明 

参数名称 说明 

Create missing non-conductor layers 在导入文件时，不存在的子类会添加到

目标层。 

Preserve Refdes 保留位号。 

Preserve nets of shapes 保留铜箔网络。 

Preserve net of vias 保留过孔网络。 

Preserve Testpoints on vias 保留测试点。 

 

步骤 4 在“Find”窗口页面选择对象后，在单板文件中框选需要拷贝的数据。 
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图3-44 Find 命令窗口对象 

 

 

步骤 5 单击页面任意位置弹出弹窗。 

步骤 6 在弹窗中填写文件名（存放路径和文件名称不能包含中文），单击“保存”将所选的

对象保存到本地。 

图3-45 导出跨板拷贝文件 
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----结束 

3.4.1.6.12 导出元器件（Placement） 

本章节为您介绍如何导出元器件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>Placement...”。 

步骤 3 在弹出的“Export Placement”页面中，导出文件。 

1. 单击 Placement file 后的 ，选择文件导出的保存路径（存放路径和文

件名称不能包含中文）。 

2. 单击“Export”导出文件。 

图3-46 导出元器件 

 

 

----结束 

3.4.1.6.13 导出封装补偿文件（Pin Delay） 

本章节为您介绍如何导出封装补偿文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>Pin Delay...”。 
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步骤 3 在弹出的“Pin Delay Export”页面中，导出文件。 

1. 在画布中单选需要导出的器件。 

2. 单击 Pin delay file 后的 ，选择文件导出的保存路径（存放路径和文件

名称不能包含中文）。 

3. 单击“Export”导出文件。 

图3-47 导出封装补偿文件 

 

 

----结束 

 

3.4.1.6.14 导出 TXT 文件（DbExport） 

本章节为您介绍如何导出 txt 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export> DbExport…”。 

步骤 3 在 DbExport file 后的输入框输入导出的文件名，一般默认为当前文件名（存放路径和

文件名称不能包含中文）。 

步骤 4 在 Export Options 框内勾选配置参数 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 61 

 

 

单击“Export”导出文件。 

步骤 5 单击“DbExport file”框中的路径，查看 txt 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.15 导出选中区域（AreaExport） 

本章节为您介绍如何导出选中区域的参数值 txt 文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export> AreaExport…”。 

步骤 3 在画布上选择要导出的区域。 

步骤 4 选择区域后，鼠标点击左键，在弹出框中输入文件名，点击【保存】 
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步骤 5 打开 txt 文件的存放路径，查看导出的文件。 

----结束 

3.4.1.6.16 导出 pin 文件（Pinlist） 

本章节为您介绍如何导出 pin 文件。 

操作步骤 

步骤 1 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>Pinlist”。 

步骤 3 在画布区域选择要导出的元件。 

步骤 4 选中元件后，鼠标左键点击空白处。 

步骤 5 在文件保存路径弹出框中输入文件名，点击【保存】 

步骤 6 打开 excel 文件的存放路径，查看导出的文件。 

 

----结束 
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3.4.1.6.17 导出数据到本地库（Libraries） 

本章节为您介绍如何导出数据到本地库。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Export>Libraries...”。 

步骤 3 在弹出的“Export Libraries”页面中，在 Local db name 后下拉框选择封装库，单

击“Export”。 

图3-48 导出器件库文件 

 

 

 

在导出数据前需先连接封装库，且导出的数据只能导到本地库。 

----结束 

3.4.1.7 退出（Exit） 

本章节为您介绍如何退出版图工具。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“File>Exit”。 

步骤 3 在弹出的“Question”页面中，选择是否保存当前工程文件。 
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图3-49 保存提示窗口 

 

 

步骤 4 选择完成后，在弹出的“Question”页面中，选择是否退出版图编辑器。单击

“OK”立即退出。单击“Cancel”取消退出操作。 

图3-50 退出提示窗口 

 

 

----结束 

3.4.2 编辑菜单（Edit） 

3.4.2.1 编辑基础操作 

本章节为您介绍在 PCB-DESIGN 版图编辑器中编辑版图单板文件常用的快捷操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器页面编辑常用快捷操作说明如表 3-8 所示。 
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表3-8 编辑常用快捷操作说明 

操作名称 操作步骤 

撤销

（Undo） 

在菜单栏单击“Edit>Undo”，可撤销最近在画布中对单板文件的改

动操作。 

重做

（Redo） 

在菜单栏单击“Edit>Redo”，可回到撤销动作前的状态。 

复制

（Copy） 

1. 在菜单栏单击“Edit>Copy”。 

2. 在画布中单选或者框选对象，自动复制所选对象，保存到剪切板等

待粘贴。 

粘贴

（Paste） 

与复制、剪切功能配合使用。 

1. 在画布中单选或者框选对象，复制或者剪切。 

2. 在菜单栏单击“Edit>Paste”，在画布中移动鼠标，左键单击确

定粘贴对象的位置，粘贴对象。 

选择

（Select） 

1. 在菜单栏单击“Edit>Select”。 

2. 在画布中移动鼠标单选或者框选确定的对象。 

移动

（Move） 

1. 在菜单栏单击“Edit>Move”。 

2. 在画布中单选或者框选对象，移动鼠标，左键单击确定移动对象的

位置。 

删除

（Delete） 

1. 在菜单栏单击“Edit>Delete”。 

2. 选中画布中要删除的对象，左键单击任意位置删除对象。 

旋转

（Rotate） 

1. 在菜单栏单击“Edit>Rotate”。 

2. 在编辑器右侧“Options”窗口，Angle 后的输入框输入旋转角

度。在画布中单选或者框选对象，移动鼠标旋转角度，左键单击确

定旋转对象的位置。 

修改文本

（Edit 

Text） 

1. 在菜单栏单击“Edit>Edit Text”。 

2. 在画布中选中要修改的文字对象，修改内容后鼠标左键单击画布任

意位置，鼠标右键单击 Done 保存。 

线段顶点

（Vertex） 

1. 在菜单栏单击“Edit>Vertex”。 

2. 在画布中选中需要修改的 Line 对象，移动鼠标选择顶点位置，单

击鼠标左键确定位置，鼠标右键单击 Done 保存。 

锁定 1. 在菜单栏单击“Edit>Lock”。 
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操作名称 操作步骤 

（Lock） 2. 在画布中选中要锁定的对象，鼠标右键单击 Done 保存。 

解锁

（Unlock） 

1. 在菜单栏单击“Edit>Unlock”。 

2. 在画布中选中要解锁的对象，鼠标右键单击 Done 保存。 

 

----结束 

3.4.2.2 跨层复制（Z-copy） 

本章节为您介绍在 PCB-DESIGN 版图编辑器中不同层次的铜箔复制，包含电气、非电

气层间的复制。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Edit>Z-copy”。 

步骤 3 在编辑器右侧“Options”窗口，配置拷贝参数，参数说明请参见表 3-9。 

图3-51 跨层拷贝参数配置 
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表3-9 跨层拷贝参数说明表 

参数名称 说明 

Type 铜箔填充方式，可选择 Filled（填充）、

Default（默认）、Non-filled（不填

充）。 

Copy line as line 复制线段。 

Create dynamic shape 创建动态铜箔。 

Copy 复制类型，可选择 Voids(挖空)和

Netname(网络名)。 

Size 复制后对象大小，可选择 Contract(内缩)或

者 Expand(外延)。 

Offset 对象内缩和外延的值。 

 

步骤 4 选择复制到对应的层次，在画布中选择复制的对象，系统自动显示复制后的图形，鼠

标右键单击“Done”保存。 

----结束 

3.4.2.3 原地镜像（Mirror） 

本章节为您介绍如何原地镜像 cell 和 text。cells 原地镜像，按器件 Sym Origin 为锚

点；text 原地镜像使用 Add text 中的 Text just 项位置为锚点。 

操作步骤 

步骤 1 打开版图工程。 

步骤 2 在菜单栏选择“Edit> Mirror”。 

步骤 3 在编辑器左侧“Find”窗口，勾选 Cells 或 Texts。 

步骤 4 选中 cell 后，按器件 Sym Origin 为锚点，镜像展示；text 原地镜像使用 Text just 项

位置为锚点镜像展示。 
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----结束 

3.4.2.4 更改（Change） 

本章节为您介绍如何更改走线线宽、文本粗细及排列、移动走线和文本到其他层次。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Edit>Change”。 
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步骤 3 在编辑器右侧“Options”窗口，配置对象移动的层，更改走线线宽，更改文本粗细

及排列。 

1. 勾选 Line Width，在输入框内输入线宽大小，单选或者框选对象，对象自动更改

线宽大小。 

2. 勾选 Text block 和 Text just，输入文本的粗细和选择原点的定位方式（Left、

Center、Right），单选或者框选对象，对象将自动更改文本粗细及排列。 

3. 选择对象移动的层次，勾选“Change Object Layer”，单选或者框选对象，对

象自动移到相应的层次。 

图3-52 对象更改配置 

 

 

步骤 4 操作完成后，在画布中鼠标右键单击“Done”保存。 

----结束 

3.4.2.5 对象分组（Group） 

本章节为您介绍如何设置及查看对象分组。包括新建分组、编辑分组对象、查看分组

对象和删除分组。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在菜单栏选择“Edit>Group”。 

步骤 3 在编辑器右侧“Options”窗口，进行分组设置与查看。 

⚫ 新建分组并添加对象： 

a. 在编辑器右侧“Options”窗口，单击“New”，弹出“NewGroup”页

面，输入分组名称，单击“OK”新建一个分组。 

b. 在编辑器右侧“Options”窗口，选择上一步新建的分组，在画布中单选或

者框选对象，将对象添加到该分组中，在画布中鼠标右键单击“Done”保

存。 

⚫ 编辑分组对象：在编辑器右侧“Options”窗口，选择分组列表中任意一个分

组，单击“Edit”，在画布中单选或者框选对象，将对象添加到该分组中，在画布

中鼠标右键单击“Done”保存。 

⚫ 查看分组对象：在编辑器右侧“Options”窗口，选择分组列表中任意一个分

组，该分组的对象在画布中高亮显示。单击“Info”可查看分组的对象信息。 

⚫ 删除分组：在编辑器右侧“Options”窗口，选择分组列表中任意一个分组，单

击“Delete”，在弹窗中单击“Yes”删除分组。 

图3-53 Options 分组配置 

 

 

----结束 
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3.4.2.6 属性管理器（Property） 

本章节为您介绍如何使用属性管理器定义和查看对象属性及自定义属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Edit>Property...”。 

步骤 3 在弹出的“Property”页面中选择“Manager”页签定义和查看对象属性。 

1. 在页面左侧“Available Properties”下方的下拉框选择对象类型，可选择 All、

Groups、Components、Cells、Pins、Vias、Nets、Enets、Guidelines、

Dimension、Traces、Lines、Areas、Cutouts、Texts、DRC Marks。 

2. 在页面左侧属性列表中单击某一类属性，再单击“Apply”。 

3. 在画布中单选或者框选要定义属性的对象。 

4. 右侧“Object Properties”下自动显示添加的所有对象、属性及属性值。画布中

也自动高亮显示该对象。 

图3-54 定义对象属性 

 

 

步骤 4 在页面右侧“Object Properties”可对属性列表进行编辑。 

⚫ 单击 可以按降序排序，单击 可以按升序排序。 
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⚫ 右侧属性列表中勾选对象属性前的方框，单击 可以删除对象属性。 

⚫ 右侧属性列表中勾选对象属性前的方框，单击 可以批量修改属性值。 

⚫ 右侧属性列表中勾选对象属性前的方框，勾选“Filter”只显示已选择的属性。 

步骤 5 在弹出的“Property”页面中选择“Define”页签可自定义属性。 

⚫ 新增属性：在“Available Properties”中单击“Add”可以新增属性。在弹窗中

输入属性名称，单击“OK”。在“Data Elements”中勾选对象类型，在 Data 

Type 后的下拉框选择数据类型，单击“Apply”。 

⚫ 修改属性：在“Available Properties”中选择对象属性，在“Data Elements”

中勾选需要修改的对象类型，单击“Apply”。 

⚫ 复制属性：在“Available Properties”中单击“Copy”可以复制属性。在弹窗

中输入属性名称，单击“OK”。在“Data Elements”中勾选对象类型，在 Data 

Type 后的下拉框选择数据类型，单击“Apply”。 

⚫ 删除属性：在“Available Properties”中选择需要删除的属性，单击

“Delete”。只可删除自定义的属性，系统默认设置的属性不可删除。 
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图3-55 自定义属性 

 

 

----结束 

3.4.2.7 配置网络飞线（Configure Net） 

本章节为您介绍如何给对象配置网络飞线。两个焊盘之间的网络连接叫网络飞线，也

称鼠线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Edit>Configure Net”。 

步骤 3 在画布中选择一个网络，在编辑器右侧“Options”窗口配置 No Rat(false/true)和

Voltage，单击“Apply”完成配置。 
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1. 在 No Rat 后的下拉框选择，可选择 false（显示网络飞线）、true（不显示网络

飞线）。 

2. 在 Voltage 后的输入框可设置为 none 或者非 none。设置为非 none 且是数值

后，飞线显示为地网络的样式。 

3. 在画布中鼠标右键单击“Done”保存。 

图3-56 配置网络飞线 

 

 

----结束 

3.4.3 显示菜单（Display） 

3.4.3.1 单板文件缩放基础操作 

本章节为您介绍在编辑器中对单板文件缩放的基础操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器页面常用单板文件缩放操作说明如表 3-10 所示。 

表3-10 单板文件缩放常用快捷操作说明 

操作名称 操作步骤 

适应窗口（Zoom Fit） 菜单栏选择“Display>Zoom Fit”，或

按快捷键 F2，画布中单板文件将以原点

为中心适应显示当前单板文件中的所有

对象。 
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操作名称 操作步骤 

放大（Zoom In） 画布中单板文件将以鼠标为中心放大，

方便查看。 

单板文件放大，有如下两种操作方式。 

⚫ 菜单栏选择“Display>Zoom In”，

或按快捷键 F11。 

⚫ 向前滑动鼠标滚轮。 

缩小（Zoom Out） 画布中单板文件将以鼠标为中心缩小。 

单板文件缩小，有如下两种操作方式。 

⚫ 菜单栏选择“Display>Zoom 

Out”，或按快捷键 F12。 

⚫ 向后滑动鼠标滚轮。 

指定区域放大（Zoom Area） 菜单栏选择“Display>Zoom Area”，

鼠标左键在画布中框出需要放大的区

域，松开鼠标左键，指定区域将会被放

大显示。 

 

----结束 

3.4.3.2 状态显示（Status） 

本章节为您介绍如何查看单板连接状态、未连接铜箔、DRC 状态报告。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display>Status... ”。 

步骤 3 在弹出的“Status”页面中，查看对象状态、报告。 

步骤 4 在“Status”列查看对象连接状态，绿色标识表示报告正常。黄色标识表示警告。红

色标识表示报告异常，需要处理。 
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图3-57 Status 页面 

 

 

步骤 5 在“Report”列单击 图标，弹出的页面中显示相应的报告。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示报告文件。 

⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当前

报告文件。 
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⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 

图3-58 报告显示界面 

 

 

步骤 6 在弹出的“Status”页面中，单击“Update”可刷新“DRC errors”数据。单击

“Refresh”可刷新页面数据。 
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图3-59 Status 页面 

 

 

----结束 

3.4.3.3 查询（Info） 

本章节为您介绍如何在编辑器中查看对象属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display>Info”。 

步骤 3 在“Find”命令窗口选择对象类型，画布中单选或者框选对象，在弹出的“Show 

Info”页面中，显示全部对象的属性。 
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图3-60 Info 属性页面 

 

 

----结束 

3.4.3.4 测量（Measure） 

本章节为您介绍如何测量画布中两对象之间的间距和铜箔宽度大小。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display>Measure”。 

步骤 3 在画布中单击测量的起点，然后单击测量的终点，在弹出的“Measure”页面中，显

示测量对象的间距数据。 
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图3-61 显示测量数据页面 

 

 

----结束 

3.4.3.5 查看对象规则信息（Constraint） 

本章节为您介绍如何在编辑器中查看对象物理与间距规则约束。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display>Constraint”。 

步骤 3 在“Find”命令窗口选择对象类型，画布中单选或者框选对象。 

步骤 4 在弹出的“Show Constraints”页面中，显示所有对象的物理约束和间距约束。可在

页面中进行如下操作。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示文件规则约束。 
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⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当前

规则约束文件。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 

图3-62 Show Constraints 规则显示页面 

 

 

----结束 

3.4.3.6 高亮/颜色显示基础操作 

本章节为您介绍在编辑器中对象显示的基础操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器单板文件常用显示操作说明如表 3-11 所示。 
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表3-11 显示常用快捷操作说明 

操作名称 操作步骤 

高亮显示（Highlight） 菜单栏选择“Display>Highlight”，选择

颜色类型，选择形状类型，在画布中单选或

者框选对象，自动高亮显示。 

取消高亮显示（Dehighlight） 菜单栏选择“Display>Dehighlight ”，取

消高亮显示有如下两种操作方式。 

⚫ 单选或者框选高亮对象，取消高亮显示。 

⚫ 在编辑器右侧“Options”窗口，选择

“Nets”取消全部网络高亮显示。选择

“Cells”取消全部器件高亮显示。选择

“Pins”取消全部 pin 高亮显示。选择

“All”取消全部对象高亮显示。 

阴影显示（Shadow Toggle） 菜单栏选择“Display>Shadow Toggle”，

在画布中除高亮显示的对象，其他对象将会

阴影显示。 

网络颜色显示（Nets Color） 1. 菜单栏选择“Display>Nets Color”。 

2. 在弹出的“Nets Color”页面中，选择网

络，选择颜色类型，单击 。单击

“Apply”，然后单击“OK”。 

 

----结束 

 

在阴影显示模式下，高亮显示中没有勾选“Bright hilight”，画布中全部对象将会阴影显示。 

3.4.3.7 图层翻转显示（Flip Design） 

本章节为您介绍如何在编辑器中进行图层翻转显示操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在 PCB-DESIGN 版图编辑器中图层翻转有三种方式。 

⚫ 支持菜单栏选择 

a. 在菜单栏选择“Display>Flip Design ”，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷键操作 

a. 给图层翻转设置快捷键，操作方法请参见 3.19.2 自定义配置临时快捷键。 

b. 执行快捷键命令后，画布中自动显示翻转后的图层。 

c. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷命令搜索 

a. 在命令窗口下方“Type command here”栏输入“flip design”，按回车

键，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

 

进入翻转状态后，右下角会有“Flip Design Mode”提示。 

----结束 

 

3.4.3.8 保存环境配置文件（Save Layer View） 

本章节为您介绍将 Layerset 保存为环境配置文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器点击 Save Layer View。 
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步骤 3 在环境配置层创建文件，显示文件和文件保存路径。 
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步骤 4 配置层文件在 layerselist 只能查看不能修改。 
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----结束 

3.4.3.9 隐藏 DRC 基础操作（Waive DRCs） 

本章节为您介绍在编辑器中对隐藏 DRC 的基础操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器中隐藏 DRC 的基础操作说明如表 3-12 所示。 
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表3-12 隐藏 DRC 检查的基础操作说明 

操作名称 操作步骤 

隐藏 DRC（Waive） 1. 菜单栏选择“Display>Waive DRCS>Waive”。 

2. 在画布中双击 DRC 或者框选 DRC 并单击任意位置，选

中的 DRC 会自动变成红色。 

显示隐藏 DRC

（Show） 

显示隐藏的 DRC 需要配合不显示隐藏 DRC 使用，先操作

不显示隐藏 DRC 才能进行显示隐藏的 DRC 操作。 

菜单栏选择“Display>Waive DRCS>Show”，画布中系

统自动显示红色 DRC。 

不显示隐藏 DRC

（Blank） 

菜单栏选择“Display>Waive DRCS>Blank”，画布中不

显示红色 DRC。 

恢复 DRC

（Restore） 

1. 菜单栏选择“Display>Waive DRCS>Restore”。 

2. 在画布中双击隐藏的 DRC 或者框选并单击任意位置，选

中的 DRC 会自动恢复隐藏。 

恢复全部 DRC

（Restore All） 

1. 菜单栏选择“Display>Waive DRCS>Restore All”。 

2. 在打开弹窗单击“OK”，恢复隐藏。 

 

----结束 

3.4.3.10 打开/关闭飞线（All On/All Off） 

本章节为您介绍如何全开或全关网络飞线，不同模式下打开/关闭飞线。 

前提条件 

已配置网络飞线，具体操作请参见 3.4.2.7 配置网络飞线（Configure Net）。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器页面常用飞线开/关操作设置说明如表 3-13 所示。 
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表3-13 飞线开/关基础操作设置 

操作名称 操作步骤 

全开（All On） 菜单栏选择“Display > Guidelines > All On”，自动打开

全部飞线。 

全关（All Off） 菜单栏选择“Display >Guidelines  > All Off”，自动关闭

全部飞线。 

打开/关闭模式

（Custom） 

菜单栏选择“Display > Guidelines > Custom”，网络飞

线的打开和关闭有如下三种操作方式。 

⚫ 按网络打开/关闭 

1. 在“Guidelines”栏选择网络“Net”。 

2. 选择打开按钮“Show Rats”或者选择关闭按钮

“Blank Rats”。 

3. 单击画布中的对象，自动打开或者关闭飞线。 

⚫ 按器件打开/关闭 

1. 在“Guidelines”栏选择器件“Components”。 

2. 选择打开按钮“Show Rats”或者选择关闭按钮

“Blank Rats”。 

3. 单击画布中的对象，自动打开或者关闭飞线。 

⚫ 按器件与器件打开/关闭 

1. 在“Guidelines”栏选择器件“Components-

Components”。 

2. 选择打开按钮“Show Rats”或者选择关闭按钮

“Blank Rats”。 

3. 选择画布中的一个对象，在选择另一对象，单击

“OK”自动打开或者关闭飞线。 

 

----结束 

3.4.3.11 格点（Grids） 

本章节为您介绍编辑器中如何进行格点设置。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display > Grids...”。 

步骤 3 在弹出的“Define Grid”页面中，选择格点类型。单击 Type 下的格点类型前的圆圈

选择格点类型，可选择 Place（器件），Trace（走线），Via（过孔），Other（其

他）。 

步骤 4 单击 新增格点。 

步骤 5 在弹出的“Add Grid”页面中，在 GridName 后的输入框填写格点名称，单击

“OK”。 

步骤 6 选择新增的格点，修改格点间距、格点偏移量，单击“OK”。 

图3-63 格点设置 

 

 

步骤 7 在编辑器底部的格点栏选择新增的格点，单击格点的快捷图标 打开格点，再次单

击关闭格点。 
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图3-64 显示新增格点 

 

 

----结束 

3.4.3.12 打开/关闭网络关系简化模式（Schedule Net/UnSchedule Net） 

本章节为您介绍简化对象网络关系的基础操作。飞线在显示上不是单一连接的网络。

在查看飞线网络时，飞线会根据对象的距离和位置进行各种绕线处理，导致不能清晰

的看到对象之间的连接关系。需要对飞线网络进行简化，更方便的去观察两对象的网

络关系。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器中简化网络关系的基础操作说明如表 3-14 所示。 

表3-14 简化网络关系基础操作说明 

操作名称 操作步骤 

打开网络关系简化模式（Schedule 

Net） 

1. 菜单栏选择“Display > Schedule 

Net”。 

2. 单击需要查看的对象，与它相关的飞



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 92 

 

操作名称 操作步骤 

线网络就会悬挂在鼠标上，下移鼠标

能清晰看到对象之间的网络关系。 

关闭网络关系简化模式（UnSchedule 

Net） 

菜单栏选择“Display > UnSchedule 

Net”，关闭简化网络关系。 

 

----结束 

3.4.3.13 自定义工具栏（Customize Toolbar） 

本章节为您介绍如何自定义工具栏。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可增加或者删除一级菜单。 

⚫ 选择“Toolbar group”页签，在 Group Name 后的输入框输入菜单名称，单击

“Add”增加一级菜单。 

⚫ 选择“Toolbar group”页签，在左侧菜单列表中选择菜单，单击“Delete”删

除一级菜单。 
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图3-65 一级菜单工具栏设置 

 

 

步骤 4 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Place、Route、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 

3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 

6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 
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图3-66 设置工具栏快捷图标 

 

 

----结束 

3.4.4 绘制菜单（Drawing） 

3.4.4.1 非电气走线（Line） 

本章节为您介绍如何绘制非电气属性走线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Line”。 

步骤 3 在编辑器右侧“Options”窗口，配置走线的类型、拐角方向角度和线宽。 

1. 走线类型：单击 Line lock 后的第一个下拉框选择，可选择 Line（直线）和 Arc

（弧线）两种类型。 

2. 拐角方向角度：单击 Line lock 后的第二个下拉框选择，可选择 45、90 和 any。 

3. 线宽：在 Line Width 后的输入框输入线宽。 
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图3-67 线段配置 

 

 

步骤 4 在画布中进入绘制走线状态。 

1. 左键单击确定走线起点。 

2. 移动鼠标，左键单击生成拐点。 

3. 再次左键单击确定走线终点，右键单击“Next”或者右键单击“Done”，完成

走线绘制。 

图3-68 绘制线段 

 

 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 96 

 

 

⚫ 右键单击“Next”完成当前走线绘制，不会退出绘制状态，可重新绘制新的走线。 

⚫ 右键单击“Done”完成走线绘制，保存并退出绘制状态。 

⚫ 当走线拐角角度设置为 90°时，根据鼠标位置自动生成拐点。 

⚫ 拐点固定后，移动鼠标，拐点前的走线不会再变化。 

⚫ 绘制走线过程中，右键单击“Oops”可退回落点。 

⚫ 绘制走线过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制走线过程中，右键单击“Toggle”可调整走线方向。 

⚫ 绘制走线过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.2 圆弧（Arc） 

本章节为您介绍如何绘制圆弧。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Arc”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆弧的线宽和拐角方向角度。 

1. 线宽：在 Line Width 后的输入框输入线宽。 

2. 拐角方向角度：单击 Lock angle 后的下拉框选择，可选择 0、45、90、135、

180、225、270、315。 

图3-69 圆弧配置 
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步骤 4 在画布中进入绘制圆弧状态。 

1. 左键单击确定圆弧中心点，在左键单击确定圆弧起点。 

2. 移动鼠标，左键单击确定圆弧终点，完成绘制。 

3. 圆弧绘制完成，将保持绘制圆弧状态，同时整个圆弧被选中。也可右键单击

“Done”完成圆弧绘制，保存并退出绘制状态。 

图3-70 绘制圆弧 

 

 

 

⚫ 右键单击“Done”完成圆弧绘制，保存并退出绘制状态。 

⚫ 绘制圆弧过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆弧过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆弧过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.3 圆线（Circle Line） 

本章节为您介绍如何绘制圆线。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Circle Line”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆的线宽和格点类型。 

1. 线宽：在 Line Width 后的输入框输入线宽。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

图3-71 圆线配置 

 

 

步骤 4 在画布中进入绘制圆线状态。 

1. 左键单击确定圆线中心点。 

2. 移动鼠标，左键单击确定圆线上任意一点，完成绘制。 

3. 圆线绘制完成，将保持绘制圆线状态，同时整个圆线被选中。也可右键单击

“Done”完成圆线绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图3-72 绘制圆线 

 

 

 

⚫ 右键单击“Done”完成圆线绘制，保存并退出绘制状态。 

⚫ 绘制圆线过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆线过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆线过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.4 圆形（Circle） 

本章节为您介绍如何绘制圆形区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Circle ”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆形的铜箔填充类型和格点类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图3-73 圆形区域配置 

 

 

步骤 4 在画布中进入绘制圆形区域状态。 

1. 左键单击确定圆形区域中心点。 

2. 移动鼠标，左键单击确定圆形上任意一点，完成绘制。 

3. 圆形区域绘制完成，将保持绘制圆形状态，同时整个圆形被选中。也可右键单击

“Done”完成圆形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图3-74 绘制圆形区域 

 

 

 

⚫ 右键单击“Done”完成圆形区域绘制，保存并退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.5 扇形（Fan area） 

本章节为您介绍如何绘制扇形区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Fan area ”。 

步骤 3 在编辑器右侧“Options”窗口，配置扇形的铜箔填充类型和拐角方向角度。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 
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2. 拐角方向角度：单击 Lock angle 后的下拉框选择，可选择 0、45、90、135、

180、225、270、315。 

图3-75 扇形区域配置 

 

 

步骤 4 在画布中进入绘制扇形区域状态。 

1. 左键单击确定扇形区域中心点，在左键单击确定扇形区域起点。 

2. 移动鼠标，左键单击确定扇形区域终点，完成绘制。 

3. 扇形区域绘制完成，将保持绘制扇形状态，同时整个扇形被选中。也可右键单击

“Done”完成扇形区域绘制，保存并退出绘制状态。 

图3-76 绘制扇形区域 
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⚫ 右键单击“Done”完成扇形区域绘制，保存并退出绘制状态。 

⚫ 绘制扇形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制扇形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制扇形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.6 矩形（Rectangle） 

本章节为您介绍如何绘制矩形区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Rectangle”。 

步骤 3 在编辑器右侧“Options”窗口，配置矩形的铜箔填充类型、格点类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图3-77 矩形区域配置 

 

 

步骤 4 在画布中进入绘制矩形区域状态。 

1. 左键单击确定矩形区域左上角坐标位置。 

2. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成绘制。 

3. 矩形区域绘制完成，将保持绘制矩形状态，同时整个矩形被选中。也可右键单击

“Done”完成矩形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

a. 矩形长度：在 Width 后的输入框输入长度。 

b. 矩形宽度：在 Height 后的输入框输入宽度。 

c. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner、Round。 
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d. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入框输入

倒角大小，左下角 后的输入框输入倒角大小，右下角 后的输入框输入倒

角大小。 

图3-78 绘制矩形区域 

 

 

 

⚫ 右键单击“Done”完成矩形区域绘制，保存并退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制矩形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.7 多边形（Polygon） 

本章节为您介绍如何绘制多边形区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Polygon”。 

步骤 3 在编辑器右侧“Options”窗口，配置多边形的铜箔填充类型、格点类型和拐角线段

类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 
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2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-79 多边形区域配置 

 

 

步骤 4 在画布中进入绘制多边形区域状态。 

1. 左键单击确定多边形区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相连，

右键单击“Complete”，完成绘制。 

4. 多边形区域绘制完成，将保持绘制多边形状态，同时整个多边形被选中。也可右

键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 
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图3-80 绘制多边形区域 

 

 

 

⚫ 右键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制多边形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制多边形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.8 新增文本（Add Text） 

本章节为您介绍如何新增文本。文本框增加文本便于对版图进行注释。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Add Text”。 

步骤 3 在编辑器右侧“Options”窗口，选择是否镜像、配置文本放置位置、文本比例和旋

转方向。 

1. 镜像：勾选 Mirror 前的方框，显示镜像。取消勾选，不显示镜像。 

2. 文本放置位置：单击 Text just 后的下拉框选择，可选择 Left、Right、Center。 
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3. 文本比例：在 Text block 后的输入框输入比例。 

4. 旋转方向：单击 Rotate 后的下拉框选择，可选择 0、45、90、135、180、

225、270、315。 

图3-81 文本配置 

 

 

步骤 4 在画布中单击需要添加文本的位置，在文本框中输入文本，单击文本框外任意位置进

行保存或者按键盘“Enter”键保存。如 a789 所示。 

图3-82 添加文本 
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----结束 

3.4.4.9 修剪倒角（Trim） 

本章节为您介绍如何对铜箔进行修剪倒角。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Trim”。 

步骤 3 在编辑器右侧“Options”窗口，配置倒角的修剪方式和格点类型。 

1. 修剪方式：单击修剪方式前的圆圈，可选择 corner、round、polygon。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

图3-83 修剪倒角配置 

 

 

步骤 4 在画布中，根据修剪倒角方式类型，修剪倒角。 

⚫ 倒斜角 
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a. 单击 corner 前的圆圈，在 corner 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 

图3-84 倒斜角示图 

 

 

⚫ 倒圆角 

a. 单击 round 前的圆圈，在 round 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 
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图3-85 倒圆角示图 

 

 

⚫ 多边形修剪倒角 

a. 单击 polygon 前的圆圈，在 polygon 后的下拉框选择拐角线段类型，可选

择 Line、Line45、Line Orthogonal、Arc。 

b. 在画布中单击对象垂直线边沿。 

c. 移动鼠标，单击对象水平线边沿，剪切成功。 
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图3-86 多边形修剪倒角示图 

 

 

----结束 

3.4.4.10 绘制区域（Areas） 

3.4.4.10.1 绘制器件放置区（Placement Area） 

本章节为您介绍如何绘制器件放置区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Placement Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 
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图3-87 绘制器件放置区配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-88 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.2 绘制器件禁布区（Inhibit Place） 

本章节为您介绍如何绘制器件禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Inhibit Place”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-89 绘制器件禁布区配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-90 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.3 绘制器件限高区（Placement Height） 

本章节为您介绍如何绘制器件限高区域。 

器件禁布区配置器件限高区域 

步骤 1 3.2 打开版图工程。 

步骤 2 绘制器件禁布区。 

1. 在菜单栏选择“Drawing>Rectangle”。 

2. 在编辑器右侧“Options”窗口中，选择“Inhibit Place”层。 

3. 在画布中绘制器件禁布区。 
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图3-91 绘制禁布区 

 

 

步骤 3 给绘制的器件禁布区配置限高数据。 

1. 在菜单栏选择“Edit>Property...”。 

2. 在弹出的“Property”页面中选择“Manager”页签。 

3. 在页面左侧属性列表中选择“PACKAGE_HEIGHT_MAX”属性，再单击

“Apply”。 

4. 在画布中选择添加限高的器件禁布区图形。 

5. 在 Value 列表下修改限高值。 

6. 配置完成后单击“OK”。 

图3-92 配置限高数据 

 

 

步骤 4 在菜单栏选择“Display>Info”。 

步骤 5 在“Find”命令窗口选择 Area，画布中单选器件禁布区，在弹出的“Show Info”页

面中，显示器件限高的属性。 
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图3-93 查看限高属性 

 

 

 

当禁布区和 Placement 的高度区域有重叠，且禁布区和 Placement 几何形状有重叠，同时违反

才报 DRC 错误。 

----结束 

器件 Placement 配置器件限高区域 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Placement Height”。 

步骤 3 在画布中单击器件的边界区域（Placement）。 

步骤 4 在编辑器右侧“Options”窗口，填写区域的最小高度和最大高度。 

1. 区域最小高度：在 Min height 后的输入框输入最小高度。 

2. 区域最大高度：在 Max height 后的输入框输入最大高度。 
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图3-94 绘制器件限高区域配置 

 

 

步骤 5 填写完成后，在画布中右键单击“Done”保存。 

步骤 6 在菜单栏选择“Display>Info”。 

步骤 7 在“Find”命令窗口选择 Area，画布中单选器件的边界区域（Placement），在弹出

的“Show Info”页面中，显示器件限高的属性。 

图3-95 查看限高属性 

 

 

 

当禁布区和 Placement 的高度区域有重叠，且禁布区和 Placement 几何形状有重叠，同时违反

才报 DRC 错误。 

----结束 
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3.4.4.10.4 绘制走线禁布区（Inhibit Route） 

本章节为您介绍如何绘制走线禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas> Inhibit Route”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-96 绘制走线禁布区域配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 
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3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 

图3-97 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.5 绘制走线区（Route Area） 

本章节为您介绍如何绘制走线区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Route Area”。 
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步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-98 绘制走线区域配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 123 

 

图3-99 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.6 绘制电气属性走线禁布区（Inhibit Trace） 

本章节为您介绍如何绘制电气属性走线禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Inhibit Trace”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-100 绘制电气属性走线禁布区配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-101 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.7 绘制过孔禁布区（Inhibit Via） 

本章节为您介绍如何绘制过孔禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Inhibit Via”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-102 绘制过孔禁布区配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-103 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.8 绘制禁布区（Inhibit Area） 

本章节为您介绍如何绘制禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Areas > Inhibit Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-104 绘制禁布区域配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-105 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.10.9 绘制测试点禁布区（Inhibit Probe） 

本章节为您介绍如何绘制测试点禁布区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Inhibit Probe”。 

步骤 3 在编辑器右侧“Options”窗口，配置区域的铜箔填充类型、格点类型和拐角线段类

型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图3-106 绘制测试点禁布区域配置 

 

 

步骤 4 在画布中进入绘制区域状态。 

1. 左键单击确定区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定区域的最后一个顶点，首个顶点会和最末的顶点自动相连，右

键单击“Complete”，完成绘制。 

4. 区域绘制完成，将保持绘制状态，同时整个区域图形被选中。也可右键单击

“Done”完成区域绘制，保存并退出绘制状态。 
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图3-107 绘制区域示图 

 

 

 

⚫ 右键单击“Done”完成区域绘制，保存并退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.4.11 绘制板框（Create Outline） 

3.4.4.11.1 手动绘制板框 

本章节为您介绍如何手动绘制板框。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Create Outline”。 

步骤 3 在编辑器右侧“Options”窗口，配置绘制板框区域的方式、勾选是否同时绘制走线

区域、勾选是否同时绘制器件放置区域和格点类型。 
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1. 绘制板框区域的方式：单击 Option 下绘制方式前的圆圈，可选择 Rectangle、

Circle、Polygon。 

2. 同时绘制走线区域：勾选 Route Area/All 前的方框，在绘制板框的同时绘制所有

图层走线区域，在 Contract size 后输入框填写区域避开板框距离大小。取消勾

选，不同时绘制走线区域。 

3. 同时绘制器件放置区域：勾选 Placement Area/All 前的方框，在绘制板框的同时

绘制所有图层器件放置区域，在 Contract size 后输入框填写区域避开板框距离大

小。取消勾选，不同时绘制器件放置区域。 

4. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

图3-108 绘制板框配置 

 

 

步骤 4 在画布中进入绘制板框状态。 

⚫ 选择矩形方式绘制板框操作步骤如下。 

a. 左键单击基准点，确定矩形区域左下角坐标位置， 
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b. 移动鼠标，左键单击确定矩形区域右上角坐标位置。 

c. 右键单击“Complete”，矩形区域绘制完成，将保持绘制矩形状态。 

也可右键单击“Done”完成矩形区域绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，配置矩形区域长度和宽度、倒角类型和大

小。 

i. 矩形长度：在 Width 后的输入框输入长度。 

ii. 矩形宽度：在 Height 后的输入框输入宽度。 

iii. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner、Round。 

iv. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 

图3-109 矩形板框示图 

 

 

⚫ 选择圆形方式绘制板框操作步骤如下。 

a. 左键单击确定圆形区域中心点。 

b. 移动鼠标，左键单击确定圆形上任意一点。 

c. 右键单击“Complete”，圆形区域绘制完成，将保持绘制圆形状态。 

也可右键单击“Done”完成圆形区域绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，在 Raduis 后的输入框修改圆形区域大小。 
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图3-110 圆形板框示图 

 

 

⚫ 选择多边形方式绘制板框操作步骤如下 

a. 左键单击基准点，确定多边形区域一个顶点位置。 

b. 移动鼠标，左键单击确定另一个顶点，以此类推。 

c. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连。 

d. 右键单击“Complete”，完成多边形区域绘制，将保持绘制多边形状态。 

也可右键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 

图3-111 多边形绘制板框示图 

 

 

步骤 5 在菜单栏选择“Edit>Z-copy”。 
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步骤 6 选择板框放置“Panel_Outline”层，在画布中选择复制的板框图形。 

图3-112 选择复制层次 

 

 

步骤 7 系统自动显示复制后的图形到对应层次，鼠标右键单击“Done”保存。 

----结束 

3.4.4.11.2 使用 DXF 绘制板框 

本章节为您介绍如何使用 DXF 绘制板框。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 导入 DXF 结构图文件，具体操作步骤请参见 3.4.1.5.2 导入结构图文件（DXF）。 

步骤 3 在菜单栏选择“Edit>Copy”，在画布中单选或者框选结构图外形边框。 

步骤 4 在菜单栏选择“Route>Compose Area”，在画布中单选或者框选结构图外形边框。 
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图3-113 结构图外形边框示图 

 

 

步骤 5 单击“Panel_Outline”前的方框，将结构图外形边框从“MCAD_Detail”层复制到

“Panel_Outline”层里。 

图3-114 复制界面 

 

 

 

如果导入的 DXF 文件不在画布中，选择“Setting>Tool setting>Design Parameter”设置画

布区域大小，在 X 轴和 Y 轴输入大小即可，具体数值自行考量，设置完成后将 DXF 结构图移动

到基准点位置。 

----结束 
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3.4.4.12 标注（Dimension） 

本章节为您介绍如何对标注层进行标注。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing > Dimension”。 

步骤 3 在编辑器右侧“Options”窗口，配置标注参数。 

1. 在图层下拉框选择 Dimension，单击图层前的方框显示画布中的对象。 

2. 操作模式：单击 Mode 下操作模式前的圆圈，选择 Add。 

3. 标注类型：单击 Type 后的下拉框选择，可选择 Linear dimension、Datum 

dimension、Angular dimension、Leader line、Diametral leader、Radial 

leader、Balloon leader、Chamfer leader。 

4. 文本比例：在 Text block 后的输入框输入比例。 

图3-115 标注配置 

 

 

步骤 4 根据选择标注的类型，在画布中进行标注操作。 

⚫ Linear dimension 标注类型：用以标注线性之间或两点之间的距离。 

⚫ Datum dimension 标注类型：用以对一个参考点输入标注数据（高密度标注）。 

⚫ Angular dimension 标注类型：标注两线夹角。 
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⚫ Leader line 标注类型：用以引出注解。 

⚫ Diametral leader 标注类型：用以标注圆弧直径。 

⚫ Radial leader 标注类型：用以标注圆弧半径。 

⚫ Balloon leader 标注类型：用以标注 Balloon。 

⚫ Chamfer leader 标注类型：用以标注 45°倒角尺寸。 

步骤 5 标注完成后，可在编辑器右侧“Options”窗口修改标注。 

1. 操作模式：单击 Mode 下操作模式前的圆圈，选择 Edit。 

2. 修改类型：单击 Edit 下的下拉框选择，可选择 Align dimension、Move text、

Mirror text、Change text、Change leader、Delete vertex。 

3. 文本内容：当修改类型选择 Change text 时，在 Text 后的输入框输入修改的文

本内容。 

----结束 

3.4.5 网络布局（Logic） 

本章节为您介绍如何对进行网络布局。 

3.4.5.1 Net Logic 指定网络 

操作步骤 

步骤 1 功能菜单栏，点击 Logic-Net Logic 

 

步骤 2 搜索网络 
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步骤 3 在右侧配置层选择窗口 Options-Top，勾选相应操作，说明如下表： 

 操作名称 操作步骤 

Create  创建网络 

Rename 修改网络 

Remove 列表移除网络 

Assign 附网络 

Deassign PIN 取消已附网络 

Ripup etch 取消的已附网络删除 PIN 的 trace 
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----结束 

3.4.5.2 part logic 新增位号 

操作注意：新增位号，必须要点击相同器件封装的有位号的器件，创建相同封装的新

增位号。 

操作步骤 

步骤 1 功能菜单栏，点击 Logic-Part Logic 

 

步骤 2 点击相同器件封装的有位号的器件，在弹窗中，RefDes 输入新增位号，点击 Add 
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步骤 3 新增器件放置有 2 种方式，如下图所示 

 

----结束 

3.4.5.3 Assign RefDes 给假器件器件指定位号 

操作前提： 

1、需要先创建/有位号。 

2、指定的器件位号的封装和当前假器件的封装一致。 

3、一个器件只能指定一个位号。 

操作步骤 

步骤 1 功能菜单栏，点击 Logic-Assign RefDes 
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步骤 2 在右侧配置层选择窗口 Options-Top，点击 Refdes 选择位号，如下图： 

 

----结束 

 

3.4.6 布局设计菜单（Place） 

3.4.6.1 连接封装库 

连接封装库后，可调用封装库的器件来绘制版图。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Settings...”。 

步骤 3 在弹出的“Setting”页面左侧中，单击“Library Connection Management”，配

置封装库，具体操作请参见表 3-15。 
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图3-116 连接封装库 

 

 

表3-15 封装库操作说明 

操作名称 操作说明 

添加本地封装

库 

1. 单击连接列表上方的 。 

2. 单击 Library Type 后的下拉框选择 Local。 

3. 在弹出的窗口，单击 Path 后的 ，选择本地库文件，

单击“打开”。 

4. 勾选“connect”前的方框，单击“OK”。 

添加远端封装

库 

1. 单击连接列表上方的 。 

2. 单击 Library Type 后的下拉框选择 Remote。 

3. 在 UserName 后的输入框输入用户名称。在 Password 后的输

入框输入用户密码。在 Database Name 后的输入框输入远端库

名称。在 IP 后的输入框输入服务端的 IP 地址。在 Port 后的输入

框输入服务端端口。 

4. 勾选“connect”前的方框，单击“OK”。 

连接封装库 1. 勾选“Connect”栏下的复选框，连接封装库。 

2. 单击“OK”保存设置。 
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操作名称 操作说明 

断开封装库 1. 取消勾选“Connect”栏下的复选框。 

2. 单击“OK”保存设置。 

删除封装库 1. 勾选连接列表前的复选框，单击列表上方 。 

2. 在弹出的提示框中，单击“Yes”。 

移动封装库顺

序 

封装库的使用优先级是按封装库排列顺序确定的，使用顺序依次为

1、2、3...。序号为 1 时，优先使用。 

⚫ 上升排序：勾选序号前的方框，单击图标 ，封装库往上移动。 

⚫ 下降排序：勾选序号前的方框，单击图标 ，封装库往下移动。 

 

----结束 

3.4.6.2 放置器件（Placement） 

3.4.6.2.1 手动放置本地库器件 

本章节为您介绍如何手动放置器件。 

前提条件 

已导入网表文件，具体操作请参见 0 导入网表文件（Netlist）。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Placement...” 。 

步骤 3 在弹出的“Placement”页面中，选择“Components”，选择器件、配置过滤类

型、放置模式、放置位置、放置比例。 

1. 在页面左侧第一个下拉框选择“Components”。 

2. 在页面左侧“Components”栏下方勾选 All，选择所有的放置器件。 

− 单击 输入名称，可以搜索器件。 

− 单击 可以收缩器件列表。 

− 单击 可以展开器件列表。 
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3. 过滤类型：在页面右侧，单击过滤类型前圆圈，可选择 Property（属性）和 Net

（网络）。Property 后的下拉框选择对象属性，按对象属性条件去筛选器件。

Net 后的下拉框选择对象网络，按对象网络条件去筛选器件。 

4. 放置模式：在页面右侧，Place mode 下单击模式前的圆圈，可选择 Manually

（手动放置）、Quickplace（快速放置）、Userpick（自定义）。 

5. 放置位置：在页面右侧，Place Edge 下勾选位置前的方框，可选择 Left（左

边）、Top（顶部）、Right（右边）、Bottom（底部）。 

6. 放置比例：勾选 Overlap componnents by 前的方框，在后面的输入框中输入放

置比例。 

7. 单击“Place”。 

图3-117 手动放置器件 

 

 

步骤 4 在打开的弹窗中，单击“OK”完成器件的放置。 

步骤 5 打开结构图图层“MCAD_Detail”，在画布中移动器件到相应的位置。 

----结束 
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3.4.6.2.2 分页布局放置本地库器件 

本章节为您介绍如何分页布局放置器件。 

前提条件 

已导入网表文件，具体操作请参见 0 导入网表文件（Netlist）。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Placement...” 。 

步骤 3 在弹出的“Placement”页面中，在页面左侧选择“Page”，单击 。 

步骤 4 在弹出的“Open File”页面，选择本地存放的原理图输出的分页布局文件（文件格

式.schcfg/.ifo），单击“打开”，然后单击“Import”导入。 

图3-118 导入分页布局文件 

 

 

步骤 5 在页面左侧勾选 All，选择器件列表所有器件，单击“Place”完成放置。 

⚫ 单击 输入名称，可以搜索器件。 
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⚫ 单击 可以收缩器件列表。 

⚫ 单击 可以展开器件列表。 

图3-119 分页布局放置器件 

 

 

 

⚫ 在画幅较小时，可选择 Scale 的比例大小来调整放置原理图时的每一页相对比例。 

⚫ 单击“Place”后，分页布局文件就会跟随在鼠标上，放置在单板的合适位置。分页布局文

件大小超过画幅大小或者放置的时候有一部分在画幅外都会放置失败。 

----结束 

3.4.6.3 更新器件与焊盘（Update） 

3.4.6.3.1 更新封装器件 

本章节为您介绍如何更新封装器件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place>Update...”。 
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步骤 3 在弹出的“Update”页面中，页面左侧选择“Footprints”，在器件列表中选择需要

更新的器件，勾选“Update padstacks from library”，参数说明请参见表 3-16。 

⚫ 单击 输入名称，可以搜索器件。 

⚫ 单击 可以收缩器件列表。 

⚫ 单击 可以展开器件列表。 

表3-16 更新封装配置参数说明 

参数名称 说明 

Update padstacks from library 更新封装中的 padstack。 

Ripup Etch 删除与器件直连的 Pin、Via。 

Reset text location and size 重置器件的丝印、位号、字号。 

Ignore FIXED property 忽略有锁定属性的对象，有锁定状态对

象也更新。 

 

步骤 4 单击“Update”更新一类封装器件。 

图3-120 更新封装器件 
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----结束 

3.4.6.3.2 更新焊盘 

本章节为您介绍如何更新焊盘。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place>Update...”。 

步骤 3 在弹出的“Update”页面中，选择“padstack ”，在器件列表中选择需要更新的焊

盘，单击“Update”更新焊盘。 

⚫ 单击“Viewlog”可查看报告。 

⚫ 单击 输入名称，可以搜索器件。 

⚫ 单击 可以收缩器件列表。 

⚫ 单击 可以展开器件列表。 

图3-121 更新焊盘 
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更新焊盘时，同一种焊盘名称的所有焊盘一次性更新。 

----结束 

3.4.6.4 封装更新（Refresh Cell Instance） 

本章节为您介绍如何在更新封装，可删除器件上带的 trace；可更新 text；更新原点十

字 line；更新封装边框 line 等。 

操作步骤 

步骤 1 打开版图工程 

步骤 2 功能菜单栏，Place >Place-Refresh Cell Instance 

步骤 3 在右侧配置层选择窗口 Options-Top，勾选相应操作，说明如下表： 

 

 

 

 

 

 

操作名称 操作步骤 

不勾选 part 下 silkscreen 不变，其它与库中保

持一致 

Ripup Etch 
更新时移除焊盘上连接的铜皮和走线 

Reset text location and size 
part 下丝印 text 恢复库中状态 

Ignore silkscreen item cell 下 silkscreen 的 line 不变，其它的

与库中保持一致 
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更新效果图如下：

 

----结束 

 

3.4.6.5 交换器件与模块（Swap） 

3.4.6.5.1 交换器件（Components） 

本章节为您介绍如何交换器件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Swap > Components”。 

步骤 3 在编辑器右侧“Options”窗口，可勾选 Maintain cell rotation（保持器件旋转）和

Maintain cell layer（保持器件层次）。 

步骤 4 在画布中单击要交换位置的两个器件，右键单击“Done”保存，交换后的效果如图

3-123 所示。 
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图3-122 器件交换前示例图 

 

 

图3-123 器件交换后示例图 

 

 

----结束 

3.4.6.5.2 交换模块（Modules） 

本章节为您介绍如何交换模块。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Swap > Modules”。 

步骤 3 在画布中单击要交换位置的两个模块，右键单击“Done”保存。交换后的效果如图

3-125 所示。 
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图3-124 模块交换前示例图 

 

 

图3-125 模块交换后示例图 

 

 

 

在交换模块操作前必须先创建模块。 

----结束 
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3.4.6.6 对齐（Align） 

本章节为您介绍如何多个器件按照指定方向对齐。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Align”。 

步骤 3 在画布中框选两个或多个要对齐的对象。 

步骤 4 在编辑器右侧“Options”窗口，配置对齐方式和设置间距大小。 

图3-126 对齐方式配置 

 

 

⚫ 垂直向左对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 
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图3-127 对齐前示图 

 

 

图3-128 对齐后示图 

 

 

⚫ 垂直居中对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 

图3-129 对齐前示图 
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图3-130 对齐后示图 

 

 

⚫ 垂直向右对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 

图3-131 对齐前示图 

 

 

图3-132 对齐后示图 

 

 

⚫ 水平向上对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 
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图3-133 对齐前示图 

 

 

图3-134 对齐后示图 

 

 

⚫ 水平居中对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 

图3-135 对齐前示图 
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图3-136 对齐后示图 

 

 

⚫ 水平向下对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 

图3-137 对齐前示图 

 

 

图3-138 对齐后示图 

 

 

----结束 

3.4.6.7 模块复用（Module reuse） 

本章节为您介绍如何创建模块复用。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 159 

 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Module reuse”。 

步骤 3 在编辑器右侧“Options”窗口，勾选 Reuse RefDes location（复用位号位置）。 

步骤 4 创建模块复用模板。 

1. 在画布中框选模块复用的器件，右键单击“Set Ret Module”。 

 

当创建的模板与之前已创建的模板有相同器件时，就会弹出“Place Replicate Warning”页

面，在页面中选择“Continue”，单击“OK”。 

⚫ 创建新的模板文件并包含已创建的模板文件选择“Continue”。 

⚫ 创建新的模板文件并不包含已创建的模板文件选择“Exclude”。 

⚫ 取消选择“Cancel”。 

图3-139 创建模板文件提示 

 

 

2. 在画布中单选或者框选模块复用其他对象（走线、过孔、铜箔），右键单击

“Snap Pick To” ，选择任意一个位置落点。 

3. 右键单击“Done”。 

4. 在画布中左键单击任意位置。在弹窗中输入文件名，一般默认路径为当前工程下

XXX\Output\ddb 名称\module_reuse（存放路径和文件名称不能包含中文），

单击“保存”。 

步骤 5 创建好的模板进行模块复用。 

1. 在菜单栏选择“Place > Module reuse”。 
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2. 在画布中框选器件，右键单击“Reuse Ret Module”，在模块复用列表中选择复

用模板。如果创建的模块复用模板保存路径不是默认路径时，单击“Browse”选

择保存的复用模板。 

图3-140 模块复用 

 

 

3. 系统自动匹配复用器件，也可根据需求自行匹配器件。 

a. 双击“Match”栏列表下的器件名称，在下拉框中选择匹配的器件。也可单

击 ，在弹窗中选择“Name”栏列表下的器件，单击“OK”。如

果双击“Match”栏列表下的器件名称显示为 时，表示没有合适的器

件进行匹配。 

b. 匹配完成后，单击“OK”。 
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图3-141 匹配复用器件 

 

 

4. 在画布中单击合适的位置放置。 

----结束 

3.4.6.8 解散模块（Disband Module） 

本章节为您介绍如何解散模块。解散模块功能会将所有的复用对象创建的模块进行打

散，复用对象将不以 group 的形式存在。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Disband Module”。 

步骤 3 在“Find”命令窗口，系统自动选择封装器件模块“Groups”。在画布中选择要解散

的模块，右键单击“Done”结束命令。 
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图3-142 解散模块操作界面 

 

 

 

解散模块前必须先创建模块，具体操作请参见 3.4.6.7 模块复用（Module reuse）。 

----结束 

3.4.6.9 更新模块（Update Module） 

本章节为您介绍如何更新模块。模块复用后多个模块可同步更新。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Update Module”。 

步骤 3 在画布中单击模块复用模板的任意一个对象，系统自动高亮显示模块复用模板的所有

对象。 

步骤 4 在画布中单选或者框选需要增加的其他对象（走线、过孔、铜箔），右键单击

“Done”保存。再右键单击“Done”结束命令。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 163 

 

图3-143 更新模块操作界面 

 

 

步骤 5 在弹出“Save Module Export File”页面中，选择模块复用旧的模板文件（.mrd 文

件），单击“保存”。 

图3-144 文件更新地址路径 

 

 

步骤 6 在弹窗中单击“Yes”，完成模块复用模板的更新，右键单击“Done”保存。 
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图3-145 确认更新模板文件 

 

 

步骤 7 画布中使用该模板的所有模块会同步更新。 

 

更新模块前必须先创建模块，具体操作请参见 3.4.6.7 模块复用（Module reuse）。 

----结束 

3.4.6.10 阵列过孔（Via Arrays） 

3.4.6.10.1 线性方式设置阵列过孔 

本章节为您介绍如何按线性的方式设置阵列过孔。阵列过孔就是在某一个区域上或者

走线周围，按照某种特定的规律，均匀整齐的放置过孔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Via Arrays”。 

步骤 3 在编辑器右侧“Options”窗口，在 Via Arrays 选择 Matrix 线性方式，配置操作模

式、常规操作、过孔网络和孔型、过孔阵列参数和过孔连接方式。参数说明请参见表

3-17。 
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图3-146 线性方式阵列过孔配置界面 

 

 

表3-17 阵列过孔 Matrix 参数说明表 

参数分类 参数名称 参数说明 

Operation 

Mode 

（操作模式） 

Board Mode 单击 Board Mode 前的圆圈选择整板模

式，整个图层都添加阵列过孔。 

Area Mode 单击 Area Mode 前的圆圈选择区域模

式，封闭图形区域添加阵列过孔，一般默

认此选项。 

Shape Mode 单击 Shape Mode 前的圆圈选择铜箔模

式，铜箔区域添加阵列过孔。 

General option Enable DRC check 进行 DRC 检查，勾选 Enable DRC check

前的方框，会自动去除不满足 DRC 要求
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参数分类 参数名称 参数说明 

（常规操作） 的过孔。 

Enable same net 

DRC check 

勾选 Enable same net DRC check 前的

方框，对相同网络的过孔进行 DRC 检

查，会自动去除不满足 DRC 要求的过

孔。勾选 Enable DRC check 时，才配置

此项。 

Enable preview 勾选 Enable preview 前的方框，可以先

预览过孔是否满足要求，在进行放置。 

Via net and 

padstack 

（过孔网络和焊

盘类型） 

Via net 
单击 Via net 下的 ，在弹窗输

入框中输入网络名，选择需要的过孔网

络，单击“OK”。 

Padstack 单击 Padstack 下的下拉框选择焊盘类

型。 

Matrix 

parameters 

（过孔阵列参

数） 

Staggered vias 勾选 Staggered vias 前的方框，过孔交错

放置。 

Via-boundary 

offset 

在 Via-boundary offset 下的输入框输入

过孔的边缘到铜箔的距离。 

Horizontal via-via 

gap 

在 Horizontal via-via gap 下的输入框输

入过孔之间的 X 轴间距。 

Vertical via-via 

gap 

在 Vertical via-via gap 下的输入框输入

过孔之间的 Y 轴间距。 

Themal relief 

connects 

（过孔连接方

式） 

Orthogonal 单击 Themal relief connects 后的下拉框

选择 Orthogonal，选择以正交的方式进

行连接。 

Diagonal 单击 Themal relief connects 后的下拉框

选择 Diagonal，选择以斜交的方式进行连

接。 

Full contact 单击 Themal relief connects 后的下拉框

选择 Full contact，选择以全连接的方式
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参数分类 参数名称 参数说明 

进行连接。 

8 Way Connect 单击 Themal relief connects 后的下拉框

选择 8 Way Connect，选择同时用正交和

斜交方式连接。 

None 单击 Themal relief connects 后的下拉框

选择 None，无连接方式。 

 

步骤 4 在画布中进入绘制线性阵列过孔状态。 

1. 左键单击确定添加区域左上角坐标位置。 

2. 移动鼠标，左键单击确定区域右下角坐标位置。 

3. 自动添加过孔并保持所有过孔被选中状态，左键单击画布任意一点，完成添加。 

图3-147 线性阵列过孔视图 

 

 

 

勾选“Enable preview”才能看到放置的阵列过孔。 

----结束 

3.4.6.10.2 环形方式设置阵列过孔 

本章节为您介绍如何按环形的方式设置阵列过孔。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Place > Via Arrays”。 

步骤 3 在编辑器右侧“Options”窗口，在 Via Arrays 选择 Boundary 环形方式，配置常规

操作、过孔网络和孔型、全环绕孔参数、对象圆形阵列过孔参数、过孔连接方式。参

数说明请参见表 3-18。 

图3-148 环形方式阵列过孔配置界面 

 

 

表3-18 阵列过孔 Boundary 参数说明表 

参数分类 参数名称 参数说明 

General option

（常规操作） 

Enable DRC 

check 

进行 DRC 检查，勾选 Enable DRC check

前的方框，会自动去除不满足 DRC 要求的

过孔。 

Enable same 勾选 Enable same net DRC check 前的
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参数分类 参数名称 参数说明 

net DRC check 方框，对相同网络的过孔进行 DRC 检查，

会自动去除不满足 DRC 要求的过孔。勾选

Enable DRC check 时，才配置此项。 

Enable preview 勾选 Enable preview 前的方框，可以先

预览是否满足要求，在进行放置。 

Via net and 

padstack（过孔网

络和焊盘类型） 

Via net 
单击 Via net 下的 ，在弹窗输入

框中输入网络名，选择需要的过孔网络，

单击“OK”。 

Padstack 单击 Padstack 下的下拉框选择焊盘类

型。 

Global ring 

parameters（全环

绕孔参数） 

Staggered 

rings 

勾选 Staggered rings 前的方框，选择过

孔错位排列。勾选 Fill shape/voids，才需

配置此项。 

Inside 

shape/voids 

默认沿着边沿外打孔，勾选 Inside 

shape/voids 前的方框，沿着边沿内打

孔。 

Fill 

shape/voids 

勾选 Fill shape/voids 前的方框，所选图

形，内部填满（内部矩阵孔打孔）。勾选

Inside shape/voids，才需配置此项。 

Shape tangent 

mode 

勾选 Shape tangent mode 前的方框，选

择相切打孔（内切或外切）。 

Enable 

extending cline 

勾选 Enable extending cline 前的方框，

允许过孔往走线外延长。 

Enable cline 

start point 

勾选 Enable cline start point 前的方框，

允许过孔放置在走线起点。 

Cline On 

single 

side of 

cline 

单击 Cline 后的下拉框选择 On single 

side of cline，选择走线单边布孔（数据

输入正负区分对象两边）。 
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参数分类 参数名称 参数说明 

On 

both 

side of 

cline 

单击 Cline 后的下拉框选择 On both side 

of cline，选择走线双边打孔。 

On the 

center 

of 

cline 

单击 Cline 后的下拉框选择 On the 

center of cline，选择在走线中心打孔。 

Aroun

d the 

cline 

单击 Cline 后的下拉框选择 Around the 

cline，选择围绕走线打孔（全包围）。 

Number of 

rings 

在 Number of rings 后的输入框输入走线

打孔排数。 

Ring-ring 

spacing 

在 Ring-ring spacing 后的输入框输入距

离，选择多排打孔时，排和排的距离。勾

选 Fill shape/voids，才需配置此项。 

object-ring 

parameters（环绕

参数匹配） 

Non-circular 

object settings 

单击 Non-circular object settings 前的

圆圈，选择非圆形阵列类型。 

Via-object 

offset 

在 Via-object offset 后的输入框输入过孔

偏移量。选择 Non-circular object 

settings 时，才需配置此项。 

Maximum via-

via gap 

在 Maximum via-via gap 后的输入框输

入过孔间间距最大值。选择 Non-circular 

object settings 时，才需配置此项。 

Circular object 

settings 

单击 Circular object settings 前的圆圈，

选择圆形阵列类型。 

Radius relative 

to boundary 

勾选 Radius relative to boundary 前的方

框，设置过孔与后续要放置的圆形区域的

边距。选择 Circular object settings 时，

才配置此项。 
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参数分类 参数名称 参数说明 

Via array 

radius 

在 Via array radius 后的输入框输入阵列

过孔区域半径。选择 Circular object 

settings 时，才配置此项。 

Via-via angle 在 Via-via angle 后的输入框输入过孔之

间角度。选择 Circular object settings

时，才配置此项。 

Start angle 在 Start angle 后的输入框输入开始角度。

选择 Circular object settings 时，才配置

此项。 

Themal relief 

connects（过孔连

接方式） 

Orthogonal 单击 Themal relief connects 后的下拉框

选择 Orthogonal，选择以正交的方式进

行连接。 

Diagonal 单击 Themal relief connects 后的下拉框

选择 Diagonal，选择以斜交的方式进行连

接。 

Full contact 单击 Themal relief connects 后的下拉框

选择 Full contact，选择以全连接的方式

进行连接。 

8 Way Connect 单击 Themal relief connects 后的下拉框

选择 8 Way Connect，选择同时用正交和

斜交方式连接。 

None 单击 Themal relief connects 后的下拉框

选择 None，无连接方式。 

 

步骤 4 在画布中进入绘制过孔状态。 

1. 左键单击添加过孔的对象。 

2. 画布中沿着对象的边沿自动添加过孔，并保持所有过孔被选中状态。 

3. 左键单击画布任意一点，完成添加。 
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图3-149 边沿包孔视图 

 

 

 

勾选“Enable preview”才能看到放置的阵列过孔。 

----结束 

3.4.7 布线设计菜单（Route） 

3.4.7.1 走线（Trace） 

3.4.7.1.1 电气属性走线 

本章节为您介绍如何绘制电气属性走线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Trace”。 

步骤 3 在编辑器右侧“Options”窗口，配置走线参数，具体参数说明请参见表 3-19。 
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图3-150 配置走线参数 

 

 

表3-19 电气属性走线配置参数说明 

类型 参数名称 参数说明 

- Act 当前命令执行所处的图层。 

Alt 对称的图层。 

Line（走线） Line lock 

（锁定走线） 

1. 单击 Line lock 后的第一个下拉框选择线段

类型，可选择 Line（直走线）、Arc（圆弧

走线）。 

2. 单击 Line lock 后的第二个下拉框选择角

度，可选择 45（45 度角）、90（90 度

角）、Any（任意角度）。 

Route offset 勾选 Route offset 前的方框，系统自动选择
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类型 参数名称 参数说明 

（走线的偏移角

度） 

走线的偏移角度。可在 Route offset 后的输

入框输入偏移角度。 

Direction limit 

（方向限制） 

单击 Direction limit 后的下拉框选择，可选择

DefaultDir_2、MultiDir_10。勾选 Route 

offset 时，才需配置此项。 

Miter 

（走线拐角的长

度） 

1. 单击 Miter 后的第一个下拉框选择 1。也可

在下拉框输入长度。勾选 Route offset

时，不能配置此项。 

2. 单击 Miter 后的第二个下拉框选择，可选

择 Min（最小走线拐角的长度）、Fixed

（固定的走线拐角的长度）。勾选 Route 

offset 时，不能配置此项。 

Line width（线

宽） 

在 Line width 后的输入框中输入线宽。 

Style（模式） Bubble 

（走线模式） 

单击 Bubble 后的下拉框选择，可选择 Off

（纯手工按照鼠标指引方向进行走线，不受规

则管理器中的所有约束）、Hug Route（以避

让的方式进行走线）、Push Preferred（以推

挤模式进行走线）。 

Smooth 

（推挤走线的优化

程度） 

单击 Smooth 后的下拉框选择，可选择 Off

（不优化到最大优化程度）、Minimal（小范

围内的推挤走线）、Full（全方位的推挤并尽

量优化）。所有选择仅在避让/推挤模式下生

效。 

Force Pushed 

DiffPair With 

Adapted Rules 

勾选 Force Pushed DiffPair With Adapted 

Rules 前的方框，推挤差分走线遵循当前规

则，仅在避让/推挤模式下生效。 

- Snap to T/C 

Point 

勾选 Snap to T/C Point 前的方框，自动捕捉

走线的连接点。 

Replace etch 勾选 Replace etch 前的方框，去除环路走

线，当走线形成环路、多余的线路时，系统自
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类型 参数名称 参数说明 

动去除另一条线路。 

Auto blank 

other rats 

勾选 Auto blank other rats 前的方框，布线

操作的同时关闭 PCB 中其他飞线显示。 

Gridless 勾选 Gridless 前的方框，按格点去避让。取消

勾选，则部分走线无法按格点去避让。 

Clip dangling 

traces 

勾选 Clip dangling traces 前的方框，在推挤

模式下，悬空线截断开关。取消勾选，则不截

断。 

Clearance View 勾选 Clearance View 前的方框，显示对象的

安全距离。取消勾选，则不显示。 

Enhanced Exit 

Entry 

勾选 Enhanced Exit Entry 前的方框，差分走

线时，增强出线效果。 

 

步骤 4 在画布中，单选或者框选出线对象。 

步骤 5 移动鼠标，左键单击生成拐点，以此类推。 

步骤 6 右键单击“Next”，完成走线绘制并保持绘制状态。也可以右键单击“Done”，保

存并退出绘制状态。 

----结束 

3.4.7.1.2 打孔操作 

本章节为您介绍如何进行打孔操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...” 。 

步骤 3 在规则管理器中，选择过孔类型和连接过孔器件库。 

1. 在规则管理器界面中，选择“Physical>PCS”。 

2. 单击“Via Assignments>PCS”下的表格。 
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3. 在弹出“Edit Via List”页面中，在左侧列表搜索框中，输入过孔类型名称，勾选

filter 框下的过滤条件。 

− Show vias from library：从封装库调用过孔。 

− Show vias from database：从数据库调用过孔。 

4. 在左侧过孔列表中，选择需要的过孔，单击 将过孔从左侧移到右侧。 

5. 单击“OK”。 

图3-151 器件库添加过孔界面 

 

 

步骤 4 在画布中走线画完之后，左键双击或者右键单击“Add Via”添加过孔。 
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图3-152 添加过孔示图 

 

 

----结束 

3.4.7.2 调线（Slide） 

本章节为您介绍如何进行调线操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Slide”。 

步骤 3 在编辑器右侧“Options”窗口，配置调线参数，具体参数说明请参见表 3-20。 
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图3-153 配置调线参数 

 

 

表3-20 调线配置参数说明 

类型 参数名称 说明 

Size（大小） Min Corner Size（约束最

短线段长度） 

单击 Min Corner Size 后的下拉框选

择，可选择 1x width、10x width。 

Min Arc Radius（约束最

短弧半径） 

单击 Min Arc Radius 后的下拉框选

择，可选择 1x width、10x width。 

Line Angle（新生成线段

角度） 

单击 Line Angle 后的下拉框选择，

可选择 45（45 度角）、90（90 度

角）、Default（任意角度）。 

Vertex Action（端点模

式） 

单击 Vertex Action 后的下拉框选

择，可选择 Line Corner（走线拐
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类型 参数名称 说明 

角）、Arc Corner（圆弧拐角）、

Move（滑动整条线）、Edit（滑动

拐角）、None（不滑动拐角）。 

Style（模式） Bubble（走线模式） 单击 Bubble 后的下拉框选择，可选

择 Off（纯手工按照鼠标指引方向进

行走线，不受规则管理器中的所有约

束）、Hug Route（以避让的方式

进行走线）、Push Preferred（以推

挤模式进行走线）。 

Smooth（推挤走线的优

化程度） 

单击 Smooth 后的下拉框选择，可

选择 Off（不优化到最大优化程

度）、Minimal（小范围内的推挤走

线）、Full（全方位的推挤并尽量优

化）。所有选择仅在避让/推挤模式

下生效。 

Enhanced（增

强效果） 

Enhanced Tuning（扩展

线段） 

单击 Enhanced Tuning 后的下拉框

选择，可选择 segments（向前向后

各扩展一个线段）、off（不扩

展）。 

Enhanced Pad Entry 进行 pad entry 修线，勾选

Enhanced Pad Entry 前的方框，在

空间允许时，pin 和 via 的 pad 

entry 范围内不会出现线段的端点。 

Enhanced Coner Arc 推挤差分线时，勾选 Enhanced 

Coner Arc 前的方框，参与滑动的线

段端点均导弧角。取消勾选，则不导

弧角。 

Fix Arc Vertex 勾选 Fix Arc Vertex 前的方框，弧线

滑动过程中，端点固定，弧线可以翻

转。仅在选择单弧线段滑动时才能配

置此项。 

Chamfer 勾选 Chamfer 前的方框，弧线端点
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类型 参数名称 说明 

固定时倒角。默认置灰设置，不可修

改。 

- Auto join 滑动走线时改变拐角的长度，勾选

Auto join 前的方框，开启后线段自

动合并一起滑动。取消勾选，则不合

并。 

Allow DRCs 勾选 Allow DRCs 前的方框，滑动线

段时允许 DRC 产生。取消勾选，则

不允许。 

Auto Calculate Offset 勾选 Auto Calculate Offset 前的方

框，当 Bubble 模式为 Off 并且不勾

选 Allow DRCs 时，自动计算线段滑

动的最大偏移量。 

Gridless 勾选 Gridless 前的方框，按格点去

避让。取消勾选，则部分走线不按格

点去避让。 

Clearance View 勾选 Clearance View 前的方框，显

示对象的安全距离。取消勾选，则不

显示。 

Force Adapt Constraint 

Width And Gap 

勾选 Force Adapt Constraint 

Width And Gap 前的方框，遵循当

前规则。滑动线段的线宽，差分线间

距完全使用规则线宽，间距值。 

Clip dangling traces 勾选 Clip dangling traces 前的方

框，在推挤模式下，悬空线截断开

关。取消勾选，则不截断。单击

Bubble 后的下拉框选择 Push 

Preferred，才需配置此项。 

 

步骤 4 在画布中，单选或者框选调线对象。 
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步骤 5 移动鼠标，左键单击移动对象终点位置，并保持调线状态。 

步骤 6 右键单击“Done”，保存并退出绘制状态。 

 

⚫ 框选多个调线对象时，先左键单击画布，才能移动对象。 

⚫ 右键单击“Sub-Seg Slide”，可从一个线段上切出一个子线段滑动。 

⚫ 右键单击“Single trace mode”，可只滑动差分线中选中的线段，差分线的另一根线段不

变。该选项仅在选中差分线时出现。 

----结束 

3.4.7.3 时序视图（Timing Vision） 

本章节为您介绍如何进行时序视图操作。有时序、相位要求的，可以用时序视图功

能，方便进行设计。 

前提条件： 

在版图编辑器中设置了规则约束，具体操作请参见 3.4.9.3 规则约束（Constraints 

Editor）。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Timing Vision ”。 

步骤 3 在编辑器右侧“Options”窗口，配置显示颜色和格式类型，勾选时序视图模式。 

1. 颜色：单击 Colors 下的色块，可选择显示的颜色。 

− Satisfies required timing：满足要求值。 

− Shorter than required value：小于要求值。 

− Longer than required value：大于要求值。 

2. 格式类型：单击 Pattern for critical signals 后显示的格式图标，可选择显示的格

式类型。 

3. 视图模式：单击 Timing Mode 后的下拉框选择，可选择 DRC Timing 和 DRC 

Phase。 

− 选择 DRC Timing 模式，计算选中的 pinpair 的 Min/Max Propagation 

Delays 规则和 Relative Propagation Delay 规则。 
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− 选择 DRC Phase 模式，计算选中的 pinpair 的 Differential Pair 规则。 

4. 根据 DRC Timing 和 DRC Phase 模式进行配置。 

− 在 DRC Timing 模式下，勾选 Match Group Selection Mode，单击

Match Group 组内任意 pinpair 所在的 net，整个 Match Group 组被选

中。取消勾选，只显示选择的对象。 

− 在 DRC Timing 模式下，勾选 ENet Selection Mode，单击 ENet 下任意

net，整个 Enet 被选中。取消勾选，只显示选择的对象。 

− 在 DRC Phase 模式下，勾选 Match Group Selection Mode，单击任意的

差分 pinpair，如果差分 pinpair 处于某个 Match Group，则这个 Match 

Group 里面的全部差分 pinpair 均被选中且会高亮显示。取消勾选，只显示

选择的差分 pinpair。 

− 在 DRC Phase 模式下，勾选 ENet Selection Mode，选中 ENet 整个差分

等长。取消勾选，只显示选择的对象。 

图3-154 配置时序视图 

 

 

步骤 4 在编辑器左侧“Find”命令窗口中自动显示选择网络。 
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步骤 5 在画布中框选整板的网络，差分对网络太长或者太短的网络就会分别以红色和黄色标

识出来。红色表示短于差分对的限定值，黄色表示大于差分对的限定值。绿色表示符

合预期的值。 

步骤 6 单击“Clear Selections”可取消选择所有对象。长按 Ctrl 键，鼠标左键单选或者框选

对象，可取消选择部分对象。右键单击“Done”结束命令。 

----结束 

3.4.7.4 绕线（Tune） 

本章节为您介绍如何进行绕线操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Tune”。 

步骤 3 在编辑器右侧“Options”窗口，配置绕线参数，具体参数说明请参见表 3-21。 
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图3-155 配置绕线参数 

 

 

表3-21 绕线参数设置参数说明 

类型 参数名称 说明 

style（模式） Accordion 单击 Accordion 前的圆圈，可选择折叠线。 

Trombone 单击 Trombone 前的圆圈，可选择环绕折叠线。 

Sawtooth 单击 Sawtooth 前的圆圈，可选择锯齿线。 

Centered 勾选 Centered 前的方框，可选择线段中心。 

Gap 间距，默认设置，不可修改。 

Corners 单击 Corners 后的下拉框选择，可选择 90（90 度角

直线型拐角角度）、45（45 度角直线型拐角角

度）、FullArc（圆弧型拐角角度）。只有
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类型 参数名称 说明 

Accordion、Trombone 模式下，才需配置此项。 

Miter 走线拐角的长度，默认设置，不可修改。只有

Accordion、Trombone 模式下，才需配置此项。 

- Allow 

DRCs 

勾选 Allow DRCs 前的方框，滑动线段时允许 DRC

产生。取消勾选，则不允许。 

Differentic

al Pair 

Phase 

Tune 

勾选 Differentical Pair Phase Tune 前的方框，差

分对逐步绕线。取消勾选，则不逐步绕线。 

Bump（弯折

凸线） 

Bump 

Style 

单击 Bump Style 后的圆圈，可选择 Line（直线型

弯折凸线）、Arc（圆弧型弯折凸线）。勾选

Differentical Pair Phase Tune，才需配置此项。 

Bump 

Length

（L） 

在 Bump Length（L）后的输入框输入弯折凸线长

度。勾选 Differentical Pair Phase Tune，才需配置

此项。 

Bump 

Height

（H） 

在 Bump Height（H）后的输入框输入弯折凸线距

离。勾选 Differentical Pair Phase Tune，才需配置

此项。 

Length 

added per 

bump 

增加长度，默认配置，系统会自动计算长度大小。 

 

步骤 4 在画布中单选绕线线段，移动鼠标，左键单击目标位置。 

步骤 5 画布中自动显示绕线区域效果并保持绘制状态。 

步骤 6 右键单击“Done”，保存并退出绘制状态。 
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图3-156 绘制效果图 

 

 

----结束 

3.4.7.5 拉直走线（Custom Smooth） 

本章节为您介绍如何自动调整走线上非绕线用的弯折线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Custom Smooth”。 

步骤 3 在编辑器右侧“Options”窗口，配置拉直走线参数，具体参数说明请参见表 3-22。 
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图3-157 配置拉直走线参数 

 

 

表3-22 拉直走线参数说明 

参数名称 说明 

Corner type（拐

角类型） 

单击 Corner type 后的下拉框选择，可选择 45（45 度拐

角）、Arc（圆弧拐角）。 

Restrict pad type

（连接盘的约束） 

单击 Restrict pad type 后的下拉框选择，可选择

Rectangular、All、None。 

⚫ Rectangular：除了圆形盘，其余形状的盘都需要遵守

Min-length。 

⚫ All：所有形状的盘都需要遵守 Min-length。 

⚫ None：不论走线是否连接盘，均不遵守 Min-length。 

Min-length（最

小约束长度） 

在 Min-length 后的输入框输入最小约束长度，默认为-1。 

Level（平滑处理

力度） 

单击 Level 后的下拉框选择，可选择 Full（最大程度进行平滑

处理）、Mild（最小程度进行平滑处理）。 

Convexhull deal

（弯折凸线处理） 

勾选 Convexhull deal 前的方框进行弯折凸线处理，即走线上

非绕线用的凸起弯折线。取消勾选，则不进行处理。 

 

步骤 4 在画布中单选或者框选走线。 
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步骤 5 画布中系统自动显示拉直的走线并保持绘制状态。 

步骤 6 右键单击“Done”保存并退出绘制状态。 

 

⚫ Min-length 输入负数时，线段顶端和 pad 相交的那个 seg 及其之前的 seg 不做处理。线段

末端和 pad 相交的那个 seg 及其之后的 seg 不做处理。 

⚫ Min-length 输入大于等于 seg 与 pad 的交点到 pad 外第一个拐点的距离时，线段顶端从和

pad 相交的那个 seg 之后的 seg 进行处理。线段末端从和 pad 相交的那个 seg 之前的 seg

进行处理。 

⚫ Min-length 输入小于 seg 与 pad 的交点到 pad 外第一个拐点的距离时，线段顶端以 pad

和 seg 的交点作为起点，延长 Min-length 长度后以该点作为处理点向后进行处理。线段末

端以 pad 和 seg 的交点作为起点，延长 Min-length 长度后以该点作为处理点向前进行处

理。 

⚫ custom smooth 处理限制为 10 根线，选择超出时将不做处理且在 Console 窗口中提示。 

----结束 

3.4.7.6 交换 Pin 网络（Swap Pin） 

本章节为您介绍如何交换 Pin 上的网络。交换 Pin 上的网络就是同一组网络相互交叉

时，通过交换网络简化走线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Swap Pin”。 

步骤 3 在编辑器右侧“Options”窗口，配置图层、参数类型，参数说明请参见表 3-23。 
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图3-158 配置交换 Pin 网络 

 

 

表3-23 交换 Pin 网络参数说明 

参数名称 说明 

Swap properties 

with pins 

交换 Pin 属性。需要选择时，勾选 Swap properties with pins

前的方框。 

Ignore FIXED  

property 

忽略有锁定属性的对象，有锁定状态对象也更新。需要选择

时，勾选 Ignore FIXED  property 前的方框。 

Ripup on swap 删除交换。需要选择时，勾选 Ripup on swap 前的方框。 

Diff Pair Swap 差分对交换。需要选择时，勾选 Diff Pair Swap 前的方框。 

Swap Two Pairs 交换两个差分对。勾选 Diff Pair Swap 时，才可配置此项。 

Swap Polarity 交换极性。勾选 Diff Pair Swap 时，才可配置此项。 

 

步骤 4 在画布中，选择一个需要交换的 Pin，同网络中的 Pin 都会高亮显示，再选择第二个

Pin 进行交换。 

步骤 5 画布中系统自动显示交换后的 Pin。 

----结束 
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3.4.7.7 交换网络（Swap Fuction） 

本章节为您介绍如何进行同封装不同器件间网络交换。 

操作步骤 

步骤 1 打开版图工程。 

步骤 2 准备.prt 文件。 

1. 创建本地库 A：双击打开 Library_manager，点开菜单栏 file->new 

2. 将.ddb 数据导入本地库 A：file->export->library 

3. 在新创建文件夹 B，本地库 A 数据导入到 B 文件夹下：打开 Library_manager，

点开 file->export，选择 B 

4. 编辑.prt ：在 B 文件夹内找到 part 内对应封装.prt 文件数据，进行编辑并保存，

如下图： 

 

5. 将 B 文件夹下新数据导入 A 库中：打开 Library_manager，file->import，将 B

文件导入至 A 库中 

6. .ddb 单板只关联本地库 A，再导入网表 

步骤 3 在菜单栏选择“Route> Swap Fuction”进行网络交换。 
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交换效果图如下： 

 

----结束 

3.4.7.8 自动连接小线段（Derive Connectivity） 

本章节为您介绍如何将线头（走线的起点/终点）在 Pin/Via 内，但未与 Pin/Via 连接

的走线自动连接起来。操作后，修改过的走线会高亮，并且 console 栏中显示连接的

走线数量。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route> Derive Connectivity”。 

步骤 3 在编辑器右侧“Options”窗口，勾选 Option 配置选项 

类型 说明 

User select 用户选择模式，勾选后可以通过鼠标点选/框选对指定区域

的对象自动连接。 

Force Connect 强制连接模式，只在用户选择模式勾选后生效，勾选后忽略

线头需要有鼠线的限制。 

All Board Connect 整版连接按钮。 

Clear Highlight 清除高亮按钮，每次连接后走线会高亮，可以使用该按钮清

除高亮。 

效果图：
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----结束 

 

3.4.7.9 创建扇出（Create Fanout） 

本章节为您介绍如何进行自动扇出操作。扇出是从器件焊盘到相邻过孔的走线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Fanout>Create Fanout”。 

步骤 3 在编辑器右侧“Options”窗口，配置操作模式、参数类型、扇出方式、线宽和间

距。 

参数说明请参见表 3-24。 

图3-159 配置创建扇出 
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表3-24 创建扇出参数说明 

类型 说明 

Work Mode 工作模式。单击 Work Mode 后的下拉框选择，可选择

Create Fanout（创建扇出）、Mark Fanout（标记扇

出）、Unmark Fanout（取消标记）。 

Include 

Unassigned Pins 

勾选 Include Unassigned Pins 前的方框，选择对象里有网

络和无网络的 PIN 都扇出。取消勾选，只扇出选择对象里有

网络的 PIN。 

Include All Same 

Net Pins 

勾选 Include All Same Net Pins 前的方框，扇出同器件和

同网络的 PIN。取消勾选，只扇出选择对象里的 PIN。 

Increase Mode 勾选 Increase Mode 前的方框，扇出选择对象里未被扇出

的 PIN，已扇出的 PIN 不在扇出。取消勾选，扇出选择对象

里所有网络的 PIN，已扇出的 PIN 重新扇出。 

Act/Alt 扇出过孔层选择。只能选择 Top 或者 Bottom 层为开始扇

出层，终止扇出层自定义配置。 

Via 扇出过孔选择。单击 Via 后的下拉框选择，可选择 Net 

Default（按照网络规则走，在按照规则中过孔的优先级

走）、其他指定过孔（网络规则中配置的过孔类型都可

选）。 

Pattern 扇出方式和方向选择。单击 Pattern 后的下拉框选择，可选

择 VIA In Pad（盘上扇出孔）、BGA Quadrant Style

（BGA 扇出孔）、North（北方向）、South（南方向）、

East（东方向）、West（西方向）、NE（东北方向）、

NW（西北方向）、SE（东南方向）、SW（西南方向）。 

Line Width 扇出线宽选择。勾选 Line Width 前的方框，在 Line Width

后的输入框输入扇出长度。默认设置为 5，可修改。不勾

选，扇出线宽则与 CE 规则管理器保持一致。选择 BGA 

Quadrant Style、North、South、East、West、NE、

NW、SE、SW 时才会配置此选项。 

Pin-Via Space 中心扇出或者偏移扇出。单击 Pin-Via Space 后的下拉框选

择，可选择 5.00（焊盘中心到扇出过孔中心距离，默认设置

间距为 5）、Centered（扇出在周边焊盘的中心位置）。也



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 195 

 

类型 说明 

可在 Pin-Via Space 后的框内输入间距。选择 BGA 

Quadrant Style、North、South、East、West、NE、

NW、SE、SW 时才会配置此选项。 

 

步骤 4 在画布中单选或者框选对象，画布系统自动显示扇出后的对象。 

步骤 5 右键单击“Done”，保存并退出扇出状态。 

----结束 

3.4.7.10 定义电源\地属性（P&G） 

本章节为您介绍如何定义电源\地属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>P&G...”。 

步骤 3 在弹出的“Power & Ground Nets”页面中，单击 ，添加电源或者地属性。 

1. 单击 ，打开“Power GND”弹窗。 
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图3-160 定义电源\地属性 

 

 

2. 在弹窗中，Net Name 后的输入框输入电源/地属性网络名（Pwr/GND），单击

“Query”查询网络列表。 

3. 在左侧网络列表中选择电源或者地属性，单击 添加到右侧网络列表中。 

4. 单击“OK”添加电源或者地属性。 
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图3-161 添加电源或者地属性 

 

 

步骤 4 单击“OK”保存并退出定义页面。 

----结束 

3.4.7.11 创建 ENET（Create Enet） 

本章节为您介绍如何创建 ENET。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Create Enet”。 

步骤 3 在弹出的“Re-Generate Enets”页面中，添加要标记的器件。 

1. 单击 ，打开“Add Discrete Series Comps”弹窗。 

2. 在弹窗中，填写器件名称，单击“Query”查询器件列表。 

a. 填写器件名称：在 Comps Name 后的输入框输入器件名称。 
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b. 筛选器件：根据需求筛选条件。勾选配置选项前的方框，可选择 Discrete 

comps（标记器件）、pins（引脚数量）、Exclude Power&Ground Nets

（包括电源/地网络）、Value（数值）。 

3. 在左侧器件列表中选择要标记的器件，单击 添加到右侧器件列表中。 

4. 单击“OK”添加要标记的器件。 

图3-162 添加要标记器件 

 

 

步骤 4 单击“Generate”，自动生成 Enet。 
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图3-163 生成 Enet 

 

 

 

不需配置 Signal Model 属性。 

----结束 

3.4.7.12 自动创建差分对（Create Differential Pair） 

本章节为您介绍如何自动创建差分对。 

前提条件 

在进行差分对布线前，需要创建差分对网络类型。在版图工具中差分对网络类型有两

种，分别是 Enet、Net。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Create Differential Pair”。 

步骤 3 在弹出的“Create Differential Pair”页面中，选择对象网络类型，填写网络名称后

缀，单击“Query”查询符合条件的网络。 
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具体参数请参见表 3-25。 

表3-25 创建差分对参数说明 

类型 说明 

Crieria for creating 

differential pair

（自动生成差分对） 

Target object focus 单击 Target object focus 后的下

拉框选择，可选择 Enet（Enet 网

络）、Net（Net 网络）、

UnMatch（Enet 和 Net 网络）。 

Subset of positive 

Enet（net）name 

在 Subset of positive Enet

（net）name 下的输入框输入网络

名称的后缀。一般默认输入“p”

或者“+”。 

Subset of negative 

Enet（net）name 

在 Subset of negative Enet

（net）name 下的输入框输入网络

名称的后缀。一般默认输入“n”

或者“-”。 

Differential Pair 

Name 

在 Differential Pair Name 列表中

可查看差分对名称。 

positive Enet（net） 在 positive Enet（net）列表中可

查看匹配的网络名称。 

negative Enet

（net） 

在 negative Enet（net）列表中可

查看匹配的网络名称。 

Status 在 Status 列表中可查看差分对状

态。 

 

步骤 4 在查询列表中勾选需要的差分对，单击“OK”。在打开弹窗中再单击“OK”自动生

成差分对。 
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图3-164 创建差分对 

 

 

步骤 5 在菜单栏选择“Tools> Constraints Editor...” 。 

步骤 6 在 Electrical 电气规则管理器中， 选择“Differential Pair”可查看创建的差分对。也

可在 Net 网络规则管理器中设置差分对规则。 
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图3-165 规则设置 

 

 

----结束 

3.4.7.13 手动创建差分对（Create NC/NG/DPR） 

本章节为您介绍如何手动创建差分对。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Create NC/NG/DPR”。 

步骤 3 在画布中框选差分对象，右键单击“Create>Differential Pair...”。 

步骤 4 在弹出的“Create Differential Pair”页面中，填写差分对名称，单击“OK”。 
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图3-166 创建差分对 

 

 

步骤 5 在菜单栏选择“Tools> Constraints Editor...” 。 

步骤 6 在 Electrical 电气规则管理器中， 选择“Differential Pair”可查看创建的差分对。也

可在 Net 网络规则管理器中设置差分对规则。 
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图3-167 规则设置 

 

 

----结束 

3.4.7.14 批量创建 ppr 

操作前提：有共同指定起点和终点器件 

操作步骤 

步骤 1 流程设计窗口 Constraints Editor，双击打开 Constraints Editor，然后选择到

Relative Propagation Delav  
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步骤 2 选择目标网络，可单选可多选，可单根 relative 的 match group，可差分

differential diff；选择后右键点击 Create 

步骤 3 可选择是否创建 match group，可自定义修改 match group 名称 
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批量效果如下图： 

 

----结束 
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3.4.7.15 绘制铜箔（Create Area） 

本章节为您介绍如何绘制铜箔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Create Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置铜箔类型、网络、格点类型、铜箔形状。 

1. 铜箔类型：单击 Type 后的下拉框选择，可选择 Dynamic copper（动态覆

铜）、Dynamic crosshatch（动态栅格铜）、Static solid（静态覆铜）、Static 

crosshatch（静态栅格铜）。 

2. 网络类型：单击 Assign net name 下的 ，在打开的窗口搜索网络名，

选择绘制的铜箔网络。系统默认选择 Dummy Net。 

3. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

4. 铜箔形状：单击 Shapes 下选项前的圆圈，可选择 Rectangle（矩形）、Circle

（圆形）、Polygon（多边形）。 
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图3-168 绘制铜箔设置 

 

 

步骤 4 在画布中进入绘制铜箔状态，绘制铜箔形状有三种方式。 

⚫ 矩形 

a. 左键单击确定矩形铜箔左上角坐标位置。 

b. 移动鼠标，左键单击确定矩形铜箔右下角坐标位置，完成绘制。 

c. 矩形铜箔绘制完成，将保持绘制矩形状态，同时整个矩形被选中。也可右键

单击“Done”完成矩形铜箔绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

i. 矩形长度：在 Width 后的输入框输入长度。 

ii. 矩形宽度：在 Height 后的输入框输入宽度。 

iii. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner（倒斜角）、

Round（倒圆角）。 

iv. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 
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图3-169 绘制矩形铜箔 

 

 

⚫ 圆形 

a. 左键单击确定圆形铜箔中心点。 

b. 移动鼠标，左键单击确定圆形上任意一点，完成绘制。 

c. 圆形铜箔绘制完成，将保持绘制圆形状态，同时整个圆形被选中。也可右键

单击“Done”完成圆形铜箔绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 

图3-170 绘制圆形铜箔 

 

 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 210 

 

⚫ 多边形 

a. 左键单击确定多边形铜箔一个顶点位置。 

b. 移动鼠标，左键单击确定另一个顶点，以此类推。 

c. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连，右键单击“Complete”，完成绘制。 

d. 多边形铜箔绘制完成，将保持绘制多边形状态，同时整个多边形被选中。也

可右键单击“Done”完成多边形铜箔绘制，保存并退出绘制状态。 

图3-171 绘制多边形铜箔 

 

 

 

⚫ 右键单击“Done”完成绘制，保存并退出绘制状态。 

⚫ 绘制过程中，右键单击“Oops”可退回落点。 

⚫ 绘制过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制过程中，右键单击“Complete”完成绘制，并保持绘制状态。 

⚫ 绘制过程中，右键单击“Toggle”调整多边形边方向。 

⚫ 绘制过程中，右键单击“Assign net”选择对象，给对象附网络。 

⚫ 绘制过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 
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3.4.7.16 绘制铜箔分割线（Split） 

本章节为您介绍如何绘制铜箔分割线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Drawing>Line”。 

步骤 3 在画布中绘制铜箔分割线。 

1. 在编辑器右侧“Options”窗口，选择 Split 配层和操作图层。 

2. 在 Line Width 后的输入框输入线宽。 

3. 在画布中绘制分割线。 

图3-172 画铜箔分割线 

 

 

步骤 4 在菜单栏选择“Route>Split”。 

步骤 5 在画布中分割铜箔。 

1. 在编辑器右侧“Options”窗口，选择分割铜箔的图层。 

2. 在画布中选择待分割的铜箔，单击“Create”。 

3. 分割完成后，右键单击“Done”保存并退出分割状态。 

4. 在编辑器右侧“Options”窗口，分割后的铜箔在“Area list”框中自动显示在列

表里。 
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图3-173 分割铜箔 

 

 

----结束 

3.4.7.17 挖空铜箔（Cutout/Cavity） 

3.4.7.17.1 创建铜箔挖空区域（Create Cutout） 

本章节为您介绍如何创建铜箔挖空区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Cutout/Cavity>Create Cutout”。 

步骤 3 在编辑器右侧“Options”窗口，选择操作图层、配置格点类型、铜箔形状。 

1. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

2. 铜箔形状：单击 Shapes 下选项前的圆圈，可选择 Rectangle（矩形）、Circle

（圆形）、Polygon（多边形）。 
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图3-174 创建铜箔挖空 

 

 

步骤 4 在画布中进入铜箔挖空状态，铜箔挖空形状有三种方式。 

⚫ 矩形 

a. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

i. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner（倒斜角）、

Round（倒圆角）。 

ii. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 

b. 选择需要挖空的铜箔。 

c. 在铜箔上，左键单击确定矩形区域左上角坐标位置。 

d. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成挖空。 

e. 矩形区域挖空完成，将保持挖空矩形状态。也可右键单击“Done”完成矩形

区域挖空，保存并退出挖空状态。 
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图3-175 铜箔挖空矩形区域 

 

 

⚫ 圆形 

a. 选择需要挖空的铜箔。 

b. 在铜箔上，左键单击确定圆形区域中心点。 

c. 移动鼠标，左键单击确定圆形上任意一点，完成挖空。 

d. 圆形区域挖空完成，将保持挖空圆形状态。也可右键单击“Done”完成圆形

区域挖空，保存并退出挖空状态。 

图3-176 铜箔挖空圆形区域 

 

 

⚫ 多边形 

a. 选择需要挖空的铜箔。 

b. 在铜箔上，左键单击确定多边形区域一个顶点位置。 

c. 移动鼠标，左键单击确定另一个顶点，以此类推。 
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d. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连，右键单击“Complete”，完成挖空。 

e. 多边形区域挖空完成，将保持挖空多边形状态。也可右键单击“Done”完成

多边形区域挖空，保存并退出挖空状态。 

图3-177 铜箔挖空多边形区域 

 

 

 

⚫ 右键单击“Done”完成挖空，保存并退出挖空状态。 

⚫ 挖空过程中，右键单击“Oops”可退回落点。 

⚫ 挖空过程中，右键单击“Cancel”可退出挖空状态。 

⚫ 挖空过程中，右键单击“Next”可继续下一步挖空。 

⚫ 挖空过程中，右键单击“Complete”完成挖空，并保持挖空状态。 

⚫ 挖空过程中，右键单击“Toggle”调整多边形边方向。 

⚫ 挖空过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

3.4.7.17.2 静态铜箔避让（Element） 

本章节为您介绍如何操作静态铜箔避让。 

操作步 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Cutout/Cavity>Element”。 
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步骤 3 在画布中，先选择需要避让的铜箔，再单选或者框选避让对象，画布中系统自动显示

避让后的铜箔。 

图3-178 静态铜箔避让示例 

 

 

步骤 4 右键单击“Done”保存并退出避让状态。 

----结束 

3.4.7.17.3 删除铜箔挖空区域（Delete） 

本章节为您介绍如何删除铜箔挖空区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Cutout/Cavity>Delete”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要删除的挖空区域。 

步骤 4 单击画布中任意位置，删除挖空区域，保持挖空区域删除状态。 

步骤 5 右键单击“Done”完成删除挖空区域，保存并退出删除状态。 
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图3-179 删除挖空区域前 

 

 

图3-180 删除挖空区域后 

 

 

----结束 

3.4.7.17.4 移动铜箔挖空区域（Move） 

本章节为您介绍如何移动铜箔挖空区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Cutout/Cavity>Move”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要移动的挖空区域。 

步骤 4 单击鼠标左键，移动鼠标到指定位置后在单击鼠标左键，移动挖空区域并保持挖空区

域移动状态。 

步骤 5 右键单击“Done”完成移动挖空区域，保存并退出移动状态。 
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图3-181 移动挖空铜箔前 

 

 

图3-182 移动挖空铜箔后 

 

 

----结束 

3.4.7.17.5 复制铜箔挖空区域（Copy） 

本章节为您介绍如何复制铜箔挖空区域。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Cutout/Cavity>Copy”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要复制的挖空区域。 

步骤 4 单击鼠标左键，移动鼠标到指定位置后在单击鼠标左键粘贴挖空区域，复制挖空区域

并保持挖空区域复制状态。 

步骤 5 右键单击“Done”完成复制并粘贴挖空区域，保存并退出复制状态。 
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图3-183 复制挖空铜箔前 

 

 

图3-184 复制挖空铜箔后 

 

 

----结束 

3.4.7.18 铜箔编辑（Select Area or Void/Cavity） 

本章节为您介绍如何对铜箔进行编辑。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Select Area or Void/Cavity”。 

步骤 3 在编辑器右侧“Options”窗口，选择操作图层。 

步骤 4 在画布中，选择需要编辑的铜箔进行编辑操作，具体操作及鼠标右键辅助编辑操作请

参见表 3-26。 

表3-26 铜箔编辑操作说明 

操作名称 操作步骤 

移动顶点

（Move 

选择顶点，按住鼠标左键不放移动到目标位置释放鼠标。 
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操作名称 操作步骤 

vertex） 

添加顶点

（Add vertex） 

按住 ctrl 键，鼠标左键单击在铜箔边沿线进行加点。 

删除顶点

（Delete 

vertex） 

选择顶点，右键单击“Delete vertex”删除。 

移动边（Slide 

edge） 

左键单击选择边，移动到目标位置再次单击。 

保存并退出编

辑状态

（Done） 

右键单击“Done”保存并退出编辑状态。 

退回落点

（Oops） 

右键单击“Oops”可退回落点。 

退出编辑状态

（Cancel） 

右键单击“Cancel”可退出编辑状态。 

下一步

（Next） 

右键单击“Next”完成当前编辑，继续下一步编辑状态。 

给对象附网络

（Assign net） 

右键单击“Assign net”可选择对象，给对象附网络。 

铜箔动静转换

（Change area 

type） 

右键单击“Change area type”可转换铜箔动静态。 

切割铜箔

（ Edit cut） 

右键单击“Edit cut”可切割铜箔。 

主动触发动态

避让（Update 

area） 

右键单击“Update area”可主动触发动态避让。 

禁用动态避让

（Change to 

右键单击“Change to disabled”可禁用动态避让。 
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操作名称 操作步骤 

disabled） 

复制到其他层

（Copy to 

layers） 

右键单击“Copy to layers”，在弹窗中选择复制对象放置的

层，可将铜箔复制到其他层。 

动态铜箔实例

参数配置

（Parameters） 

右键单击“Parameters”可进行动态铜箔实例参数配置。 

提高优先级

（Raise 

Priority） 

右键单击“Raise Priority”可提高优先级。 

降低优先级

（ Lower 

Priority） 

右键单击“Lower Priority”可降低优先级。 

选择特定位置

落点（Snap 

Pick To） 

右键单击“Snap Pick To”可选择特定位置落点。 

 

步骤 5 在编辑器右侧“Options”窗口，铜箔类型和对象网络会随着画布中操作命令的执行

而发生改变。 

图3-185 铜箔编辑配置界面 

 

 

----结束 
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3.4.7.19 居中走线 

本章节为您介绍如何居中走线。 

操作步骤 

步骤 1 功能菜单栏，点击 Route- Spread Between Voids 

步骤 2 对象查询窗口 Find 勾选 Pins 和 Vias 

 

步骤 3 options 选择那层，居中那层两对象之间的线。 

选择 pin 脚后，两脚直接的线自动居中如下图： 
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----结束 

 

3.4.7.20 铜箔参数设置（Global Area Parameter） 

3.4.7.20.1 整板静态铜箔参数配置（Global Static Area Parameter） 

本章节为您介绍如何对整板静态铜箔进行参数配置。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Global Area Parameter>Global Static Area 

Parameter”。 

步骤 3 在弹出的“Static Shape Parameters”页面中，有三种类型的静态铜箔参数设置，根

据需求配置参数。 

⚫ Void controls 页面参数设置 

单击“Void controls”页签，根据需求设置参数，参数说明请参见表 3-27。 
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图3-186 Void controls 页面参数设置 

 

 

表3-27 控制铜箔缝隙宽度参数说明 

参数名称 说明 

Minimum aperture for 

artwork fill 

（铜箔缝隙宽度） 

在 Minimum aperture for artwork fill 后的输入框输

入铜箔缝隙宽度数值，宽度小于设置值，就不铺铜。 

Suppress shapes less 

than 

（铺设铜箔的宽度） 

在 Suppress shapes less than 后的输入框输入铺设铜

箔的宽度，默认铺出来的铜箔不会小于设置值，一般为

25mil。 

Allow shapes 

to split 

（允许铜箔分

割） 

Yes 单击 Allow shapes to split 后的下拉框选择 Yes，允

许铜箔分割。 

No 单击 Allow shapes to split 后的下拉框选择 No，不允

许铜箔分割。 

Create pin 

voids 

Individ

ually 

单击 Create pin voids 后的下拉框选择 Individually，

选择单独避让。 
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参数名称 说明 

（遇到通孔焊盘

时避让） 

In-line 单击 Create pin voids 后的下拉框选择 In-line，选择

条形避让。 

Acute angle 

trim control 

（避让时铜箔形

状） 

Round 单击 Acute angle trim control 后的下拉框选择

Round，避让时铜箔形状为圆形。 

Chamf

ered 

单击 Acute angle trim control 后的下拉框选择

Chamfered，避让时铜箔形状进行削角。 

 

⚫ Clearance 页面参数设置 

单击“Clearance”页签，根据需求设置间距参数，参数说明请参见表 3-28。 

图3-187 Clearance 页面参数设置 

 

 

表3-28 间距参数设置参数说明 

类型 参数名称 说明 

Thru pin（通孔） Oversize value 铜箔到通孔间距设置，除了约束管理器设
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类型 参数名称 说明 

置间距之外在额外增加的数值。 

Smd pin（焊盘） Oversize value 铜箔到焊盘间距设置，除了约束管理器设

置间距之外在额外增加的数值。 

Via/pin（过孔） Oversize value 铜箔到过孔间距设置，除了约束管理器设

置间距之外在额外增加的数值。 

Line/cline（走线） Oversize value 铜箔到走线间距设置，除了约束管理器设

置间距之外在额外增加的数值。 

Text（文字） Oversize value 铜箔到文字间距设置，除了约束管理器设

置间距之外在额外增加的数值。 

Area（铜箔） Oversize value 铜箔到铜箔间距设置，除了约束管理器设

置间距之外在额外增加的数值。 

 

⚫ Thermal relief connects 页面参数设置 

单击“Thermal relief connects”页签，根据需求设置连接方式参数，参数说明

请参见表 3-29。 
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图3-188 Thermal relief connects 页面参数设置 

 

 

表3-29 散热焊盘连接方式参数设置 

参数名称 说明 

Thru pins

（通孔） 

Orthogonal 单击 Thru pins 后的下拉框选择 Orthogonal，以正交

的方式进行连接。 

Diagonal 单击 Thru pins 后的下拉框选择 Diagonal，以斜交的

方式进行连接。 

Full 

Contact 

单击 Thru pins 后的下拉框选择 Full Contact，以全连

接方式进行连接。 

8 Way 

Connect 

单击 Thru pins 后的下拉框选择 8 Way Connect，同

时用正交和斜交方式进行连接。 

None 单击 Thru pins 后的下拉框选择 None，无连接方式。 

Smd pins

（焊盘） 

Orthogonal 单击 Smd pins 后的下拉框选择 Orthogonal，以正交

的方式进行连接。 

Diagonal 单击 Smd pins 后的下拉框选择 Diagonal，以斜交的
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参数名称 说明 

方式进行连接。 

Full 

Contact 

单击 Smd pins 后的下拉框选择 Full Contact，以全连

接方式进行连接。 

8 Way 

Connect 

单击 Smd pins 后的下拉框选择 8 Way Connect，同

时用正交和斜交方式进行连接。 

None 单击 Smd pins 后的下拉框选择 None，无连接方式。 

Vias（过

孔） 

Orthogonal 单击 Vias 后的下拉框选择 Orthogonal，以正交的方式

进行连接。 

Diagonal 单击 Vias 后的下拉框选择 Diagonal，以斜交的方式进

行连接。 

Full 

Contact 

单击 Vias 后的下拉框选择 Full Contact，以全连接方

式进行连接。 

8 Way 

Connect 

单击 Vias 后的下拉框选择 8 Way Connect，同时用正

交和斜交方式进行连接。 

None 单击 Vias 后的下拉框选择 None，无连接方式。 

Use fixed thermal width 

of 

在 Use fixed thermal width of 后的输入框输入使用固

定的连接线宽度，一般设置为 10mil。 

 

步骤 4 设置完成后，单击“Apply”应用，或者单击“OK”保存并退出设置窗口。 

----结束 

3.4.7.20.2 整板动态铜箔参数配置（Global Dynamic Area Parameter） 

本章节为您介绍如何对整板动态铜箔进行参数配置。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Global Area Parameter>Global Dynamic Area 

Parameter”。 
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步骤 3 在弹出的“Global Dynamic Shape Parameters”页面中，有四种类型的动态铜箔参

数设置，根据需求配置参数。 

⚫ Area fill 页面参数设置 

单击“Area fill”页签，根据需求设置参数，参数说明请参见表 3-30。 

图3-189 Area fill 页面参数设置 

 

 

表3-30 Area fill 页面参数设置参数说明 

类型 参数名称 说明 

Xhatch style（铜箔

填充方式） 

Vertical 单击 Xhatch style 后的下拉框选择 Vertical，

选择垂直分布。 

Horizont

al 

单击 Xhatch style 后的下拉框选择

Horizontal，选择水平分布。 

Diag_Po

s 

单击 Xhatch style 后的下拉框选择

Diag_Pos，选择 45°线分布。 

Diag_Ne

g 

单击 Xhatch style 后的下拉框选择

Diag_Neg，选择-45°线分布。 
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类型 参数名称 说明 

Diag_Bo

th 

单击 Xhatch style 后的下拉框选择

Diag_Both，选择+/-45°线分布。 

Hori_Ver

t 

单击 Xhatch style 后的下拉框选择

Hori_Vert，选择水平和垂直联合分布。 

Custom 单击 Xhatch style 后的下拉框选择 Custom，

选择自定义方式分布。 

Hatch set（填充铜箔

的平行线设置） 

Line 

width 

在 Line width 下的输入框输入线宽。 

Spacing 在 Spacing 下的输入框输入间距。 

Angle 在 Angle 下的输入框输入交叉线角度。 

Origin 在 Origin 后的第一个输入框输入填充线坐标原

点 X 轴坐标，第二个输入框输入 Y 轴坐标。 

Border 

width 

在 Border width 后的输入框输入铜箔边界线宽

度。 

Automatically delete isolated 

shapes 

勾选 Automatically delete isolated shapes

前的方框，自动删除孤立铜箔。取消勾选，则

不删除。 

 

⚫ Void controls 页面参数设置 

单击“Void controls”页签，根据需求设置参数，参数说明请参见表 3-31。 
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图3-190 Void controls 页面参数设置 

 

 

表3-31 控制铜箔缝隙宽度参数说明 

参数名称 说明 

Minimum aperture for 

artwork fill（铜箔缝隙宽

度） 

在 Minimum aperture for artwork fill 后的输入框

输入铜箔缝隙宽度数值，宽度小于设置值，就不铺

铜。 

Suppress shapes less than

（铺设铜箔的宽度） 

在 Suppress shapes less than 后的输入框输入铺设

铜箔的宽度，默认铺出来的铜箔不会小于设置值，一

般为 25mil。 

Create pin 

voids（遇到

通孔焊盘时

避让） 

Individually 单击 Create pin voids 后的下拉框选择

Individually，选择单独避让。 

In-line 单击 Create pin voids 后的下拉框选择 In-line，选

择条形避让。 

Acute 

angle trim 

Round 单击 Acute angle trim control 后的下拉框选择

Round，避让时铜箔形状为圆形。 
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参数名称 说明 

control（避

让时铜箔形

状） 

Chamfered 单击 Acute angle trim control 后的下拉框选择

Chamfered，避让时铜箔形状进行削角。 

 

⚫ Clearance 页面参数设置 

单击“Clearance”页签，根据需求设置间距参数，参数说明请参见表 3-32。 

图3-191 Clearance 页面参数设置 

 

 

表3-32 间距参数设置参数说明 

类型 参数名称 说明 

Thru pin（通

孔） 

Oversize value 铜箔到通孔间距设置，除了约束管理器设置间

距之外在额外增加的数值。 

Smd pin（焊

盘） 

Oversize value 铜箔到焊盘间距设置，除了约束管理器设置间

距之外在额外增加的数值。 
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类型 参数名称 说明 

Via/pin（过

孔） 

Oversize value 铜箔到过孔间距设置，除了约束管理器设置间

距之外在额外增加的数值。 

Line/cline（走

线） 

Oversize value 铜箔到走线间距设置，除了约束管理器设置间

距之外在额外增加的数值。 

Text（文字） Oversize value 铜箔到文字间距设置，除了约束管理器设置间

距之外在额外增加的数值。 

Area（铜箔） Oversize value 铜箔到铜箔间距设置，除了约束管理器设置间

距之外在额外增加的数值。 

 

⚫ Thermal relief connects 页面参数设置 

单击“Thermal relief connects”页签，根据需求设置连接方式参数，参数说明

请参见表 3-33。 

图3-192 Thermal relief connects 页面参数设置 
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表3-33 散热焊盘连接方式参数设置 

参数名称 说明 

Thru pins

（通孔） 

Orthogonal 单击 Thru pins 后的下拉框选择 Orthogonal，以正交

的方式进行连接。 

Diagonal 单击 Thru pins 后的下拉框选择 Diagonal，以斜交的

方式进行连接。 

Full 

Contact 

单击 Thru pins 后的下拉框选择 Full Contact，以全连

接方式进行连接。 

8 Way 

Connect 

单击 Thru pins 后的下拉框选择 8 Way Connect，同

时用正交和斜交方式进行连接。 

None 单击 Thru pins 后的下拉框选择 None，无连接方式。 

Smd pins

（焊盘） 

Orthogonal 单击 Smd pins 后的下拉框选择 Orthogonal，以正交

的方式进行连接。 

Diagonal 单击 Smd pins 后的下拉框选择 Diagonal，以斜交的

方式进行连接。 

Full 

Contact 

单击 Smd pins 后的下拉框选择 Full Contact，以全连

接方式进行连接。 

8 Way 

Connect 

单击 Smd pins 后的下拉框选择 8 Way Connect，同

时用正交和斜交方式进行连接。 

None 单击 Smd pins 后的下拉框选择 None，无连接方式。 

Vias（过

孔） 

Orthogonal 单击 Vias 后的下拉框选择 Orthogonal，以正交的方式

进行连接。 

Diagonal 单击 Vias 后的下拉框选择 Diagonal，以斜交的方式进

行连接。 

Full 

Contact 

单击 Vias 后的下拉框选择 Full Contact，以全连接方

式进行连接。 

8 Way 

Connect 

单击 Vias 后的下拉框选择 8 Way Connect，同时用正

交和斜交方式进行连接。 

None 单击 Vias 后的下拉框选择 None，无连接方式。 
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参数名称 说明 

Use fixed thermal width 

of 

在 Use fixed thermal width of 后的输入框输入使用固

定的连接线宽度，一般设置为 10mil。 

 

步骤 4 设置完成后，单击“Apply”应用，或者单击“OK”保存并退出设置窗口。 

----结束 

3.4.7.21 两个重叠铜箔合并操作（Areas Operator） 

本章节为您介绍如何进行两个重叠铜箔的合并操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Areas Operator”。 

步骤 3 在编辑器右侧“Options”窗口，配置铜箔的操作方式。 

⚫ And：铜箔合并后，保留铜箔重叠部分，并简化为一个铜箔图形。 

⚫ Or：铜箔合并后，两个铜箔都保留，并简化为一个铜箔图形。 

⚫ Andnot：铜箔合并后，保留第一块铜箔没有和第二块铜箔重叠的部分，并简化为

一个铜箔图形。 

⚫ Xor：铜箔合并后，只删除铜箔重叠部分，其余铜箔部分保留。 

图3-193 铜箔操作方式配置 

 

 

步骤 4 在画布中，选择第一块铜箔，在选择第二块铜箔，显示合并后的铜箔。 
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图3-194 铜箔合并操作 

 

 

 

两块铜箔必须有重叠部分，否则不能执行铜箔操作命令。 

----结束 

3.4.7.22 转换动静态铜箔（Change Area Type） 

本章节为您介绍如何转换动静态铜箔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Change Area Type”。 

步骤 3 在编辑器右侧“Options”窗口，配置铜箔状态（To dynamic copper/To static 

solid）。 

⚫ To dynamic copper：转换动态铜箔。 

⚫ To static solid：转换静态铜箔。 

步骤 4 在画布中单选或者框选铜箔，在弹出窗口中，单击“Yes”。 

步骤 5 画布中自动显示转换后的铜箔。 

步骤 6 右键单击“Done”保存并退出转换状态。 

步骤 7 转换完成后，可在画布中查看转换状态。 

1. 在菜单栏选择“Display>Info”。 
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2. 单选或者框选转换状态后的铜箔。 

3. 在弹窗中查看转换状态后的铜箔属性。 

图3-195 动态铜转静态铜示图 

 

 

图3-196 静态铜转动态铜示图 

 

 

----结束 

3.4.7.23 刷新整板铜箔（Update Area） 

本章节为您介绍如何刷新整板动态铜箔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Update Area”。 
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步骤 3 在编辑器右侧“Options”窗口，勾选 All，单击“Change To Disabled”，然后单

击“Update To Smooth”刷新动态铜箔并实施自动避让。在图层后面会显示动态铜

箔数量，刷新结果 Disable 必须为 0。 

图3-197 刷新整板铜箔 

 

 

----结束 

3.4.7.24 合并同网络铜箔（Merge Area） 

本章节为您介绍如何合并两个同网络铜箔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Merge Area”。 

步骤 3 在画布中，选择需要合并的第一个铜箔，在选择第二个铜箔。 

步骤 4 画布中自动显示合并后的铜箔。 
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图3-198 合并后铜箔 

 

 

----结束 

3.4.7.25 线段闭合为封闭图形（Compose Area） 

本章节为您介绍如何通过线段闭合为封闭的图形。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Compose Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数，参数说明请参见表 3-34。 
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图3-199 闭合图形操作配置 

 

 

表3-34 线段闭合为封闭的图形参数说明 

参数名称 说明 

Delete shape after compose 勾选 Delete shape after compose 前的方

框，可删除闭合后多余图形。取消勾选，则不

删除。 

Use auto gap 勾选 Use auto gap 前的方框，可自动闭合缺

口。取消勾选，则不自动闭合。 

Round corners 勾选 Round corners 前的方框，可倒角，并在

Radius 后输入框输入倒角角度。取消勾选，则

不倒角。 

 

步骤 4 在画布中框选线段，右键单击“Done”保存并退出转换状态。 
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图3-200 闭合封闭图形示例 

 

 

----结束 

3.4.7.26 打散封闭图形为线段（Decompose Area） 

本章节为您介绍如何打散封闭图形为线段。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Decompose Area”。 

步骤 3 在编辑器右侧“Options”窗口，选择是否删除打散后多余图形。 

勾选 Delete shape after decompose 前的方框，可删除打散后多余图形。取消勾

选，则不删除。 

图3-201 打散图形操作配置 
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步骤 4 在画布中框选封闭图形，右键单击“Done”保存并退出转换状态。 

图3-202 打散封闭图形示例 

 

 

----结束 

3.4.7.27 删除孤立铜箔（Delete Islands） 

本章节为您介绍如何删除孤立铜箔。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Delete Isolate elements>Delete Islands”。 

步骤 3 在编辑器右侧“Options”窗口，单击“Delete all on layer”，删除全部孤立铜箔。 

图3-203 删除孤立铜箔设置 

 

 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 243 

 

----结束 

3.4.7.28 测试点（Testprep） 

3.4.7.28.1 自动添加测试点（Automatic） 

本章节为您介绍如何自动添加测试点。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Testprep>Automatic...”。 

步骤 3 在弹出“Testpoint Automatic”页面中，单击“Parameters...”，设置测试点参

数，操作步骤请参见 3.4.7.28.3 设置测试点参数（Parameters）。 

步骤 4 设置完成后，在弹出“Testpoint Automatic”页面中，选择网络、勾选配置选项、选

择执行模式，单击“Generate”。参数说明请参见表 3-35。 
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图3-204 自动添加测试点配置 

 

 

表3-35 自动添加测试点参数说明 

类型 参数名称 说明 

Select Net

（选择网络） 

All 单击 All 前的圆圈，选择所有网络。 

Specify 单击 Specify 前的圆圈，选择具体某个网络。单击

选择网络列表文件。 

Option（配

置选项） 

Allow test 

directly on 

pad 

勾选 Allow test directly on pad 前的方框，优先

焊盘上添加测试点（焊盘为过孔焊盘）。取消勾

选，则不优先添加。 

Allow Smd 

Tps Process 

勾选 Allow Smd Tps Process 前的方框，允许添

加偏盘测试点。取消勾选，则不允许添加。 

Overwrite 单击 Overwrite 前的圆圈，选择全覆盖添加测试
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类型 参数名称 说明 

点。 

Incremental 单击 Incremental 前的圆圈，选择增量添加测试

点。 

 

----结束 

3.4.7.28.2 手动添加测试点（Manual） 

本章节为您介绍如何手动添加测试点。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Testprep>Manual”。 

步骤 3 在编辑器右侧“Options”窗口，单击“Parameters...”，设置测试点参数。操作步

骤请参见 3.4.7.28.3 设置测试点参数（Parameters）。 

步骤 4 设置完成后，在编辑器右侧“Options”窗口，配置操作类型，勾选配置参数，参数

说明请参见表 3-36。 

图3-205 手动添加测试点配置 

 

 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 246 

 

表3-36 手动添加测试点参数说明 

类型 参数名称 说明 

Mode

（操作类

型） 

Add 单击 Add 前的圆圈，选择添加测试

点。 

Delete 单击 Delete 前的圆圈，选择删除测

试点。 

Query 单击 Query 前的圆圈，选择查询测试

点。 

- Allow Smd Tps Process 勾选 Allow Smd Tps Process 前的方

框，允许添加偏盘测试点。取消勾

选，则不允许添加。 

 

步骤 5 在画布中单选或者框选操作对象，画布中将自动添加、删除、查询操作对象测试点。 

 

如果无法添加、删除、查询操作对象测试点，操作命令窗口框内会有具体提示。 

----结束 

3.4.7.28.3 设置测试点参数（Parameters） 

本章节为您介绍如何设置测试点参数。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Testprep>Parameters”。 

步骤 3 在弹出的“Testprep Parameters”页面中，进入“General”属性参数设置界面。 

步骤 4 在设置界面中，根据需求修改测试点配置参数和类型。参数说明请参见表 3-37。 
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图3-206 General 参数设置 

 

 

表3-37 General 参数名称说明表 

类型 参数名称 说明 

Metho

dology

（方式） 

Layer（添加测

试点的图层） 

Top 单击 Layer 后的下拉框选择 Top，选择顶

层添加测试点。 

Bottom 单击 Layer 后的下拉框选择 Bottom，选

择底层添加测试点。 

Test Method

（测试点添加方

式） 

Single 单个添加，此为默认设置，不可修改。 

Restrict

ions

（约束配

Allow under 

component

（允许添加面

Never 单击 Allow under component 后的下拉

框选择 Never，器件 Assembly 或者

Place Bound 区域不能添加测试点。配置

Component representation 时，才配置
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类型 参数名称 说明 

置） 向） 此项。 

Top 

Layer 

only 

单击 Allow under component 后的下拉

框选择 Top Layer only，顶层添加测试点

时器件 Assembly 或者 Place Bound 区

域能添加测试点。配置 Component 

representation 时，才配置此项。 

Bottom 

Layer 

only 

单击 Allow under component 后的下拉

框选择 Bottom Layer only，底层添加测

试点时器件 Assembly 或者 Place Bound

区域能添加测试点。配置 Component 

representation 时，才配置此项。 

Either 

Layer 

单击 Allow under component 后的下拉

框选择 Either Layer，在顶层或者底层添

加测试点时器件不受 Assembly 或者

Place Bound 区域限制。配置

Component representation 时，才配置

此项。 

Component 

representation

（器件区域选

择） 

Assembl

y 

单击 Component representation 后的

下拉框选择 Assembly，可在装配层器件

区域放置测试点。 

Place 

Bound 

单击 Component representation 后的

下拉框选择 Place Bound，可在器件本体

层区域放置测试点。 

Probe 

Type

（测试点

类型） 

Probe Spacing

（测试点中心

距） 

Probe 

Spacing 

双击 Probe Spacing 列下的表格，填写

测试点中心距。 

Figure（图标样

式配置） 

Triangle 单击 Figure 下的下拉框选择 Triangle，

选择三角形。 

Rectangl

e 

单击 Figure 下的下拉框选择

Rectangle，选择矩形。 

Square 单击 Figure 下的下拉框选择 Square，选
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类型 参数名称 说明 

择正方形。 

Hexagon

X 

单击 Figure 下的下拉框选择

HexagonX，选择六角形 X。 

Hexagon

Y 

单击 Figure 下的下拉框选择

HexagonY，选择六角形 Y。 

Octagon 单击 Figure 下的下拉框选择 Octagon，

选择八边形。 

Diamon

d 

单击 Figure 下的下拉框选择 Diamond，

选择菱形。 

OblongX 单击 Figure 下的下拉框选择 OblongX，

选择椭圆形 X。 

OblongY 单击 Figure 下的下拉框选择 OblongY，

选择椭圆形 Y。 

 

步骤 5 参数设置完成后，单击“Apply”应用。 

步骤 6 在“Testprep Parameters”页面中，单击“Padstack Selection”，进入测试点焊盘

参数设置界面。 

步骤 7 在设置界面中，根据需求修改测试点焊盘配置参数和类型。参数说明请参见表 3-38。 
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图3-207 Padstack Selection 参数设置 

 

 

表3-38 Padstack Selection 参数名称说明表 

类型 参数名称 说明 

Pin type（Pin

类型） 

Via 单击 Pin type 后的下拉框选择 Via，给 Via 上添加测

试点。 

Any Pin 单击 Pin type 后的下拉框选择 Any Pin，给 Pin 上添

加测试点。 

Any Pnt 单击 Pin type 后的下拉框选择 Any Pnt，给 Via 或

者 Pin 上添加测试点。 

Pad stack 

type（封装类

型） 

Either 单击 Pin type 后的下拉框选择 Either，两者都选

择。 

SMT/Blin

d 

单击 Pin type 后的下拉框选择 SMT/Blind，给表贴

Via 或者表贴 Pin 添加测试点。 
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类型 参数名称 说明 

Thru 单击 Pin type 后的下拉框选择 Thru，给通孔或者通

Pin 添加测试点。 

Select SmdTp to via 

Offset value（偏心距配

置） 

单击 Select SmdTp to via Offset value 后的下拉框

选择，可选择 10、15。偏盘测试点偏心距为默认设

置，只能选择 10mils 和 15mils。 

New Via（添

加测试点对

象） 

SMT 

Testpad 

（表贴测试

点） 

在 New Via 栏下，默认设置不可修改。 

Thru Via 

（通孔测试

点） 

在 New Via 栏下，默认设置不可修改。 

TOP Side Testpoint 

（元面测试点） 

元面测试点，可在 TOP Side Testpoint 列下添加元

面测试点对象。 

BOTTOM Side Testpoint 

（焊面测试点） 

焊面测试点，可在 BOTTOM Side Testpoint 列下添

加焊面测试点对象。 

Enable（选择按钮） 勾选 Enable 栏下的方框，此封装在添加测试点时同

时更新封装。 

Existing Via（当前已存在

的封装） 

Existing Via 栏下显示当前已存在的封装。 

TOP Side Replacement

（元面新的封装） 

用于替换旧封装的新封装，可在 TOP Side 

Replacement 列下添加元面新的封装。 

BOTTOM Side 

Replacement（焊面新的封

装） 

用于替换旧封装的新封装，可在 BOTTOM Side 

Replacement 列下添加焊面新的封装。 

Add Exiting Vias（添加封

装） 

勾选 Replace vias 后，单击 Add Exiting Vias，可添

加封装。 

Replace vias（替换封装） 勾选 Replace vias 前的方框，可选择替换封装。 
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步骤 8 单击“SMT Testpad”栏的 ，在弹窗中选择添加测试点的对象，单击

“OK”完成测试点对象配置。 

步骤 9 可进行封装替换配置。 

1. 勾选 Replace vias 前的方框，单击“Add Exiting Vias”。 

2. 单击 选择用于替换旧封装的新封装。 

3. 勾选 Enable，在添加测试点时同时更新封装。 

步骤 10 参数设置完成后，单击“Apply”应用。 

步骤 11 单击“OK”，保存设置并退出设置窗口。 

 

⚫ General 设置页面，选择在 Top 层添加测试点，在 Padstack Selection 页面也要在对应的

TOP Side Testpoint 下单击 添加测试点对象。 

⚫ General 设置页面，选择在 Bottom 层添加测试点，在 Padstack Selection 页面也要在对应

的 BOTTOM Side Testpoint 下单击 添加测试点对象。 

----结束 

3.4.7.29 泪滴（Teardrop/Tapered Trace） 

3.4.7.29.1 批量添加泪滴（Batch） 

本章节为您介绍如何批量添加泪滴。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Teardrop/Tapered Trace>Batch”。 

步骤 3 在弹出“Teardrop and Tapered Trace Parameters”页面中，配置选项、选择图

层、对象和焊盘形状、泪滴参数、线的参数。 

参数说明请参见表 3-39。 
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图3-208 批量添加泪滴参数设置 

 

 

表3-39 添加泪滴参数说明 

类型 参数名称 说明 

Global 

Options（全

部选项） 

Dynamic 勾选 Dynamic 前的方框，泪滴上的线改变时泪滴

也会跟着改变。取消勾选，则不会改变。 

Curved 勾选 Curved 前的方框，泪滴边沿弧度化。取消勾

选，则不会边沿弧度化。 

Allow DRC 勾选 Allow DRC 前的方框，在添加更多泪滴时，

允许 DRC 检查。取消勾选，则不允许 DRC 检查。 

Layer（图

层） 

All 单击 All 前的圆圈，选择所有图层。 

Top 单击 Top 前的圆圈，选择顶层。 

Bottom 单击 Bottom 前的圆圈，选择底层。 

Visible 单击 Visible 前的圆圈，选择可视层。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 254 

 

类型 参数名称 说明 

Objects（对

象） 

Pins 勾选 Pins 前的方框，选择 Pin。 

Vias 勾选 Vias 前的方框，选择过孔。 

T 

connections 

勾选 T connections 前的方框，选择测试点。 

Circular 

pads 

勾选 Circular pads 前的方框，选择圆形焊盘。在

输入框后输入尺寸最大值。 

Square 

pads 

勾选 Square pads 前的方框，选择正方形焊盘。

在输入框后输入尺寸最大值。 

Rectangular 

pads 

勾选 Rectangular pads 前的方框，选择矩形焊

盘。在输入框后输入尺寸最大值。 

Oblong 

pads 

勾选 Oblong pads 前的方框，选择椭圆形焊盘。

在输入框后输入尺寸最大值。 

Octang 

pads 

勾选 Octang pads 前的方框，选择八边形焊盘。

在输入框后输入尺寸最大值。 

Shape pads 勾选 Shape pads 前的方框，选择多边形焊盘。 

Pads 

without 

drills 

勾选 Pads without drills 前的方框，无孔盘。 

Teardrop 

Option 

（泪滴参数） 

Obj

ect 

All 选择全部对象，单击 Object 后的下拉框选择 All。 

Pins 选择 pin，单击 Object 后的下拉框选择 Pins。 

Vias 选择过孔，单击 Object 后的下拉框选择 Vias。 

Ts 选择测试点，单击 Object 后的下拉框选择 Ts。 

Desired 

angle 

在 Desired angle 后的输入框输入泪滴头夹角大

小。 

Max angle 在 Max angle 后的输入框输入最大角度。 

Max offset 在 Max offset 后的输入框输入最大偏移量。 

Arc offset 在 Arc offset 后的第一个输入框输入弧线偏移量最
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类型 参数名称 说明 

小值。第二个输入框输入弧线偏移量最大值。 

Line width 在 Line width 后的第一个输入框输入泪滴线宽最

小值。第二个输入框输入泪滴线宽最大值。 

泪滴线宽的设置：3-25 之间添加泪滴，小于 3 或

者大于 25 不添加泪滴，参数可按需求设置。 

Tapered 

Trace 

Options（渐

变线泪滴参

数） 

Tapered 

traces 

勾选 Tapered traces 前的方框，对渐变线泪滴进

行设置，让线宽变化的地方进行圆环过渡。 

Min 

segment 

angle 

在 Min segment angle 后的输入框输入线段最小

角度。 

Desired 

angle 

在 Desired angle 后的输入框输入渐变线泪滴角度

大小。 

Max offset 在 Max offset 后的输入框输入渐变线泪滴最大偏

移量。 

 

步骤 4 单击“Apply”，画布中自动添加泪滴并高亮显示全部添加的泪滴。 

 

自动添加一次泪滴后，再次添加，软件会把整板泪滴全部删除后，重新添加。 

----结束 

3.4.7.29.2 手动操作泪滴（Interactive） 

本章节为您介绍如何手动操作泪滴，包括添加普通泪滴、删除普通泪滴、增加渐变线

泪滴、删除渐变线泪滴。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Teardrop/Tapered Trace>Interactive”。 

步骤 3 在 PCB-DESIGN 版图编辑器手动操作泪滴说明如表 3-40 所示。 
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图3-209 手动操作泪滴配置 

 

 

表3-40 手动操作泪滴说明 

操作名称 操作步骤 

Teardrop Add

（添加普通泪

滴） 

1. 在编辑器右侧“Options”窗口，单击“Change 

Parameter”修改泪滴配置的参数。 

2. 在编辑器右侧“Options”窗口，在 Mode 框里，单击

“Teardrop Add”。 

3. 在画布中单选或者框选操作对象，系统自动显示并高亮添加

的泪滴。 

Teardrop 

Delete（删除普

通泪滴） 

1. 在编辑器右侧“Options”窗口，在 Mode 框里，单击

“Teardrop Delete”。 

2. 在画布中单选或者框选操作对象，系统自动删除泪滴。 

Taper Add（添

加渐变线泪滴） 

1. 在编辑器右侧“Options”窗口，单击“Change 

Parameter”修改渐变线泪滴配置的参数。 

2. 在编辑器右侧“Options”窗口，在 Mode 框里，单击

“Taper Add”。 

3. 在画布中单选或者框选操作对象，系统自动显示并高亮添加

的渐变线泪滴。 

Taper Delete

（删除渐变线泪

滴） 

1. 在编辑器右侧“Options”窗口，在 Mode 框里，单击

“Taper Delete”。 

2. 在画布中单选或者框选操作对象，系统自动删除泪滴。 
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----结束 

3.4.7.29.3 查看缺失泪滴报告（Missing teardrop） 

本章节为您介绍如何查看缺失泪滴报告。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Teardrop/Tapered Trace>Missing teardrop”。 

步骤 3 在弹出的“Teardrop Report”页面中，查看相应的缺失泪滴报告。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示报告文件。 

⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当

前报告文件。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 

图3-210 缺失泪滴报告 

 

 

步骤 4 单击“Item”列表中的缺失泪滴对象，画布中会高亮显示该位置。 

----结束 
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3.4.7.29.4 查看缺失渐变线泪滴报告（Missing tapered） 

本章节为您介绍如何查看缺失渐变线泪滴报告。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Teardrop/Tapered Trace>Missing tapered”。 

步骤 3 在弹出的“Tapered Report”页面中，查看相应的缺失渐变线泪滴报告。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示报告文件。 

⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当

前报告文件。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 

图3-211 缺失渐变线泪滴报告 

 

 

步骤 4 单击“Item”列表中的缺失渐变线泪滴对象，画布中会高亮显示该位置。 

----结束 

3.4.7.30 走线转铜（Trace To Area） 

本章节为您介绍如何将电气性走线转换成铜箔。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Trace To Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置对象类型、网络类型、转换模式。参数说明请

参见表 3-41。 

图3-212 走线转铜配置 

 

 

表3-41 线转铜参数说明 

类型 参数名称 说明 

select 

layer（选

择对象） 

the same to trace 在 select layer 框中，单击 the same to 

trace 前的圆圈，走线转换只能转换到当前

层。 

select area subclass 在 select layer 框中，单击 select area 

subclass 前的圆圈，走线转换可以转换到其

他层。 
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类型 参数名称 说明 

select net

（选择网

络） 

the same to trace 在 select net 框中，单击 the same to trace

前的圆圈，转换后铜箔只能与走线同网络。 

select area net 在 select net 框中，单击 select area net 前

的圆圈，转换后铜箔可以自定义网络。单击

下方的 ，在弹窗中可以自定义网

络。 

setting 

data（设置

数据） 

Expand 在 Expand 后的输入框输入外延或者内缩数

值。 

delete trace after 

create area 

勾选 delete trace after create area 前的方

框，线转铜后自动删除线段。 

 

步骤 4 在画布中，单选或者框选走线，画布中系统自动显示转换后的铜箔，并保持转换状

态。 

步骤 5 右键单击“Done”，保存并退出转换状态。 

步骤 6 转换完成后，可在画布中查看转换状态。 

1. 在菜单栏选择“Display>Info”。 

2. 单选或者框选转换状态后的铜箔。 

3. 在弹窗中查看转换状态后的铜箔属性。 

图3-213 线转铜示图 

 

 

----结束 
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3.4.7.31 铜转线（Area To Line） 

本章节为您介绍如何将铜箔转换成线。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Area To Line”。 

步骤 3 在画布中，单选或者框选铜箔，画布中系统自动显示转换后的铜箔边沿线，并保持转

换状态。 

步骤 4 右键单击“Done”，保存并退出转换状态。 

步骤 5 转换完成后，可在画布中查看转换状态。 

1. 在菜单栏选择“Display>Info”。 

2. 单选或者框选转换状态后的非电气线。 

3. 在弹窗中查看转换状态后的非电气线属性。 

图3-214 铜转线示图 

 

 

----结束 

3.4.7.32 自动转换走线拐角（Auto-interactive Convert Corner） 

本章节为您介绍如何自动转换走线拐角。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Route>Modify Traces>Auto-interactive Convert Corner”。 
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步骤 3 在编辑器右侧“Options”窗口配置参数。 

1. 拐角弧化：在 Convert Type 后的下拉框中自动识别 Arc（圆弧拐角）。 

2. 在 cns 区域转换拐角：在 Allow in cns areas 后的下拉框中选择 Yes，允许在规

则区域（Rule area 区域）转换拐角。如果不允许在 cns 区域转换拐角，则选择

No。 

3. 合适的半径尺寸：在 Preferred Radius Size 后的下拉框中自动识别“5x width”

（5 倍线宽），可自定义设置合适的尺寸。尺寸大小可以按倍数线宽设置，也可

以输入数值。倍数线宽取值范围为“1xwidth-10x width”，数值取值范围为

“0-600”但输入数值不能为 0。 

4. 最小的半径尺寸：在 Min Radius Size 后的下拉框中自动识别“1x width”（1

倍线宽）。尺寸大小可以按倍数线宽设置，也可以输入数值。倍数线宽取值范围

为“1xwidth-10x width”，数值取值范围为“0-600”但输入数值不能为 0。

Min Radius Size 的取值不能大于 Preferred Radius Size 的取值。 

5. 允许 DRC 检查：勾选 Allow DRCs 前的方框。 

图3-215 拐角配置 

 

 

步骤 4 在画布中单选或者框选走线，画布中走线拐角系统自动显示成圆弧拐角。 

步骤 5 在画布中单击任意位置，完成走线拐角转换并保持转换状态。也可以右键单击

“Done”，保存并退出拐角转换状态。 
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图3-216 拐角转换前示图 

 

 

图3-217 拐角转换后示图 

 

 

----结束 

3.4.8 生产配置菜单（Manufacture） 

3.4.8.1 倒角（Drafting） 

3.4.8.1.1 线性倒角（Chamfer） 

本章节为您介绍如何在画布中对线段进行线性倒角。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Manufacture>Drafting>Chamfer”。 
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步骤 3 在编辑器右侧“Options”窗口，配置线段剪切长度和倒角角度。 

1. 线段剪切长度：在 First 后的输入框输入长度，在 Second 后的输入框输入 0。 

2. 倒角角度：单击 Chamfer angle 后的下拉框选择，可选择 0、30、45、60、

90、120、135、150。 

图3-218 线性倒角配置 

 

 

步骤 4 在画布中框选线段倒角位置。也可以先选择倒角位置的一根线，再选另一根线。 

步骤 5 在画布中自动显示线段倒角结果。 

----结束 

3.4.8.1.2 圆弧倒角（Fillet） 

本章节为您介绍如何在画布中对线段进行圆弧倒角。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Manufacture>Drafting>Fillet”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆弧半径。 

圆弧半径：在 Radius 后的输入框输入半径大小。 
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图3-219 圆弧倒角配置 

 

 

步骤 4 在画布中框选线段倒角位置。也可以先选择倒角位置的一根线，再选另一根线。 

步骤 5 在画布中自动显示线段倒角结果。 

----结束 

3.4.8.2 生成钻孔表格（Drill Legend） 

本章节为您介绍如何在画布中生成钻孔表格。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Manufacture>Drill Legend”。 

步骤 3 在弹出的“Drill Legend”页面中，配置单位、字体格式大小、排列顺序类型、钻孔属

性。 

1. 单位：单击 Output unit 后的下拉框选择，可选择 Mils（千分之一英寸）和

Millimeter（毫米）两种类型。 

2. 字体格式大小：单击“Text size”，在列表中双击表格修改数值大小。 

3. 排列顺序类型：单击 By hole size 框下的排序类型前的圆圈，可选择 Ascending

（上升排序）和 Descending（下降排序）。 

4. 钻孔属性类型：单击 By plating status 框下的属性类型前的圆圈，可选择 Plated 

first（优先选择金属化孔排序）和 Non-plated first（优先选择非金属化孔排

序）。 

步骤 4 配置完成后，单击“OK”。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 266 

 

图3-220 生成钻孔表格配置 

 

 

步骤 5 在画布中，表格悬挂在鼠标上，单击表格放置位置，生成钻孔表格。 

图3-221 钻孔表格示图 

 

 

----结束 
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3.4.9 工具菜单（Tools） 

3.4.9.1 设置叠层（Stack-up Editor） 

3.4.9.1.1 自动添加叠层 

本章节为您介绍如何自动添加 PCB 板叠层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Stack-up Editor...”。 

步骤 3 在弹出的“Stack-up Editor”页面中，单击“Auto cross-section”添加 PCB 板叠

层。 

1. 在弹出的“Set layout cross section”页面中，在“Please input layer_state”

栏下填写层叠的缩写首字母，单击“Add”。 

2. 在“Set layout cross section”页面“Current layer”栏下自动显示添加的叠

层。 
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图3-222 叠层显示 

 

 

步骤 4 在弹出的“Stack-up Editor”页面中，修改叠层厚度、叠层材料信息、正负层和介

质，参数说明请参见表 3-42。 

图3-223 叠层配置 
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表3-42 叠层参数说明表 

参数类型 参数名称 操作说明 

Name（图层名

称） 

Top（叠层顶

层） 

图层为默认设置不能修改。 

Bottom（叠层底

层） 

图层为默认设置不能修改。 

Gnd（叠层内层

地层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Power（叠层内

层电源层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Art（叠层内层信

号层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Type（图层类

型） 

Surface（表层） 表层为默认设置不能修改。 

Conductor（走

线层） 

单击 Type 栏下的下拉框选择 Conductor。 

Dielectric（介质

层） 

介质层为默认设置不能修改。 

Plane（大铜箔

层、平面或者负

片） 

单击 Type 栏下的下拉框选择 Plane。 

Thickness（层

厚） 

Thickness（层的

厚度） 

双击 Thickness 栏下的输入框修改层的厚度

数值，根据实际情况进行设置。 

Material（材料

类型） 

FR-4（FR-4 绝

缘材料） 

常用的绝缘材料，一般介质才会使用绝缘材

料。单击 Material 栏下的下拉框选择 FR-4。 

COPPER（铜

箔） 

单击 Material 栏下的下拉框选择 COPPER。 

GOLD（金） 单击 Material 栏下的下拉框选择 GOLD。 

SILVER（银） 单击 Material 栏下的下拉框选择 SILVER。 

Stacking（叠 Core（芯板） 单击 Stacking 栏下的下拉框选择 Core。 
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参数类型 参数名称 操作说明 

层） Prepreg（半固

化片） 

单击 Stacking 栏下的下拉框选择 Prepreg。 

Negative（负

片） 

Negative（负

片） 

勾选 Negative 栏下的方框，设置为负片层。

取消勾选，不设置为负片层。 

Dielectric 

Constant（介

质常数） 

Dielectric 

Constant（介质

常数） 

双击 Dielectric Constant 栏下的输入框修改

介质常数，根据实际情况进行设置。 

velocity（速

率） 

velocity（速

率） 

一般为默认设置。 

 

步骤 5 设置完成后，单击“OK”。 

 

⚫ 叠层的缩写字母，s 代表信号层，g 代表地层，p 代表电源层。 

⚫ 叠层 Top 层和 Bottom 层是固定配置，“Please input layer_state”栏输入叠层首位和末位

一定是字母 S，而且只能输入小写字母。 

----结束 

3.4.9.1.2 手动添加叠层 

本章节为您介绍如何手动添加 PCB 板叠层。整个项目需要几层，逐一去定义每一层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Stack-up Editor...”。 

步骤 3 在弹出的“Stack-up Editor”页面中，有两种添加方式，分别是在 Top 层下添加和

Bottom 层上添加。 

⚫ Top 层下添加 

a. 在弹出的“Stack-up Editor”页面中，右键单击图层“Top”，单击“Add 

Layer”。 
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b. 在弹出的“Add Layers”页面中，配置添加图层数量、填写图层名称、图层

添加位置、图层类型、材料类型。 

i. 图层数量：在 Count of new layers 后的输入框输入添加的数量。 

ii. 图层名称：在 Name prefix 后的输入框输入图层名称。 

iii. 图层添加位置：图层添加位置为默认设置不能修改，只能选择 Below 

Top（在 Top 层下添加）。 

iv. 图层类型：单击 Layer type 下的选项。可选择 Conductor、

Dielectric、Plane。 

v. 材料类型：单击 Layer Material 下的选项，可选择 FR-4、COPPER、

GOLD、SILVER。 

 Conductor 对应的 Material 可选择 COPPER、GOLD、SILVER。 

 Dielectric 对应的 Material 可选择 FR-4。 

 Plane 对应的 Material 可选择 COPPER、GOLD、SILVER。 

c. 完成设置，单击“OK”。 

图3-224 Top 层添加叠层示例图 

 

 

⚫ Bottom 层上添加 
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a. 在弹出的“Stack-up Editor”页面中，右键单击图层“Bottom”，单击

“Add Layer”。 

b. 在弹出的“Add Layers”页面中，配置添加图层数量、填写图层名称、图层

添加位置、图层类型、材料类型。 

i. 图层数量：在 Count of new layers 后的输入框输入添加的数量。 

ii. 图层名称：在 Name prefix 后的输入框输入图层名称。 

iii. 图层添加位置：图层添加位置为默认设置不能修改，只能选择 Above 

Bottom（在 Bottom 层上添加）。 

iv. 图层类型：单击 Layer type 下的选项。可选择 Conductor、

Dielectric、Plane。 

v. 材料类型：单击 Layer Material 下的选项，可选择 FR-4、COPPER、

GOLD、SILVER。 

 Conductor 对应的 Material 可选择 COPPER、GOLD、SILVER。 

 Dielectric 对应的 Material 可选择 FR-4。 

 Plane 对应的 Material 可选择 COPPER、GOLD、SILVER。 

c. 完成设置，单击“OK”。 

图3-225 Bottom 层添加叠层示例图 
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步骤 4 在弹出的“Stack-up Editor”页面中，修改叠层厚度、叠层材料信息、正负层和介

质。参数说明请参见表 3-43。 

图3-226 叠层配置 

 

 

表3-43 叠层参数说明表 

参数类型 参数名称 操作说明 

Name（图层名

称） 

Top（叠层顶

层） 

图层为默认设置不能修改。 

Bottom（叠层底

层） 

图层为默认设置不能修改。 

Gnd（叠层内层

地层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Power（叠层内

层电源层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Art（叠层内层信

号层） 

图层为默认设置，双击 Name 栏下的图层名

称，可修改图层名称。 

Type（图层类

型） 

Surface（表层） 表层为默认设置不能修改。 

Conductor（走

线层） 

单击 Type 栏下的下拉框选择 Conductor。 
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参数类型 参数名称 操作说明 

Dielectric（介质

层） 

介质层为默认设置不能修改。 

Plane（大铜箔

层、平面或者负

片） 

单击 Type 栏下的下拉框选择 Plane。 

Thickness（层

厚） 

Thickness（层的

厚度） 

双击 Thickness 栏下的输入框修改层的厚度

数值，根据实际情况进行设置。 

Material（材料

类型） 

FR-4（FR-4 绝

缘材料） 

常用的绝缘材料，一般介质才会使用绝缘材

料。单击 Material 栏下的下拉框选择 FR-4。 

COPPER（铜

箔） 

单击 Material 栏下的下拉框选择 COPPER。 

GOLD（金） 单击 Material 栏下的下拉框选择 GOLD。 

SILVER（银） 单击 Material 栏下的下拉框选择 SILVER。 

Stacking（叠

层） 

Core（芯板） 单击 Stacking 栏下的下拉框选择 Core。 

Prepreg（半固

化片） 

单击 Stacking 栏下的下拉框选择 Prepreg。 

Negative（负

片） 

Negative（负

片） 

勾选 Negative 栏下的方框，设置为负片层。

取消勾选，不设置为负片层。 

Dielectric 

Constant（介

质常数） 

Dielectric 

Constant（介质

常数） 

双击 Dielectric Constant 栏下的输入框修改

介质常数，根据实际情况进行设置。 

velocity（速

率） 

velocity（速

率） 

一般为默认设置。 

 

步骤 5 设置完成后，单击“OK”。 

 

⚫ 在图层的上方添加选择“Above”，在图层下方添加选择“Below”。 

⚫ 选择新建的图层，右键单击“Remove Layer”可移除当前层。 
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⚫ 选择新建的图层，右键单击“Add Layer pair Above”可在当前层上方成对添加层次，命名

Lay_n。 

⚫ 选择新建的图层，右键单击“Add Layer pair Below”可在当前层下方成对添加层次，命名

Lay_n。 

⚫ 选择新建的图层，右键单击“Add Layer Above”可在当前层上方单层添加介质层，不命

名。 

⚫ 选择新建的图层，右键单击“Add Layer Below”可在当前层下方单层添加介质层，不命

名。 

⚫ 选择新建的图层，右键单击“Remove Layer pair”可成对移除层次。 

----结束 

3.4.9.2 用户自定义层（Define User Layer） 

本章节为您介绍如何添加和删除用户自定义层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Define User Layer” 。 

步骤 3 在弹出的“Define User Layer”页面中，选择自定义层操作，单击“OK”保存。 

⚫ 添加自定义层 

a. 在弹出的“Define User Layer”页面中，单击 。 

i. 在弹出的“Add User Layer”弹窗中填写自定义层名称。 

ii. 单击“OK”保存层命名。 

b. 单击“OK”。 
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图3-227 添加自定义层 

 

 

⚫ 删除自定义层 

a. 选择已添加的自定义层，单击图标 删除自定义层。 

b. 单击“OK”。 
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图3-228 删除自定义层 

 

 

----结束 

3.4.9.3 规则约束（Constraints Editor） 

3.4.9.3.1 规则管理器介绍 

规则管理器就是对设置的规则数据进行管理，这些数据是提供给 DRC 检查的。物理、

电气、间距 DRC 通过对网络对象的相关属性进行检查并将检查结果与规则管理器中的

规则值进行比较，比较不通过的，则在页面中展示出 DRC 图标。 

规则管理器分类 

版图工具提供三种规则管理器和一个配置界面：Rule 规则集管理器、Net 网络规则管

理器、Electrical 电气规则管理器和 DFA 规则配置界面。 
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表3-44 规则管理器分类说明 

类型 说明 

Rule 规则集

管理器 

Rule 规则集 规则集可理解为模板，定义好模板后方便后面 net

去使用。 

Master 规则集的定义界面，可以定义物理、间距等若干个

规则集，供不同网络引用。 

Minimum

规则集 

二次防护，该规则集以及引用该规则集的对象都会

检查对应值是不是处于 minimum 规则集设置的范

围内。可根据不同厂家的加工精度进行不同的设

置，防止设计的版图在生产上出问题。 

Net 网络规

则管理器 

Physical 物理规则配置界面，设置网络中对象和其他网络对

象的最小间距规则。 

Spacing 异网间距规则配置界面，设置网络对象和其他网络

对象的最小间距规则。 

Same Net 

Spacing 

同网间距规则配置界面，设置网络对象和同网络对

象的最小间距规则。 

Electrical 电

气规则管理

器 

Electrical 电

气规则 

设置走线长度规则、差分对长度误差、等长规则

等。 

DFA 规则配

置界面 

DFA 规则 设置 pkg to pkg 的长宽之间的间距规则。 

 

规则管理器界面数据介绍 

⚫ 界面数值颜色分类： 

− 白色值：没有修改过的值。 

− 蓝色值：代表用户修改过的值。 

− 绿色值：代表在规则设置正常范围内的值。 

− 红色值：代表不在规则设置正常范围内的值，需要报 DRC。 

⚫ 规则集页签值： 
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− 冒号分割值：代表每一层的该属性规则值。 

− 单个值：代表所有层的该属性值一致。 

规则管理器组对象介绍 

组对象出现的目的是为了方便配置规则，方便给多个网络配置同一个规则。 

⚫ 组对象的类型 

− Enet：分离器件（电容、电阻等）两个引脚两边的网络组成的整体。网络即

为电压，当一个网络经过了分离器件后，电压会发生改变，引脚两端的网络

不属于同一个网络，将分离器件的两个 net 当作一个整体来进行管理，于是

有了 Enet 的概念。 

− DPR：差分对，一般在设计过程中两个网络对于时序、信号要求相同时，会

将其作为差分组，方便走线、进行等长等检查。差分对可以包含两个 Net，

也可以包含两个 Enet，也可以是一个 net 和一个 Enet。 

− NGRP：网络组，一种简单的组关系，没有物理含义。可以对多个网络创建

网络组，方便对组内的网络进行统一的规则值设置。 

− NCLS：和网络组类似，但检查优先级更高。 

⚫ 规则继承优先级 

Net>Enet>DPR>NGRP>NCLS，用户自定义修改优先级最高。 

3.4.9.3.2 Rule 规则集管理器 

4.4.8.3.2.1 创建物理检查规则 

本章节为您介绍如何根据项目要求设置 PCB 板物理检查规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建物理规则设置。参数类型说明请参见表

3-45。 

1. 在规则管理器界面中，选择“Physical>PCS”。 

2. 右键单击“Create>physical...”创建物理规则设置文件。 
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3. 在弹出的“Create Physical CSet”页面中，在 Physical CSet 后的输入框填写文

件名，单击“OK”。 

4. 在创建的列表中选择需要修改的参数表格。 

5. 右键单击“Edit”修改表格中的参数或者双击表格修改参数。 

图3-229 创建物理规则 

 

 

表3-45 物理规则设置参数说明 

参数名称 说明 参数子选项说明 

Trace Width      线宽 - 

Neck Neck 模式 Min：最小线宽 

Max Length：neck 模式下走线总

长 

Differential Pair 差分对物理规则 Min Line Spacing：最小线内间距 

Primary Gap：差分对最优先线间

距 

Neck Gap：差分对 Neck 模式下

的线间距 

Tolerance：公差 

Via Assigments 选择孔列表 - 

BB via Stagger 埋孔、盲孔打在焊盘上

错开的距离即中心距 

- 

Pad-Pad Connect Pad-Pad 直连允许的类

型 

ALL_ALLOWED：都允许 

NOT_ALLOWED：都不允许 

VIAS_PINS_ONLY：仅允许器件管
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参数名称 说明 参数子选项说明 

脚与过孔直连 

VIAS_VIAS_ONLY：仅允许过孔与

过孔直连 

MICROVIAS_MICROVIAS_ONLY

：仅允许微孔直连 

MICROVIAS_MICROVIAS 

_COINCIDENT_ONLY：仅允许微

孔和微孔中心直连 

Etch 检查该层是否可以布线

和铺铜 

TRUE：是 

FALSE：否 

Ts T 点允许出现的位置 ANYWHERE：任何位置都允许出

现 T 点 

TS_NOT_ALLOWED：任何位置都

不允许出现 T 点 

PINS_ONLY：仅允许器件管脚的

位置出现 T 点 

PINS_VIAS_ONLY：仅允许器件管

脚与过孔直连的位置出现 T 点 

 

 

⚫ 创建的物理规则会在 NET 规则里同步生成。 

⚫ 物理规则设置完成后不能单独使用，要在 NET 规则里给对象赋予约束规则才可使用。 

⚫ Trace Width 是提供给走线时使用的，DRC 检查无法区分线段走线是处于哪种模式下，在检

查时只会使用 neck 值进行检查，使用 neck 的线宽作为最小线宽对所有模式下的走线进行

检查。 

⚫ DPR 差分对物理规则检查：Min Line Spacing 的值，是给规则检查时使用的，作为规则检

查的预期值。Primary Gap、Neck Gap 是提供给差分走线的参数，在走线时使用。Neck

即为 neck 模式下差分走线时使用的最小线间距。设置值时规定：Min Line Spacing 

<=Primary Gap – Tolerance 并且 Min Line Spacing <=Neck Gap – Tolerance。 
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----结束 

4.4.8.3.2.2 创建间距检查规则 

本章节为您介绍如何根据项目要求设置 PCB 板间距规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建间距规则设置。参数类型说明请参见表

3-46。 

1. 在规则管理器界面中，选择“Spacing>SCS”。 

2. 右键单击“Create>spacing...”创建间距参数设置文件。 

3. 在弹出的“Create Spacing CSet”页面中，在 Spacing CSet 后的输入框填写文

件名，单击“OK”。 

4. 在创建的列表中，选择需要修改的参数表格。 

5. 右键单击“Edit”修改表格中的参数，或者双击表格修改参数。 

图3-230 创建间距规则 

 

 

表3-46 间距规则设置参数说明 

参数名称 参数说明 

Trace 走线 

Thru Pin 通孔 

SMD Pin 表贴焊盘 

Test Pin 有测试点的 Pin 
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参数名称 参数说明 

Thru Via 过孔（T-B） 

BB Via 盲埋孔 

Microvia 微孔，一般指小于 0.1mm 钻孔的 via 

Test Via 有测试点的过孔 

Bond Finger smd 焊盘中的一种，不上锡，没有钢网

层，金手指 

Areas 铜箔 

Hole 孔 

 

 

⚫ 创建的间距规则会在 NET 规则里同步生成。 

⚫ 间距规则设置完成后不能单独使用，要在 NET 规则里给对象赋予约束规则才可使用。 

⚫ 间距检查：间距检查检查项命名规则都是采用 A to B 这种形式设置在这个组对象或者 Net 网

络里，A 类型的 item 到 B 类型的 item 允许的最小间距。 

⚫ 间距检查的分类：间距检查分为异网间距检查（Spacing）和同网络间距检查(Same Net 

Spacing)。异网间距检查则设置该网络对象对于其它网络对象允许的最小间距。同网间距检

查则设置该网络对象与该网络对象允许的最小间距。 

----结束 

4.4.8.3.2.3 创建同网络间距检查规则 

本章节为您介绍如何根据项目要求设置 PCB 板同网络间距规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建同网络间距规则设置。参数类型说明请

参见表 3-47。 

1. 在规则管理器界面中，选择“Same Net Spacing>SNCS”。 
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2. 右键单击“Create>sameNet...”创建同网络间距参数设置文件。 

3. 在弹出的“Create sameNet CSet”页面中，在 sameNet CSet 后的输入框填写

文件名，单击“OK”。 

4. 在创建的列表中，选择需要修改的参数表格。 

5. 右键单击“Edit”修改表格中的参数，或者双击表格修改参数。 

图3-231 创建同网络间距规则 

 

 

表3-47 同网络间距规则设置参数说明 

参数名称 参数说明 

Trace 走线 

Thru Pin 通孔 

SMD Pin 表贴焊盘 

Test Pin 有测试点的 Pin 

Thru Via 过孔（T-B） 

BB Via 盲埋孔 

Microvia 微孔，一般指小于 0.1mm 钻孔的 via 

Test Via 有测试点的过孔 

Bond Finger smd 焊盘中的一种，不上锡，没有钢网

层，金手指 

Areas 铜箔 

Hole 孔 
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⚫ 创建的间距规则会在 NET 规则里同步生成。 

⚫ 间距规则设置完成后不能单独使用，要在 NET 规则里给对象赋予约束规则才可使用。 

⚫ 间距检查：间距检查检查项命名规则都是采用 A to B 这种形式设置在这个组对象或者 Net

网络里，A 类型的 item 到 B 类型的 item 允许的最小间距。 

⚫ 间距检查的分类：间距检查分为异网间距检查（Spacing）和同网络间距检查(Same Net 

Spacing)。异网间距检查则设置该网络对象对于其它网络对象允许的最小间距。同网间距检

查则设置该网络对象与该网络对象允许的最小间距。 

----结束 

3.4.9.3.3 Net 网络规则管理器 

4.4.8.3.3.1 创建 Net Class 规则 

本章节为您介绍如何根据项目要求设置 Net Class 规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建 Net Class 规则设置。 

1. 在规则管理器界面中，选择“Net >All>NET”。 

图 4-239 创建 Net Class 入口 

 

 

2. 右键单击“Create>Net Class...”创建 Net Class 规则参数设置文件。 
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图 4-240 创建 Net Class 

 

 

3. 在弹出的“Create Net Class”页面中，在 Net Class 后的输入框填写文件名，

选择是否同时创建物理规则和间距规则，单击“OK”。 

4. 在新建的规则中选择“NET>DEFAULT”，右键单击“Edit”，选择赋予对象规

则。 

图 4-241 赋予对象规则 

 

 

5. 在创建的列表中，选择需要修改的参数表格。 

6. 右键单击“Edit”修改表格中的参数，或者双击表格修改参数。 
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图 4-242 修改表格参数 

 

 

 

⚫ 在 All 文件中创建的 NET Class 规则会同步到 Net Class 文件，可在 Net Class 文件里编辑

表格参数。 

⚫ 可以选择多个 NET 赋予同一个规则。 

⚫ NetClass-Class: 表示此 NCLS 中的任意网络遇定义中另一 NCLS 中的任意网络都使用该间

距检查规则进行检查。 

----结束 

4.4.8.3.3.2 创建 Net Group 规则 

本章节为您介绍如何根据项目要求设置 Net Group 规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建 Net Group 规则设置。 

1. 在规则管理器界面中，选择“Net >All>NET”。 

图 4-243 创建 Net Group 入口 
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2. 右键单击“Create>Net Group...”创建 Net Group 规则参数设置文件。 

图 4-244 创建 Net Group 

 

 

3. 在弹出的“Create NetGroup”页面中，在 NetGroup 后的输入框填写文件名，

单击“OK”。 

4. 在新建的规则中选择“NET>DEFAULT”，右键单击“Edit”，选择赋予对象规

则。 

图 4-245 赋予对象规则 
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5. 在创建的列表中，选择需要修改的参数表格。 

6. 右键单击“Edit”修改表格中的参数，或者双击表格修改参数。 

图 4-246 修改表格参数 

 

 

 

⚫ 在 All 文件中创建的 NET 规则会同步到 Net Group 文件，可在 Net Group 文件里编辑表格

参数。 

⚫ Group 会在电气规则 Electrial 下同时创建，Class 不能。 

⚫ 可以选择多个 NET 赋予同一个规则。 

----结束 

4.4.8.3.3.3 创建 Region 规则 

本章节为您介绍如何根据项目要求设置区域内规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 
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步骤 3 在弹出的“Constraints Editor”页面中，创建 Region 规则设置。 

1. 在规则管理器界面中，选择“Net >Region>Dsn”。 

2. 右键单击“Create>Region...”创建 Region 规则。 

3. 在弹出的“Create Region”页面中，在 Region 后的输入框填写文件名，单击

“OK”。 

4. 在新建的规则中选择“RGN>DEFAULT”，右键单击“Edit”，选择赋予对象规

则。 

5. 在创建的列表中，选择需要修改的参数表格。右键单击“Edit”修改表格中的参

数，或者双击表格修改参数。 

图 4-247 创建物理 Region 规则 

 

 

 

⚫ Region 规则优先级大于 NET 规则，只适用于局部区域范围。 

⚫ 在 Region 页签上定义区域的物理规则 Region 属性，绑定此属性的 rule Area 则遵从此区

域属性的物理规则。也可以创建异网间距 Region 规则和同网间距 Region 规则，创建方法

同物理 Region 规则。 

⚫ RCLS：region 内部此 NCLS 中的网络使用此检查规则进行检查。 

⚫ RCC：region 内部此 NCLS 中任意网络遇到定义中另一 NCLS 中的任意网络都使用该规则进

行规则检查。 

步骤 4 给 Region 区域添加规则。 

1. 在菜单栏选择“Drawing>Rectangle”。 

2. 在编辑器右侧“Options”窗口中，选择“Rule Area”层。 
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3. 在画布中绘制 Region 规则的区域。 

4. 在编辑器右侧“Options”窗口中，单击 Assign to Region 下的 ，在

弹窗中选择已创建的规则，可选择 Physical、Spacing、Same Net Spacing 的

区域规则。如果物理、间距规则都想限制，物理、间距规则需要各勾选一个。 

图 4-248Region 区域添加规则 

 

 

步骤 5 区域规则设置完成后，可在画布中查看 Region 区域规则。 

1. 在菜单栏选择“Display>Info”。 

2. 单选或者框选 Region 规则区域。 

3. 在弹窗中查看对应的 Region 区域规则属性。 

图 4-249 查看 Region 区域规则 

 

 

----结束 
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3.4.9.3.4 Electrical 电气规则管理器 

4.4.8.3.4.1 Basic Elements 检查项 

Basic Elements 具体检查项目说明参数如表 3-48 所示。 

表3-48 Basic Elements 检查项说明 

检查项目 项目说明 

Stub Length 从配置的 TX 开始，整个网络中最长的非共享路径，从某一个

pin（tx）出发信号的最长非公共路径。 

Exposed Length Top/bottom 层的总的 cline 长度（暴露在外的 cline 长度总

和）。 

Parallel  平行于单条 seg 的一定范围内的线长之和。 

Layer Sets 该网络的对象允许分布在哪些层，查的是走线、铜箔。

Length 计算除了配置层外 pin 和 via 走线的长度总和，只看

表层。 

Via Count  统计 net 中 via 的个数，并与设置的规则值进行比较。 

Match Vias 以组对象 net 中 via 数目最小的为基准，与其它 net 所包含的

via 对比，只对组对象生效。用于检测过孔尺寸是否符合要

求。 

Via Quantity 单纯统计 via 的个数。 

Loop 检查网络中有没有环路，存在环路则报 DRC。 

Single-line 

Impedance 

单端阻抗检查。 

 

4.4.8.3.4.2 电气检查规则 

电气检查规则类型有四种，请参见表 3-49。 
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表3-49 检查规则类型说明 

检查规则

类型 

说明 检查规则

类型子项 

检查规则子项说明 

Min/Max 

Propagati

on 

Delays 

信号在 pin 上传输需要

时间 

Pin 

Delay 

信号在 Pin 上传输的时延 

Prop 

Delay 

(Min) 

Pinpair 时延 

Min Pinpair 时延最小值 

Actual 计算出的 Pinpair 时延实际值 

Margin

（Min） 

实际值与最小值的差值（实际值

-Min） 

Prop 

Delay 

(Max) 

Pinpair 时延 

Max Pinpair 时延最大值 

Actual 计算出的 Pinpair 时延实际值 

Margin

（Max） 

最大值与实际值的差值（Max-

实际值） 

Total 

Etch 

Length 

计算网络的总长，设置

总长的最小值、最大

值，判断该网络总长是

否超过这个范围。没超

过使用绿色显示，超过

显示红色，并报 DRC。

Margin 值为实际值与最

大值或最小值的差值。 

- - 

Different

ail Pair 

差分对一般要求两条线

信号传输时序相同，因

此需比较差分对下两个

pin pair 路径网络传输

Uncoupl

ed 

Length 

用于约束差分线的不匹配长度，

例如差分线引线处可能存在不耦

合的情况，设置 Max 值设置不

耦合长度的最大允许值。 
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检查规则

类型 

说明 检查规则

类型子项 

检查规则子项说明 

信号的时间差。 Dynami

c Phase 

对差分线内线差值做约束，即两

条差分线的长度差值不能超过

[max – tolerance，max + 

tolerance]这个范围。当超过这

个范围时，则显示红色，报

DRC，没超过显示绿色。

Margin 为 Actual – max。 

Relative 

Propagati

on Delay 

对于不是差分的一些

pinpair，在设计时要求

它们的信号传输时延相

同，需要等长时，则需

要用到 relative 

Propagation Delay，

将它们创建成 MGRP，

就能对其进行等长计算

规则管理。 

MGRP 仅电气检查有的特殊组对象。将

多个 pin pair 路径组成

MGRP，选择将网络添加到

MGRP 中时会自动创建 pinpair

路径，无法创建 pinpair 路径的

网络无法添加到 MGRP 中。 

GLOBAL MGRP 都按照 GLOBAL 中设置

的 target 进行比较 

LOCAL 是对 MGRP 内同网络下的

pinpair 进行比较，只要设置的

是 LOCAL 就会自动给每个网络

设置一个 target，如果没有任意

两个 pinpair 是同一网络下的，

则都为 target。 

 

 

PinPair 即为两个 pin 的连接路径，用 pinpair 来标明路径。同一 Net 下的两个 pin 或者是同一

Enet 下的两个 pin，都能组成 pinpair。 

3.4.9.3.5 DFA 规则配置界面 

在布局过程中设置 DFA 规则可以对封装与封装进行实时的间距检查，从而提高工作效

率。封装与封装之间的距离是通过封装边界区域进行约束的，所以每一个封装都要有

用于 DFA 检查的边界区域（Placement）。可以设置 4 种间距值，分别是 side to side
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（S:S）、end to end（E:E）、side to end（S:E）、end to side（E:S）。side 与 end 由

程序自行判定，对于长方形封装，定义封装的长边为 side，短边为 end。 

创建 DFA 规则 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，创建 DFA 规则设置。 

1. 在规则管理器界面中，选择“Manufacturing >Design For Assembly”。 

2. 设置规则面向：单击“Top”，选择在正面设置 DFA 规则。单击“Bottom”，

选择在反面设置 DFA 规则。 

3. 选择封装器件：单击“Show cell classifications”或者右键单击“Add 

Symbol”，在弹窗中勾选需要设置规则的封装器件，单击“OK”。 

 

⚫ 如果版图文件中不存在封装器件，在弹窗中不显示任何的封装器件。 

⚫ 如果想删除已选择的器件，可选择器件对应的表格，右键单击“Delete Rows”删除。 

4. 设定不同封装的间距值：在 Default 后的输入框输入封装间距值，单击“Apply 

to selected cells”可以一次性设定所有封装的间距值。也可双击封装间距列表中

的表格，手动对单个表格内的间距数值进行修改。例如表格里输入 50：200：

20：100，则表示分别对 side to side、end to end、side to end、end to side

设定的间距规则。 
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图3-232 创建 DFA 规则 

 

 

步骤 4 设置完成后，单击 关闭窗口即可。 

----结束 

应用 DFA 规则 

步骤 1 3.2 打开版图工程。 

步骤 2 在应用 DFA 规则前需要先创建 DFA 规则，具体操作请参见创建 DFA 规则。 

步骤 3 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 4 在规则管理器界面中，选择“Manufacturing >Design For Assembly”。 

步骤 5 单击 DRC Mode 下“ON”前的圆圈打开 DFA 规则检查。如果不想对 DFA 规则进行

检查，单击“off”前的圆圈关闭即可。 
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图3-233 DFA 规则检查开关 

 

 

步骤 6 在画布中放置器件时，会实时显示 DFA 间距符号。如果摆放间距小于 DFA 间距，就

会显示 DRC 错误。封装与封装之间的距离是通过封装边界区域（Placement）进行约

束的，检查 Placement 和 Placement 边沿之间的是否满足数据配置，器件相交时不

进行检查。例如 side to side 的间距值设置为 50 时，如果摆放间距小于 DFA 间距，

就会显示 DRC 错误。 

1. 在画布中放置已设置 DFA 规则的器件。 

2. 在菜单栏选择“Display>Info”。 

3. 单击 DRC 图标，在弹窗中可查看设置 DFA 规则的间距值和实际间距值。 

图3-234 DFA 间距检查示图 

 

 

----结束 

3.4.9.3.6 导入/导出 Constrains 和 Cset 规则 

4.4.8.3.5.1 导入 Constrains 规则 

本章节为您介绍如何导入 Constrains 规则。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，选择导入 Constrains 规则。 

1. 在页面中，选择“File>Import>Constrains...”进入导入规则窗口。 

2. 在弹出的“Import Constraint”页面中，勾选需要的规则类型。 

a. Value：勾选 Value 框内的方框，可选择 Physical、Spacing、SameNet、

Electrical、Design。 

b. CSet：勾选 CSet 框内的方框，可选择 Physical、Spacing、SameNet。 

c. Switch：勾选 Switch 框内的方框，可选择 Enable。 

3. 在 Mode 旁的下拉框选择导入模式，可选 Merge、Override 

4. 在 Constraint File 输入框后单击 ，在弹窗中选择导入的文件（.txt 文

件），单击“打开”。 

5. 单击“OK”完成 Constraints 规则导入。 

 

⚫ Value 导入 Net、Electrical、Manufacturing 文件夹里的规则数据。 

 

⚫ CSet 导入 Rule 文件夹里的规则数据。 

 

⚫ Switch 导入规则的 DRC 检查开关模式。 
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⚫ Merge 模式：数据相同部分覆盖，不同部分以当前单板数据为主。 

⚫ Override 模式：数据相同部分覆盖，不同部分以导入文件数据为主。 

图3-235 导入 Constrains 规则 

 

 

----结束 

4.4.8.3.5.2 导入 Cset 规则 

本章节为您介绍如何导入 Cset 规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，选择导入 Cset 规则。 

1. 在页面中，选择“File>Import>Cset...”进入导入规则窗口。 
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2. 在弹出的“CSet”页面中，单击 。 

3. 在弹窗中选择导入的文件（.csv 文件），单击“打开”。 

4. 单击 Group 后的下拉框选择，可选择 REFLOW_TECHNICS、

WAVEFLOW_TECHNICS。 

5. 勾选 All Cset。 

6. 单击“OK”完成 Cset 规则导入。 

图3-236 导入 Cset 规则 

 

 

----结束 

4.4.8.3.5.3 导出 Constrains 规则 

本章节为您介绍如何导出 Constrains 规则。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在菜单栏选择“Tools> Constraints Editor...”。 

步骤 3 在弹出的“Constraints Editor”页面中，选择导出 Constrains 规则。 

1. 在页面中选择“File>Export>Constrains...”进入导出规则窗口。 

2. 在弹出的“Export Constraint”页面中，勾选需要的规则类型。 

a. Value：勾选 Value 框内的方框，可选择 Physical、Spacing、SameNet、

Electrical、Design。 

b. CSet：勾选 CSet 框内的方框，可选择 Physical、Spacing、SameNet。 

c. Switch：勾选 Switch 框内的方框，可选择 Enable。 

3. 单击“OK”完成 Constraints 规则导出。 

 

⚫ Value 导出 Net、Electrical、Manufacturing 文件夹里的规则数据。 

 

⚫ CSet 导出 Rule 文件夹里的规则数据。 

 

⚫ Switch 导出规则的 DRC 检查开关模式。 
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图3-237 导出 Constrains 规则 

 

 

----结束 

3.4.9.3.7 规则文件新旧对比报告 

操作步骤 

步骤 1 流程设计窗口 Constraints Editor，双击打开 Constraints Editor，点击 File-Import-

Constraints 

 

步骤 2 导入关联文件 

 

效果图如下： 
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----结束 

3.4.9.4 修改/替换焊盘（Padstack） 

3.4.9.4.1 修改焊盘（Modify Design Padstack） 

4.4.8.4.1.1 修改同一类别焊盘 

本章节为您介绍如何修改 PCB 版图中同一类别的焊盘。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Design Padstack” 。 

步骤 3 在编辑器右侧“Options”窗口，选择需要修改的焊盘，单击“Edit”。 

1. 在 Name 后的输入框输入焊盘名称，搜索焊盘。 

2. 搜索完成后，在 Name 下方的搜索列表中，单击焊盘名称。 
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3. 单击“Edit”，进入焊盘编辑器界面。 

图3-238 修改同一类别焊盘参数配置 

 

 

步骤 4 在弹出焊盘编辑器弹窗中，配置焊盘参数。 

1. 单击 Connect Pad 列下的焊盘。 

2. 选择焊盘形状：在 Geometry 后的下拉框选择，可选择 Circle、Square、

Oblong、Rectangle、Rounded rectangle、Chamfered rectangle、 

N-sided polygon、Octagon、Donut。 

3. 根据不同的焊盘形状，配置参数。 

− Circle（圆形） 

i. 在 Geometry 后的下拉框选择 Circle。 

ii. 在 Diameter 后的输入框输入直径。 

− Square（方形） 
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i. 在 Geometry 后的下拉框选择 Square。 

ii. 在 Width 后的输入框输入方形长度。 

− Oblong（椭圆形） 

i. 在 Geometry 后的下拉框选择 Oblong。 

ii. 在 Width 后的输入框输入椭圆形 X 轴方向长度大小。 

iii. 在 Height 后的输入框输入椭圆形 Y 轴方向长度大小。 

− Rectangle（矩形） 

i. 在 Geometry 后的下拉框选择 Rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

− Rounded rectangle（倒圆角的矩形） 

i. 在 Geometry 后的下拉框选择 Rounded rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner radiu 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− Chamfered rectangle（倒斜角的矩形） 

i. 在 Geometry 后的下拉框选择 Chamfered rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner charr 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− N-sided polygon（多边形） 

i. 在 Geometry 后的下拉框选择 N-sided polygon。 

ii. 在 Diameter 后的输入框输入直径。 

iii. 在 sides 后的输入框输入多边形边数。边数只能是双数，不能输入单

数。 

− Octagon（八边形） 

i. 在 Geometry 后的下拉框选择 Octagon。 
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ii. 在 Width 后的输入框输入长度。 

− Donut（空心圆） 

i. 在 Geometry 后的下拉框选择 Donut。 

ii. 在 Outer Diame 后的输入框输入外径。 

iii. 在 Inner Diamet 后的输入框输入内径。 

图3-239 配置焊盘参数示图 

 

 

步骤 5 修改完成后，选择“File>Update to Design”，单击“Yes”保存。 

或者选择“File>Update to Design and Exit”，单击“Yes”保存并退出。 

 

⚫ 焊盘需要偏移时，可在配置焊盘参数页面，Offset 后的输入框输入偏移量。 

⚫ 在编辑器右侧“Options”窗口，单击“Purge”，在弹窗中选择不需要使用的焊盘，单击

“OK”。在 Name 下方的搜索列表中会自动清除不使用的焊盘。 

⚫ 单击“Reset”，重置参数配置。 

----结束 
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4.4.8.4.1.2 修改单个焊盘 

本章节为您介绍如何修改 PCB 版图中单个焊盘。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Design Padstack” 。 

步骤 3 在编辑器右侧“Options”窗口，选择需要修改的焊盘，单击“Edit”。 

1. 在 Name 后的输入框输入焊盘名称，搜索焊盘。 

2. 搜索完成后，在 Name 下方的搜索列表中，单击焊盘名称。 

3. 勾选“instance”，在 New name 后的输入框会显示新的焊盘名称。 

4. 根据需求选择焊盘筛选条件，可选择 Cell（焊盘类型）、Pin（引脚数量）、

Refdes（位号）。 

− Cell：在 Cell 后的下拉框选择焊盘类型名称。 

− Pin：在 Pin 后的下拉框选择引脚数量。 

− Refdes：在 Refdes 后的下拉框选择位号标识。 

5. 单击“Edit”，进入焊盘编辑器界面。 
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图3-240 修改单个焊盘参数配置 

 

 

步骤 4 弹出焊盘编辑器弹窗中，配置焊盘参数。 

1. 单击 Connect Pad 列下的焊盘。 

2. 选择焊盘形状：在 Geometry 后的下拉框选择，可选择 Circle、Square、

Oblong、Rectangle、Rounded rectangle、Chamfered rectangle、 

N-sided polygon、Octagon、Donut。 

3. 根据不同的焊盘形状，配置参数。 

− Circle（圆形） 

i. 在 Geometry 后的下拉框选择 Circle。 

ii. 在 Diameter 后的输入框输入直径。 

− Square（方形） 

i. 在 Geometry 后的下拉框选择 Square。 

ii. 在 Width 后的输入框输入方形长度。 
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− Oblong（椭圆形） 

i. 在 Geometry 后的下拉框选择 Oblong。 

ii. 在 Width 后的输入框输入椭圆形 X 轴方向长度大小。 

iii. 在 Height 后的输入框输入椭圆形 Y 轴方向长度大小。 

− Rectangle（矩形） 

i. 在 Geometry 后的下拉框选择 Rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

− Rounded rectangle（倒圆角的矩形） 

i. 在 Geometry 后的下拉框选择 Rounded rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner radiu 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− Chamfered rectangle（倒斜角的矩形） 

i. 在 Geometry 后的下拉框选择 Chamfered rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner charr 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− N-sided polygon（多边形） 

i. 在 Geometry 后的下拉框选择 N-sided polygon。 

ii. 在 Diameter 后的输入框输入直径。 

iii. 在 sides 后的输入框输入多边形边数。边数只能是双数，不能输入单

数。 

− Octagon（八边形） 

i. 在 Geometry 后的下拉框选择 Octagon。 

ii. 在 Width 后的输入框输入长度。 

− Donut（空心圆） 
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i. 在 Geometry 后的下拉框选择 Donut。 

ii. 在 Outer Diame 后的输入框输入外径。 

iii. 在 Inner Diamet 后的输入框输入内径。 

图3-241 配置焊盘参数示图 

 

 

步骤 5 修改完成后，选择“File>Update to Design”，单击“Yes”保存。 

或者选择“File>Update to Design and Exit”，单击“Yes”保存并退出。 

 

⚫ 勾选“instance”，会创建一个新的焊盘封装。在编辑完成后，单击“File>Save as...”，可

保存到本地封装库。如果没有本地封装库，会保存失败，需要先创建本地封装库。 

⚫ 焊盘需要偏移时，可在配置焊盘参数页面，Offset 后的输入框输入偏移量。 

⚫ 在编辑器右侧“Options”窗口，单击“Purge”，在弹窗中选择不需要使用的焊盘，单击

“OK”。在 Name 下方的搜索列表中会自动清除不使用的焊盘。 

⚫ 单击“Reset”，重置参数配置。 

----结束 
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3.4.9.4.2 修改焊盘封装（Modify Library Padstack） 

本章节为您介绍如何修改 PCB 版图封装库中焊盘封装。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Library Padstack” 。 

步骤 3 在弹出的“Select Library Padstack”页面中，在页面左侧选择需要编辑的焊盘，单

击“OK”。 

图3-242 选择焊盘 

 

 

步骤 4 自动进入焊盘编辑器，可对孔盘进行编辑，也可对焊盘进行编辑。具体操作请参见 5.2 

编辑孔盘和焊盘。 

----结束 

3.4.9.4.3 替换（Replace） 

本章节为您介绍如何替换 PCB 版图焊盘和孔盘。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Padstack>Replace” 。 

步骤 3 在编辑器右侧“Options”窗口，勾选替换孔盘选项，参数说明请参见表 3-50。 

图3-243 替换焊盘配置 

 

 

表3-50 替换焊盘参数说明 

参数名称 说明 

Single Via replace 

mode 

只替换当前选中 Via 的焊盘。需要选择时，勾选 Single 

Via replace mode 前的方框。 

Ignore MIRRORED 

property 

忽略镜像属性。需要选择时，勾选 Ignore MIRRORED 

property 前的方框。 
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参数名称 说明 

Replace Via manually 将一定范围内 Via 的焊盘批量替换。需要选择时，勾选

Replace Via manually 前的方框。 

Ignore FIXED 

property 

忽略有锁定属性的对象，有锁定状态对象也更新。需要选

择时，勾选 Ignore FIXED property 前的方框。 

 

步骤 4 焊盘替换有两种替换方式。 

⚫ 在画布中选择焊盘 

a. 在画布中，单击一个焊盘，再单击另一个替换的焊盘。 

b. 在编辑器右侧“Options”窗口，配置焊盘筛选条件，可选择 Symbol（焊盘

类型）、Pin（引脚数量）、RefDes（位号）、Net（网络），单击

“Replace”替换。 

◼ Symbol：在 Symbol 后的输入框输入焊盘类型名称。 

◼ Pin：在 Pin 后的输入框输入引脚数量。 

◼ RefDes：在 RefDes 后的输入框输入位号标识。 

◼ Net：在 Net 后的输入框输入网络名。 

⚫ 在 Options 窗口中选择焊盘 

a. 在编辑器右侧“Options”窗口，“Old”栏单击 选择被替换焊

盘。 

b. “New”栏单击 选择替换的焊盘。 

c. 在编辑器右侧“Options”窗口，配置焊盘筛选条件，可选择 Symbol（焊盘

类型）、Pin（引脚数量）、RefDes（位号）、Net（网络），单击

“Replace”替换。 

◼ Symbol：在 Symbol 后的输入框输入焊盘类型名称。 

◼ Pin：在 Pin 后的输入框输入引脚数量。 

◼ RefDes：在 RefDes 后的输入框输入位号标识。 

◼ Net：在 Net 后的输入框输入网络名。 
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图3-244 Options 窗口选择焊盘配置 

 

 

 

⚫ 焊盘筛选条件可通过单击画布中的对象自动识别和手动在输入框中输入两种方式设置，若设

置无效则会退回上个设置值。 

⚫ “*”号标识表示同一类别焊盘，如不需要筛选焊盘，则在输入框中保留“*”号标识，可替换

同一类别焊盘。 

⚫ 单击“Reset”，可重置替换配置，恢复到配置窗口初始界面。 

----结束 

3.4.9.4.4 刷新（Refresh） 

本章节为您介绍如何对替换后的焊盘进行刷新和查看刷新日志。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在菜单栏选择“Tools>Padstack>Refresh” 。 

步骤 3 在弹出的“Update”页面中，在页面左侧列表中勾选 All 前的方框，选择所有焊盘，

单击“Update”刷新。 

⚫ 单击 输入名称，可查询焊盘。 

⚫ 单击 可以收缩焊盘列表。 

⚫ 单击 可以展开焊盘列表。 

图3-245 刷新焊盘 

 

 

步骤 4 在弹出的“Place Update”页面查看更新报告或者单击“Viewlog”查看。 
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图3-246 更新报告 

 

 

步骤 5 报告查看完成后，单击报告右上角的 关闭报告即可。 

 

⚫ 刷新功能只适用于刷新封装库中的焊盘。 

⚫ 在版图编辑器上修改的焊盘需保存到封装库，否则使用刷新功能，版图上修改的焊盘会被刷

新成封装库中存在的焊盘。 

----结束 

3.4.9.4.5 配置镜像孔映射关系（Via Mirror Map） 

针对孔的起止层不是对称层，需要配置映射关系。本章节为您介绍如何配置镜像孔映

射关系。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Padstack>Via Mirror Map” 。 

步骤 3 在弹出的“Via Mirror Map”页面中，配置过孔和埋盲孔。 

⚫ 过孔镜像孔映射关系配置 
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a. 单击“Add Via Name”，自动生成 Via 列表。单击 可删除列表。 

b. 在“Sources Via Name”栏添加起止层非对称 Via 列表。 

i. 在“Sources Via Name”栏，单击 。 

ii. 在打开弹窗左侧列表中选择起止层非对称 Via，单击“OK”。 

c. 在“Destination Via Name”栏，添加镜像后目标 Via 列表。 

i. 在“Destination Via Name”栏，单击 。 

ii. 在打开弹窗左侧列表中选择镜像后目标 Via，单击“OK”。 

d. 配置完成后，单击“OK”。 

图3-247 过孔镜像孔映射关系配置 

 

 

⚫ 埋盲孔镜像孔映射关系配置 

a. 单击“Add Exiting B/B Via”，导入版图中所有埋盲孔。单击 可删除列

表。 

b. 单击“New”，在弹出窗口中，输入新的埋盲孔名称，单击“OK”。 

c. 配置完成后，单击“OK”。 
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图3-248 埋盲孔镜像孔映射关系配置 

 

 

----结束 

3.4.9.5 编辑版图参数（Design Parameters） 

本章节为您介绍如何编辑版图参数。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Design Parameters...”。 

步骤 3 在弹出的“Design Parameters Editor”页面中，配置使用单位、图纸大小、画布大

小及基准点和显示模式。参数说明请参见表 3-51。 
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图3-249 版图参数编辑 

 

 

表3-51 版图参数编辑参数说明 

参数类型 参数名称 操作说明 

Design 

Size 

（编辑参

数） 

Mils（千分之一英寸） 单击 User units 后的下拉框选择。 

Millimeter（毫米） 单击 User units 后的下拉框选择。 

A4（A4 纸张大小） 单击 Size 后的下拉框选择。 

B5（B5 纸张大小） 单击 Size 后的下拉框选择。 

C3（C3 纸张大小） 单击 Size 后的下拉框选择。 

D（D 纸张大小） 单击 Size 后的下拉框选择。 

Other（其他） 单击 Size 后的下拉框选择。 

Width（画布宽方向） 在 Width 后的输入框输入宽方向数值。 

Height（画布高方向） 在 Height 后的输入框输入高方向数值。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 320 

 

参数类型 参数名称 操作说明 

Lower left（画布左下

角） 

在 Lower left 后的第一个输入框输入 X 轴

数值，第二个输入框输入 Y 轴数值。 

Origin（基准点） 在 Origin 后的第一个输入框输入 X 轴数

值，第二个输入框输入 Y 轴数值。 

Display 

modes 

（显示模

式） 

Connect points（连接

点） 

在 Display modes 框内，勾选选项前的

方框。 

Filled pads（将 via 和

pin 由中空改为填满） 

在 Display modes 框内，勾选选项前的

方框。 

Connect line endcaps

（导线拐弯处的平滑） 

在 Display modes 框内，勾选选项前的

方框。 

Thermal/Anti pads（花

盘/反焊盘） 

在 Display modes 框内，勾选选项前的

方框。 

Design origin（设计基准

点） 

在 Display modes 框内，勾选选项前的

方框。 

Plated holes（金属化

孔） 

在 Display modes 框内，勾选选项前的

方框。 

Non-plated holes（非金

属化孔） 

在 Display modes 框内，勾选选项前的

方框。 

Padless holes（无焊盘

孔） 

在 Display modes 框内，勾选选项前的

方框。 

Drill labels（钻孔表） 在 Display modes 框内，勾选选项前的

方框。 

Net name on traces（显

示走线网络名称） 

在 Display modes 框内，勾选选项前的

方框。 

Net name on areas（显

示铜箔网络名称） 

在 Display modes 框内，勾选选项前的

方框。 

Net name on pins（显

示 Pin 网络名称） 

在 Display modes 框内，勾选选项前的

方框。 
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步骤 4 配置完成后，单击“OK”保存。 

----结束 

3.4.9.6 DRC 检查基本操作 

本章节为您介绍如何根据选择的检查规则，在设计时进行全局和实时的 DRC 检查操

作。DRC 检查即设计规则检查，用于 PCB 在布局布线过程中检查和发现于预定设置规

范不符的设计，用于保证设计正确性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器中 DRC 检查基础操作说明如表 3-52 所示。 

表3-52 DRC 检查的基础操作说明 

操作名称 操作步骤 

打开 DRC 实时检查 打开 DRC 有两种操作方式。 

⚫ 在关闭 DRC 情况下，菜单栏选择“Tools>Online 

DRC”打开 DRC。 

⚫ 在版图编辑器左下角单击快捷图标 ，开启实时显

示 DRC 检查。 

关闭 DRC 实时检查 关闭 DRC 有两种操作方式。 

⚫ 在打开 DRC 情况下，菜单栏选择“Tools>Online 

DRC”关闭 DRC。 

⚫ 在版图编辑器左下角单击快捷图标 ，关闭实时显

示 DRC 检查。 

查看 DRC 检查结果 1. 在版图编辑器左下角单击快捷图标旁的三角形菜单图

标 。 

2. 单击“DRC Result...”，弹出 DRC 检查结果报告。 

打开 DRC 全局检查 1. 在版图编辑器左下角单击快捷图标旁的三角形菜单图
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操作名称 操作步骤 

标 。 

2. 单击“Update DRC”，根据选择的检查规则对版图

进行全局 DRC 检查。 

清除所有 DRC 检查 1. 在版图编辑器左下角单击快捷图标旁的三角形菜单图

标 。 

2. 单击“Clear All DRC”，在弹窗中单击“Yes”，清

除所有的 DRC 检查。 

 

----结束 

DRC 图标含义 

⚫ 圆形 DRC 图标分为四部分，顶部是实际值，底部是设置的规则值，左侧和右侧都

是违反的规则类型。 

图3-250 DRC 图标示例图 

 

 

⚫ 在 Show info 页面中可查看违反的规则类型以及规则值与实际值。 

a. 在菜单栏选择“Display > Info”或按快捷键 F4。 

b. 在“Find”命令窗口选择“DRC Marks”。 
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c. 在画布中单击 DRC，在弹出窗口中可查看违反的规则类型以及规则值与实际

值。 

图3-251 查看 DRC 图标信息 

 

 

3.4.9.7 DRC 检查规则和查看 DRC 结果（DRC Manager） 

本章节为您介绍如何设置 DRC 检查规则和查看 DRC 结果。 

DRC 检查规则 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>DRC Manager...” 。 

步骤 3 在弹出的“DRC Manager”页面中，选择“Config”页签，配置 DRC 规则类型、勾

选 DRC 规则配置项和输入 DRC 规则值，单击“OK”。 

1. DRC 规则：单击 Config 页面左侧下方的规则类型，可选择 Design（设计 DRC

检查规则）、Electrical（电气 DRC 检查规则）、Physical（物理 DRC 检查规

则）、Spacing（间距 DRC 检查规则）、Same Net Spacing（同网间距检查规

则）和 Inhibit Area（禁布区检查规则）。 

2. DRC 配置项：勾选在页面右侧 On 列下方的方框，可打开 DRC 配置项规则，取

消勾选则关闭规则。勾选“Mark All Constraints”后的方框，打开全部 DRC 配

置项规则，取消勾选，则关闭全部规则。 
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图3-252 管理 DRC 

 

 

步骤 4 单击“Result”页面查看检查结果。DRC 检查会按照勾选的规则进行检查，不合符规

则的会报出来，未勾选的规则不符合要求时不会报出来。 

----结束 

查看 DRC 结果 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>DRC Manager...” 。 

步骤 3 在弹出的“DRC Manager”页面中，选择“Result”页签，查看 DRC 检查结果。也

可以单击快捷图标旁的三角形菜单图标 ，选择“DRC Result...”，查看

DRC 检查结果。 

⚫ 有 6 种类型 DRC 检查结果，间距 DRC 检查规则（Spacing）、同网间距检查规则

（Same Net Spacing）、物理 DRC 检查规则（Physical）、禁布区检查规则

（Inhibit）、电气 DRC 检查规则（Electrical）、设计 DRC 检查规则（Design）。 

⚫ DRC 检查结果都会显示两种报告，分别是不合符规则的 DRC 报告和隐藏的 DRC

报告。 

⚫ 左键双击“DRC Errors”列表下的 DRC 检查结果，展开显示列表里的所有 DRC

结果。 
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⚫ 左键双击“Waived DRCs ”列表下的 DRC 结果，展开显示列表里的所有隐藏的

DRC 结果。 

图3-253 查看 DRC 结果 

 

 

步骤 4 结果查看完成后，单击“OK”关闭窗口。 

----结束 

3.4.9.8 Window DRC 检查（Window DRC） 

本章节为您介绍如何对绘制的窗口中的元素进行 DRC 检查。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Window DRC”。 

步骤 3 在“Find”命令窗口选择检查对象，在画布中框选检查的范围。 

步骤 4 在画布中框选的范围系统自动显示 DRC 检查结果。在 DRC 检查结果不显示状态下，

框选范围才能在画布中显示 DRC 结果。 

----结束 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 326 

 

3.4.9.9 背钻（Back Drill） 

3.4.9.9.1 背钻设置工具（Backdrill Design Tools） 

4.4.8.9.1.1 查看背钻属性（BACKDRILL PROPERTIES SHOW） 

本章节为您介绍如何查看及核对已定义的背钻属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Back Drill>Backdrill Design Tools”。 

步骤 3 在弹出的“BackDrill”页面中，单击“BACKDRILL PROPERTIES SHOW”。 

步骤 4 在弹出的“Show Backdrill Property”页面中可查看背钻属性，背钻属性说明请参见

表 3-53。 

1. 在页面左侧“Select a Backdrill Property”下单击某一类背钻属性，页面右侧展

示对应的对象及属性。 

2. 查看属性后单击 关闭即可。 

图3-254 查看背钻属性 
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表3-53 背钻属性说明 

属性名称 属性对象 属性说明 

BACK_DRILL Nets 网络上所有定义该属性的器件管

脚和过孔都做背钻，一般用于高

速背钻。 

BACKDRILL_INCLUDE Cells、Pins、Vias 所有定义该属性的器件、器件管

脚和过孔都做背钻。 

BACKDRILL_EXCLUDE Cells、Pins、Vias 所有定义该属性的器件、器件管

脚和过孔不做背钻。 

BACKDRILL_CONTACT_E

ND 

Cells、Pins 设置器件或者器件管脚的连接结

束层。 

BACKDRILL_SPACING Pins、Vias 设置器件管脚或者过孔的背钻间

距。 

BACKDRILL_INSULATION

_T 

Vias 所有定义绝缘背钻属性的过孔在

绝缘背钻正面（Top 面）做背

钻。 

BACKDRILL_INSULATION

_B 

Vias 所有定义绝缘背钻属性的过孔在

绝缘背钻反面（Bottom 面）做

背钻。 

 

----结束 

4.4.8.9.1.2 定义背钻属性（BACKDRILL PROPERTIES EDIT） 

本章节为您介绍如何给网络、器件、器件管脚和过孔等背钻对象定义背钻属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Back Drill>Backdrill Design Tools”。 

步骤 3 在弹出的“BackDrill”页面中，单击“BACKDRILL PROPERTIES EDIT”。 
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步骤 4 在弹出的“Property”页面中选择“Manager”页签，根据场景定义背钻属性。 

⚫ 定义高速背钻属性 

a. 在页面左侧“Available Properties”下方的下拉框选择 Nets。 

b. 在左侧属性列表中单击 BACK_DRILL，再单击“Apply”。 

c. 在画布中单选或者框选要定义背钻属性的对象。 

d. 右侧“Object Properties”下自动添加所有对象、属性及属性值。画布中也

自动高亮显示该对象。 

e. 在页面右侧“Object Properties”可对属性列表进行编辑。 

◼ 单击 可以按降序排序，单击 可以按升序排序。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以删除对象属性。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以批量修改属性值。 

◼ 右侧属性列表中勾选对象属性前的方框，勾选“Filter”只显示已选择的

属性。 

f. 属性定义完成后，单击“OK”关闭即可。 

图3-255 定义高速背钻属性 

 

 

⚫ 部分过孔或 PIN 不背钻 

a. 在页面左侧“Available Properties”下方的下拉框选择，可选择 Cells、

Pins 或者 Vias。 
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b. 在左侧属性列表中单击 BACKDRILL_EXCLUDE，再单击“Apply”。 

c. 在画布中单选或者框选 Cell、Pin 或者 Via。 

d. 右侧“Object Properties”下自动添加所有对象、属性及属性值。画布中也

自动高亮显示该对象。 

e. 在页面右侧“Object Properties”可对属性列表进行编辑。 

◼ 单击 可以按降序排序，单击 可以按升序排序。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以删除对象属性。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以批量修改属性值。 

◼ 右侧属性列表中勾选对象属性前的方框，勾选“Filter”只显示已选择的

属性。 

f. 属性定义完成后，单击“OK”关闭即可。 

图3-256 定义不背钻属性 

 

 

⚫ 定义绝缘背钻属性 

a. 在页面左侧“Available Properties”下方的下拉框选择 Vias。 

b. 在左侧属性列表中单击 BACKDRILL_INSULATION_T 或者

BACKDRILL_INSULATION_B，再单击“Apply”。 

c. 在画布中单选或框选 Via。 
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d. 右侧“Object Properties”下自动添加所有对象、属性及属性值。画布中也

自动高亮显示该对象。 

e. 在页面右侧“Object Properties”可对属性列表进行编辑。 

◼ 单击 可以按降序排序，单击 可以按升序排序。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以删除对象属性。 

◼ 右侧属性列表中勾选对象属性前的方框，单击 可以批量修改属性值。 

◼ 右侧属性列表中勾选对象属性前的方框，勾选“Filter”只显示已选择的

属性。 

f. 属性定义完成后，单击“OK”关闭即可。 

图3-257 定义绝缘背钻属性 

 

 

----结束 

4.4.8.9.1.3 定义绝缘背钻属性（BACKDRILL INSULATION EDIT） 

绝缘背钻主要针对盒式产品、屏蔽罩和散热器等与单板接触部件绝缘的应用场景，分

为正面（绝缘背钻 Top 面）和背面（绝缘背钻 Bottom 面）两种类型。本章节为您介

绍如何通过指定背钻区域给背钻对象定义属性。 
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操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在指定层绘制绝缘背钻区域。 

1. 在菜单栏选择“Drawing>Rectangle”。 

2. 在编辑器右侧“Options”窗口，第一个下拉框选择 Manufacturing。第二个下

拉框选择绝缘背钻区域的指定层，可选择 BackDrill_Insulation_Top（绝缘背钻

Top 面）或者 BackDrill_Insulation_Bottom（绝缘背钻 Bottom 面）。 

3. 在画布中绘制绝缘背钻区域。 

a. 左键单击确定矩形区域左上角坐标位置。 

b. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成绘制。 

c. 右键单击“Done”完成矩形区域绘制，保存并退出绘制状态。 

图3-258 绘制绝缘背钻区域 

 

 

步骤 3 在菜单栏选择“Tools>Back Drill>Backdrill Design Tools”。 

步骤 4 在弹出的“BackDrill”页面中，单击“BACKDRILL INSULATION EDIT”。 
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步骤 5 在弹出的“BackDrill Insulation Set”页面中，有两种方式设置指定区域可接触的网

络。 

⚫ 搜索网络名添加网络 

a. 在 Net 后的输入框输入网络名称，单击 添加。 

b. 左侧框中自动显示添加的网络。左键双击网络名可删除已添加的网络。 

⚫ 画布中选择添加网络 

a. 单击“Select Net”，在画布中单选需要添加的网络。 

b. 左侧框中自动显示添加的网络。左键双击网络名可删除已添加的网络。 

图3-259 设置网络 

 

 

步骤 6 在弹出的“BackDrill Insulation Set”页面中给过孔设置绝缘背钻属性。 

1. 在隔筋面后的下拉框选择指定绝缘背钻区域的层。 

2. 单击“Auto Get Vias”获取过孔。 

3. 在弹窗的输入框中输入过孔的区域范围，单击“OK”。如果只在绝缘背钻区域中

选择过孔，区域范围输入值为 0。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 333 

 

4. 在隔筋面下方的过孔列表框内自动显示获取的过孔，画布中自动高亮获取的所有

过孔。 

5. 单击“Add Props”添加绝缘背钻属性。 

6. 在“Selected Vias List”下方可以进行多种便捷操作。 

− POFV：勾选 POFV 前的方框，选择做 POFV 的过孔；取消勾选，不选择做

POFV 的过孔。 

− 手动添加过孔：单击“Select Via”在画布中单击或者框选过孔，过孔列表框

内自动添加选中的过孔。 

− 选中并高亮过孔：单击“Hilight Vias”过孔列表框内所有的过孔在画布中被

选中并高亮显示。 

− 过滤选中的过孔：单击“Filter Via”过滤掉在画布中所有被选中的过孔。 

− 删除过孔列表：单击“Clear List”删除过孔列表。 

− 显示所有绝缘背钻属性的过孔：单击“Show Prop Via”在画布中高亮显示

所有定义绝缘背钻属性的过孔。 

− 删除过孔的绝缘背钻属性：单击“Delete Vias Props”删除所有过孔的绝缘

背钻属性。 
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图3-260 定义绝缘背钻属性 

 

 

步骤 7 属性定义完成后，单击“Exit”退出即可。 

----结束 

4.4.8.9.1.4 背钻设置与检查（SETUP AND CHECK BACKDRILL） 

本章节为您介绍如何设置背钻参数、高亮核对背钻、检查与分析背钻、输出背钻文

件、输出与删除背钻禁布区。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Back Drill>Backdrill Design Tools”。 

步骤 3 给背钻对象定义背钻属性，定义属性操作请参见定义背钻属性（BACKDRILL 

PROPERTIES EDIT）。 

步骤 4 在弹出的“BackDrill”页面中，单击“SETUP AND CHECK BACKDRILL”。 
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步骤 5 在弹出的“Backdrill Setup and Analysis”页面中设置背钻参数，参数说明请参见表

3-54。 

1. 页面中系统将自动预填背钻孔径，可根据需求进行修改。在“BDSize”栏下选择

需要修改的背钻孔径数值，输入新的背钻孔径数值即可。 

2. 在“Cut”栏下的下拉框选择背钻钻穿层，在“NCut”栏下的下拉框选择背钻不

钻穿层。 

表3-54 背钻参数说明 

参数名称 参数说明 

Object 焊盘类型（PIN/VIA） 

HoleSize 焊盘孔径大小（精度为 2 位小数） 

Froms Stub 开始层(孔开始/结束层) 

Tos Stub 结束层（孔内部接近开始层的连接

层） 

FromLyr 背钻开始层（背钻 Top 面或者背钻

Bottom 面） 

BDSize 背钻孔径大小 

Cut 背钻钻穿层 

NCut 背钻不钻穿层 

 

 

⚫ 在“Setup BackDrill Parameters”下的背钻数据是经过筛选符合做背钻的网络上的 Pins 或

Vias（带 Hole）。 

⚫ 同一行的背钻数据是相同孔径的 Pins 或者 Vias 在相同的布线网络符合背钻要求的集合。 

步骤 6 按照类型高亮背钻孔并报告其数量。 

1. 在 Selected BackDrill Type 后的下拉框选择需要查看的背钻类型进行背钻高亮核

对。 

2. 在下拉框后显示了高亮的背钻孔数量，画布中也高亮显示所有此背钻类型的对

象。也可在弹出的报告窗口查看背钻孔数量和背钻对象。 
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步骤 7 设置钻头距内外层图形的安全距离。 

1. 在 Inside Layer 后的输入框输入背钻孔到内层图形的安全距离。 

2. 在 Outside Layer 后的输入框输入背钻孔到外层图形的安全距离。 

步骤 8 运行背钻安全检查。 

1. 单击“Analyze and Report”查看和分析背钻报告。 

2. 在弹出报告中可以查看网络、背钻类型、背钻属性、坐标等详细信息。单击报告

中对象的坐标，画布中高亮显示对象的位置。 

步骤 9 单击“Output Backdrill Files”输出背钻文件。可根据输出的背钻文件对背钻孔进行

高亮核对。 

1. 在 Selected BackDrill Files 后的下拉框选择需要查看的对象的钻带进行背钻高亮

核对。 

2. 在下拉框后显示了高亮的背钻孔数量，画布中也高亮显示所有此钻带的对象。 

3. 可在弹出报告窗口查看背钻孔数量和对象。在弹出页面报告中，可对报告页面进

行如下操作。 

− 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），

单击“打开”自动显示报告文件。 

− 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保

存当前报告文件。 

− 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精

确查询，查询到的数据会加底色显示。 

− 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模

糊查询，查询到的数据会加底色显示。查询出多条符合条件时，可单击

选中上一个，单击 选中下一个。 

步骤 10 单击“Add Inhibit Route”添加背钻位置的禁布区图形。添加的图形可在 Inhibit 

Route 配层查看。单击“Delete Inhibit Route”可删除添加的禁布区图形。 

步骤 11 单击“Review BD RK DRCs”查看 Route Keepout DRCs。 

步骤 12 单击“Save Setups and Quit”保存设置并关闭窗口。 
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图3-261 背钻设置与检查 

 

 

----结束 

4.4.8.9.1.5 删除背钻属性（DELETE BACKDRILL PROERTIES） 

本章节为您介绍如何删除背钻属性。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Back Drill>Backdrill Design Tools”。 

步骤 3 在弹出的“BackDrill”页面中，单击“DELETE BACKDRILL PROERTIES”。 

步骤 4 在弹出的提示窗口中单击“OK”。 

图3-262 删除提示窗口 

 

 

步骤 5 删除完成后弹出提示窗口，查看完成后单击“OK”关闭即可。 
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图3-263 删除结果提示窗口 

 

 

----结束 

3.4.9.9.2 输出背钻表格（Backdrill Chart） 

本章节为您介绍如何输出背钻表格。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在输出背钻表格前需先设置背钻参数，具体操作请参见背钻设置与检查（SETUP AND 

CHECK BACKDRILL）。 

步骤 3 在菜单栏选择“Tools>Back Drill>Backdrill Chart”。 

步骤 4 在弹出的“Backdrilling Chart”页面中生成背钻表格。 

1. 页面中系统将自动预填 Stub 值，可根据需求进行修改。在“Stub”栏下选择需

要修改的 Stub 数值，输入新的 Stub 数值即可。 

2. 可根据需求增加背钻表格。 

a. 在左侧“#”栏下右键单击表格序号，选择“Append”增加背钻表格。右键

单击新增的表格序号，选择“Delete”可删除表格。 

b. 根据需求设置背钻表格内容。 

3. 单击“Create”生成背钻表格。 
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图3-264 生成背钻表格 

 

 

步骤 5 在画布中单击合适位置放置表格。 

图3-265 放置背钻表格 

 

 

步骤 6 输出的背钻表格可在编辑器右侧“Selection”窗口的

“Manufacturing>Smart_Drill”层查看。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 340 

 

图3-266 查看背钻表格 

 

 

----结束 

3.4.9.9.3 防隔筋短路检查（Check SolderMask Short-Circuit） 

本章节为您介绍如何进行防隔筋短路检查。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 对象定义绝缘背钻属性才能进行防隔筋短路检查。定义属性具体操作请参见定义绝缘

背钻属性（BACKDRILL INSULATION EDIT）。 

步骤 3 在菜单栏选择“Tools>Back Drill>Check SolderMask Short-Circuit”。 

步骤 4 在弹出的“防隔筋短路检查工具”页面中设置检查参数。 

1. 在背钻文件选择框下选择背钻文件，系统默认全选。左键双击背钻文件名称可删

除背钻文件。 

2. 在 Name 后的下拉框选择非标背钻过孔。选择后的过孔显示在下方列表框中，左

键双击过孔名称可删除过孔，也可单击“Clear”删除过孔列表。 

3. 在隔筋地网络设置中设置网络，有两种方式可以设置网络。 

− 搜索网络名添加网络 
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i. 在 Net 后的输入框输入网络名称，单击 添加。 

ii. 左侧框中自动显示添加的网络，左键双击网络名可删除已添加的网络。

也可单击“Clear”删除网络列表。 

− 画布中选择添加网络 

i. 单击“Select”在画布中单选需要添加的网络。 

ii. 左侧框中自动显示添加的网络，左键双击网络名可删除已添加的网络。

也可单击“Clear”删除网络列表。 

4. 在隔筋面后的下拉框选择指定绝缘背钻区域的层。 

5. 在间距后的输入框输入间距。 

6. 单击“Check”。 

图3-267 防隔筋短路检查 

 

 

步骤 5 在弹出的“防隔筋短路”页面中确认检查结果。 

1. 可对检查结果进行分类查看。 

− 按照物件类型过滤，过滤类型可选择 Via、Pin、Trace、Area。 
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− 按照结果状态过滤，过滤类型可选择待确认、已解决、误报。 

2. 单击检查结果列表“NO.”栏下的序号，画布中自动高亮显示对象。确认结果无

误后，左键双击“状态”栏下的检查结果修改状态，可选择待确认、已解决、误

报三种状态。 

3. 状态修改完成后，单击“保存状态”保存。 

4. 所有检查结果确认完成后，单击“退出审查”退出窗口。 

图3-268 确认检查结果 

 

 

----结束 

3.4.9.10 修改设置（Settings） 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Settings...”。 
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步骤 3 在弹出的“Setting”页面中，对工程（Project）、工具（Tool）、显示

（Display）、颜色（Color）、器件（Components）、铜箔（Area）等设置进行修

改。参数说明请参见表 3-55。 

图3-269 参数设置界面 

 

 

表3-55 设置参数说明 

类型 参数名称 说明 

Project 

Setting

（工程设

置） 

General（常规操作） Console 命令栏相同前缀命令关联设

置。 

Library Connection 

Management（封装库连

接） 

封装库配置远端公共库、本地库，配置

好封装库后才能导入网表。 

Project（工程设置） 配置自动保存的时间、最大备份个数和

撤销次数。 

Tool 

Setting

（工具设

置） 

Design Parameter（版图

参数设置） 

设置使用单位、画布尺寸、画布偏置坐

标、原点坐标、配置显示选项。 

Text（文本设置） 设置字体放置位置、字体大小、字体规

格，设置 DRC 尺寸大小。 
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类型 参数名称 说明 

Display

（显示设

置） 

General（显示

基本设置） 

大板性能增强模式、显示比例、格点自

动跳转切换开关、鼠标划过对象高亮/显

示属性开关、高性能模式开关等配置。 

Cursor（鼠标

模式设置） 

鼠标箭头、十字光标模式设置。 

Highlight（高

亮设置） 

高亮设置（已禁用）。 

Color

（颜色设

置） 

Display（显示

颜色设置） 

高亮、格点、飞线、DRC、钻孔、走

线、孔表、背景等颜色设置。 

Shape（铜箔

高亮设置） 

铜箔高亮设置，包括整板

（Brightness）、焊盘（Global 

transparency）、铜箔（Shapes 

transparency）的高亮设置，以及静态

动态铜箔样式、对象过滤器大小设置

等。 

Compo

nents

（器件设

置） 

Discrete 

comps（器件

位号设置） 

各器件的位号文字设置。 

Placement（器件设置） 器件放置面向，模块复用配对比例，默

认器件高度设置等。 

Area

（铜箔设

置） 

General（铜箔

填充基本设

置） 

铜箔填充设置（Defer performing 

fill），不勾选即填充，反之不填充，以

及填充类型（动/静态铜箔）选择。 

Manufa

cture

（工具设

置） 

General（工具

基本设置） 

背钻最小起钻孔径，塞孔允许最小、最

大尺寸设置、最小叠层大小。 

Testpre

p（测试

General（测试

点基本设置） 

测试点放置面向及配层设置，测试点类

型选择。 
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类型 参数名称 说明 

点设

置） 

Padstack 

Selection（焊

盘选择设置） 

测试点焊盘类型添加设置。 

Constrai

nt（规

则管理

器设

置） 

General（规则

管理器基本设

置） 

过孔长度计算开关、pin Delay 检查

DRC 开关设置。 

Interactive（叠孔是否一

起操作开关） 

叠孔的拆分，勾选此项叠孔被一起移动

操作，取消勾选此项叠孔分开被移动操

作。 

 

步骤 4 设置完成后，单击“Apply”应用。 

步骤 5 单击“OK”保存设置。 

----结束 

 

3.4.9.10.1 过孔分离某种过孔批量移动 

操作步骤 

步骤 1 功能菜单栏，点击 Tools-setting 中 interactive 下的 stacked_via_off 去勾选。

（setting 中 interactive 下的 stacked_via_off，勾选是多个单独过孔，不勾选，多个

同心圆的过孔 Z 轴重叠孔，定义成一个完整的过孔） 

步骤 2 功能栏，选择移动命令后 ，框选目标孔，右键选择 split stack，然后选择要

移走的过孔类型 

如下图： 
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----结束 

3.4.9.11 查看所有报告（Reports） 

本章节为您介绍如何查看所有报告。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Reports...”。 

步骤 3 在弹出的“Report”页面中，显示版图所有的报告类型。 
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图3-270 版图所有的报告 

 

 

步骤 4 双击需要生成的报告类型，在弹出的页面中，显示相应的报告。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示报告文件。 

⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当

前报告文件。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 
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图3-271 查看报告 

 

 

----结束 

3.4.9.12 压缩导出单板文件（Db Compress） 

本章节为您介绍如何压缩导出单板文件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Db Compress”。 

步骤 3 在弹出的“Question”页面中，导出压缩单板文件，单击“Yes”。 

图3-272 压缩单板文件提示 

 

 

步骤 4 在弹出的“Save db”页面中，选择文件保存路径（保存路径不能有中文），单击“保

存”。 
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图3-273 保存压缩单板文件入口 

 

 

----结束 

3.4.9.13 查看单板报告（Db Doctor Report） 

本章节为您介绍如何查看单板检查报告。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Tools>Db Doctor Report”。 

步骤 3 在弹出的“Db Doctor Report”页面中，显示相应的报告。 

⚫ 单击图标 ，弹出“open file”窗口，选择本地文件（.html 格式文件），单击

“打开”自动显示报告文件。 

⚫ 单击图标 ，弹出“save file”窗口，输入文件名，单击“保存”，自动保存当

前报告文件。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询，查询到的数据会加底色显示。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询，查询到的数据会加底色显示。查询出多条符合条件时，可单击 选中上一

个，单击 选中下一个。 
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图3-274 单板报告 

 

 

----结束 

3.4.9.14 封装库编辑器快捷键（Library Manager） 

本章节为您介绍如何快捷启动 Library Manager 程序及。 

操作步骤 

步骤 1 打开版图工程。 

步骤 2 选择功能菜单“Tools> Library Manager”。 
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步骤 3 封装库管理具体功能详见第 5 节 PCB-DESIGN 封装库管理。 

----结束 

3.4.10 窗口菜单（Windows） 

本章节为您介绍如何打开、关闭、显示和隐藏窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在 PCB-DESIGN 版图编辑器页面各个窗口的打开和关闭窗口操作说明如表 3-56 所

示。 
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图3-275 打开/关闭窗口入口 

 

 

表3-56 窗口操作说明 

操作名称 操作步骤 

左侧流程设计窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Design Flow”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口 ，显示隐藏的窗口。 

左侧工程文件窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Project”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口 ，显示隐藏的窗口。 
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操作名称 操作步骤 

左侧对象查询窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Find”自动打开窗口，取消

勾选关闭窗口或者单击窗口右上角

的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口 ，显示隐藏的窗口。 

左侧网络查询窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Nets”自动打开窗口，取

消勾选关闭窗口或者单击窗口右上

角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口 ，显示隐藏的窗口。 

左侧器件查询窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Components”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口 ，显示隐藏的窗口。 

底部操作命令窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Console”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 
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操作名称 操作步骤 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗

口。 

底部信息窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Message”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗

口。 

底部对象元素窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Elements”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗

口。 

底部局部放大视图窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Detail”自动打开窗口，取

消勾选关闭窗口或者单击窗口右上

角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击
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操作名称 操作步骤 

窗口底部 ，显示隐藏的窗口。 

右侧图层窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Layer”自动打开窗口，取

消勾选关闭窗口或者单击窗口右上

角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗口。 

右侧配层选择窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Selection”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗口。 

右侧配置窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Options”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 

⚫ 显示/隐藏 

单击窗口右上角的 隐藏窗口。单击

窗口底部 ，显示隐藏的窗口。 

顶部工具栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Toolbar”自动打开工具栏，

取消勾选关闭工具栏。 
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操作名称 操作步骤 

底部状态栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Status bar”自动打开状态

栏，取消勾选关闭状态栏。 

重置窗口 1. 在菜单栏选择“Windows”。 

2. 勾选“Reset Default”重置所有隐藏

的窗口，恢复默认设置。 

 

 

在窗口关闭情况下，勾选窗口才能展示窗口。 

----结束 

3.4.11 帮助菜单（Help） 

3.4.11.1 查看常用快捷键（Keyboard Shortcuts Reference） 

在版图工具中配置的快捷键可在“Keyboard Shortcuts Reference”菜单进行查看。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>Keyboard Shortcuts Reference” 。 

步骤 3 在弹出的“Defined Aliases”页面，可查看已配置的快捷键列表。 
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图3-276 Defined Aliases 页面 

 

 

步骤 4 在“Defined Aliases”页面，可按查询条件快速定位到快捷键，查询到的数据会加底

色显示。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询。查询出多条符合条件时，可单击 选中上一个，单击 选中下一个。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 358 

 

图3-277 查询示例 

 

 

步骤 5 查询完成后，单击右上角 关闭页面。 

----结束 

3.4.11.2 快捷键全量命令（Keyboard Commands） 

在版图工具中快捷键操作设置是有限制的，可在“Keyboard Commands”菜单查看

可预置哪些快捷键操作命令。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>Keyboard Commands” 。 

步骤 3 在弹出的“Keyboard Commands”页面，在搜索框中填入对象名称，可精确搜索快

捷键操作命令。 
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图3-278 快捷键的全量操作命令 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

3.4.11.3 查看软件版本信息（About） 

在版图工具中可在“About”菜单查看软件版本信息。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>About” 。 

步骤 3 在弹出的“About”页面，查看软件版本信息。 
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图3-279 About 页面 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

3.4.11.4 导出 log（Packing Logs） 

在版图工具中可在“Packing Logs”菜单导出所有的 Log，方便开发人员定位问题。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>Packing Logs” 。 

步骤 3 在弹出的“Packing Log”页面，选择 Log 文件名。选择 Log 文件存放路径，单击

“OK”。 
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图3-280 Packing Logs 页面 

 

 

----结束 

3.4.11.5 切换 License（Register） 

本章节为您介绍如何切换浮动 License 和固定 License。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>Register” 。 

步骤 3 在弹窗中可以切换浮动 License 和固定 License。 

⚫ 切换浮动 License 

a) 在弹出的“License Activation”弹窗页面，选择“Floating License”页

签，在“Server address”下的输入框内输入服务端地址。服务端地址为域

名地址。 
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b) 单击“Test Connection”测试浮动 License 服务端的连通性。 

 

c) 单击“Activate”，切换 License。 

 

⚫ 切换固定 License 

a) 在弹出的“License Activation”弹窗页面，选择“Fixed License”页签，

单击 选择本地的 License 文件。 

 

License 文件的保存路径不能有中文，且 License 文件名称也不能有中文。 

 

b) 单击“Activate”，切换 License。 

 

----结束 
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3.5 顶部工具栏 

3.5.1 工具栏打开与关闭 

本章节为您介绍如何在版图编辑器中打开与关闭工具栏。工具栏提供了设置及显示菜

单栏对应的功能按钮，方便快捷操作。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Toolbar”自动打开工具栏，取消勾选关闭工具栏。 

----结束 

3.5.2 工具栏图标设置 

本章节为您介绍如何设置哪些图标显示在工具栏上。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Place、Route、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 

3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 
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6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 

图3-281 设置工具栏快捷图标 

 

 

步骤 4 鼠标左键长按并拖拽快捷图标前的 ，可以移动整排快捷图标的位置。 

图3-282 快捷图标示图 

 

 

----结束 

3.5.3 工具栏图标含义及功能 

文件菜单 

序号 图标 含义及功能 

1  新建工程 
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序号 图标 含义及功能 

2  打开工程 

3  协同 Client 端 

4  保存 

5  另存为 

6  关闭工程 

7  宏命令 

8  网表 

9  结构图文件 

10 
 

IDF 文件 

11  跨板拷贝文件 

12  元器件 

13  A2P 文件 

14  光绘文件 

15  NC 文件 

16  ODB++文件 

17  IPC356A 文件 

18  压缩包 

19  退出 

 

编辑菜单 

序号 图标 含义及功能 

1  撤销 

2  重做 
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序号 图标 含义及功能 

3  复制 

4  跨层复制 

5  粘贴 

6  选择 

7  移动 

8  删除 

9 
 

旋转 

10  修改文本 

11  线段顶点 

12  锁定 

13  解锁 

14  对象分组 

15  属性管理器 

 

显示菜单 

序号 图标 含义及功能 

1  适应窗口 

2  放大 

3  缩小 

4  指定区域放大 

5  查询 

6  测量 

7  查看对象规则信息 
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序号 图标 含义及功能 

8 
 

高亮显示 

9  取消高亮显示 

10  阴影显示 

11  网络颜色显示 

12  隐藏 DRC 

13  打开全部飞线 

14  关闭全部飞线 

15  格点 

16  打开网络关系简化模式 

17  关闭网络关系简化模式 

18  自定义工具栏 

 

绘制菜单 

序号 图标 含义及功能 

1  非电气走线 

2  圆弧 

3  圆线 

4  圆形 

5  扇形 

6  矩形 

7  多边形 

8  新增文本 

9  修剪倒角 
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序号 图标 含义及功能 

10  绘制器件放置区 

11  绘制器件禁布区 

12  绘制器件高度区 

13  绘制走线禁布区 

14  绘制走线区 

15  绘制电气属性走线禁布区 

16  绘制过孔禁布区 

17  绘制禁布区 

18  绘制测试点禁布区 

19  绘制板框 

20  标注 

 

布局设计菜单 

序号 图标 含义及功能 

1  放置器件 

2 
 

更新器件与焊盘 

3  交换器件与模块 

4  对齐 

5  模块复用 

6  解散模块 

7  阵列过孔 
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布线设计菜单 

序号 图标 含义及功能 

1  电气属性走线 

2  调线 

3  绕线 

4  拉直走线 

5  交换 Pin 网络 

6  创建自动扇出 

7  定义电源/地属性 

8 
 

自动生成差分对 

9  绘制铜箔 

10  挖空铜箔区域 

11  静态铜箔避让 

12  删除铜箔挖空区域 

13  移动铜箔挖空区域 

14  复制铜箔挖空区域 

15  铜箔编辑 

16  两个重叠铜箔合并操作 

17  转换动静态铜箔 

18  更新动态铜箔 

19  合并同网络铜箔 

20  线段闭合为封闭图形 

21  打散封闭图形为线段 

22  删除孤立铜箔 

23  自动添加测试点 
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序号 图标 含义及功能 

24  手动添加测试点 

25  设置测试点参数 

 

生产配置菜单 

序号 图标 含义及功能 

1  生成钻孔表格 

 

工具菜单 

序号 图标 含义及功能 

1  设置叠层 

2  用户自定义层 

3  规则管理器 

4  修改焊盘 

5  替换 

6  刷新 

7 
 

编辑版图参数 

8  DRC 检查 

9  设置 

10  报告 
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3.6 左侧流程设计窗口 

3.6.1 流程设计窗口打开与关闭 

本章节为您介绍如何在版图编辑器中打开与关闭流程设计窗口。流程设计窗口也叫

Design Flow 窗口，可以选择窗口的流程目录直接打开设置的页面进行编辑。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Design Flow”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关

闭窗口。 

----结束 

3.6.2 流程设计功能说明 

在 PCB-DESIGN 版图编辑器中，双击流程窗口中的设计流程，直接进入对应流程的操

作界面，流程设计窗口的流程说明请参见表 3-57。 

表3-57 流程说明 

流程分类 流程 说明 

Create Design（创建

设计） 

New Project 新建工程 

Design Parameters 编辑版图参数 

Create Board Outline 绘制板框 

Netlist（网表） Library Config 连接器件库 

Import Netlist 导入网表 

Placement（布局） Stack-up Editor 设置叠层 

Placement 放置器件 

Constraints（规则管 Constraints Editor 编辑规则管理器 
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流程分类 流程 说明 

理器） DRC Manager 管理 DRC 

Routing（布线） Add Trace 添加走线 

Slide 调线 

Create Area 绘制铜箔 

Create Cutout 挖空铜箔 

Manufacturing（生产

配置） 

Add Testprep 添加测试点 

Add Dimension 添加标注 

Export Gerber 导出光绘 

Export NC 导出 NC 文件 

Export ODB++ 导出 ODB++文件 

Export IPC365A 导出 IPC365A 文件 

Export DXF 导出结构图文件 

Export IDF 导出 IDF 文件 

Export Archiving 导出压缩包 

 

3.7 左侧工程文件窗口 

3.7.1 工程文件窗口打开与关闭 

工程文件窗口也叫 Project 窗口，在窗口中可以新建和打开单板文件。本章节为您介

绍如何在版图编辑器中打开与关闭工程文件窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 
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步骤 3 勾选“Project”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

3.7.2 工程文件窗口说明 

在 PCB-DESIGN 版图编辑器中工程文件窗口有三个文件夹，文件说明请参见表 3-

58。 

表3-58 文件说明列表 

文件类型 说明 

DesignFiles 单板文件夹，放置单板文件。 

⚫ 右键单击文件夹可打开单板文件，具

体操作请参见 3.2.2 打开单板文件。 

⚫ 右键单击文件夹下的单板文件，可对

单板文件进行编辑，具体操作请参见

3.7.3 单板文件操作。 

Library 器件文件夹，放置封装器件文件。 

Output 输出文件夹，放置输出的文件。 

⚫ 存在输出文件的前提条件下，右键单

击文件夹下的文件可打开文件报告，

在画布中自动显示报告的弹窗。 

 

3.7.3 单板文件操作 

本章节为您介绍版图工程单板文件操作命令指示。具体操作指示请参见表 3-59。 

表3-59 单板文件操作指示 

操作名称 操作步骤 

打开单板文件（.ddb 文件） 在关闭当前单板文件的前提条件下，才

能打开单板文件。 
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操作名称 操作步骤 

1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件）。 

2. 单击“Open”，画布中直接打开单

板文件。 

关闭单板文件（.ddb 文件） 1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件）。 

2. 单击“Close”，画布中直接关闭单

板文件。 

保存单板文件（.ddb 文件） 1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件）。 

2. 单击“Save”，画布中直接保存单板

文件。 

另存单板文件（.ddb 文件） 1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件），单击“Save 

As”。 

2. 在画布弹窗中，填写另存的单板文件

名称，单击“保存”。 

重命名单板文件（.ddb 文件） 在关闭当前单板文件的前提条件下，才

能重命名单板文件。 

1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件）。 

2. 单击“Rename”，重命名单板文

件。 

移除单板文件（.ddb 文件） 在关闭当前单板文件的前提条件下，才

能移除单板文件。 

1. 右键单击“DesignFiles”下的单板文

件（.ddb 文件）。 

2. 单击“Remove”，移除单板文件。 
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3.8 左侧对象查询窗口 

3.8.1 对象查询窗口打开与关闭 

对象查询窗口也叫 Find 窗口，在窗口中可以查询画布中任何对象。本章节为您介绍如

何在版图编辑器中打开与关闭对象查询窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Find”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗口。 

----结束 

3.8.2 对象选择与查询 

3.8.2.1 对象选择 

本章节为您介绍如何在对象查询窗口中选择对象。 

选择对象 

⚫ 在执行操作命令前提条件下，在窗口中勾选对象前的方框，画布中可以单选或者

框选对象。在窗口中不勾选对象，画布中单选或者框选不了对象。 

⚫ 单击窗口的“On”全部打开对象，单击窗口的“Off”全部关闭对象。 

⚫ 画布中对象参数说明请参见表 3-60。 

表3-60 对象参数说明表 

参数名称 说明 

Groups 模块 

Traces 电气属性走线 

Components 器件 

Lines 非电气属性走线 
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参数名称 说明 

Cells 器件封装 

Trace segs 走线 seg 

Enets 电气网络 

Other segs 其他 seg 

Nets 网络 

Areas 闭合图形 

Pins 引脚 

Cutouts/Cavities 挖空的铜箔 

Vias 过孔 

Texts 文本 

Guidelines 网络飞线 

DRC Marks DRC 显示 

Dimension 标注 

 

3.8.2.2 对象查询 

本章节为您介绍如何在对象查询窗口中查询对象。查询对象有两种方式，直接查询对

象和按名称查询对象。 

直接查询对象 

步骤 1 在窗口中，单击“Find by Query”。 

步骤 2 在弹出的“Find by Query”页面中，在页面左侧选择查询对象类型，在页面右侧填写

查询信息，单击“OK”。 

步骤 3 查询完成后，画布中系统自动高亮显示查询对象。 
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图3-283 直接查询对象 

 

 

----结束 

按名称查询对象 

⚫ 在窗口中，在“Find by name”里选择查询对象类型，根据选择查询方式

（Name/List）查询。 

⚫ 按 Name 查询方式 

a. 选择“Name”查询方式，在方框中填写查询对象名称，单击窗口任意一点

或者将鼠标移到画布中，画布中系统自动高亮显示查询对象。 

b. 查询更多对象，可以单击“More...”，在弹窗中选择查询对象类型，在左侧

列表中选择对象， 

单击“OK”，画布中自动跳转到查询对象位置。 
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图3-284 按 Name 查询方式 

 

 

⚫ 按 List 查询方式 

a. 选择“List”查询方式，单击 。 

b. 在弹窗中选择本地文件（.lst 文件），单击“打开”。 

c. 画布中系统自动高亮显示查询对象。 
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图3-285 打开 List 文件 

 

 

3.9 左侧网络查询窗口 

3.9.1 网络列表窗口打开与关闭 

网络列表窗口也叫 Nets 窗口，在窗口中网络列表展示了单板所有的网络，可以在网络

窗口查看所有的器件网络。本章节为您介绍如何在版图编辑器中打开与关闭网络列表

窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Nets”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗口。 

----结束 

3.9.2 网络窗口网络查询 

本章节为您介绍如何在网络列表窗口中查询网络。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 单击 输入网络名称，查询网络。 

步骤 3 单击查询的网络，画布中自动显示该网络的位置。 

----结束 

3.10 左侧器件查询窗口 

3.10.1 器件窗口打开与关闭 

器件窗口也叫 Components 窗口，在窗口中器件列表展示了单板所有的器件，可以查

看所有的器件。本章节为您介绍如何在版图编辑器中打开与关闭器件窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Components”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关

闭窗口。 

----结束 

3.10.2 器件窗口器件查询 

本章节为您介绍如何在器件窗口中查询器件。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 单击 输入器件名称，查询器件。 

⚫ 单击 可以收缩器件列表。 

⚫ 单击 可以展开器件列表。 

步骤 3 单击查询的器件，画布中自动高亮显示器件的位置。 

----结束 
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3.11 右侧图层窗口 

3.11.1 图层窗口打开与关闭 

图层窗口也叫 Layer 窗口，在窗口中可以选择版图绘制的层次。本章节为您介绍如何

在版图编辑器中打开与关闭图层窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Layer”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

3.11.2 图层功能及说明 

图层功能 

⚫ 信号层：提供信号传输与通信。 

⚫ 地层：提供良好的接地引用。 

⚫ 电源层：提供电源供应。 

图层名称及说明 

PCB 板由多个图层叠加组成，具体图层名称及说明请参见表 3-61。 

表3-61 图层名称及说明 

图层名称 说明 

Top 板件顶层，即板件元件层。 

Art 内层信号层，一般会在 Art 后添加层次顺序（例如 Art02，数字

02 指第二层）。 

Gnd 内层地层，一般会在 Gnd 后添加层次顺序（例如 Gnd02，数字

02 指第二层）。 
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图层名称 说明 

Pwr 内层电源层，一般会在 Pwr 后添加层次顺序（例如 Pwr02，数字

02 指第二层）。 

Bottom 板件底层，即板件焊接层。 

 

信号层配层名称及说明 

信号层（Signals）配层名称及说明请参见表 3-62。 

表3-62 信号层配层名称及说明 

配层名称 说明 

Conductor 图层的走线 

Via 图层的过孔 

Pin 图层的 Pin 

Drc 图层的 Drc 检查 

 

3.11.3 图层基础操作 

本章节为您介绍如何打开图层、关闭图层、切换图层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在编辑器的右侧图层窗口，打开/关闭图层及切换图层。图层基础操作如表 3-63 所

示。 

表3-63 图层基础操作 

操作方式 操作步骤 

打开/关闭全部图层 1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 
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操作方式 操作步骤 

⚫ 勾选 Signals 对应“All”列下的方框，打开全部图层。

取消勾选，关闭全部图层。 

⚫ 勾选 All Layer 对应“All”列下的方框，打开全部图

层。取消勾选，关闭全部图层。 

打开/关闭全部图层

Conductor 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Conductor”列下的方框，打开全

部图层 Conductor。取消勾选，关闭全部图层

Conductor。 

⚫ 勾选 All Layer 对应“Conductor”列下的方框，打开

全部图层 Conductor。取消勾选，关闭全部图层

Conductor。 

打开/关闭全部图层

Via 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Via”列下的方框，打开全部图层

Via。取消勾选，关闭全部图层 Via。 

⚫ 勾选 All Layer 对应“Via”列下的方框，打开全部图层

Via。取消勾选，关闭全部图层 Via。 

打开/关闭全部图层

Pin 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Pin”列下的方框，打开全部图层

Pin。取消勾选，关闭全部图层 Pin。 

⚫ 勾选 All Layer 对应“Pin”列下的方框，打开全部图层

Pin。取消勾选，关闭全部图层 Pin。 

打开/关闭全部图层

Drc 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Drc”列下的方框，打开全部图层

Drc。取消勾选，关闭全部图层 Drc。 

⚫ 勾选 All Layer 对应“Drc”列下的方框，打开全部图层

Drc。取消勾选，关闭全部图层 Drc。 
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操作方式 操作步骤 

打开/关闭单层图层 1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 勾选图层对应的“All”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层

Conductor 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Conductor”列下的方框，打开单层图

层，取消勾选，关闭单层图层。 

打开/关闭单层图层

Via 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Via”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层

Pin 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Pin”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层

Drc 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Drc”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭 All 层的

Drc 

1. 勾选 All 对应“Drc”列下的方框，打开全部图层 Drc。取

消勾选，关闭全部图层 Drc。 

切换图层 1. 在“Layerset”栏选择打开的图层，画布中自动显示图层

信息。 

2. 在“Layerset”栏选择另一层图层，直接切换图层。 

 

 

单击图层方框前的色块，可以切换图层显示的颜色和图层铜箔显示的格式类型。 

----结束 
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3.11.4 自定义显示图层 

本章节为您介绍如何自定义显示图层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在“Selection”窗口中，单击“All Off”，关闭所有配层。 

步骤 3 在“Layer”窗口中，单击快捷图标 。 

步骤 4 在弹出的“Save”页面中，填写新定义的图层名称，单击“OK”。 

图3-286 创建新定义图层 

 

 

步骤 5 在“Layer”窗口中，单击快捷图标 ，进入图层设置界面。 

步骤 6 在弹出“Layerset Edit”页面中，单击“+Add”，选择图层的配层类型，单击

“OK”。 

⚫ 选择图层，单击 ，图层往上排序。单击 ，图层往下排序。 

⚫ 选择图层，单击 ，删除图层。 

⚫ 单击 ，刷新图层。 
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图3-287 自定义显示图层 

 

 

 

单击快捷图标 时，Layerset 不能打开任何图层，如果提示“Whether to overwrite the 

existing layerset”则是打开了图层，直接关闭图层即可。 

----结束 

3.12 右侧配层选择窗口 

3.12.1 配层选择窗口打开与关闭 

配层选择窗口也叫 Selection 窗口，Selection 窗口可以直观的看到配层的分类。在绘

制版图的过程中，方便切换不同的装配层查看版图。本章节为您介绍如何在版图编辑

器中打开与关闭配层选择窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Selection”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭

窗口。 

----结束 
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3.12.2 配层名称及说明 

前提条件 

已创建版图图层，才可在配层选择窗口查看配层信息。 

配层名称及说明 

配层选择窗口有四种配层类型，分别是层次整体可见性（Global visibility）、绘制层次

（Drawing Objects）、绘制区域（Drawing Area）、板件元件（Board Elements）。 

具体配层名称及含义请参见表 3-64。 

表3-64 配层名称说明表 

窗口配层类型 配层名称 说明 

配层整体可见性

（Global 

visibility） 

全部配层 ⚫ All On：打开板件全部配层 

⚫ All Off：关闭板件全部配层 

⚫ Setting：进入设置界面 

绘制配层

（Drawing 

Objects） 

Conductor 图层的走线 

Pin 图层的 Pin 

Via 图层的过孔 

Drc 走线层 DRC 

Planning 布线规划 Boundle 

绘制区域

（Drawing Area） 

Placement Area 器件放置区 

Room Area 器件分类区 

Route Area 走线区域 

Rule Area 规则区域 

Inhibit Place 器件禁布区 

Inhibit Route 走线禁布区 

Inhibit Via 过孔禁布区 
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窗口配层类型 配层名称 说明 

Inhibit Probe 测试点禁布 

Boundary 动态铜箔外框 

Split 平面层分割线 

板件元件（Board 

Elements） 

Layout Assembly_T

op 

元面装配层 

Assembly_

Bottom 

焊面装配层 

Silkscreen_

Top 

元面丝印层 

Silkscreen_

Bottom 

焊面丝印层 

Resist_Top 元面阻焊层 

Resist_Bott

om 

焊面阻焊层 

Stencil_Top 元面钢网层 

Stencil_Bot

tom 

焊面钢网层 

Layout_Out

line 

Layout 层单板外框 

Panel_Outli

ne 

单板外框 

Dimension 标注层 

MCAD_Det

ail 

DXF 结构图导入层 

MCAD_Not

es 

DXF 结构图导入另一层（背面层） 

FPC_Coverl 元面柔板保护膜层 
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窗口配层类型 配层名称 说明 

ay_Top 

FPC_Coverl

ay_Bottom 

焊面柔板保护膜层 

FPC_Route_

Outline 

柔板布线区 

FPC_Bend_

Line 

柔板弯折线 

FPC_Bend_

Outline 

柔板弯折线外框 

FPC_Outlin

e 

柔板外框 

FPC_Stiffen

er_Top 

元面柔板补强材料层 

FPC_Stiffen

er_Bottom 

焊面柔板补强材料层 

FPC_Shield

_Top 

元面柔板保护膜层 

FPC_Shield

_Bottom 

焊面柔板保护膜层 

Cell Assembly_T

op 

元面装配层 

Assembly_

Bottom 

焊面装配层 

Silkscreen_

Top 

元面丝印层 

Silkscreen_

Bottom 

焊面丝印层 

Resist_Top 元面阻焊层 
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窗口配层类型 配层名称 说明 

Resist_Bott

om 

焊面阻焊层 

Stencil_Top 元面钢网层 

Stencil_Bot

tom 

焊面钢网层 

Origin 中心/基准点 

Placement_

Top 

器件本体层 

Placement_

Bottom 

器件本体层 

Dimension 标注层 

Placement_

Embedded 

埋嵌器件本体层 

Assembly_E

mbedded 

埋嵌器件装配层 

Resist_Emb

edded 

埋嵌器件阻焊层 

Stencil_Em

bedded 

埋嵌器件钢网层 

Slot_Embe

dded 

埋嵌器件开槽层 

Part 

RefDes 

Assembly_T

op 

元面器件装配层位号文字 

Assembly_

Bottom 

焊面器件装配层位号文字 

Assembly_E

mbedded 

器件装配层位号文字 

Silkscreen_ 元面器件丝印层位号文字 
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窗口配层类型 配层名称 说明 

Top 

Silkscreen_

Bottom 

焊面器件丝印层位号文字 

Slot TOP 顶层 

Gnd02 内层地层，数字 02 指第二层 

Art03 内层信号层，数字 03 指第三层 

Pwr04 内层电源层，数字 04 指第四层 

Bottom 底层 

Manuf

acturin

g 

Smart_Drill Smart_Drill 层，尺寸标注及特殊文

字标识 

FilledArea_

Both 

元焊面填充区 

FilledArea_

Bottom 

焊面填充区 

FilledArea_

Top 

元面填充区 

BackDrill_In

sulation_To

p 

元面背钻绝缘 

BackDrill_In

sulation_Bo

ttom 

焊面背钻绝缘 

Drill_Chart 钻孔表格（动态添加）。

Drill_Chart-M-N（任意 10 层，生

成 10 个此文件，10 个文件名称 M-

N 有所不同） 

Drill_Figure 钻孔标识 

Dimension 标注层 
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窗口配层类型 配层名称 说明 

AutoSilk_T

op 

元面自动丝印层 

AutoSilk_B

ottom 

焊面自动丝印层 

Probe_Mar

k_Top 

元面测试点添加层 

Probe_Mar

k_Bottom 

焊面测试点添加层 

Gerber_Out

line 

光绘输出外框 

Surface_Fin

ish 

表面处理 

Annotation 批注 

User 用户自定义层 

 

3.12.3 打开/关闭配层 

本章节为您介绍如何在打开/关闭配层。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在编辑器的右侧配层选择窗口，有两种方式打开/关闭配层。具体操作如表 3-65 所

示。 

表3-65 打开/关闭配层操作指示 

操作方式 操作步骤 

打开/关闭全部配层 选择配层类型，单击“On”，打开全部

配层。单击“Off”，关闭全部配层。 
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操作方式 操作步骤 

打开/关闭单层配层 ⚫ 选择一层配层，勾选“Off”列下的方

框，打开单层配层。取消勾选，关闭

单层配层。 

⚫ 打开配层时，“On”列下的方框会显

示颜色，单击方框，可以切换颜色和

格式类型。 

打开/关闭 All 层 All 层是所有层次元素的结合层，打开/

关闭 All 层操作方式如下： 

⚫ 选择 All 层，勾选“Off”列下的方

框，打开单层配层。取消勾选，关闭

单层配层。 

⚫ 打开配层时，“On”列下的方框会显

示颜色，单击方框，可以切换颜色和

格式类型。 

 

----结束 

3.13 右侧配置窗口 

3.13.1 配置窗口打开与关闭 

配置窗口也叫 Options 窗口，在绘制版图的过程中，在 Options 窗口可以给画布中的

对象操作进行配置。本章节为您介绍如何在版图编辑器中打开与关闭配置窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Options”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 
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3.13.2 配置窗口参数配置 

本章节为您介绍如何在配置窗口中为执行的菜单命令配置参数。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 当配置窗口处于显示状态时，执行菜单命令，右侧配置窗口会显示命令的配置信息。 

步骤 3 在右侧“Options”窗口中，根据需求配置命令的参数。 

步骤 4 在画布中执行操作命令。 

----结束 

 

⚫ 文件菜单的配置操作请参见 3.4.1 文件菜单（File）。 

⚫ 编辑菜单的配置操作请参见 3.4.2 编辑菜单（Edit）。 

⚫ 显示菜单的配置操作请参见 3.4.3 显示菜单（Display）。 

⚫ 绘制菜单的配置操作请参见 3.4.4 绘制菜单（Drawing）。 

⚫ 布局菜单的配置操作请参见 3.4.6 布局设计菜单（Place）。 

⚫ 布线菜单的配置操作请参见 3.4.7 布线设计菜单（Route）。 

⚫ 生产配置菜单的配置操作请参见 3.4.8 生产配置菜单（Manufacture）。 

⚫ 工具菜单的配置操作请参见 3.4.9 工具菜单（Tools）。 

3.13.3 pin number 显示功能 

本章节为您介绍如何在配置窗口中显示 pin number。注意：pin number 显示功能非

必要不开，或者打开浏览，用完关闭，需要再开。 

操作步骤 

步骤 1 功能菜单栏，点击 Windows-Selection 

步骤 2 在右侧配置层选择窗口 Selection-Board Elements-下拉选择 Cell-勾选 pin_Number 
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步骤 3 PIN number 可移动可删除可编辑； 

步骤 4 若删除了 PIN number，可在 console 栏输入命令 ddb_fix_rebuild_pin_number 

repair 按回车键修复。

 

----结束 
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3.14 底部操作命令窗口 

3.14.1 操作命令窗口打开与关闭 

操作命令窗口也叫 Console 窗口，可直接在窗口里输入命令，画布中的对象将直接执

行操作，使绘制版图操作更加便捷。本章节为您介绍如何在版图编辑器中打开与关闭

操作命令窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Console”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

3.14.2 操作命令窗口指示 

本章节为您介绍如何在操作命令窗口中输入指示命令。 

界面指示 

⚫ 在画布中，滚动鼠标滚轮，窗口界面会显示画布的比例大小。 

⚫ 在画布中，操作命令执行，窗口界面会显示具体操作步骤。 

⚫ 在窗口里输入命令，画布中的对象将直接执行操作。 

⚫ 支持快捷命令搜索，在窗口下方“Type command here”栏输入快捷键首字

母，显示所有有关首字母的快捷命令。 

常用操作 

在窗口命令输入框内输入操作命令，画布中对象立即执行操作命令。操作方法请参见

表 3-66。 
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表3-66 命令窗口的常用操作指示 

操作名称 操作步骤 

命令窗口输入移动坐标 1. 在画布中，选择需要移动的对象。 

2. 在“Console”的命令窗口，输入坐

标，字母不区分大小写。 

⚫ 只移动 X 轴坐标：在命令输入框中

输入“X+空格键+X 轴移动坐标

值”并按回车键。 

⚫ 只移动 Y 轴坐标：在命令输入框中

输入“Y+空格键+Y 轴移动坐标

值”并按回车键。 

⚫ 只移动 X 和 Y 轴坐标：在命令输

入框中输入“X+空格键+X 轴移动

坐标值+空格键+Y+空格键+Y 轴

移动坐标值”并按回车键。 

命令窗口输入快捷键 “Console”的命令窗口，支持 alias 和

funckey 命令两种方式设置临时快捷

键。 

⚫ funckey 命令设置方法：在

“Console”命令窗口，在命令输入框

中输入“funckey+快捷键按键字母+

操作命令”并按回车键。设置快捷键

完成后，键盘输入快捷键字母。 

⚫ alias 命令设置方法：在“Console”

命令窗口，在命令输入框中输入

“alias+快捷键按键字母+操作命令”

并按回车键。设置快捷键完成后，键

盘输入快捷键字母。 
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3.15 底部信息窗口 

3.15.1 信息窗口打开与关闭 

信息窗口也叫 Message 窗口，可直接在窗口里查看版图信息。本章节为您介绍如何在

版图编辑器中打开与关闭信息窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Message”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

3.15.2 信息窗口说明 

功能说明 

版图汇总性信息会显示在窗口中，可在窗口查看提示的信息。 

3.16 底部对象元素窗口 

3.16.1 对象元素窗口打开与关闭 

对象元素窗口也叫 Elements 窗口，在窗口里可查询对象所有元素。本章节为您介绍

如何在版图编辑器中打开与关闭对象元素窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Elements”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭

窗口。 
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----结束 

3.16.2 对象元素窗口查询 

本章节为您介绍如何在对象元素窗口中查询对象元素类型和数量。查询对象元素有两

种方式，按网络查询对象元素和按器件查询对象元素。 

按网络查询 

步骤 1 在窗口中，选择“Physical Net”。 

步骤 2 单击 输入网络名称，查询网络对象。在查询的网络对象列表中，会显示 Pins 和

Vias 的数量、Enet。 

步骤 3 单击查询的网络对象，画布中自动高亮显示对象的位置。 

----结束 

按器件查询 

步骤 1 在窗口中，选择“Componnent”。 

步骤 2 单击 输入器件名称，查询器件对象。在查询的器件对象列表中，会显示对象的层次

面向、属性、封装器件名称、Pin 数量、类型、群组。 

步骤 3 单击查询的对象，画布中自动高亮显示对象的位置。 

----结束 

3.17 底部局部放大视图窗口 

3.17.1 局部放大视图窗口打开与关闭 

局部放大视图窗口也叫 Detail 窗口，在窗口中可以放大在画布中的局部视图，便于在

绘制版图过程中查看具体位置的版图视图。本章节为您介绍如何在版图编辑器中打开

与关闭放大局部视图窗口。 

操作步骤 

步骤 1 3.2 打开版图工程。 
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步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Detail”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

3.17.2 局部放大视图 

本章节为您介绍如何在局部放大视图窗口中放大视图。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 左键单击画布中任意位置，窗口显示鼠标所在位置的局部放大视图。 

图3-288 局部放大视图示例图 

 

 

----结束 
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3.18 底部状态栏 

3.18.1 状态栏打开与关闭 

本章节为您介绍如何在版图编辑器中打开与关闭状态栏。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Status bar”自动打开状态栏，取消勾选“Status bar”自动关闭状态栏。 

----结束 

3.18.2 状态栏功能说明 

在 PCB-DESIGN 版图编辑器中状态栏显示 DRC，坐标，格点及配置对应的功能按

钮，方便快捷操作。功能说明请参见表 3-67。 

表3-67 状态栏功能说明 

状态栏功能类型 功能说明 

显示 DRC 检查基础操作 
⚫ 在版图编辑器左下角单击快捷图标 ，开启实

时显示 DRC 检查。 

⚫ 在版图编辑器左下角单击快捷图标 ，关闭实

时显示 DRC 检查。 

⚫ DRC Result... 

1. 在版图编辑器左下角单击快捷图标旁的三角形

菜单图标 。 

2. 单击“DRC Result...”，弹出 DRC 检查结果

报告。 

⚫ Update DRC 

1. 在版图编辑器左下角单击快捷图标旁的三角形

菜单图标 。 
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状态栏功能类型 功能说明 

2. 单击“Update DRC”，根据勾选的检查规则

对版图进行全局 DRC 检查。 

⚫ Clear All DRC 

1. 在版图编辑器左下角单击快捷图标旁的三角形

菜单图标 。 

2. 单击“Clear All DRC”，在弹窗中单击

“Yes”，清除所有的 DRC 检查。 

显示画布中鼠标坐标 在画布中，单击任意一点，状态栏自动显示 X 轴坐

标和 Y 轴坐标。 

显示格点选择和配置 ⚫ 在栅格快捷图标前的栅格类型框

，可以选择设置好的

栅格格式类型。 

⚫ 单击栅格快捷图标 ，显示格点。再次单击，

不显示格点。 

⚫ 单击“Get”快捷打开“Find”窗口的 Pin 和

Via。 

⚫ 单击“Offset”快捷设置偏移量。 

打开/关闭右侧窗口 
⚫ 单击快捷图标 ，打开层次窗口。再次单击快

捷图标 ，关闭层次窗口。 

⚫ 单击快捷图标 ，打开配层选择窗口。再次单

击快捷图标 ，关闭配层选择窗口。 

⚫ 单击快捷图标 ，打开配置窗口。再次单击快

捷图标 ，关闭配置窗口。 
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3.19 快捷键配置和使用 

3.19.1 快捷键介绍 

快捷键分类 

版图工具提供三种快捷键：系统自带快捷键、自定义配置临时快捷键和自定义配置永

久快捷键。 

表3-68 快捷键类型说明 

快捷键类型 说明 优先级 

系统自带快捷键 在未自定义永久快捷键前，系统预置

的快捷键可在菜单栏选择“Help  > 

Keyboard Shortcuts 

Reference”  ，打开“Defined 

Aliases”页面，查看有哪些预置快

捷键。 

第 3 优先级，可被自定

义快捷键覆盖。 

3.19.2 自定义配

置临时快捷键 

版图工具支持在 Console 窗口配置

临时快捷键，配置的临时快捷键只针

对当前打开工程有效，关闭工程后失

效。 

第 1 优先级为 Console

的命令窗口自定义的临

时快捷键，在自定义临

时快捷键时，如果和永

久快捷键或系统自带的

快捷键冲突，会临时覆

盖永久快捷键或系统自

带的快捷键。 

3.19.3 自定义配

置永久快捷键 

版图工具支持通过 ENV 文件配置永

久快捷键，配置的永久快捷键对所有

工程永久有效。配置完成后，需要关

闭版图工具重启后生效。 

第 2 优先级为 ENV 文件

中设置的永久快捷键，

在自定义永久快捷键

时，如果和系统自带的

快捷键冲突，会覆盖系

统自带的快捷键。 
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快捷键约束说明 

⚫ 提供 alias、funckey 命令，funckey 定义的快捷键立即执行，alias 定义的快捷键

需要手动回车生效。建议单键使用 funckey 命令，组合键使用 alias 命令。 

⚫ 提供 unalias、unfunckey 命令，用于取消快捷键的定义。 

⚫ 快捷键设置区分大小写，例如可同时设置 funckey b delete 和 funckey B silde

并且能正常识别。 

⚫ 空格键的快捷键定义，只支持 funckey，例如 funckey Space move。 

⚫ 方向键如果设置成快捷键，则优先响应快捷键，不再响应版图移动功能。 

⚫ 支持定义多个命令组合，例如 alias x 'move;findfilter type Groups on'，类似

batch 批量执行，注意用单引号。 

⚫ 支持组合键设置，设置时首字符~和 C 都表示 Ctrl 键，A 表示 Alt 键，S 表示

Shift 键。 

− Ctrl+字母键组合时，Ctrl 的简写要求是~，不能是 C，例如 alias ~S  

save。 

− 支持 Ctrl+Shift 组合，简写为 CS。 

− 支持 Alt+Ctrl 组合，简写为 AC。 

− 支持 Alt+Shift 组合，简写为 AS。 

− Shift 键和字母或数字的组合，不允许被设置成快捷键，如 Shift+A。 

快捷键配置示例参考 

分类 操作 快捷键命令 

常用功能键配置 取消 alias Esc cancel 

插入走线 alias Insert trace 

删除 alias Delete delete 

旋转 alias Home rotate 

放大 alias PgUp zoom in 

缩小 alias PgDn zoom out 

组合键配置 添加线 alias CSF5 add line 

移动 alias SF3 move 
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分类 操作 快捷键命令 

设置格点 打开格点 funckey o option cfg 

grid_toggle on 

关闭格点 funckey f option cfg 

grid_toggle off 

打开/关闭格点(开关切换) funckey f option cfg 

grid_toggle 

设置格点类型为

Place/PG25 

funckey 1 option cfg 

grid_type Place/PG25 

设置飞线 打开所有飞线 funckey 2 guidelines all 

关闭所有飞线 funckey 3 unguidelines 

all 

关闭某个网络的飞线 funckey 4 'guidelines 

net;option cfg 

guideline_blank true' 

显示某个网络的飞线 funckey 5 'guidelines 

net;option cfg 

guideline_blank false' 

查看信息 查看 via 信息 funckey 4 'info;findfilter 

all off;findfilter type 

Vias on' 

查看 trace seg 信息 funckey 4 'info;findfilter 

all off;findfilter type 

Trace_segs on' 

snap pick to 设置 选择圆弧位置落点 funckey 1 snap pick 

to@arc circle 

选择图形中心位置落点 funckey 2 snap pick 

to@area center 

选择器件中心位置落点 funckey 3 snap pick 

to@cell center 
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分类 操作 快捷键命令 

选择器件基准点位置落点 funckey 4 snap pick 

to@cell origin 

选择交点位置落点 funckey 5 snap pick 

to@intersection 

选择 pin 位置落点 funckey 6 snap pick 

to@pin 

选择线段位置落点 funckey 7 snap pick 

to@segment 

选择线段中心位置落点 funckey 8 snap pick 

to@segment midpoint 

选择线段顶点位置落点 funckey 9 snap pick 

to@segment vertex 

选择过孔位置落点 funckey 0 snap pick 

to@via 

层叠开关快捷设置 打开层属性 Layer 窗口

Top 层 Via 显示 

funckey o option cfg 

layer Top Via on 

关闭层属性 Layer 窗口

Top 层 Via 显示 

funckey p option cfg 

layer Top Via off 

打开所有层的显示 funckey 1 option cfg 

open_all_layer 

关闭所有层的显示 funckey 1 option cfg 

close_all_layer 

打开层属性 Selection 窗

口 Drawing Objects 子层

下 Conductor 中 Top 层

显示 

funckey 1 option cfg 

sublayer Drawing 

Objects Conductor Top 

on 

关闭层属性 Selection 窗

口 Drawing Area 子层下

Placement Area 中 Top

funckey 1 option cfg 

sublayer Drawing Area 

Placement Area Top off 
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分类 操作 快捷键命令 

层显示 

打开/关闭层属性

Selection 窗口 Drawing 

Area 子层下 Placement 

Area 中 Top 层显示(自动

切换) 

funckey 1 option cfg 

sublayer Drawing Area 

Placement Area Top 

设置 Layerset 模板名为

Test 

option cfg add_layerset 

Test 

切换到名为 Test 的

layerset 

option cfg layerset_type 

Test 

其他 设置空格旋转固定角度 funckey Space 

rotate;angle 90 

原地旋转 funckey r 'rotate; 

findfilter Cells; findfilter 

type rotate on' 

旋转 funckey c rotate 

镜像 先执行选择快捷键命令：

funckey s select 

再执行镜像快捷键命令：

funckey m mirror 

编辑文本 funckey a edit text 

交换管脚 PIN funckey h pin swap 

交换器件 funckey g swap 

components 

手动创建差分 funckey a create cons 

修线折线 funzckey z Sub-Seg 

Slide 

差分和单根切换 funckey a single trace 
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分类 操作 快捷键命令 

mode 

裁剪铜箔 funckey t trim 

绘制铜箔图形 funckey s draw area 

选中铜箔图形 funckey d shape selectt 

给铜箔附网络属性（选中

目标网络，给选中铜箔附

目标网络） 

funckey f pop shape 

select assign net 

静态铜箔避让 element funckey a element 

cutout 

动静态铜箔转化 先执行选中对象快捷键命

令：funckey d shape 

select 

再执行转化铜箔的快捷键

命令：funckey a 

change_single_area_typ

e 

给已选择的过孔附网络 funckey a pop select 

assign net 

格点切换 funckey ~1 option cfg 

grid_type Place/PG25 

单个截线 funckey a pop 

delete_cut 

批量截线 funckey a 

group_cut_line 

 

3.19.2 自定义配置临时快捷键 

版图工具支持在 Console 窗口设置临时快捷键，临时快捷键只针对当前打开工程有

效，关闭工程后失效。支持通过 alias 和 funckey 命令两种方式设置临时快捷键，
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funckey 定义的快捷键立即执行，alias 定义的快捷键需要手动回车生效，建议单键使

用 funckey 命令，组合键使用 alias 命令。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在编辑器底部的“Console”的命令窗口，支持 alias 和 funckey 命令两种方式设置临

时快捷键。 

 

⚫ funckey 命令设置方法：在“Console”命令窗口，在命令输入框中输入

“funckey+快捷键按键字母+操作命令”并按回车键，如图 3-289 所示。 

图3-289 funckey 命令设置快捷键 

 

 

⚫ alias 命令设置方法：在“Console”命令窗口，在命令输入框中输入“alias+快

捷键按键字母+操作命令”并按回车键，如图 3-290 所示。 
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图3-290 alias 命令设置快捷键 

 

 

步骤 3 设置快捷键完成后，键盘输入快捷键字母，使用快捷键。例如在“Console”命令窗

口设置“alias CSF5 add line”后，在键盘输入“CSF5”，编辑器左下角和命令窗口

会显示正在用快捷键执行的命令，如图 3-291 所示。 

图3-291 使用快捷键 

 

 

----结束 

3.19.3 自定义配置永久快捷键 

版图工具支持通过 ENV 文件的形式配置永久快捷键，配置在 ENV 文件中的快捷键对

使用版图的所有工程有效。ENV 文件支持通过 alias 和 funckey 命令两种方式设置临

时快捷键，funckey 定义的快捷键立即执行，alias 定义的快捷键需要手动回车生效，

建议单键使用 funckey 命令，组合键使用 alias 命令。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 411 

 

操作步骤 

步骤 1 在本地目录“C:\Users\用户工号\.pcb”下找到 ENV 文件。 

步骤 2 打开 ENV 文件，在文件里面添加需要设置的快捷键命令。 

步骤 3 设置完成后，保存文件，重启 PCB-DESIGN 版图编辑器后设置的快捷键才能生效。 

----结束 

3.19.4 查看已配置的快捷键 

在版图工具中配置的快捷键可在“Keyboard Shortcuts Reference”菜单进行查看。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help  > Keyboard Shortcuts Reference”  。 

步骤 3 在弹出的“Defined Aliases”页面，可查看已配置的快捷键列表。 
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图3-292 配置的快捷键列表 

 

 

步骤 4 在“Defined Aliases”页面，可按查询条件快速定位到快捷键，查询到的数据会加底

色显示。 

⚫ 勾选“match word”，在输入框中搜索查询关键字，按回车键可按关键字精确查

询。 

⚫ 勾选“match case”，在输入框中搜索查询关键字，按回车键可按关键字模糊查

询。查询出多条符合条件时，可单击 选中上一个，单击 选中下一个。 
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图3-293 查看配置的快捷键列表 

 

 

----结束 

3.19.5 快捷键的全量操作命令 

在版图工具中快捷键操作命令设置是有限制的，可在“Keyboard Commands”菜单

查看可设置的快捷键操作命令。 

操作步骤 

步骤 1 3.2 打开版图工程。 

步骤 2 在菜单栏选择“Help>Keyboard Commands” 。 

步骤 3 在弹出的“Keyboard Commands”页面，在搜索框中填入操作命令名称，可精确搜

索快捷键操作命令。 
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图3-294 快捷键的全量操作命令 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

3.20 并行设计 

3.20.1 Server 端发布版图 

本章节为您介绍如何在服务端（Server 端）进行发布版图，供客户端（Client 端）连

接使用。 

操作步骤 

步骤 1 双击“PCB_Builder”，打开 PCB-DESIGN 版图编辑器。 

步骤 2 单击“Team”，然后单击“Collaboration Server”。 
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图3-295 进入 Server 端 

 

 

步骤 3 在弹出“Select a historical project”页面中，选择工程（.prj），单击“打开”。 

图3-296 打开历史工程 

 

 

步骤 4 在弹出的窗口，单击三角形图标 ，三角形图标 变成正方形图标 ，开启工程连

接。 



PCB版图设计 

用户指南 3 PCB-DESIGN版图编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 416 

 

开启工程连接后，单击“Pause”可进入协同独占模式，单击“Exit pause”退出模

式。 

图3-297 开启工程连接 

 

 

步骤 5 单击正方形图标 ，关闭工程连接。单击 关闭窗口。 

图3-298 关闭工程连接 

 

 

----结束 

3.20.2 Client 端并行设计 

本章节为您介绍如何在客户端（Client 端）进行版图连接使用。 

操作步骤 

步骤 1 双击“PCB_Builder”，打开 PCB-DESIGN 版图编辑器。 

步骤 2 单击“Team”，然后单击“Collaboration Client”。 
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图3-299 进入 Client 端 

 

 

步骤 3 在弹出“Create a new project”页面中，在“文件名”处填写工程名称（名称不能

为中文），单击“保存”，创建一个新的工程。 

图3-300 创建工程 

 

 

步骤 4 根据端口号选择服务端（Server 端）进行版图同步。 

1. 先在服务端（Server 端）开启连接，开启连接操作请参见 3.20.1 Server 端发布

版图。 
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2. 连接开启后在“Collaboration Client”页面中，单击“Query”。 

3. 在弹出的页面中输入服务端（Server 端）的 IP 地址。IP 地址可在服务端

（Server 端）“Owner”栏查看。 

4. 根据端口号单击选择需要连接的服务端（Server 端），然后单击“Connect”进

行版图同步。端口号可在“Host”栏查看。 

图3-301 开启连接 

 

 

步骤 5 版图连接后直接进入工程文件界面，单击“Save Server Db”保存服务端（Server

端）单板文件。 

图3-302 保存单板文件 
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步骤 6 单击“Disconnect”，在弹窗中单击“Yes”关闭连接，单击 关闭窗口。 

图3-303 关闭连接 

 

----结束 

 

3.20.3 并行设计测试点文件导入及高亮显示 

操作步骤 

步骤 1 导入文件：1、协同导入文件，不用暂停；2、只能查看，不能在这个工具中添加.支

持.txt、.lst、.scr 的文件格式；若传递的.scr 文件双击打不开，可以复制一份改后缀

为.txt，即可查看内容，.txt 也可直接导入；手动编辑，新建记事本.txt 即可，将网络

复制粘贴到文件中保存导入软件即可，也可修改.txt 格式为.lst 再导入也可以。 
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步骤 2 可单机配置测试点添加参数，也可协同暂停配置参数，协同添加测试点；协同时，未

暂停配置测试地添加参数，可以添加测试点，且另存文件中已经添加上的测试点数据
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都保存了，但是未暂停配置的个性化参数，保存不了，若想保存，请暂停协同设置

后，另存即可保存配置的参数。 

 

效果图如下： 
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----结束 

 

4 PCB-DESIGN 封装库管理 

4.1  编辑器界面介绍 

4.2  菜单栏 

4.3  顶部工具栏 
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4.4  左侧封装窗口 

4.1 编辑器界面介绍 

编辑器界面由菜单栏、工具栏、封装窗口、画布组成，如 4.1 编辑器界面介绍所示。 

封装库各个部分的相关操作请参见表 4-1。 

图4-1 编辑器界面 

 

 

表4-1 编辑器界面操作 

编辑器界面 使用方法 

菜单栏 菜单栏提供了封装库常用的功能，关于菜单栏的具体操作

请参见 4.2 菜单栏。 

工具栏 工具栏提供了设置及显示菜单栏对应的功能按钮，方便快

捷操作，关于工具栏的具体操作请参见 4.3 顶部工具栏。 

封装窗口 编辑器封装窗口可查询和编辑封装库全部封装，关于封装

窗口的具体操作请参见 4.4 左侧封装窗口。 

画布 封装库中，画布用于查看封装图形。 
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4.2 菜单栏 

4.2.1 文件菜单（File） 

4.2.1.1 创建封装库（New） 

本章节为您介绍如何创建封装库。PCB-DESIGN 封装库管理目前只支持创建本地封装

库和远端封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>New...”。 

步骤 3 在弹出的“New”页面中，可创建本地库和远端库。 

⚫ 创建本地库 

a. 封装库类型：单击 Library Type 后的下拉框选择 Local。 

b. 库名称：在 Database Name 后的输入框输入本地库名称。 

c. 保存路径：单击 Path 后的 ，在弹出窗口中选择存放库文件的文件

夹，单击“选择文件夹”。 

d. 单击“OK”创建本地库。 



PCB版图设计 

用户指南 4 PCB-DESIGN封装库管理 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 425 

 

图4-2 创建本地库 

 

 

⚫ 创建远端库 

a. 封装库类型：单击 Library Type 后的下拉框选择 Remote。 

b. 管理员名称：在 AdminUserName 后的输入框输入管理员名称。 

c. 管理员密码：在 AdminPassword 后的输入框输入管理员密码。 

d. 用户名称：在 UserName 后的输入框输入用户名称。 

e. 用户密码：在 Password 后的输入框输入用户密码。 

f. 库名称：在 Database Name 后的输入框输入远端库名称。 

g. IP 地址：在 IP 后的输入框输入 IP 地址。 

h. 端口：在 Port 后的输入框输入端口。 

i. 单击“OK”创建远端库。 
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图4-3 创建远端库 

 

 

 

⚫ 创建的库为空库，库里面不存在任何封装。 

⚫ 空库添加封装的方式有两种，手动添加封装和导入封装。具体操作请参见 4.4.5 封装库添加

封装。 

⚫ 保存路径不能有中文。 

----结束 

4.2.1.2 导入封装库文件（Import） 

本章节为您介绍如何将封装库文件导入封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Import”。 

步骤 3 在弹出的“Import”页面中，可将库文件导入到本地库。 

1. 单击“Local”，选择本地库页签。 
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2. 单击 Path 后的 ，在弹出窗口中选择存在库文件的文件夹，单击“选择

文件夹”。 

3. 单击 Database Name 后的下拉框选择封装库。 

4. 单击“Import”导入库文件。 

图4-4 导入本地库 

 

 

 

⚫ 库文件导入本地库，需先创建本地封装库，具体操作请参见 4.2.1.1 创建封装库（New）。 

⚫ 保存路径不能有中文。 

----结束 

4.2.1.3 导出封装库文件（Export） 

本章节为您介绍如何导出封装库文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Export”。 

步骤 3 在弹出的“Export”页面中，可导出本地库的库文件。 

1. 单击 Path 后的 ，在弹出窗口中选择存放库文件的文件夹，单击“选择

文件夹”。 
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2. 单击 Database Name 后的下拉框选择需要导出的本地库。 

3. 单击“Export”导出库文件。 

图4-5 导出封装库 

 

 

 

保存路径不能有中文。 

----结束 

4.2.1.4 退出（Exit） 

本章节为您介绍如何退出封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Exit”。 

步骤 3 在弹窗中单击“Yes”退出封装库。 
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图4-6 退出封装库 

 

 

----结束 

4.2.2 编辑菜单（Edit） 

4.2.2.1 刷新（Refresh） 

本章节为您介绍如何刷新封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Edit>Refresh”。 

步骤 3 编辑器界面自动恢复到初始状态，不展开和显示任何封装。 

图4-7 界面示图 
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单击刷新后，封装列表的封装也会更新。 

----结束 

4.2.3 工具菜单（Tools） 

4.2.3.1 编辑器工具 

本章主要介绍封装库管理的其他编辑工具，包括焊盘编辑器、封装编辑器、形状编辑

器。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Tools”。在“Tools”菜单下有 3 个编辑小工具，这 3 个编辑小工具

的具体操作请参见表 4-2。 

表4-2 小工具操作说明 

小工具 操作说明 

焊盘编

辑器 

在封装库管理菜单栏选择“Tools>Padstack Editor...”，进入焊盘编辑

器。 

编辑器提供了修改和替换封装库焊盘等功能，方便快捷操作，关于焊盘

编辑器的具体操作请参见 5 PCB-DESIGN 焊盘编辑器。 

封装编

辑器 

在封装库管理菜单栏选择“Tools>Footprint Editor...”，进入封装编辑

器。 

编辑器提供了修改封装库封装等功能，方便快捷操作，关于封装编辑器

的具体操作请参见 6 PCB-DESIGN 封装编辑器。 

形状编

辑器 

在封装库管理菜单栏选择“Tools>Shape Editor...”，进入形状编辑

器。 

编辑器提供了修改焊盘封装和铜箔等功能，方便快捷操作，关于形状编

辑器的具体操作请参见 7 PCB-DESIGN 形状编辑器。 

 

----结束 
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4.2.3.2 连接封装库（Settings） 

连接封装库后，可查看和编辑封装库的数据。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Tools>Settings...”。 

步骤 3 在弹出的“Setting”页面左侧，单击“Library Connection Management”，配置

封装库，具体操作请参见表 4-3。 

图4-8 连接封装库 

 

 

表4-3 封装库操作说明 

操作名称 操作说明 

添加本地封装 1. 单击连接列表上方的 。 
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操作名称 操作说明 

库 2. 单击 Library Type 后的下拉框选择 Local。 

3. 在弹出的窗口，单击 Path 后的 ，选择本地库文件，

单击“打开”。 

4. 勾选“connect”前的方框，单击“OK”。 

添加远端封装

库 

1. 单击连接列表上方的 。 

2. 单击 Library Type 后的下拉框选择 Remote。 

3. 在 UserName 后的输入框输入用户名称。在 Password 后的输

入框输入用户密码。在 Database Name 后的输入框输入远端库

名称。在 IP 后的输入框输入服务端的 IP 地址。在 Port 后的输入

框输入服务端端口。 

4. 勾选“connect”前的方框，单击“OK”。 

连接封装库 1. 勾选“Connect”栏下的复选框，连接封装库。 

2. 单击“OK”保存设置。 

断开封装库 1. 取消勾选“Connect”栏下的复选框。 

2. 单击“OK”保存设置。 

删除封装库 1. 勾选连接列表前的复选框，单击列表上方 。 

2. 在弹出的提示框中，单击“Yes”。 

移动封装库顺

序 

封装库的使用优先级是按封装库排列顺序确定的，使用顺序依次为

1、2、3...。序号为 1 时，优先使用。 

⚫ 上升排序：勾选序号前的复选框，单击图标 ，封装库往上移

动。 

⚫ 下降排序：勾选序号前的复选框，单击图标 ，封装库往下移

动。 

 

----结束 

4.2.4 窗口菜单（Windows） 

本章节为您介绍如何打开和关闭窗口。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB-DESIGN 封装库管理页面各个窗口的打开和关闭窗口操作说明如表 4-4 所示。 

图4-9 打开/关闭窗口入口 

 

 

表4-4 窗口操作说明 

操作名称 操作步骤 

顶部工具栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Toolbar”自动打开工具栏，

取消勾选关闭工具栏。 

左侧封装窗口 1. 在菜单栏选择“Windows”。 

2. 勾选“Library”自动打开封装窗口，

取消勾选关闭封装窗口。 

 

----结束 

4.2.5 帮助菜单（Help） 

4.2.5.1 查看软件版本信息（About） 

在封装库工具中可在“About”菜单查看软件版本信息。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Help>About” 。 

步骤 3 在弹出的“About”页面，查看软件版本信息。 

图4-10 About 页面 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

4.3 顶部工具栏 

4.3.1 工具栏打开与关闭 

本章节为您介绍如何在封装库中打开与关闭工具栏。工具栏提供了设置及显示菜单栏

对应的功能按钮，方便快捷操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Toolbar”自动打开工具栏，取消勾选关闭工具栏。 

----结束 
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4.3.2 工具栏图标含义及功能 

文件菜单 

序号 图标 含义及功能 

1  创建封装库 

2  导入封装库文件 

3  导出封装库文件 

4  导入 Allegro 封装库文件 

5  退出 

 

编辑菜单 

序号 图标 含义及功能 

1  刷新 

 

工具菜单 

序号 图标 含义及功能 

1  封装库连接 

 

4.4 左侧封装窗口 

4.4.1 封装窗口打开与关闭 

本章节为您介绍如何在封装库中打开与关闭封装窗口。封装窗口也叫 Library 窗口，

在窗口中可以查看和编辑器件封装。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Library”自动打开封装窗口，取消勾选关闭封装窗口。 

----结束 

4.4.2 封装类型说明 

封装库封装窗口有四种封装类型，分别是 Pads、Padstacks、Footprints、Parts。四

个封装之间是上下级关系（Pads<Padstacks<Footprints<Parts）， 

具体封装类型说明请参见表 4-5。 

表4-5 封装类型说明 

类型 说明 

Parts 一个 Part 对应一个 Footprint，一个 Footprint 可以被多个 Part

使用。 

Footprints 一个 Footprint 中有多个 Padstack，一个 Padstack 可以被多个

Footprint 使用。 

Padstacks 一个 Padstack 中有多个 Pad，一个 Pad 可以被多个 Padstack

使用。 

Pads 一个 Pad 可以被多个 Padstack 使用。 

 

4.4.3 查看封装 

本章节为您介绍如何查看封装库封装。 

前提条件 

在编辑器左侧封装窗口存在封装库。如不存在封装库，需创建和导入封装库封装，具

体操作请参见 4.2.1.1 创建封装库（New）和 4.2.1.2 导入封装库文件（Import）。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在编辑器左侧封装窗口，双击需要查看的封装库，再双击封装库下需要查看的封装类

型（Pads、Padstacks、Footprints、Parts），再双击类型下的“Default”，

“Default”下展示封装列表。 

图4-11 查看封装列表 

 

 

步骤 3 在展开的封装列表中，单击封装名称，画布中系统自动显示封装图形。如图 4-12 所

示。 
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图4-12 查询封装示例图 

 

 

 

封装前的三角图标 用于展开和收缩封装列表。 

----结束 

4.4.4 编辑封装基础操作 

本章节为您介绍在 PCB 封装库管理中编辑封装常用的快捷操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB 封装库管理界面编辑常用快捷操作说明如表 4-6 所示。 

表4-6 编辑常用快捷操作说明 

操作类

型 

操作名称 操作步骤 

右键操

作 

New 

Category（添

加封装类别） 

1. 在封装库管理左侧封装窗口，单击封装类型，右键单

击“New Category”。 

说明 

封装类型可选择 Pads、Padstacks、Footprints、Parts。 
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操作类

型 

操作名称 操作步骤 

2. 在弹出的窗口中，在“Please Enter New Category 

Name”下的输入框输入封装类别名称，单击

“OK”。 

Delete 

Category（删

除封装类别） 

1. 在封装库管理左侧封装窗口，单击创建的封装类别，

右键单击“Delete Category”。 

说明 

需创建并存在封装类别，才可删除。具体操作请参见此表第一栏

New Category。 

2. 在弹出的窗口中，单击“OK”。 

New Pad（添

加 Pad） 

1. 在封装库管理左侧封装窗口，双击“Pads”，单击

“Default”，右键单击“New Pad”。 

2. 在弹出的窗口中，在“Please Enter New Pad”下的

输入框输入封装名称，单击“OK”。 

New Padstack

（添加

Padstack） 

1. 在封装库管理左侧封装窗口，双击“Padstacks”，

单击“Default”，右键单击“New Padstack”。 

2. 在弹出的窗口中，在“Please Enter New 

Padstack”下的输入框输入封装名称，单击

“OK”。 

New 

Footprint（添

加 Footprint） 

1. 在封装库管理左侧封装窗口，双击“Footprints”，

单击“Default”，右键单击“New Footprint”。 

2. 在弹出的窗口中，在“Please Enter New 

Footprint”下的输入框输入封装名称，单击

“OK”。 

Open（打开封

装编辑器） 

1. 在封装库管理左侧封装窗口，单击封装名称，右键单

击“Open”。 

说明 

封装名称可选择 Pads、Padstacks、Footprints 类型下的封

装。 

2. 系统自动打开封装编辑器。 

Change 

Category（改

变封装类别） 

1. 在封装库管理左侧封装窗口，单击封装名称，右键单

击“Change Category”。 

2. 在弹出的窗口中，单击下拉框选择封装类别，单击



PCB版图设计 

用户指南 4 PCB-DESIGN封装库管理 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 440 

 

操作类

型 

操作名称 操作步骤 

“OK”。 

Delete（删除

封装） 

1. 在封装库管理左侧封装窗口，单击封装名称，右键单

击“Delete”。 

2. 在弹出的窗口中，单击“OK”，再次单击“OK”。 

关联上

下级 

Pads 1. 双击 Pads 的封装名称，再双击“Related 

Padstacks”。 

2. 在“Related Padstacks”下方可查看与 Pads 关联的

封装名称。 

Padstacks 1. 双击 Padstacks 的封装名称，再双击“Related 

Pads”和“Related Footprints”。 

2. 在“Related Pads”和“Related Footprints”下方

可查看与 Padstacks 关联的封装名称。 

Footprints 1. 双击 Footprints 的封装名称，再双击“Related 

Parts”和“Related Padstacks”。 

2. 在“Related Parts”和“Related Padstacks”下方

可查看与 Footprints 关联的封装名称。 

Parts 1. 双击 Parts 的封装名称，再双击“Related 

Footprints”。 

2. 在“Related Footprints”下方可查看与 Parts 关联

的封装名称。 

 

 

⚫ 封装类别是封装类型的子项。Default 是封装类别，也是封装类型默认的子项，不可删除。 

⚫ 可以创建封装类别，也可以删除创建的封装类别。 

⚫ 可以改变封装的类别，只能在同一种封装类型下改变封装类别，不能跨封装类型。 

例如 Pads 下的封装只能存放在 Pads 的类别里，不能放置在 Padstacks 的类别里。 

⚫ 关联的 Related Pads 、Related Padstacks 、Related Footprints 是创建封装时自动创建

的，不需要单独创建。 

----结束 
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4.4.5 封装库添加封装 

本章节为您介绍如何在封装库添加封装。 

前提条件 

⚫ 已在编辑器左侧封装窗口存在封装库，如不存在，请先创建封装库，具体操作请

参见 4.2.1.1 创建封装库（New）。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB 封装库管理中，封装库添加封装有自动添加和导入封装的两种操作方式。 

⚫ 导入封装 

a. 导入封装具体操作请参见 4.2.1.2 导入封装库文件（Import）。 

b. 封装导入完成后，可在对应的封装类型查看，具体操作请参见 4.4.3 查看封

装。 

⚫ 手动添加封装 

a. 在封装库管理左侧封装窗口，双击封装库，可添加的封装类型有三种，分别

为 Pads、Padstacks、Footprints。 

◼ 添加 Pads 

1) 双击“Pads”，单击“Default”，右键单击“New Pad”。 

2) 在弹出的窗口中，在“Please Enter New Pad”下的输入框输入封

装名称，单击“OK”。 

3) 在封装列表中选择上一步新建的封装，右键单击“Open”，打开形

状编辑器编辑，编辑 Pads 类型的封装。 

◼ 添加 Padstacks 

1) 双击“Padstacks”，单击“Default”，右键单击“New 

Padstack”。 

2) 在弹出的窗口中，在“Please Enter New Padstack”下的输入框

输入封装名称，单击“OK”。 

3) 在封装列表中选择上一步新建的封装，右键单击“Open”，打开焊

盘编辑器编辑，编辑 Padstacks 类型的封装。 

◼ 添加 Footprints 
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1) 双击“Footprints”，单击“Default”，右键单击“New 

Footprint”。 

2) 在弹出的窗口中，在“Please Enter New Footprint”下的输入框

输入封装名称，单击“OK”。 

3) 在封装列表中选择上一步新建的封装，右键单击“Open”，打开封

装编辑器编辑，编辑 Footprints 类型的封装。 

b. 手动添加封装完成后，可在对应的封装类型查看，具体操作请参见 4.4.3 查

看封装。 

----结束 

 

 

5 PCB-DESIGN 焊盘编辑器 

5.1  菜单栏 

5.2  编辑孔盘和焊盘 

5.3  关联封装 
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5.1 菜单栏 

5.1.1 文件菜单（File） 

5.1.1.1 打开（Open） 

本章节为您介绍如何从焊盘编辑器中打开封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在焊盘编辑器菜单栏中选择“File>Open...”。 

步骤 3 在弹出的“Open”页面中，打开封装。 

1. 在封装库列表中选择一个库。 

2. 单击封装库，在页面左上角 Padstacks 后的输入框输入封装名称，键盘按

“Enter”回车键。 

3. 在左侧封装列表中，系统自动显示封装名称。 

4. 单击封装名称，右侧会显示封装图形。 

5. 单击“OK”。 
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图5-1 打开封装示图 

 

 

步骤 4 在编辑器下方 Select pad to change 框下，图层的 Connect Pad 栏自动显示选择的

封装。 

 

⚫ 在打开封装库时，会提示保存当前封装提醒。保存提示弹窗中可以单击“Yes”。如果不符合

规则，会弹出保存提醒，单击“Save with warning”保存，再单击“OK”会保存成功，系

统自动打开封装库。 

⚫ 在打开封装库时，会提示保存当前封装提醒。保存提示弹窗中可以单击“No”不保存，系

统自动打开封装库。 

----结束 

5.1.1.2 保存（Save） 

本章节为您介绍如何从焊盘编辑器中保存封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在封装库管理菜单栏选择“Tools>Padstack Editor...”。 
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步骤 3 在焊盘编辑器菜单栏中选择“File>Save”。 

步骤 4 系统自动保存。 

 

如果不符合规则，会弹出保存提醒，单击“Save with warning”保存，再单击“OK”会保存

成功。 

----结束 

5.1.1.3 另存（Save as） 

本章节为您介绍如何从焊盘编辑器中另存封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在封装库管理菜单栏选择“Tools>Padstack Editor...”。 

步骤 3 在焊盘编辑器菜单栏中选择“File>Save as...”。 

步骤 4 在打开弹窗中，填写封装名称，选择连接的库。 

1. 封装名称：在 Padstack Name 后的输入框中输入封装名称。 

2. 连接的库：在 Connect Address 后的下拉框选择连接的库。 

3. 单击“OK”。 

图5-2 另存封装 

 

 

 

如果不符合规则，会弹出保存提醒，单击“Save with warning”保存，再单击“OK”会保存

成功。 
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----结束 

5.1.1.4 查看报告（Report） 

本章节为您介绍如何从焊盘编辑器中打开报告。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在封装库管理菜单栏选择“Tools>Padstack Editor...”。 

步骤 3 在焊盘编辑器菜单栏中选择“File>Report”。 

步骤 4 在弹出的 Report 页面中，可以查询焊盘封装的具体信息。 

图5-3 查看报告 

 

 

----结束 

5.1.1.5 退出（Exit） 

本章节为您介绍如何退出焊盘编辑器。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在封装库管理菜单栏选择“Tools>Padstack Editor...”。 

步骤 3 在焊盘编辑器菜单栏选择“File>Exit”。 

步骤 4 在弹窗中单击“Yes”退出焊盘编辑器。 

图5-4 退出焊盘编辑器 

 

 

----结束 

5.1.2 工具菜单（Tools） 

5.1.2.1 连接封装库（Setting） 

本章节为您介绍如何从焊盘编辑器中连接封装库。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在焊盘编辑器菜单栏中选择“Tools>Setting...”。 

步骤 3 在弹出的“Setting”页面中，可对封装库进行连接与操作，具体请参见表 5-1。 
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图5-5 连接封装库 

 

 

表5-1 封装库操作说明 

操作名称 操作说明 

添加本地封装

库 

1. 单击连接列表上方的 。 

2. 单击 Library Type 后的下拉框选择 Local。 

3. 在弹出的窗口，单击 Path 后的 ，选择本地库文件，

单击“打开”。 

4. 勾选“connect”前的方框，单击“OK” 

添加远端封装

库 

1. 单击连接列表上方的 。 

2. 单击 Library Type 后的下拉框选择 Remote。 

3. 在 UserName 后的输入框输入用户名称。在 Password 后的输

入框输入用户密码。在 Database Name 后的输入框输入远端库

名称。在 IP 后的输入框输入服务端的 IP 地址。在 Port 后的输入

框输入服务端端口。 

4. 勾选“connect”前的方框，单击“OK”。 
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操作名称 操作说明 

连接封装库 1. 勾选“Connect”栏下的复选框，连接封装库。 

2. 单击“OK”保存设置。 

断开封装库 1. 取消勾选“Connect”栏下的复选框。 

2. 单击“OK”保存设置。 

删除封装库 1. 勾选连接列表前的复选框，单击列表上方 。 

2. 在弹出的提示框中，单击“Yes”。 

移动封装库顺

序 

封装库的使用优先级是按封装库排列顺序确定的，使用顺序依次为

1、2、3...。序号为 1 时，优先使用。 

⚫ 上升排序：勾选序号前的复选框，单击图标 ，封装库往上移

动。 

⚫ 下降排序：勾选序号前的复选框，单击图标 ，封装库往下移

动。 

 

----结束 

5.1.3 帮助菜单（Help） 

5.1.3.1 查看软件版本信息（About） 

在焊盘编辑器工具中可在“About”菜单查看编辑器版本信息。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在焊盘编辑器菜单栏中选择“Help>About”。 

步骤 3 在弹出的“About”页面，查看编辑器版本信息。 
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图5-6 About 页面 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

5.2 编辑孔盘和焊盘 

5.2.1 编辑孔盘 

本章节为您介绍如何从焊盘编辑器中编辑孔盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在弹出页面中，单击 Select padstack usage 后的下拉框选择，可选择 Through、

SMD、Via、BBVia、Microvia、Slot。 

步骤 3 根据不同的焊盘用途配置参数。 
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图5-7 孔盘配置示例 

 

 

⚫ Through（通孔） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）、Non-Plated（非金属化孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Circle（圆形）、

Square（方形）。 

c. 钻孔大小：在 Finished Size 后的输入框输入钻孔大小。 

d. 正负公差：在+Tolerance 后的输入框输入正公差。在-Tolerance 后的输入

框输入负公差。 

e. 钻标形状：单击 Figure 后的下拉框选择，可选择 Circle、Square、

Hexagon X、Hexagon Y、Octagon、Cross、Diamond、Rectangle、

Triangle、Oblong X、Oblong Y。 

◼ Circle（圆形） 

1) 在 Diameter 后的输入框输入直径。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Square（方形） 
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1) 在 Size 后的输入框输入边长。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon X（六角形 X） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon Y（六角形 Y） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Octagon（八边形） 

1) 在 Size 后的输入框输入长度。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Cross（十字标） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Diamond（菱形） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Rectangle（矩形） 

1) 在 Width 后的输入框输入矩形长度。 

2) 在 Height 后的输入框输入矩形宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Triangle（三角形） 

1) 在 Width 后的输入框输入三角形长度。 

2) 在 Height 后的输入框输入三角形高度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong X（椭圆形 X） 
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1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong Y（椭圆形 Y） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

⚫ SMD（表贴焊盘） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Circle（圆形）、

Square（方形）。 

c. 钻孔大小：在 Finished Size 后的输入框输入钻孔大小。 

d. 正负公差：在+Tolerance 后的输入框输入正公差。在-Tolerance 后的输入

框输入负公差。 

e. 钻标形状：单击 Figure 后的下拉框选择，可选择 Circle、Square、

Hexagon X、Hexagon Y、Octagon、Cross、Diamond、Rectangle、

Triangle、Oblong X、Oblong Y。 

◼ Circle（圆形） 

1) 在 Diameter 后的输入框输入直径。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Square（方形） 

1) 在 Size 后的输入框输入边长。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon X（六角形 X） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon Y（六角形 Y） 
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1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Octagon（八边形） 

1) 在 Size 后的输入框输入长度。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Cross（十字标） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Diamond（菱形） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Rectangle（矩形） 

1) 在 Width 后的输入框输入矩形长度。 

2) 在 Height 后的输入框输入矩形宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Triangle（三角形） 

1) 在 Width 后的输入框输入三角形长度。 

2) 在 Height 后的输入框输入三角形高度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong X（椭圆形 X） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong Y（椭圆形 Y） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 
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f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

⚫ Via（过孔） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）、Non-Plated（非金属化孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Circle（圆形）、

Square（方形）。 

c. 钻孔大小：在 Finished Size 后的输入框输入钻孔大小。 

d. 正负公差：在+Tolerance 后的输入框输入正公差。在-Tolerance 后的输入

框输入负公差。 

e. 钻标形状：单击 Figure 后的下拉框选择，可选择 Circle、Square、

Hexagon X、Hexagon Y、Octagon、Cross、Diamond、Rectangle、

Triangle、Oblong X、Oblong Y。 

◼ Circle（圆形） 

1) 在 Diameter 后的输入框输入直径。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Square（方形） 

1) 在 Size 后的输入框输入边长。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon X（六角形 X） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon Y（六角形 Y） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Octagon（八边形） 

1) 在 Size 后的输入框输入长度。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Cross（十字标） 
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1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Diamond（菱形） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Rectangle（矩形） 

1) 在 Width 后的输入框输入矩形长度。 

2) 在 Height 后的输入框输入矩形宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Triangle（三角形） 

1) 在 Width 后的输入框输入三角形长度。 

2) 在 Height 后的输入框输入三角形高度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong X（椭圆形 X） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong Y（椭圆形 Y） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

⚫ BBvia（盲埋孔） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）、Non-Plated（非金属化孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Circle（圆形）、

Square（方形）。 

c. 钻孔大小：在 Finished Size 后的输入框输入钻孔大小。 
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d. 正负公差：在+Tolerance 后的输入框输入正公差。在-Tolerance 后的输入

框输入负公差。 

e. 钻标形状：单击 Figure 后的下拉框选择，可选择 Circle、Square、

Hexagon X、Hexagon Y、Octagon、Cross、Diamond、Rectangle、

Triangle、Oblong X、Oblong Y。 

◼ Circle（圆形） 

1) 在 Diameter 后的输入框输入直径。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Square（方形） 

1) 在 Size 后的输入框输入边长。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon X（六角形 X） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon Y（六角形 Y） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Octagon（八边形） 

1) 在 Size 后的输入框输入长度。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Cross（十字标） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Diamond（菱形） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Rectangle（矩形） 
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1) 在 Width 后的输入框输入矩形长度。 

2) 在 Height 后的输入框输入矩形宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Triangle（三角形） 

1) 在 Width 后的输入框输入三角形长度。 

2) 在 Height 后的输入框输入三角形高度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong X（椭圆形 X） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong Y（椭圆形 Y） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

⚫ Microvia（微孔） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Circle（圆形）、

Square（方形）。 

c. 钻孔大小：在 Finished Size 后的输入框输入钻孔大小。 

d. 正负公差：在+Tolerance 后的输入框输入正公差。在-Tolerance 后的输入

框输入负公差。 

e. 钻标形状：单击 Figure 后的下拉框选择，可选择 Circle、Square、

Hexagon X、Hexagon Y、Octagon、Cross、Diamond、Rectangle、

Triangle、Oblong X、Oblong Y。 

◼ Circle（圆形） 

1) 在 Diameter 后的输入框输入直径。 

2) 在 Characters 后的输入框输入符号标识。 
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◼ Square（方形） 

1) 在 Size 后的输入框输入边长。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon X（六角形 X） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Hexagon Y（六角形 Y） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Octagon（八边形） 

1) 在 Size 后的输入框输入长度。 

2) 在 Characters 后的输入框输入符号标识。 

◼ Cross（十字标） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Diamond（菱形） 

1) 在 Width 后的输入框输入长度。 

2) 在 Height 后的输入框输入宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Rectangle（矩形） 

1) 在 Width 后的输入框输入矩形长度。 

2) 在 Height 后的输入框输入矩形宽度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Triangle（三角形） 

1) 在 Width 后的输入框输入三角形长度。 

2) 在 Height 后的输入框输入三角形高度。 

3) 在 Characters 后的输入框输入符号标识。 
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◼ Oblong X（椭圆形 X） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

◼ Oblong Y（椭圆形 Y） 

1) 在 Width 后的输入框输入椭圆形 X 轴长度。 

2) 在 Height 后的输入框输入椭圆形 Y 轴长度。 

3) 在 Characters 后的输入框输入符号标识。 

f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

⚫ Slot（钻槽） 

a. 钻孔属性：单击 Hole Plating 后选项前的圆圈选择，可选择 Plated（金属化

孔）、Non-Plated（非金属化孔）。 

b. 钻孔类型：单击 Hole Type 后的下拉框选择，可选择 Oval（椭圆形）、

Rectangle（矩形）。 

c. X size：在 X size 后的输入框输入钻槽大小。在 X tolerance 的第一个输入

框输入正公差，第二个输入框输入负公差。 

d. Y size：在 Y size 后的输入框输入钻槽大小。在 Y tolerance 的第一个输入框

输入正公差，第二个输入框输入负公差。 

e. 位号标识：在 Characters 后的输入框输入符号标识。 

f. 钻孔偏移坐标：在 Offset X 后的输入框输入 X 轴钻孔偏移坐标，在 Offset Y

后的输入框输入 Y 轴钻孔偏移坐标。 

步骤 4 参数编辑完成后，单击“Save”保存或者“Save as...”另存为新的焊盘封装。 

 

如果不符合规则，会弹出保存提醒，单击“Save with warning”保存，在单击“OK”会保存

成功。 

----结束 

5.2.2 编辑焊盘 

本章节为您介绍如何编辑焊盘。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在弹出页面中，在 Select pad to change 框下配置焊盘参数。 

图5-8 配置焊盘参数示图 

 

 

1. 单击 Connect Pad 列下的焊盘或者 None。 

2. 选择焊盘形状：在 Geometry 后的下拉框选择，可选择 Circle、Square、

Oblong、Rectangle、Rounded rectangle、Chamfered rectangle、 

N-sided polygon、Octagon、Donut。 

3. 根据不同的焊盘形状，配置参数。 

− Circle（圆形） 

i. 在 Geometry 后的下拉框选择 Circle。 

ii. 在 Diameter 后的输入框输入直径。 

− Square（方形） 

i. 在 Geometry 后的下拉框选择 Square。 
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ii. 在 Width 后的输入框输入方形长度。 

− Oblong（椭圆形） 

i. 在 Geometry 后的下拉框选择 Oblong。 

ii. 在 Width 后的输入框输入椭圆形 X 轴方向长度大小。 

iii. 在 Height 后的输入框输入椭圆形 Y 轴方向长度大小。 

− Rectangle（矩形） 

i. 在 Geometry 后的下拉框选择 Rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

− Rounded rectangle（倒圆角的矩形） 

i. 在 Geometry 后的下拉框选择 Rounded rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner radiu 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− Chamfered rectangle（倒斜角的矩形） 

i. 在 Geometry 后的下拉框选择 Chamfered rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner charr 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− N-sided polygon（多边形） 

i. 在 Geometry 后的下拉框选择 N-sided polygon。 

ii. 在 Diameter 后的输入框输入直径。 

iii. 在 sides 后的输入框输入多边形边数。边数只能是双数，不能输入单

数。 

− Octagon（八边形） 

i. 在 Geometry 后的下拉框选择 Octagon。 

ii. 在 Width 后的输入框输入长度。 
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− Donut（空心圆） 

i. 在 Geometry 后的下拉框选择 Donut。 

ii. 在 Outer Diame 后的输入框输入外径。 

iii. 在 Inner Diamet 后的输入框输入内径。 

− Shape 

i. 单击 Pad Name 后的 ，打开封装库。 

ii. 在封装库封装列表中选择需要的封装，单击“OK”。 

步骤 3 参数编辑完成后，单击“Save”保存或者“Save as...”另存为新的焊盘封装。 

 

⚫ 如果不符合规则，会弹出保存提醒，单击“Save with warning”保存，再单击“OK”会保

存成功。 

⚫ Thermal Pad 

⚫ 单击 Thermal Pad 列下的焊盘或者 None。 

1. 在 Geometry 后的下拉框选择 Flash。 

2. 单击 Pad Name 后的 ，打开封装库。 

3. 在封装库封装列表中选择需要的封装，单击“OK”。 

⚫ Clearance Pad 的操作同 Connect Pad 的操作。 

----结束 

5.3 关联封装 

本章节为您介绍如何从焊盘编辑器中关联封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Padstack_Editor”打开 PCB 焊盘编辑器。 

步骤 2 在弹出页面中，在 Select pad to change 框下配置关联的焊盘，具体操作请参见

5.2.2 编辑焊盘。 

步骤 3 在封装库管理左侧封装窗口中，可以查看关联的封装。具体请参见表 5-2。 
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表5-2 关联封装操作说明 

关联名称 操作步骤 

Pads 1. 双击 Pads 的封装名称，再双击“Related Padstacks”。 

2. 在“Related Padstacks”下方可查看与 Pads 关联的封装

名称。 

Padstacks 1. 双击 Padstacks 的封装名称，再双击“Related Pads”和

“Related Footprints”。 

2. 在“Related Pads”和“Related Footprints”下方可查

看与 Padstacks 关联的封装名称。 

Footprints 1. 双击 Footprints 的封装名称，再双击“Related Parts”

和“Related Padstacks”。 

2. 在“Related Parts”和“Related Padstacks”下方可查

看与 Footprints 关联的封装名称。 

Parts 1. 双击 Parts 的封装名称，再双击“Related 

Footprints”。 

2. 在“Related Footprints”下方可查看与 Parts 关联的封

装名称。 

----结束 
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6 PCB-DESIGN 封装编辑器 

6.1  编辑器界面介绍 

6.2  菜单栏 

6.3  顶部工具栏 

6.4  左侧对象查询窗口 

6.5  右侧图层窗口 

6.6  右侧配层选择窗口 

6.7  右侧配置窗口 

6.8  底部操作命令窗口 

6.9  底部信息窗口 

6.10  底部局部放大视图窗口 

6.11  底部状态栏 

6.1 编辑器界面介绍 

PCB-DESIGN 封装编辑器界面由菜单栏、工具栏、对象查询窗口、画布、图层窗口、

配层选择窗口、配置窗口、操作命令窗口、信息窗口、局部放大视图窗口、状态栏组

成，如图 6-1 所示。 

编辑器各个部分的相关操作请参见 6.1 编辑器界面介绍。 
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图6-1 编辑器界面 

 

 

表6-1 编辑器界面操作 

编辑器界面 使用方法 

菜单栏 菜单栏提供了编辑器常用的功能，关于菜单栏的具体操作请

参见 6.2 菜单栏。 

工具栏 工具栏提供了设置及显示菜单栏对应的功能按钮，方便快捷

操作，关于工具栏的具体操作请参见 6.3 顶部工具栏。 

对象查询窗口 对象查询窗口提供了查询画布中任何对象的功能，关于对象

查询窗口的具体操作请参见 6.4 左侧对象查询窗口。 

画布 编辑器中，画布用于查看和绘制封装等操作。 

图层窗口 图层窗口用于打开和选择绘制的层次，关于图层窗口的具体

操作请参见 6.5 右侧图层窗口。 

配层选择窗口 配层选择窗口用于打开和选择绘制的配层，关于配层窗口的

具体操作请参见 6.6 右侧配层选择窗口。 

配置窗口 配置窗口提供了操作命令的所有配置功能，关于配置窗口的

具体操作请参见 6.7 右侧配置窗口。 

操作命令窗口 操作命令窗口提供了输入操作命令，画布中的对象直接执行

操作的功能，关于操作命令窗口的具体操作请参见 6.8 底部

操作命令窗口。 
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编辑器界面 使用方法 

信息窗口 信息窗口提供了快速查看信息的功能，关于信息窗口的具体

操作请参见 6.9 底部信息窗口。 

局部放大视图窗口 局部放大视图窗口便于在绘制过程中查看具体位置，关于局

部放大视图窗口的具体操作请参见 6.10 底部局部放大视图

窗口。 

状态栏 状态栏提供了编辑器中显示坐标、格点及配置功能按钮，方

便快捷操作，关于状态栏的具体操作请参见 6.11 底部状态

栏。 

 

6.2 菜单栏 

6.2.1 文件菜单（File） 

6.2.1.1 新建封装（New） 

本章节为您介绍如何从封装编辑器中新建封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>New...”。 

步骤 3 在弹出提示窗口中，选择是否保存当前封装。 

⚫ 保存 

a. 单击“Yes”。 

b. 在弹窗中，Footprint Name 后的输入框输入封装名称。在 Database Name

后的下拉框选择存放封装的封装库。 

c. 单击“OK”。 
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图6-2 保存当前封装 

 

⚫ 不保存 

单击“Cancel”。 

步骤 4 在弹出的“New Drawing”页面中，新建封装。 

1. 在 Drawing Name 后的输入框输入新的封装名称。 

2. 在 Database Name 后的下拉框选择存放封装的封装库。 

3. 在 Drawing Type 后的下拉框选择封装类型。 

图6-3 新建封装 

 

 

步骤 5 新建完成后，系统自动打开封装。 
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图6-4 打开封装示图 

 

 

 

⚫ 新建的封装编辑完成后需先保存到封装库中，才能在封装库打开。 

⚫ 保存路径不能有中文。 

----结束 

6.2.1.2 打开封装（Open） 

本章节为您介绍如何从封装编辑器中打开封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Open...”。 

步骤 3 在弹出提示窗口中，选择是否保存当前封装。 

⚫ 保存 

a. 单击“Yes”。 

b. 在弹窗中，Footprint Name 后的输入框输入封装名称。在 Database Name

后的下拉框选择存放的封装库。 

c. 单击“OK”。 
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图6-5 保存当前封装 

 

 

⚫ 不保存 

单击“No”。 

步骤 4 在弹出的“Open”页面中，打开封装。 

1. 单击封装库，在页面左上角 Footprints 后的输入框输入封装名称，键盘按

“Enter”回车键。 

2. 在左侧封装列表中，系统自动显示封装名称。 

3. 单击封装名称，右侧会显示封装图形。 

4. 单击“OK”。 
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图6-6 打开封装示图 

 

 

----结束 

6.2.1.3 保存封装（Save） 

本章节为您介绍如何从封装编辑器中保存封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Save”。 

步骤 3 在弹出窗口中，保存封装。 

1. 在 Footprint Name 后的输入框输入封装名称。 

2. 在 Database Name 后的下拉框选择存放的封装库。 

3. 单击“OK”。 
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图6-7 保存封装 

 

 

----结束 

6.2.1.4 另存封装（Save As） 

本章节为您介绍如何从封装编辑器中另存封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Save As...”。 

步骤 3 在弹出窗口中，另存封装。 

1. 在 Footprint name 后的输入框输入封装名称。 

2. 在 Database Name 后的下拉框选择存放的封装库。 

3. 单击“OK”。 

图6-8 另存封装 

 

 

----结束 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 473 

 

6.2.1.5 创建元件（Create Part） 

本章节为您介绍如何从封装编辑器中创建元件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Create Part...”。 

步骤 3 在弹出窗口中，创建元件。 

1. 在 Part Name 后的输入框输入 Part 名称。 

2. 在 Device Type 后的下拉框选择，可选择 IC、IO、DISCRETE。 

3. 单击 File path 后的 ，选择保存 part 的文件夹。 

4. 勾选 Save part to library，在 Local db name 后的下拉框选择存放 Part 的封装

库。 

5. 单击“OK”。 

图6-9 创建 Part 

 

 

 

保存路径不能有中文。 

----结束 
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6.2.1.6 导入（Import） 

6.2.1.6.1 导入结构图文件（DXF） 

本章节为您介绍如何导入结构图文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Import>DXF...”。 

步骤 3 在弹出的“Import  DXF”页面中，配置导入 DXF 参数。 

1. 单击 DXF file 输入框后的 ，选择需要导入的结构图文件（.dxf 文

件）。 

2. 在 Units 后的下拉框选择单位，可选择 MM 和 MILS。 

3. 勾选 DXF layer 前的方框，选择所有结构图层文件。 

4. 在 Class 后的下拉框选择放置文件的“Layout”配层。在 SubClass 后的下拉框

选择放置结构图的“MCAD_Detail”配层。单击“Map”更新放置文件的配层。 

图6-10 导入结构图 

 

 

步骤 4 参数配置完成后，单击“Import”。 
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步骤 5 结构图导入完成后，显示报告弹窗，查看报告后单击 关闭即可。导入的结构图可在

“MCAD_Detail”配层查看。 

 

MCAD_Detail 配层放置于 Selection 窗口的“Board Elements>Layout”。 

----结束 

6.2.1.6.2 导入 Pin 文件（Pinlist In） 

本章节为您介绍如何导入 Pin 文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Import>Pinlist In...”。 

步骤 3 在弹出窗口中，导入 Pin 文件。 

1. 单击 Pin File 后的 ，在弹出的页面中，选择需要导入的文件（.csv 文

件），单击“打开”。 

2. 在 Text block 后的输入框输入字体大小。 

3. 勾选 Delete existing pins 前的方框，删除已存在的 Pin。取消勾选，则不删除。 

4. 单击“Import”。 

图6-11 导入 Pin 文件 

 

 

----结束 
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6.2.1.7 导出（Export） 

6.2.1.7.1 导出结构图文件（DXF） 

本章节为您介绍如何导出结构图文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Export>DXF...”。 

步骤 3 在弹出的“Export DXF”页面中，配置导出参数。 

1. 在 DXF output file 后的输入框输入导出的文件名，一般默认为当前文件名（存放

路径和文件名称不能包含中文）。 

2. 在 Output Units 后的下拉框，选择单位“MM”或者“MILS”。 

3. 勾选全部的“Class”结构图层文件，单击“Map”更新“DXF layer”。 

图6-12 导出 DXF 文件 

 

 

步骤 4 配置完成后，单击“Export”导出文件。 
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步骤 5 单击“View Path”查看结构图文件的存放路径，查看导出的文件。 

----结束 

6.2.1.7.2 导出 Pin 文件（Pinlist Out） 

本章节为您介绍如何导出 Pin 文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Export>Pinlist Out...”。 

步骤 3 在弹出窗口中，导出 Pin 文件。 

1. 单击 Pin File 后的 ，在弹出的页面中，输入导出的文件名，一般默认

为当前文件名（存放路径和文件名称不能包含中文），单击“保存”。 

2. 勾选 Include pin text location 前的方框，导出时包括 Pin 文本位置。取消勾

选，则不包括。 

3. 单击“Export”。 

图6-13 导出 Pin 文件 

 

 

----结束 

6.2.1.8 宏命令（Scripting） 

本章节为您介绍如何录制一个宏命令。宏命令可以快速的将您制作过程中所有的操作

命令转换成文本，方便下次使用。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Scripting”。 

步骤 3 在弹出的“Scripting”页面中，单击 选择录制脚本保存路径（存放路径和

文件名称不能包含中文），单击“Record”开始录制。 

图6-14 开始录制 

 

 

步骤 4 录制完成后，在菜单栏选择“File>Scripting”。 

步骤 5 在弹出的“Scripting”页面中，单击“Stop”，即可停止录制。 

图6-15 结束录制 

 

 

步骤 6 打开录制脚本保存路径，查看录制脚本文件。录制后的脚本文件以 txt 格式保存。 
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图6-16 宏命令文件 

 

 

----结束 

6.2.1.9 退出（Exit） 

本章节为您介绍如何退出封装编辑器。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“File>Exit”。 

步骤 3 在弹出的“Question”页面中，选择是否保存当前封装。 
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图6-17 保存提示窗口 

 

 

步骤 4 选择完成后，在弹出的“Question”页面中，单击“OK”退出封装编辑器。 

 

----结束 

6.2.2 编辑菜单（Edit） 

6.2.2.1 编辑基础操作 

本章节为您介绍在 PCB-DESIGN 封装编辑器中编辑封装常用的快捷操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在封装编辑器页面编辑常用快捷操作说明如表 6-2 所示。 

表6-2 编辑常用快捷操作说明 

操作名称 操作步骤 

撤销

（Undo） 

在菜单栏单击“Edit>Undo”，可撤销最近在画布中对封装的改动

操作。 

重做 在菜单栏单击“Edit>Redo”，可回到撤销动作前的状态。 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 481 

 

操作名称 操作步骤 

（Redo） 

复制

（Copy） 

1. 在菜单栏单击“Edit>Copy”。 

2. 在画布中单选或者框选对象，自动复制所选对象，保存到剪切板

等待粘贴。 

粘贴

（Paste） 

与复制、剪切功能配合使用。 

1. 在画布中单选或者框选对象，复制或者剪切。 

2. 在菜单栏单击“Edit>Paste”，在画布中移动鼠标，左键单击确

定粘贴对象的位置，粘贴对象。 

选择

（Select） 

1. 在菜单栏单击“Edit>Select”。 

2. 在画布中移动鼠标单选或者框选确定的对象。 

移动

（Move） 

1. 在菜单栏单击“Edit>Move”。 

2. 在画布中单选或者框选对象，移动鼠标，左键单击确定移动对象

的位置。 

删除

（Delete） 

1. 在菜单栏单击“Edit>Delete”。 

2. 选中画布中要删除的对象，左键单击任意位置删除对象。 

旋转

（Rotate） 

1. 在菜单栏单击“Edit>Rotate”。 

2. 在编辑器右侧“Options”窗口，Angle 后的输入框输入旋转角

度。在画布中单选或者框选对象，移动鼠标旋转角度，左键单击

确定旋转对象的位置。 

修改文本

（Edit Text） 

1. 在菜单栏单击“Edit>Edit Text”。 

2. 在画布中选中要修改的文字对象，修改内容后鼠标左键单击画布

任意位置，鼠标右键单击 Done 保存。 

线段顶点

（Vertex） 

1. 在菜单栏单击“Edit>Vertex”。 

2. 在画布中选中需要修改的 Line 对象，移动鼠标选择顶点位置，单

击鼠标左键确定位置，鼠标右键单击 Done 保存。 

锁定

（Lock） 

1. 在菜单栏单击“Edit>Lock”。 

2. 在画布中选中要锁定的对象，鼠标右键单击 Done 保存。 

解锁

（Unlock） 

1. 在菜单栏单击“Edit>Unlock”。 

2. 在画布中选中要解锁的对象，鼠标右键单击 Done 保存。 
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----结束 

6.2.2.2 跨层复制（Z-copy） 

本章节为您介绍在 PCB-DESIGN 封装编辑器中如何进行跨层复制。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Edit>Z-copy”。 

步骤 3 在编辑器右侧“Options”窗口，配置拷贝参数，参数说明请参见表 6-3。 

图6-18 跨层拷贝参数配置 

 

 

表6-3 跨层拷贝参数说明表 

参数名称 说明 

Type 铜箔填充方式，可选择 Filled（填充）、

Default（默认）、Non-filled（不填

充）。 
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参数名称 说明 

Copy line as line 复制线段。 

Copy 复制类型，可选择 Voids(挖空)和

Netname(网络名)。 

Size 复制后对象大小，可选择 Contract(内缩)或

者 Expand(外延)。 

Offset 对象内缩和外延的值。 

 

步骤 4 选择复制到对应的层次，在画布中选择复制的对象，系统自动显示复制后的图形，鼠

标右键单击“Done”保存。 

----结束 

6.2.2.3 剪切线段（Group Cut Line） 

本章节为您介绍在 PCB-DESIGN 封装编辑器中如何剪切线段。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Edit>Group Cut Line”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数。 

1. 在 Cut Distance 后的输入框输入线段剪切长度。 

2. 勾选 Delete middle line 前的方框，删除剪切的中间线段。取消勾选，则不删

除。 
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图6-19 配置剪切线段参数 

 

 

步骤 4 在编辑器左侧“Find”窗口勾选操作对象。 

步骤 5 在画布中，框选需要剪切的区域，系统自动显示剪切后的线段。 

图6-20 剪切前示图 
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图6-21 剪切后示图 

 

 

----结束 

6.2.2.4 更改（Change） 

本章节为您介绍如何更改对象的层，走线线宽，文本粗细及排列。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Edit>Change”。 

步骤 3 在编辑器右侧“Options”窗口，配置对象移动的层，更改走线线宽，更改文本粗细

及排列。 

1. 勾选 Line Width，在输入框内输入线宽大小，单选或者框选对象，对象自动更改

线宽大小。 

2. 勾选 Text block 和 Text just，输入文本的粗细和选择原点的定位方式（Left、

Center、Right），单选或者框选对象，对象将自动更改文本粗细及排列。 

3. 选择对象移动的层次，勾选“Change Object Layer”，单选或者框选对象，对

象自动移到相应的层次。 
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图6-22 对象更改配置 

 

 

步骤 4 操作完成后，在画布中鼠标右键单击“Done”保存。 

----结束 

6.2.2.5 调整器件位号（Adjust Text Center） 

本章节为您介绍在 PCB-DESIGN 封装编辑器中如何将器件位号调整到器件中心。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Edit>Adjust Text Center”。 

步骤 3 在弹出的“Adjust Text Center”页面中，单击“Yes”。 
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图6-23 调整器件位号 

 

 

步骤 4 调整成功后，在弹出的提示弹窗中单击“OK”关闭即可。 

----结束 

6.2.2.6 Pin 对齐（Align Pin） 

本章节为您介绍在 PCB-DESIGN 封装编辑器中如何对齐 Pin。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Edit>Align Pin”。 

步骤 3 在画布中框选两个或多个要对齐的对象。 

步骤 4 在编辑器右侧“Options”窗口，配置对齐方式和设置间距大小。 

图6-24 对齐方式配置 
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⚫ 垂直居中对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 

图6-25 对齐前示图 

 

 

图6-26 对齐后示图 

 

 

⚫ 水平居中对齐 

a. 在 Align Type 框中单击对齐图标 。 

b. 在 Spacing 框中勾选 Equal，在 spacing 后的输入框中输入间距大小。 
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图6-27 对齐前示图 

 

 

图6-28 对齐后示图 

 

 

----结束 

6.2.3 显示菜单（Display） 

6.2.3.1 封装文件缩放基础操作 

本章节为您介绍在编辑器中对封装文件缩放的基础操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在 PCB-DESIGN 封装编辑器页面常用封装文件缩放操作说明如表 6-4 所示。 

表6-4 封装文件缩放常用快捷操作说明 

操作名称 操作步骤 

适应窗口（Zoom Fit） 菜单栏选择“Display > Zoom Fit”，
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操作名称 操作步骤 

或按快捷键 F2，画布中封装文件将以原

点为中心适应显示当前封装文件中的所

有对象。 

放大（Zoom In） 画布中封装文件将以鼠标为中心放大，

方便查看。封装文件放大，有如下两种

操作方式。 

⚫ 菜单栏选择“Display>Zoom In”，

或按快捷键 F11。 

⚫ 向前滑动鼠标滚轮。 

缩小（Zoom Out） 画布中封装文件将以鼠标为中心缩小。

封装文件缩小，有如下两种操作方式。 

⚫ 菜单栏选择“Display>Zoom 

Out”，或按快捷键 F12。 

⚫ 向后滑动鼠标滚轮。 

指定区域放大（Zoom Shape） 菜单栏选择“Display>Zoom 

Shape”，鼠标左键在画布中框出需要

放大的区域，松开鼠标左键，指定区域

将会被放大显示。 

 

----结束 

6.2.3.2 查询（Info） 

本章节为您介绍如何在编辑器中查看对象属性。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Display > Info”。 

步骤 3 在“Find”命令窗口选择对象类型，画布中单选或者框选对象，在弹出的“Show 

Info”页面中，显示全部对象的属性。 
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图6-29 Info 属性页面 

 

 

----结束 

6.2.3.3 测量（Measure） 

本章节为您介绍如何测量画布中两对象之间的间距和铜箔宽度大小。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Display > Measure”。 

步骤 3 在画布中单击测量的起点，然后单击测量的终点，在弹出的“Measure”页面中，显

示测量对象的间距数据。 
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图6-30 显示测量数据页面 

 

 

----结束 

6.2.3.4 高亮显示基础操作 

本章节为您介绍在编辑器中对象显示的基础操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在 PCB-DESIGN 封装编辑器单板文件常用显示操作说明如表 6-5 所示。 

表6-5 显示常用快捷操作说明 

操作名称 操作步骤 

高亮显示（Highlight） 菜单栏选择“Display>Highlight”，选择颜色类型，选

择形状类型，在画布中单选或者框选对象，自动高亮显

示。 
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操作名称 操作步骤 

取消高亮显示

（Dehighlight） 

菜单栏选择“Display>Dehighlight”，取消高亮显示

有如下两种操作方式。 

⚫ 单选或者框选高亮对象，取消高亮显示。 

⚫ 在编辑器右侧“Options”窗口，选择“Nets”取消

全部网络高亮显示。选择“Cells”取消全部器件高亮

显示。选择“Pins”取消全部 pin 高亮显示。选择

“All”取消全部对象高亮显示。 

 

----结束 

6.2.3.5 图层翻转显示（Flip Design） 

本章节为您介绍如何在编辑器中进行图层翻转显示操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在编辑器中图层翻转有三种方式。 

⚫ 支持菜单栏选择 

a. 在菜单栏选择“Display>Flip Design ”，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷键操作 

a. 给图层翻转设置快捷键，操作方法请参见 3.19.2 自定义配置临时快捷键。 

b. 执行快捷键命令后，画布中自动显示翻转后的图层。 

c. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷命令搜索 

a. 在命令窗口下方“Type command here”栏输入“flip design”，按回车

键，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

 

进入翻转状态后，右下角会有“Flip Design Mode”提示。 
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----结束 

6.2.3.6 格点（Grids） 

本章节为您介绍编辑器中如何进行格点设置。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Display > Grids...”。 

步骤 3 在弹出的“Define Grid”页面中，选择格点类型。单击 Type 下的格点类型前的圆

圈，可选择 Place（器件），Trace（走线），Via（过孔），Other（其他）。 

步骤 4 单击 新增格点。 

步骤 5 在弹出的“Add Grid”页面中，在 GridName 后的输入框填写格点名称，单击

“OK”。 

步骤 6 选择新增的格点，修改格点间距、格点偏移量，单击“OK”。 

图6-31 格点设置 
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步骤 7 在编辑器底部的格点栏选择新增的格点，单击格点的快捷图标 打开格点，再次单

击关闭格点。 

图6-32 显示新增格点 

 

 

----结束 

6.2.3.7 自定义工具栏（Customize Toolbar） 

本章节为您介绍如何自定义工具栏。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可增加或者删除一级菜单。 

⚫ 选择“Toolbar group”页签，在 Group Name 后的输入框输入菜单名称，单击

“Add”增加一级菜单。 

⚫ 选择“Toolbar group”页签，在左侧菜单列表中选择菜单，单击“Delete”删

除一级菜单。 
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图6-33 一级菜单工具栏设置 

 

 

步骤 4 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Shape、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 

3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 

6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 
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图6-34 设置工具栏快捷图标 

 

 

----结束 

6.2.4 绘制菜单（Drawing） 

6.2.4.1 非电气走线（Line） 

本章节为您介绍如何绘制非电气属性走线。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Line”。 

步骤 3 在编辑器右侧“Options”窗口，配置走线的类型、拐角方向角度和线宽。 

1. 走线类型：单击 Line lock 后的第一个下拉框选择，可选择 Line（直线）和 Arc

（弧线）两种类型。 

2. 拐角方向角度：单击 Line lock 后的第二个下拉框选择，可选择 45、90 和 any。 

3. 线宽：在 Line Width 后的输入框输入线宽。 
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图6-35 线段配置 

 

 

步骤 4 在画布中进入绘制走线状态。 

1. 左键单击确定走线起点。 

2. 移动鼠标，左键单击生成拐点。 

3. 再次左键单击确定走线终点，右键单击“Next”或者右键单击“Done”，完成

走线绘制。 

图6-36 绘制线段 

 

 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 499 

 

 

⚫ 右键单击“Next”完成当前走线绘制，不会退出绘制状态，可重新绘制新的走线。 

⚫ 右键单击“Done”完成走线绘制，保存并退出绘制状态。 

⚫ 当走线拐角角度设置为 90°时，根据鼠标位置自动生成拐点。 

⚫ 拐点固定后，移动鼠标，拐点前的走线不会再变化。 

⚫ 绘制走线过程中，右键单击“Oops”可退回落点。 

⚫ 绘制走线过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制走线过程中，右键单击“Toggle”可调整走线方向。 

⚫ 绘制走线过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.2 圆弧（Arc） 

本章节为您介绍如何绘制圆弧。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Arc”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆弧的线宽和拐角方向角度。 

1. 线宽：在 Line Width 后的输入框输入线宽。 

2. 拐角方向角度：单击 Lock angle 后的下拉框选择，可选择 0、45、90、135、

180、225、270、315。 

图6-37 圆弧配置 
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步骤 4 在画布中进入绘制圆弧状态。 

1. 左键单击确定圆弧中心点，在左键单击确定圆弧起点。 

2. 移动鼠标，左键单击确定圆弧终点，完成绘制。 

3. 圆弧绘制完成，将保持绘制圆弧状态，同时整个圆弧被选中。也可右键单击

“Done”完成圆弧绘制，保存并退出绘制状态。 

图6-38 绘制圆弧 

 

 

 

⚫ 右键单击“Done”完成圆弧绘制，保存并退出绘制状态。 

⚫ 绘制圆弧过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆弧过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆弧过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.3 圆线（Circle Line） 

本章节为您介绍如何绘制圆线。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Circle Line”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆的线宽和格点类型。 

1. 线宽：在 Line Width 后的输入框输入线宽。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

图6-39 圆线配置 

 

 

步骤 4 在画布中进入绘制圆线状态。 

1. 左键单击确定圆线中心点。 

2. 移动鼠标，左键单击确定圆线上任意一点，完成绘制。 

3. 圆线绘制完成，将保持绘制圆线状态，同时整个圆线被选中。也可右键单击

“Done”完成圆线绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图6-40 绘制圆线 

 

 

 

⚫ 右键单击“Done”完成圆线绘制，保存并退出绘制状态。 

⚫ 绘制圆线过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆线过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆线过程中，右键单击“Snap pick to”可选择特定位置落点。 

----结束 

6.2.4.4 圆形（Circle） 

本章节为您介绍如何绘制圆形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Circle ”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆形的铜箔填充类型和格点类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图6-41 圆形区域配置 

 

 

步骤 4 在画布中进入绘制圆形区域状态。 

1. 左键单击确定圆形区域中心点。 

2. 移动鼠标，左键单击确定圆形上任意一点，完成绘制。 

3. 圆形区域绘制完成，将保持绘制圆形状态，同时整个圆形被选中。也可右键单击

“Done”完成圆形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图6-42 绘制圆形区域 

 

 

 

⚫ 右键单击“Done”完成圆形区域绘制，保存并退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.5 扇形（Fan area） 

本章节为您介绍如何绘制扇形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Fan area ”。 

步骤 3 在编辑器右侧“Options”窗口，配置扇形的铜箔填充类型和拐角方向角度。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 
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2. 拐角方向角度：单击 Lock angle 后的下拉框选择，可选择 0、45、90、135、

180、225、270、315。 

图6-43 扇形区域配置 

 

 

步骤 4 在画布中进入绘制扇形区域状态。 

1. 左键单击确定扇形区域中心点，在左键单击确定扇形区域起点。 

2. 移动鼠标，左键单击确定扇形区域终点，完成绘制。 

3. 扇形区域绘制完成，将保持绘制扇形状态，同时整个扇形被选中。也可右键单击

“Done”完成扇形区域绘制，保存并退出绘制状态。 

图6-44 绘制扇形区域 
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⚫ 右键单击“Done”完成扇形区域绘制，保存并退出绘制状态。 

⚫ 绘制扇形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制扇形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制扇形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.6 矩形（Rectangle） 

本章节为您介绍如何绘制矩形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Rectangle”。 

步骤 3 在编辑器右侧“Options”窗口，配置矩形的铜箔填充类型、格点类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图6-45 矩形区域配置 

 

 

步骤 4 在画布中进入绘制矩形区域状态。 

1. 左键单击确定矩形区域左上角坐标位置。 

2. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成绘制。 

3. 矩形区域绘制完成，将保持绘制矩形状态，同时整个矩形被选中。也可右键单击

“Done”完成矩形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

a. 矩形长度：在 Width 后的输入框输入长度。 

b. 矩形宽度：在 Height 后的输入框输入宽度。 

c. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner、Round。 
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d. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入框输

入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的输入框输

入倒角大小。 

图6-46 绘制矩形区域 

 

 

 

⚫ 右键单击“Done”完成矩形区域绘制，保存并退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制矩形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.7 多边形（Polygon） 

本章节为您介绍如何绘制多边形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Polygon”。 

步骤 3 在编辑器右侧“Options”窗口，配置多边形的铜箔填充类型、格点类型和拐角线段

类型。 

1. 铜箔填充类型：根据所选的层次自动识别铜箔填充类型，不可手动修改。 
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2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

3. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 

图6-47 多边形区域配置 

 

 

步骤 4 在画布中进入绘制多边形区域状态。 

1. 左键单击确定多边形区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相连，

右键单击“Complete”，完成绘制。 

4. 多边形区域绘制完成，将保持绘制多边形状态，同时整个多边形被选中。也可右

键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 510 

 

图6-48 绘制多边形区域 

 

 

 

⚫ 右键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制多边形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制多边形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.4.8 新增文本（Add Text） 

本章节为您介绍如何新增文本。文本框增加文本便于封装符号进行注释。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Add Text”。 

步骤 3 在编辑器右侧“Options”窗口，选择是否镜像，配置文本放置位置、文本比例和旋

转方向。 

1. 镜像：勾选 Mirror 前的方框，显示镜像。取消勾选，不显示镜像。 

2. 文本放置位置：单击 Text just 后的下拉框选择，可选择 Left、Right、Center。 
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3. 文本比例：在 Text block 后的输入框输入比例。 

4. 旋转方向：单击 Rotate 后的下拉框选择，可选择 0、45、90、135、180、

225、270、315。 

图6-49 文本配置 

 

 

步骤 4 在画布中单击需要添加文本的位置，在文本框中输入文本，单击文本框外任意位置进

行保存或者按键盘“Enter”键保存。如 a789 所示。 

图6-50 添加文本 
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----结束 

6.2.4.9 修剪倒角（Trim） 

本章节为您介绍如何对铜箔进行修剪倒角。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Trim”。 

步骤 3 在编辑器右侧“Options”窗口，配置倒角的修剪方式和格点类型。 

1. 修剪方式：单击修剪方式前的圆圈，可选择 corner、round、polygon。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

图6-51 修剪倒角配置 

 

 

步骤 4 在画布中，根据修剪倒角方式类型，修剪倒角。 

⚫ 倒斜角 
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a. 单击 corner 前的圆圈，在 corner 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 

图6-52 倒斜角示图 

 

 

⚫ 倒圆角 

a. 单击 round 前的圆圈，在 round 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 
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图6-53 倒圆角示图 

 

 

⚫ 多边形修剪倒角 

a. 单击 polygon 前的圆圈，在 polygon 后的下拉框选择拐角线段类型，可选

择 Line、Line45、Line Orthogonal、Arc。 

b. 在画布中单击对象垂直线边沿。 

c. 移动鼠标，单击对象水平线边沿，剪切成功。 
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图6-54 多边形修剪倒角示图 

 

 

----结束 

6.2.4.10 复制粘贴（Create Detail） 

本章节为您介绍如何快速复制粘贴。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Create Detail”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数。 

1. 在 Scaling Factor 后的输入框输入放大倍数。 

2. 勾选 Filled pads 前的方框，填充焊盘；取消勾选，则不填充。 
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图6-55 配置参数 

 

 

步骤 4 在画布中框选对象，对象将按配置的放大倍数复制并悬挂在鼠标上。 

步骤 5 选择粘贴的图层，在画布中单击任意位置放置，对象自动显示在画布中。 

图6-56 复制粘贴示图 

 

 

----结束 

6.2.4.11 管脚（Pins） 

本章节为您介绍如何编辑管脚。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Pins”。 
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步骤 3 在编辑器右侧“Options”窗口，配置参数。 

1. 选择封装库：单击选项前的圆圈，可选择 Connect、Mechanical。 

2. 单击 PadStack 后的 ，在弹窗中选择焊盘，单击“OK”。 

3. 在 x 栏对应的 Qty（数量）下的输入框输入封装数量；Spacing（间距）下的输入

框输入距离；Order（顺序）下的下拉框选择，可选择 Left、Right。 

4. 在 y 栏对应的 Qty（数量）下的输入框输入封装数量；Spacing（间距）下的输

入框输入距离；Order（顺序）下的下拉框选择，可选择 Up、Down。 

5. 旋转角度：在 Rotation 后的下拉框选择，可选择 0、45、90、135、180、

225、270、315。 

6. 在 Pin #后的输入框输入位号，在 Inc 后的输入框输入位号递增数量。 

7. 在 Text block 后的输入框输入字号字体大小。 

8. 在 Offset x 轴输入框输入 x 轴偏移量坐标；y 轴输入框输入 y 轴偏移量坐标。 

图6-57 设置管脚参数 

 

 

步骤 4 单击画布中任意一点添加管脚。 

----结束 
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6.2.4.12 修改管脚数字（Pin Number Modify） 

本章节为您介绍如何修改管脚数字。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Pin Number Modify...”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数 

1. 在 Pin #后的输入框输入位号。 

2. 在 Inc 后的下拉框选择位号递增数量。 

图6-58 配置参数 

 

 

步骤 4 在画布中，单击位号，系统自动修改。 

----结束 

6.2.4.13 修改管脚数字位置及数字（Pins Number Modify） 

本章节为您介绍如何修改管脚数字位置及数字。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing>Pins Number Modify...”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数。 

1. 单击 Arrangement 下的选项前的圆圈，可选择 Counterclockwise、

Clockwise、Staggered 
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2. 单击 Start Position 下的选项前的圆圈，可选择 Left Down、Left Up、Right 

Down、Right Up。 

3. 在 Pin #后的输入框输入位号。 

4. 在 Inc 后的下拉框选择位号递增数量。 

图6-59 配置参数 

 

 

步骤 4 在画布中，框选位号，系统自动修改。 

----结束 

6.2.4.14 标注（Dimension） 

本章节为您介绍如何对标注层进行标注。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Drawing > Dimension”。 

步骤 3 在编辑器右侧“Options”窗口，配置标注参数。 
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1. 在图层下拉框选择 Dimension，单击图层前的方框显示画布中层次的对象。 

2. 操作模式：单击 Mode 下操作模式前的圆圈，选择 Add。 

3. 标注类型：单击 Type 后的下拉框选择，可选择 Linear dimension、Datum 

dimension、Angular dimension、Leader line、Diametral leader、Radial 

leader、Balloon leader、Chamfer leader。 

4. 文本比例：在 Text block 后的输入框输入比例。 

图6-60 标注配置 

 

 

步骤 4 根据选择标注的类型，在画布中进行标注操作。 

⚫ Linear dimension 标注类型：用以标注线性之间或者两点之间的距离。 

⚫ Datum dimension 标注类型：用以对一个参考点输入标注数据（高密度标注）。 

⚫ Angular dimension 标注类型：用以标注两线夹角。 

⚫ Leader line 标注类型：用以引出注解。 

⚫ Diametral leader 标注类型：用以标注圆弧直径。 

⚫ Radial leader 标注类型：用以标注圆弧半径。 

⚫ Balloon leader 标注类型：用以标注 Balloon。 

⚫ Chamfer leader 标注类型：用以标注 45°倒角尺寸。 

步骤 5 标注完成后，可在编辑器右侧“Options”窗口修改标注。 

1. 操作模式：单击 Mode 下操作模式前的圆圈，选择 Edit。 
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2. 修改类型：单击 Edit 下的下拉框选择，可选择 Align dimension（对齐标注）、

Move text（移动文本）、Mirror text（镜像文本）、Change text（修改文

本）、Change leader（修改指引线）、Delete vertex（删除顶点）。 

3. 文本内容：当修改类型为 Change text 时，可在 Text 后的输入框输入文本内

容。 

----结束 

6.2.5 铜箔编辑菜单（Shape） 

6.2.5.1 绘制铜箔（Create Area） 

本章节为您介绍如何绘制铜箔。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Create Area”。 

步骤 3 在编辑器右侧“Options”窗口，配置网络、格点类型、铜箔形状。 

1. 网络类型：单击 Assign net name 下的 ，在打开的窗口搜索网络名，

选择绘制的铜箔网络。系统默认选择 Dummy Net。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

3. 铜箔形状：单击 Shapes 下选项前的圆圈，可选择 Rectangle（矩形）、Circle

（圆形）、Polygon（多边形）。 
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图6-61 绘制铜箔设置 

 

 

步骤 4 在画布中进入绘制铜箔状态，绘制铜箔形状有三种方式。 

⚫ 矩形 

a. 左键单击确定矩形铜箔左上角坐标位置。 

b. 移动鼠标，左键单击确定矩形铜箔右下角坐标位置，完成绘制。 

c. 矩形铜箔绘制完成，将保持绘制矩形状态，同时整个矩形被选中。也可右键

单击“Done”完成矩形铜箔绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

i. 矩形长度：在 Width 后的输入框输入长度。 

ii. 矩形宽度：在 Height 后的输入框输入宽度。 

iii. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner、Round。 
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iv. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 

图6-62 绘制矩形铜箔 

 

 

⚫ 圆形 

a. 左键单击确定圆形铜箔中心点。 

b. 移动鼠标，左键单击确定圆形上任意一点，完成绘制。 

c. 圆形铜箔绘制完成，将保持绘制圆形状态，同时整个圆形被选中。也可右键

单击“Done”完成圆形铜箔绘制，保存并退出绘制状态。 

d. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图6-63 绘制圆形铜箔 

 

 

⚫ 多边形 

a. 左键单击确定多边形铜箔一个顶点位置。 

b. 移动鼠标，左键单击确定另一个顶点，以此类推。 

c. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连，右键单击“Complete”，完成绘制。 

d. 多边形铜箔绘制完成，将保持绘制多边形状态，同时整个多边形被选中。也

可右键单击“Done”完成多边形铜箔绘制，保存并退出绘制状态。 
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图6-64 绘制多边形铜箔 

 

 

 

⚫ 右键单击“Done”完成绘制，保存并退出绘制状态。 

⚫ 绘制过程中，右键单击“Oops”可退回落点。 

⚫ 绘制过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制过程中，右键单击“Complete”完成绘制，并保持绘制状态。 

⚫ 绘制过程中，右键单击“Toggle”调整多边形边方向。 

⚫ 绘制过程中，右键单击“Assign net”选择对象，给对象附网络。 

⚫ 绘制过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.5.2 挖空铜箔（Cutout/Cavity） 

6.2.5.2.1 创建铜箔挖空区域（Create Cutout） 

本章节为您介绍如何创建铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Create Cutout”。 

步骤 3 在编辑器右侧“Options”窗口，选择操作图层，配置格点类型、铜箔形状。 
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1. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

2. 铜箔形状：单击 Shapes 下选项前的圆圈，可选择 Rectangle（矩形）、Circle

（圆形）、Polygon（多边形）。 

图6-65 创建铜箔挖空 

 

 

步骤 4 在画布中进入铜箔挖空状态，铜箔挖空形状有三种方式。 

⚫ 矩形 

a. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

i. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner（倒斜角）、

Round（倒圆角）。 

ii. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 

b. 选择需要挖空的铜箔。 

c. 在铜箔上，左键单击确定矩形区域左上角坐标位置。 
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d. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成挖空。 

e. 矩形区域挖空完成，将保持挖空矩形状态。也可右键单击“Done”完成矩形

区域挖空，保存并退出挖空状态。 

图6-66 铜箔挖空矩形区域 

 

 

⚫ 圆形 

a. 选择需要挖空的铜箔。 

b. 在铜箔上，左键单击确定圆形区域中心点。 

c. 移动鼠标，左键单击确定圆形上任意一点，完成挖空。 

d. 圆形区域挖空完成，将保持挖空圆形状态。也可右键单击“Done”完成圆形

区域挖空，保存并退出挖空状态。 

图6-67 铜箔挖空圆形区域 

 

 

⚫ 多边形 

a. 选择需要挖空的铜箔。 
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b. 在铜箔上，左键单击确定多边形区域一个顶点位置。 

c. 移动鼠标，左键单击确定另一个顶点，以此类推。 

d. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连，右键单击“Complete”，完成挖空。 

e. 多边形区域挖空完成，将保持挖空多边形状态。也可右键单击“Done”完成

多边形区域挖空，保存并退出挖空状态。 

图6-68 铜箔挖空多边形区域 

 

 

 

⚫ 右键单击“Done”完成挖空，保存并退出挖空状态。 

⚫ 挖空过程中，右键单击“Oops”可退回落点。 

⚫ 挖空过程中，右键单击“Cancel”可退出挖空状态。 

⚫ 挖空过程中，右键单击“Next”可继续下一步挖空。 

⚫ 挖空过程中，右键单击“Complete”完成挖空，并保持挖空状态。 

⚫ 挖空过程中，右键单击“Toggle”调整多边形边方向。 

⚫ 挖空过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

6.2.5.2.2 静态铜箔避让（Element） 

本章节为您介绍如何操作静态铜箔避让。 

操作步 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 
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步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Element”。 

步骤 3 在画布中，选择需要避让的铜箔，再单选或者框选避让对象，画布中系统自动显示避

让后的铜箔。 

图6-69 静态铜箔避让示例 

 

 

步骤 4 右键单击“Done”保存并退出避让状态。 

----结束 

6.2.5.2.3 删除铜箔挖空区域（Delete） 

本章节为您介绍如何删除铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Delete”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要删除的挖空区域。 

步骤 4 单击画布中任意位置，删除挖空区域，保持挖空区域删除状态。 

步骤 5 右键单击“Done”完成删除挖空区域，保存并退出删除状态。 
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图6-70 删除挖空区域前 

 

 

图6-71 删除挖空区域后 

 

 

----结束 

6.2.5.2.4 移动铜箔挖空区域（Move） 

本章节为您介绍如何移动铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Move”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要移动的挖空区域。 

步骤 4 单击鼠标左键，移动鼠标到指定位置后再单击鼠标左键，移动挖空区域并保持挖空区

域移动状态。 

步骤 5 右键单击“Done”完成移动挖空区域，保存并退出移动状态。 
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图6-72 移动挖空铜箔前 

 

 

图6-73 移动挖空铜箔后 

 

 

----结束 

6.2.5.2.5 复制铜箔挖空区域（Copy） 

本章节为您介绍如何复制铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Copy”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要复制的挖空区域。 

步骤 4 单击鼠标左键，移动鼠标到指定位置后再单击鼠标左键粘贴挖空区域，复制挖空区域

并保持挖空区域复制状态。 

步骤 5 右键单击“Done”完成复制并粘贴挖空区域，保存并退出复制状态。 
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图6-74 复制挖空铜箔前 

 

 

图6-75 复制挖空铜箔后 

 

 

----结束 

6.2.5.3 剪切铜箔（Cut Shape） 

本章节为您介绍如何剪切铜箔。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Cut Shape”。 

步骤 3 在编辑器右侧“Options”窗口，选择操作图层，配置格点类型、铜箔剪切类型。 

1. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

2. 在 Cut Shape Type 下选择铜箔剪切类型，可选择 Rectangles、Free。 

选择 Free 需要在 Line Type 后的下拉框配置线条类型，可选择 line 45、line 

90、line off、arc 45、arc 90、arc off。 
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图6-76 配置参数 

 

 

步骤 4 根据剪切类型不同，画布中的操作方式也不同。 

⚫ Rectangles 

a. 在画布中框选需要剪切的铜箔。 

b. 系统自动显示剪切后的铜箔。 

⚫ Free 

a. 在画布中左键单击确定剪切线段的一个顶点位置。 

b. 移动鼠标，左键单击确定另一个顶点。 

c. 鼠标右键单击 Cut&Remove，系统自动显示剪切后的铜箔。 

----结束 

6.2.5.4 编辑铜箔（Select Shape or Void/Cavity） 

本章节为您介绍如何对铜箔进行编辑。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Select Shape or Void/Cavity”。 

步骤 3 在编辑器右侧“Options”窗口，选择操作图层。 

步骤 4 在画布中，选择需要编辑的铜箔进行编辑操作，具体操作及鼠标右键辅助编辑操作请

参见表 6-6。 
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表6-6 铜箔编辑操作说明 

操作名称 操作步骤 

移动顶点（Move 

vertex） 

选择顶点，按住鼠标左键不放移动到目标位置释放鼠

标。 

添加顶点（Add 

vertex） 

按住 ctrl 键，鼠标左键单击在铜箔边沿线进行加点。 

删除顶点（Delete 

vertex） 

选择顶点，右键单击“Delete vertex”删除。 

保存并退出编辑状态

（Done） 

右键单击“Done”保存并退出编辑状态。 

退回落点（Oops） 右键单击“Oops”可退回落点。 

退出编辑状态

（Cancel） 

右键单击“Cancel”可退出编辑状态。 

下一步（Next） 右键单击“Next”完成当前编辑，继续下一步编辑状

态。 

给对象附网络（Assign 

net） 

右键单击“Assign net”可选择对象，给对象附网络。 

铜箔动静转换（Change 

area type） 

右键单击“Change area type”可转换铜箔动静态。 

切割铜箔（ Edit cut） 右键单击“Edit cut”可切割铜箔。 

复制到其他层（Copy to 

layers） 

右键单击“Copy to layers”，在弹窗中选择复制对象

放置的层，可将铜箔复制到其他层。 

选择特定位置落点

（Snap Pick To） 

右键单击“Snap Pick To”可选择特定位置落点。 

 

步骤 5 在编辑器右侧“Options”窗口，铜箔转换和对象网络会随着画布中操作命令的执行

而发生改变。 
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图6-77 铜箔编辑配置界面 

 

 

----结束 

6.2.5.5 两个重叠铜箔合并操作（Shape Operator） 

本章节为您介绍如何进行两个重叠铜箔的合并操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Shape Operator”。 

步骤 3 在编辑器右侧“Options”窗口，配置铜箔的操作方式。 

⚫ And：铜箔合并后，保留铜箔重叠部分，并简化为一个铜箔图形。 

⚫ Or：铜箔合并后，两个铜箔都保留，并简化为一个铜箔图形。 

⚫ Andnot：铜箔合并后，保留第一块铜箔没有和第二块铜箔重叠的部分，并简化为

一个铜箔图形。 

⚫ Xor：铜箔合并后，只删除铜箔重叠部分，其余铜箔部分保留。 

图6-78 铜箔操作方式配置 
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步骤 4 在画布中，选择第一块铜箔，在选择第二块铜箔，显示合并后的铜箔。 

图6-79 铜箔合并操作 

 

 

 

两块铜箔必须有重叠部分，否则不能执行铜箔操作命令。 

----结束 

6.2.5.6 合并同网络铜箔（Merge Shape） 

本章节为您介绍如何合并两个同网络铜箔。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Merge Shape”。 

步骤 3 在画布中，选择需要合并的第一个铜箔，在选择第二个铜箔。 

步骤 4 画布中自动显示合并后的铜箔。 
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图6-80 合并后铜箔 

 

 

----结束 

6.2.5.7 线段闭合为封闭图形（Compose Shape） 

本章节为您介绍如何通过线段闭合为封闭的图形。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Compose Shape”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数，选择是否倒角，参数说明请参见表 6-7。 

图6-81 闭合图形操作配置 
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表6-7 线段闭合为封闭的图形参数说明 

参数名称 说明 

Delete shape after compose 勾选 Delete shape after compose 前的方

框，可删除闭合后多余图形。取消勾选，则不

删除。 

Use auto gap 勾选 Use auto gap 前的方框，可自动闭合缺

口。取消勾选，则不自动闭合。 

Round corners 勾选 Round corners 前的方框，可倒角，并在

Radius 后的输入框输入倒角角度。取消勾选，

则不倒角。 

 

步骤 4 在画布中，框选线段，右键单击“Done”保存并退出转换状态。 

图6-82 闭合封闭图形示例 

 

 

----结束 

6.2.5.8 打散封闭图形为线段（Decompose Shape） 

本章节为您介绍如何打散封闭图形为线段。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Shape>Decompose Shape”。 

步骤 3 在编辑器右侧“Options”窗口，选择是否删除打散后多余图形。 

勾选 Delete shape after decompose 前的方框，可删除打散后多余图形。取消勾

选，则不删除。 

图6-83 打散图形操作配置 

 

 

步骤 4 在画布中，框选封闭图形，右键单击“Done”保存并退出转换状态。 

图6-84 打散封闭图形示例 

 

 

----结束 
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6.2.6 生产配置菜单（Manufacture） 

6.2.6.1 倒角（Drafting） 

6.2.6.1.1 线性倒角（Chamfer） 

本章节为您介绍如何在画布中对线段进行线性倒角。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Manufacture>Drafting>Chamfer”。 

步骤 3 在编辑器右侧“Options”窗口，配置线段剪切长度和倒角角度。 

1. 线段剪切长度：在 First 后的输入框输入长度，在 Second 后的输入框输入 0。 

2. 倒角角度：单击 Chamfer angle 后的下拉框选择，可选择 0、30、45、60、

90、120、135、150。 

图6-85 线性倒角配置 

 

 

步骤 4 在画布中框选线段倒角位置。也可以先选择倒角位置的一根线，再选另一根线。 

步骤 5 在画布中自动显示线段倒角结果。 

----结束 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 541 

 

6.2.6.1.2 圆弧倒角（Fillet） 

本章节为您介绍如何在画布中对线段进行圆弧倒角。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Manufacture>Drafting>Fillet”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆弧半径。 

圆弧半径：在 Radius 后的输入框输入半径大小。 

图6-86 圆弧倒角配置 

 

 

步骤 4 在画布中框选线段倒角位置。也可以先选择倒角位置的一根线，再选另一根线。 

步骤 5 在画布中自动显示线段倒角结果。 

----结束 

6.2.7 工具菜单（Tools） 

6.2.7.1 用户自定义层（Define User Layer） 

本章节为您介绍如何添加和删除用户自定义层。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Define User Layer” 。 

步骤 3 在弹出的“Define User Layer”页面中，选择自定义层操作，单击“OK”保存。 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 542 

 

⚫ 添加自定义层 

a. 在弹出的“Define User Layer”页面中，单击 。 

i. 在弹出的“Add User Layer”弹窗中填写自定义层名称。 

ii. 单击“OK”保存层命名。 

b. 单击“OK”。 

图6-87 添加自定义层 

 

 

⚫ 删除自定义层 

a. 选择已添加的自定义层，单击图标 删除自定义层。 

b. 单击“OK”。 
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图6-88 删除自定义层 

 

 

----结束 

6.2.7.2 重置层颜色（Layer Color Reset） 

本章节为您介绍如何重置层颜色。Footprint Editor 的每一层有默认颜色，用户可通

过此功能重置每一层对应的颜色。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Layer Color Reset” 。 

步骤 3 在弹出的 Define Color 页面中，单击“OK”，系统自动重置层颜色。 
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图6-89 重置层颜色 

 

 

----结束 

6.2.7.3 修改/替换焊盘（Padstack） 

6.2.7.3.1 修改焊盘（Modify Design Padstack） 

5.2.7.3.1.1 修改同一类别焊盘 

本章节为您介绍如何修改同一类别的焊盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Design Padstack” 。 

步骤 3 在编辑器右侧“Options”窗口，选择需要修改的焊盘，单击“Edit”。 

1. 在 Name 后的输入框输入焊盘名称，搜索焊盘。 

2. 搜索完成后，在 Name 下方的搜索列表中，单击焊盘名称。 

3. 单击“Edit”，进入焊盘编辑器界面。 
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图6-90 修改同一类别焊盘参数配置 

 

 

步骤 4 在弹出焊盘编辑器弹窗中，配置焊盘参数。 

1. 单击 Connect Pad 列下的焊盘。 

2. 选择焊盘形状：在 Geometry 后的下拉框选择，可选择 Circle、Square、

Oblong、Rectangle、Rounded rectangle、Chamfered rectangle、 

N-sided polygon、Octagon、Donut。 

3. 根据不同的焊盘形状，配置参数。 

− Circle（圆形） 

i. 在 Geometry 后的下拉框选择 Circle。 

ii. 在 Diameter 后的输入框输入直径。 

− Square（方形） 

i. 在 Geometry 后的下拉框选择 Square。 

ii. 在 Width 后的输入框输入方形长度。 
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− Oblong（椭圆形） 

i. 在 Geometry 后的下拉框选择 Oblong。 

ii. 在 Width 后的输入框输入椭圆形 X 轴方向长度大小。 

iii. 在 Height 后的输入框输入椭圆形 Y 轴方向长度大小。 

− Rectangle（矩形） 

i. 在 Geometry 后的下拉框选择 Rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

− Rounded rectangle（倒圆角的矩形） 

i. 在 Geometry 后的下拉框选择 Rounded rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner radiu 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− Chamfered rectangle（倒斜角的矩形） 

i. 在 Geometry 后的下拉框选择 Chamfered rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner charr 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− N-sided polygon（多边形） 

i. 在 Geometry 后的下拉框选择 N-sided polygon。 

ii. 在 Diameter 后的输入框输入直径。 

iii. 在 sides 后的输入框输入多边形边数。边数只能是双数，不能输入单

数。 

− Octagon（八边形） 

i. 在 Geometry 后的下拉框选择 Octagon。 

ii. 在 Width 后的输入框输入长度。 

− Donut（空心圆） 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 547 

 

i. 在 Geometry 后的下拉框选择 Donut。 

ii. 在 Outer Diame 后的输入框输入外径。 

iii. 在 Inner Diamet 后的输入框输入内径。 

图6-91 配置焊盘参数示图 

 

 

步骤 5 修改完成后，选择“File>Update to Design”，单击“Yes”保存。 

或者选择“File>Update to Design and Exit”，单击“Yes”保存并退出。 

 

⚫ 焊盘需要偏移时，可在配置焊盘参数页面，Offset 后的输入框输入偏移量。 

⚫ 在编辑器右侧“Options”窗口，单击“Purge”，在弹窗中选择不需要使用的焊盘，单击

“OK”。在 Name 下方的搜索列表中会自动清除不使用的焊盘。 

⚫ 单击“Reset”，重置参数配置。 

----结束 
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5.2.7.3.1.2 修改单个焊盘 

本章节为您介绍如何修改单个焊盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Design Padstack” 。 

步骤 3 在编辑器右侧“Options”窗口，选择需要修改的焊盘，单击“Edit”。 

1. 在 Name 后的输入框输入焊盘名称，搜索焊盘。 

2. 搜索完成后，在 Name 下方的搜索列表中，单击焊盘名称。 

3. 勾选“instance”，在 New name 后的输入框会显示新的焊盘名称。 

4. 根据需求选择焊盘筛选条件，可选择 Cell（焊盘类型）、Pin（引脚数量）、

Refdes（位号）。 

− Cell：在 Cell 后的下拉框选择焊盘类型名称。 

− Pin：在 Pin 后的下拉框选择引脚数量。 

− Refdes：在 Refdes 后的下拉框选择位号标识。 

5. 单击“Edit”，进入焊盘编辑器界面。 
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图6-92 修改单个焊盘参数配置 

 

 

步骤 4 弹出焊盘编辑器弹窗中，配置焊盘参数。 

1. 单击 Connect Pad 列下的焊盘。 

2. 选择焊盘形状：在 Geometry 后的下拉框选择，可选择 Circle、Square、

Oblong、Rectangle、Rounded rectangle、Chamfered rectangle、 

N-sided polygon、Octagon、Donut。 

3. 根据不同的焊盘形状，配置参数。 

− Circle（圆形） 

i. 在 Geometry 后的下拉框选择 Circle。 

ii. 在 Diameter 后的输入框输入直径。 

− Square（方形） 

i. 在 Geometry 后的下拉框选择 Square。 

ii. 在 Width 后的输入框输入方形长度。 
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− Oblong（椭圆形） 

i. 在 Geometry 后的下拉框选择 Oblong。 

ii. 在 Width 后的输入框输入椭圆形 X 轴方向长度大小。 

iii. 在 Height 后的输入框输入椭圆形 Y 轴方向长度大小。 

− Rectangle（矩形） 

i. 在 Geometry 后的下拉框选择 Rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

− Rounded rectangle（倒圆角的矩形） 

i. 在 Geometry 后的下拉框选择 Rounded rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner radiu 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− Chamfered rectangle（倒斜角的矩形） 

i. 在 Geometry 后的下拉框选择 Chamfered rectangle。 

ii. 在 Width 后的输入框输入矩形长度。 

iii. 在 Height 后的输入框输入矩形宽度。 

iv. 在 Corner charr 后的输入框输入倒角大小。 

v. 勾选倒角，可选择 Upper left（左上角）、Upper right（右上角）、

Lower left（左下角）、Lower right（右下角）。 

− N-sided polygon（多边形） 

i. 在 Geometry 后的下拉框选择 N-sided polygon。 

ii. 在 Diameter 后的输入框输入直径。 

iii. 在 sides 后的输入框输入多边形边数。边数只能是双数，不能输入单

数。 

− Octagon（八边形） 

i. 在 Geometry 后的下拉框选择 Octagon。 

ii. 在 Width 后的输入框输入长度。 

− Donut（空心圆） 
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i. 在 Geometry 后的下拉框选择 Donut。 

ii. 在 Outer Diame 后的输入框输入外径。 

iii. 在 Inner Diamet 后的输入框输入内径。 

图6-93 配置焊盘参数示图 

 

 

步骤 5 修改完成后，选择“File>Update to Design”，单击“Yes”保存。 

或者选择“File>Update to Design and Exit”，单击“Yes”保存并退出。 

 

⚫ 勾选“instance”，会创建一个新的焊盘封装。在编辑完成后，单击“File>Save as...”，可

保存到本地封装库。如果没有本地封装库，会保存失败，需要先创建本地封装库。 

⚫ 焊盘需要偏移时，可在配置焊盘参数页面，Offset 后的输入框输入偏移量。 

⚫ 在编辑器右侧“Options”窗口，单击“Purge”，在弹窗中选择不需要使用的焊盘，单击

“OK”。在 Name 下方的搜索列表中会自动清除不使用的焊盘。 

⚫ 单击“Reset”，重置参数配置。 

----结束 
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6.2.7.3.2 修改焊盘封装（Modify Library Padstack） 

本章节为您介绍如何修改封装库中焊盘封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Padstack>Modify Library Padstack” 。 

步骤 3 在弹出的“Select Library Padstack”页面中，在页面左侧选择需要编辑的焊盘，单

击“OK”。 

图6-94 选择焊盘 

 

 

步骤 4 自动进入焊盘编辑器，可对孔盘进行编辑，也可对焊盘进行编辑。具体操作请参见 5.2 

编辑孔盘和焊盘。 

----结束 

6.2.7.3.3 替换（Replace） 

本章节为您介绍如何替换焊盘和孔盘。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Padstack>Replace” 。 

步骤 3 在编辑器右侧“Options”窗口，勾选替换孔盘选项，参数说明请参见表 6-8。 

图6-95 替换焊盘配置 

 

 

表6-8 替换焊盘参数说明 

参数名称 说明 

Single Via replace 

mode 

只替换当前选中 Via 的焊盘。需要选择时，勾选 Single 

Via replace mode 前的方框。 

Ignore MIRRORED 

property 

忽略镜像属性。需要选择时，勾选 Ignore MIRRORED 

property 前的方框。 
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参数名称 说明 

Replace Via manually 将一定范围内 Via 的焊盘批量替换。需要选择时，勾选

Replace Via manually 前的方框。 

Ignore FIXED 

property 

忽略有锁定属性的对象，有锁定状态对象也更新。需要选

择时，勾选 Ignore FIXED property 前的方框。 

 

步骤 4 焊盘替换有两种替换方式。 

⚫ 在画布中选择焊盘 

a. 在画布中，单击一个焊盘，再单击另一个替换的焊盘。 

b. 在编辑器右侧“Options”窗口，配置焊盘筛选条件，可选择 Symbol（焊盘

类型）、Pin（引脚数量）、RefDes（位号）、Net（网络），单击

“Replace”替换。 

◼ Symbol：在 Symbol 后的输入框输入焊盘类型名称。 

◼ Pin：在 Pin 后的输入框输入引脚数量。 

◼ RefDes：在 RefDes 后的输入框输入位号标识。 

◼ Net：在 Net 后的输入框输入网络名。 

⚫ 在 Options 窗口中选择焊盘 

a. 在编辑器右侧“Options”窗口，“Old”栏单击 选择被替换焊

盘。 

b. “New”栏单击 选择替换的焊盘。 

c. 在编辑器右侧“Options”窗口，配置焊盘筛选条件，可选择 Symbol（焊盘

类型）、Pin（引脚数量）、RefDes（位号）、Net（网络），单击

“Replace”替换。 

◼ Symbol：在 Symbol 后的输入框输入焊盘类型名称。 

◼ Pin：在 Pin 后的输入框输入引脚数量。 

◼ RefDes：在 RefDes 后的输入框输入位号标识。 

◼ Net：在 Net 后的输入框输入网络名。 
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图6-96 Options 窗口选择焊盘配置 

 

 

 

⚫ 焊盘筛选条件可通过单击画布中的对象自动识别和手动在输入框中输入两种方式设置，若设

置无效则会退回上个设置值。 

⚫ “*”号标识表示同一类别焊盘，如不需要筛选焊盘，则在输入框中保留“*”号标识，可替换

同一类别焊盘。 

⚫ 单击“Reset”，可重置替换配置，恢复到配置窗口初始界面。 

----结束 

6.2.7.3.4 刷新（Refresh） 

本章节为您介绍如何对替换后的焊盘进行刷新和查看刷新日志。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 
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步骤 2 在封装库管理菜单栏选择“Tools>Footprint Editor...”。 

步骤 3 在弹出的“Update”页面中，在页面左侧列表中勾选 All 前的方框，选择所有焊盘，

单击“Update”刷新。 

⚫ 单击 输入名称，查询焊盘。 

⚫ 单击 可以收缩焊盘列表。 

⚫ 单击 可以展开焊盘列表。 

图6-97 刷新焊盘 

 

 

步骤 4 在弹出的“Place Update”页面查看更新报告或者单击“Viewlog”查看。 
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图6-98 更新报告 

 

 

步骤 5 报告查看完成后，单击报告右上角的 关闭报告即可。 

 

⚫ 刷新功能只适用于刷新封装库中的焊盘。 

⚫ 在编辑器上修改的焊盘需保存到封装库，否则使用刷新功能，修改的焊盘会被刷新成封装库

中存在的焊盘。 

----结束 

6.2.7.4 编辑封装参数（Design Parameters） 

本章节为您介绍如何编辑封装参数。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Design Parameters...”。 

步骤 3 在弹出的“Design Parameters Editor”页面中，配置使用单位、图纸大小、画布大

小及基准点和显示模式。参数说明请参见表 6-9。 
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图6-99 编辑封装参数 

 

 

表6-9 编辑封装参数说明 

参数类型 参数名称 操作说明 

Design Size

（编辑参数） 

Mils（千分之一英

寸） 

单击 User units 后的下拉框选择。 

Millimeter（毫米） 单击 User units 后的下拉框选择。 

Microns(微米) Microns 微米，小数点后 1 位精度 

1mm=39.37mil=1000μm 

1mil=25.4 μm 

A4（A4 纸张大小） 单击 Size 后的下拉框选择。 

B5（B5 纸张大小） 单击 Size 后的下拉框选择。 

C3（C3 纸张大小） 单击 Size 后的下拉框选择。 

D（D 纸张大小） 单击 Size 后的下拉框选择。 
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参数类型 参数名称 操作说明 

Other（其他） 单击 Size 后的下拉框选择。 

Width（画布宽方

向） 

在 Width 后的输入框输入宽方向数值。 

Height（画布高方

向） 

在 Height 后的输入框输入高方向数值。 

Lower left（画布左

下角） 

在 Lower left 后的第一个输入框输入 X 轴

数值，第二个输入框输入 Y 轴数值。 

Origin（基准点） 在 Origin 后的第一个输入框输入 X 轴数

值，第二个输入框输入 Y 轴数值。 

Display 

modes 

（显示模式） 

Connect points（连

接点） 

在 Display modes 框内，勾选选项前的

方框。 

Filled pads（将 via

和 pin 由中空改为填

满） 

在 Display modes 框内，勾选选项前的

方框。 

Connect line 

endcaps（导线拐弯

处的平滑） 

在 Display modes 框内，勾选选项前的

方框。 

Thermal/Anti pads

（花盘/反焊盘） 

在 Display modes 框内，勾选选项前的

方框。 

Design origin（设计

基准点） 

在 Display modes 框内，勾选选项前的

方框。 

Plated holes（金属

化孔） 

在 Display modes 框内，勾选选项前的

方框。 

Non-plated holes

（非金属化孔） 

在 Display modes 框内，勾选选项前的

方框。 

Padless holes（无焊

盘孔） 

在 Display modes 框内，勾选选项前的

方框。 

Drill labels（钻孔 在 Display modes 框内，勾选选项前的
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参数类型 参数名称 操作说明 

表） 方框。 

Net name on traces

（显示走线网络名称） 

在 Display modes 框内，勾选选项前的

方框。 

Net name on areas

（显示铜箔网络名称） 

在 Display modes 框内，勾选选项前的

方框。 

Net name on pins

（显示 Pin 网络名称） 

在 Display modes 框内，勾选选项前的

方框。 

Pin number（显示

Pin 符号） 

在 Display modes 框内，勾选选项前的

方框。 

 

步骤 4 配置完成后，单击“OK”保存。 

----结束 

6.2.7.5 修改设置（Settings） 

本章节为您介绍如何修改设置。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Tools>Settings...”。 

步骤 3 在弹出的“Setting”页面中，对工程（Project）、工具（Tool）、显示

（Display）、颜色（Color）、铜箔（Area）等设置进行修改。参数说明请参见表 6-

10。 
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图6-100 参数设置界面 

 

 

表6-10 设置参数说明 

类型 参数名称 说明 

Project 

Setting 

（工程设

置） 

General 

（常规操作） 

Console 命令栏相同前缀命令关联设

置。 

Library Connection 

Management 

（封装库连接） 

封装库配置远端公共库、本地库，配置

好封装库后才能导入网表。 

Tool 

Setting 

（工具设

置） 

Design Parameter 

（参数设置） 

设置使用单位、画布尺寸、画布偏置坐

标、原点坐标、配置显示选项。 

Text 

（文本设置） 

设置字体放置位置、字体大小、字体规

格，设置 DRC 尺寸大小。 

Display 

（显示设

置） 

General 

（显示基本设

置） 

显示比例、格点自动跳转切换开关、鼠

标划过对象高亮/显示属性开关，高性能

模式开关等配置。 

Cursor 

（鼠标模式设

鼠标箭头，十字光标模式设置。 
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类型 参数名称 说明 

置） 

Highlight 

（高亮设置） 

高亮设置（已禁用）。 

Color 

（颜色设

置） 

Display 

（显示颜色设

置） 

高亮、格点、飞线、DRC、钻孔、走

线、孔表、背景等颜色设置。 

Shape 

（铜箔高亮设

置） 

铜箔高亮设置，包括整板

（Brightness）、焊盘（Global 

transparency）、铜箔（Shapes 

transparency）的高亮设置，以及静态

动态铜箔样式、对象过滤器大小设置

等。 

Area 

（铜箔设

置） 

General 

（铜箔填充基本

设置） 

铜箔填充设置（Defer performing 

fill），不勾选即填充，反之不填充。以

及填充类型（动/静态铜箔）选择。 

Manufa

cture 

（工具设

置） 

General 

（工具基本设

置） 

背钻最小起钻孔径，塞孔允许最小、最

大尺寸设置、最小叠层大小。 

Testpre

p 

（测试点

设置） 

General 

（测试点基本设

置） 

测试点放置面向及配层设置，测试点类

型选择。 

Padstack 

Selection 

（焊盘选择设

置） 

测试点焊盘类型添加设置。 

Constrai

nt 

（规则管

理器设

General 

（规则管理器基

本设置） 

过孔长度计算开关、pin Delay 检查

DRC 开关设置。 
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类型 参数名称 说明 

置） 

Interactive 

（叠孔是否一起操作开关） 

叠孔的拆分，勾选此项叠孔被一起移动

等操作，不勾选此项叠孔分开被移动等

操作。 

 

步骤 4 设置完成后，单击“Apply”应用。 

步骤 5 单击“OK”保存设置。 

----结束 

6.2.8 窗口菜单（Windows） 

本章节为您介绍如何打开、关闭、显示和隐藏窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在 PCB-DESIGN 封装编辑器页面各个窗口的打开和关闭窗口操作说明如表 6-11 所

示。 

图6-101 打开/关闭窗口入口 

 

 



PCB版图设计 

用户指南 6 PCB-DESIGN封装编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 564 

 

表6-11 窗口操作说明 

操作名称 操作步骤 

左侧对象查询窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Find”自动打开窗口，取消

勾选关闭窗口或者单击窗口右上角

的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口 ，显示隐藏的窗口。 

底部操作命令窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Console”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐

藏的窗口。 

底部信息窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Message”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏

的窗口。 

底部局部放大视图窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 
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操作名称 操作步骤 

2. 勾选“Detail”自动打开窗口，取

消勾选关闭窗口或者单击窗口右上

角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏

的窗口。 

右侧图层窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Layer”自动打开窗口，取

消勾选关闭窗口或者单击窗口右上

角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏的窗

口。 

右侧配层选择窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Selection”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏的窗

口。 

右侧配置窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Options”自动打开窗口，

取消勾选关闭窗口或者单击窗口右
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操作名称 操作步骤 

上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏的窗

口。 

顶部工具栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Toolbar”自动打开工具栏，

取消勾选关闭工具栏。 

底部状态栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Status bar”自动打开状态

栏，取消勾选关闭状态栏。 

重置窗口 1. 在菜单栏选择“Windows”。 

2. 勾选“Reset Default”重置所有隐藏

的窗口，恢复默认设置。 

 

 

在窗口关闭情况下，勾选窗口才能展示窗口。 

----结束 

6.2.9 帮助菜单（Help） 

6.2.9.1 查看软件版本信息（About） 

在封装编辑器工具中可在“About”菜单查看软件版本信息。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Help>About” 。 

步骤 3 在弹出的“About”页面，查看软件版本信息。 
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图6-102 About 页面 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

6.3 顶部工具栏 

6.3.1 工具栏打开与关闭 

本章节为您介绍如何在 PCB-DESIGN 封装编辑器中打开与关闭工具栏。工具栏提供了

设置及显示菜单栏对应的功能按钮，方便快捷操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Toolbar”自动打开工具栏，取消勾选关闭工具栏。 

----结束 

6.3.2 工具栏图标设置 

本章节为您介绍如何设置哪些图标显示在工具栏上。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Shape、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 

3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 

6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 

图6-103 设置工具栏快捷图标 
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步骤 4 鼠标左键长按并拖拽快捷图标前的 ，可以移动整排快捷图标的位置。 

图6-104 快捷图标示图 

 

 

----结束 

6.3.3 工具栏图标含义及功能 

文件菜单 

序号 图标 含义及功能 

1  新建封装 

2  打开封装 

3  保存封装 

4  另存封装 

5  结构图文件 

6  宏命令 

7  退出 

 

编辑菜单 

序号 图标 含义及功能 

1  撤销 

2  重做 

3  复制 

4  跨层复制 

5  粘贴 
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序号 图标 含义及功能 

6  选择 

7  移动 

8  删除 

9 
 

旋转 

10  修改文本 

11  线段顶点 

12  锁定 

13  解锁 

 

显示菜单 

序号 图标 含义及功能 

1  适应窗口 

2  放大 

3  缩小 

4  指定区域放大 

5  查询 

6  测量 

7 
 

高亮显示 

8  取消高亮显示 

9  格点 

10  自定义工具栏 
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绘制菜单 

序号 图标 含义及功能 

1  非电气走线 

2  圆弧 

3  圆线 

4  圆形 

5  扇形 

6  矩形 

7  多边形 

8  新增文本 

9  修剪倒角 

10  引脚 

11  标注 

 

铜箔编辑菜单 

序号 图标 含义及功能 

1  绘制铜箔 

2  挖空铜箔区域 

3  静态铜箔避让 

4  删除铜箔挖空区域 

5  移动铜箔挖空区域 

6  复制铜箔挖空区域 

7  铜箔编辑 

8  两个重叠铜箔合并操作 
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序号 图标 含义及功能 

9  合并同网络铜箔 

10  线段闭合为封闭图形 

11  打散封闭图形为线段 

12  删除孤立铜箔 

 

工具菜单 

序号 图标 含义及功能 

1  用户自定义层 

2  修改焊盘 

3  替换 

4  刷新 

5 
 

编辑参数 

6  设置 

 

6.4 左侧对象查询窗口 

6.4.1 对象查询窗口打开与关闭 

对象查询窗口也叫 Find 窗口，在窗口中可以查询画布中任何对象。本章节为您介绍如

何在 PCB-DESIGN 封装编辑器中打开与关闭对象查询窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 
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步骤 3 勾选“Find”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗口。 

----结束 

6.4.2 对象选择与查询 

6.4.2.1 对象选择 

本章节为您介绍如何在对象查询窗口中选择对象。 

选择对象 

⚫ 在执行操作命令前提条件下，在窗口中勾选对象前的方框，画布中可以单选或者

框选对象。在窗口中不勾选对象，画布中单选或者框选不了对象。 

⚫ 单击窗口的“On”全部打开对象，单击窗口的“Off”全部关闭对象。 

⚫ 画布中对象参数说明请参见表 6-12。 

表6-12 对象参数说明表 

参数名称 说明 

Lines 非电气属性走线 

Cells 器件封装 

Other segs 其他 seg 

Areas 闭合图形 

Pins 引脚 

Texts 文本 

DRC Marks DRC 显示 

 

6.4.2.2 对象查询 

本章节为您介绍如何在对象查询窗口中查询对象。 
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操作步骤 

步骤 1 在窗口中，单击“Find by Query”。 

步骤 2 在弹出的“Find by Query”页面中，在页面左侧选择查询对象类型，在页面右侧填写

查询信息，单击“OK”。 

步骤 3 查询完成后，画布中系统自动高亮显示查询对象。 

图6-105 直接查询对象 

 

 

----结束 

6.5 右侧图层窗口 

6.5.1 图层窗口打开与关闭 

图层窗口也叫 Layer 窗口，在窗口中可以选择绘制的层次。本章节为您介绍如何在

PCB-DESIGN 封装编辑器中打开与关闭图层窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Layer”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 
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----结束 

6.5.2 图层功能及说明 

图层功能 

⚫ 信号层：提供信号传输与通信。 

⚫ 地层：提供良好的接地引用。 

⚫ 电源层：提供电源供应。 

图层名称及说明 

PCB 板由多个图层叠加组成，具体图层名称及说明请参见表 6-13。 

表6-13 图层名称及说明 

图层名称 说明 

Top 板件顶层，即板件元件层。 

Art 内层信号层，一般会在 Art 后添加层次顺序（例如 Art02，数字

02 指第二层）。 

Gnd 内层地层，一般会在 Gnd 后添加层次顺序（例如 Gnd02，数字

02 指第二层）。 

Pwr 内层电源层，一般会在 Pwr 后添加层次顺序（例如 Pwr02，数字

02 指第二层）。 

Bottom 板件底层，即板件焊接层。 

 

信号层配层名称及说明 

信号层（Signals）配层名称及说明请参见表 6-14。 

表6-14 信号层配层名称及说明 

配层名称 说明 

Conductor 图层的走线 
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配层名称 说明 

Via 图层的过孔 

Pin 图层的 Pin 

Drc 图层的 Drc 检查 

 

6.5.3 图层基础操作 

本章节为您介绍如何打开图层、关闭图层、切换图层。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在编辑器的右侧图层窗口，打开/关闭图层及切换图层。图层基础操作如表 6-15 所

示。 

表6-15 图层基础操作 

操作方式 操作步骤 

打开/关闭全部图层 1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“All”列下的方框，打开全部图层。

取消勾选，关闭全部图层。 

⚫ 勾选 All Layer 对应“All”列下的方框，打开全部图

层。取消勾选，关闭全部图层。 

打开/关闭全部图层

Conductor 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Conductor”列下的方框，打开全

部图层 Conductor。取消勾选，关闭全部图层

Conductor。 

⚫ 勾选 All Layer 对应“Conductor”列下的方框，打开

全部图层 Conductor。取消勾选，关闭全部图层

Conductor。 
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操作方式 操作步骤 

打开/关闭全部图层

Via 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Via”列下的方框，打开全部图层

Via。取消勾选，关闭全部图层 Via。 

⚫ 勾选 All Layer 对应“Via”列下的方框，打开全部图层

Via。取消勾选，关闭全部图层 Via。 

打开/关闭全部图层

Pin 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Pin”列下的方框，打开全部图层

Pin。取消勾选，关闭全部图层 Pin。 

⚫ 勾选 All Layer 对应“Pin”列下的方框，打开全部图层

Pin。取消勾选，关闭全部图层 Pin。 

打开/关闭全部图层

Drc 

1. 勾选“Signals”前的方框。 

2. 有两种操作方式，如下 

⚫ 勾选 Signals 对应“Drc”列下的方框，打开全部图层

Drc。取消勾选，关闭全部图层 Drc。 

⚫ 勾选 All Layer 对应“Drc”列下的方框，打开全部图层

Drc。取消勾选，关闭全部图层 Drc。 

打开/关闭单层图层 1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 勾选图层对应的“All”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层

Conductor 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Conductor”列下的方框，打开单层图

层，取消勾选，关闭单层图层。 

打开/关闭单层图层

Via 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Via”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层 1. 勾选“Signals”前的方框。 
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操作方式 操作步骤 

Pin 2. 选择打开/关闭的图层。 

3. 单击图层对应的“Pin”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭单层图层

Drc 

1. 勾选“Signals”前的方框。 

2. 选择打开/关闭的图层。 

3. 单击图层对应的“Drc”列下的方框，打开单层图层，取消

勾选，关闭单层图层。 

打开/关闭 All 层的

Drc 

1. 勾选 All 对应“Drc”列下的方框，打开全部图层 Drc。取

消勾选，关闭全部图层 Drc。 

切换图层 1. 在“Layerset”栏选择打开的图层，画布中自动显示图层

信息。 

2. 在“Layerset”栏选择另一层图层，直接切换图层。 

 

 

单击图层方框前的色块，可以切换图层显示的颜色和图层铜箔显示的格式类型。 

----结束 

6.5.4 自定义显示图层 

本章节为您介绍如何自定义显示图层。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在“Selection”窗口中，单击“All Off”，关闭所有配层。 

步骤 3 在“Layer”窗口中，单击快捷图标 。 

步骤 4 在弹出的“Save”页面中，填写新定义的图层名称，单击“OK”。 
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图6-106 创建新定义图层 

 

 

步骤 5 在“Layer”窗口中，单击快捷图标 ，进入图层设置界面。 

步骤 6 在弹出“Layerset Edit”页面中，单击“+Add”，选择图层的配层类型，单击

“OK”。 

⚫ 选择图层，单击 ，图层往上排序。单击 ，图层往下排序。 

⚫ 选择图层，单击 ，删除图层。 

⚫ 单击 ，刷新图层。 

图6-107 自定义显示图层 

 

 

 

单击快捷图标 时，Layerset 不能存在任何图层，如果提示“Whether to overwrite the 

existing layerset”则是存在图层，直接关闭图层即可。 

----结束 
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6.6 右侧配层选择窗口 

6.6.1 配层选择窗口打开与关闭 

配层选择窗口也叫 Selection 窗口，Selection 窗口可以直观的看到配层的分类。在绘

制的过程中，方便切换不同的装配层。本章节为您介绍如何在 PCB-DESIGN 封装编辑

器中打开与关闭配层选择窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Selection”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭

窗口。 

----结束 

6.6.2 配层名称及说明 

前提条件 

已创建图层，才可在配层选择窗口查看配层信息。 

配层名称及说明 

配层选择窗口有四种配层类型，分别是层次整体可见性（Global visibility）、绘制层次

（Drawing Objects）、绘制区域（Drawing Area）、板件元件（Board Elements）。 

具体配层名称及含义请参见表 6-16。 

表6-16 配层名称说明表 

窗口配层类型 配层名称 说明 

配层整体可见性

（Global 

visibility） 

全部配层 ⚫ All On：打开板件全部配层 

⚫ All Off：关闭板件全部配层 

⚫ Setting：进入设置界面 
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窗口配层类型 配层名称 说明 

绘制配层

（Drawing 

Objects） 

Conductor 图层的走线 

Pin 图层的 Pin 

Via 图层的过孔 

Drc 走线层 DRC 

Planning 布线规划 Boundle 

绘制区域

（Drawing Area） 

Placement Area 器件放置区 

Room Area 器件分类区 

Route Area 走线区域 

Rule Area 规则区域 

Inhibit Place 器件禁布区 

Inhibit Route 走线禁布区 

Inhibit Via 过孔禁布区 

Inhibit Probe 测试点禁布 

Boundary 动态铜箔外框 

Split 平面层分割线 

板件元件（Board 

Elements） 

Layout Assembly_T

op 

元面装配层 

Assembly_

Bottom 

焊面装配层 

Silkscreen_

Top 

元面丝印层 

Silkscreen_

Bottom 

焊面丝印层 

Resist_Top 元面阻焊层 

Resist_Bott 焊面阻焊层 
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窗口配层类型 配层名称 说明 

om 

Stencil_Top 元面钢网层 

Stencil_Bot

tom 

焊面钢网层 

Layout_Out

line 

Layout 层单板外框 

Panel_Outli

ne 

单板外框 

Dimension 标注层 

MCAD_Det

ail 

DXF 结构图导入层 

MCAD_Not

es 

DXF 结构图导入另一层（背面层） 

FPC_Coverl

ay_Top 

元面柔板保护膜层 

FPC_Coverl

ay_Bottom 

焊面柔板保护膜层 

FPC_Route_

Outline 

柔板布线区 

FPC_Bend_

Line 

柔板弯折线 

FPC_Bend_

Outline 

柔板弯折线外框 

FPC_Outlin

e 

柔板外框 

FPC_Stiffen

er_Top 

元面柔板补强材料层 

FPC_Stiffen 焊面柔板补强材料层 
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窗口配层类型 配层名称 说明 

er_Bottom 

FPC_Shield

_Top 

元面柔板保护膜层 

FPC_Shield

_Bottom 

焊面柔板保护膜层 

Cell Assembly_T

op 

元面装配层 

Assembly_

Bottom 

焊面装配层 

Silkscreen_

Top 

元面丝印层 

Silkscreen_

Bottom 

焊面丝印层 

Resist_Top 元面阻焊层 

Resist_Bott

om 

焊面阻焊层 

Stencil_Top 元面钢网层 

Stencil_Bot

tom 

焊面钢网层 

Origin 中心/基准点 

Placement_

Top 

器件本体层 

Placement_

Bottom 

器件本体层 

Dimension 标注层 

Placement_

Embedded 

埋嵌器件本体层 
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窗口配层类型 配层名称 说明 

Assembly_E

mbedded 

埋嵌器件装配层 

Resist_Emb

edded 

埋嵌器件阻焊层 

Stencil_Em

bedded 

埋嵌器件钢网层 

Slot_Embe

dded 

埋嵌器件开槽层 

Part 

RefDes 

Assembly_T

op 

元面器件装配层位号文字 

Assembly_

Bottom 

焊面器件装配层位号文字 

Assembly_E

mbedded 

器件装配层位号文字 

Silkscreen_

Top 

元面器件丝印层位号文字 

Silkscreen_

Bottom 

焊面器件丝印层位号文字 

Slot TOP 顶层 

Gnd02 内层地层，数字 02 指第二层 

Art03 内层信号层，数字 03 指第三层 

Pwr04 内层电源层，数字 04 指第四层 

Bottom 底层 

Manuf

acturin

g 

Smart_Drill Smart_Drill 层，尺寸标注及特殊文

字标识 

FilledArea_

Both 

元焊面填充区 
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窗口配层类型 配层名称 说明 

FilledArea_

Bottom 

焊面填充区 

FilledArea_

Top 

元面填充区 

BackDrill_In

sulation_To

p 

元面背钻绝缘 

BackDrill_In

sulation_Bo

ttom 

焊面背钻绝缘 

Drill_Chart 钻孔表格（动态添加）。

Drill_Chart-M-N（任意 10 层，生

成 10 个此文件，10 个文件名称 M-

N 有所不同） 

Drill_Figure 钻孔标识 

Dimension 标注层 

AutoSilk_T

op 

元面自动丝印层 

AutoSilk_B

ottom 

焊面自动丝印层 

Probe_Mar

k_Top 

元面测试点添加层 

Probe_Mar

k_Bottom 

焊面测试点添加层 

Gerber_Out

line 

光绘输出外框 

Surface_Fin

ish 

表面处理 
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窗口配层类型 配层名称 说明 

Annotation 批注 

User 用户自定义层 

 

6.6.3 打开/关闭配层 

本章节为您介绍如何在打开/关闭配层。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在编辑器的右侧配层选择窗口，有两种方式打开/关闭配层。具体操作如表 6-17 所

示。 

表6-17 打开/关闭配层操作指示 

操作方式 操作步骤 

打开/关闭全部配层 选择配层类型，单击“On”，打开全部

配层。单击“Off”，关闭全部配层。 

打开/关闭单层配层 ⚫ 选择一层配层，勾选“Off”列下的方

框，打开单层配层。取消勾选，关闭

单层配层。 

⚫ 打开配层时，“On”列下的方框会显

示颜色，单击方框，可以切换颜色和

格式类型。 

打开/关闭 All 层 All 层是所有层次元素的结合层，打开/

关闭 All 层操作方式如下： 

⚫ 选择 All 层，勾选“Off”列下的方

框，打开单层配层。取消勾选，关闭

单层配层。 

⚫ 打开配层时，“On”列下的方框会显

示颜色，单击方框，可以切换颜色和

格式类型。 
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----结束 

6.7 右侧配置窗口 

6.7.1 配置窗口打开与关闭 

配置窗口也叫 Options 窗口，在绘制的过程中，在 Options 窗口可以给画布中的对象

操作进行配置。本章节为您介绍如何在 PCB-DESIGN 封装编辑器中打开与关闭配置窗

口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Options”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

6.7.2 配置窗口参数配置 

本章节为您介绍如何在配置窗口中为执行的菜单命令配置参数。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 当配置窗口处于显示状态时，执行菜单命令，右侧配置窗口会显示命令的配置信息。 

步骤 3 在右侧“Options”窗口中，根据需求配置命令的参数。 

步骤 4 在画布中执行操作命令。 

----结束 

 

⚫ 编辑菜单的配置操作请参见 6.2.2 编辑菜单（Edit）。 
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⚫ 显示菜单的配置操作请参见 6.2.3 显示菜单（Display）。 

⚫ 绘制菜单的配置操作请参见 6.2.4 绘制菜单（Drawing）。 

⚫ 铜箔编辑菜单的配置操作请参见 6.2.5 铜箔编辑菜单（Shape）。 

⚫ 工具菜单的配置操作请参见 6.2.7 工具菜单（Tools）。 

6.8 底部操作命令窗口 

6.8.1 操作命令窗口打开与关闭 

操作命令窗口也叫 Console 窗口，可直接在窗口里输入命令，画布中的对象将直接执

行操作，使绘制操作更加便捷。本章节为您介绍如何在 PCB-DESIGN 封装编辑器中打

开与关闭操作命令窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Console”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

6.8.2 操作命令窗口指示 

本章节为您介绍如何在操作命令窗口中输入指示命令。 

界面指示 

⚫ 在画布中，滚动鼠标滚轮，窗口界面会显示画布的比例大小。 

⚫ 在画布中，操作命令执行，窗口界面会显示具体操作步骤。 

⚫ 在窗口里输入命令，画布中的对象将直接执行操作。 

⚫ 支持快捷命令搜索，在窗口下方“Type command here”栏输入快捷键首字

母，显示所有有关首字母的快捷命令。 
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常用操作 

在窗口命令输入框内输入操作命令，画布中对象立即执行操作命令。操作方法请参见

表 6-18。 

表6-18 命令窗口的常用操作指示 

操作名称 操作步骤 

命令窗口输入移动坐标 1. 在画布中，选择需要移动的对象。 

2. 在“Console”的命令窗口，输入坐

标，字母不区分大小写。 

⚫ 只移动 X 轴坐标：在命令输入框中

输入“X+空格键+X 轴移动坐标

值”并按回车键。 

⚫ 只移动 Y 轴坐标：在命令输入框中

输入“Y+空格键+Y 轴移动坐标

值”并按回车键。 

⚫ 只移动 X 和 Y 轴坐标：在命令输

入框中输入“X+空格键+X 轴移动

坐标值+空格键+Y+空格键+Y 轴

移动坐标值”并按回车键。 

命令窗口输入快捷键 “Console”的命令窗口，支持 alias 和

funckey 命令两种方式设置临时快捷

键。 

⚫ funckey 命令设置方法：在

“Console”命令窗口，在命令输入框

中输入“funckey+快捷键按键字母+

操作命令”并按回车键。设置快捷键

完成后，键盘输入快捷键字母。 

⚫ alias 命令设置方法：在“Console”

命令窗口，在命令输入框中输入

“alias+快捷键按键字母+操作命令”

并按回车键。设置快捷键完成后，键

盘输入快捷键字母。 
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6.9 底部信息窗口 

6.9.1 信息窗口打开与关闭 

信息窗口也叫 Message 窗口，可直接在窗口里查看信息。本章节为您介绍如何在

PCB-DESIGN 封装编辑器中打开与关闭信息窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Message”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

6.9.2 信息窗口说明 

功能说明 

PCB-DESIGN 封装编辑器汇总信息会显示在窗口中，可在窗口查看提示的信息。 

6.10 底部局部放大视图窗口 

6.10.1 局部放大视图窗口打开与关闭 

局部放大视图窗口也叫 Detail 窗口，在窗口中可以放大在画布中的局部视图，便于在

绘制过程中查看具体位置的视图。本章节为您介绍如何在 PCB-DESIGN 封装编辑器中

打开与关闭放大局部视图窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 
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步骤 3 勾选“Detail”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

6.10.2 局部放大视图 

本章节为您介绍如何在局部放大视图窗口中放大视图。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 左键单击画布中任意位置，窗口显示鼠标所在位置的局部放大视图。 

图6-108 局部放大视图示例图 

 

 

----结束 
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6.11 底部状态栏 

6.11.1 状态栏打开与关闭 

本章节为您介绍如何在 PCB-DESIGN 封装编辑器中打开与关闭状态栏。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Footprint Editor”打开 PCB 封装编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Status bar”自动打开状态栏，取消勾选“Status bar”自动关闭状态栏。 

----结束 

6.11.2 状态栏功能说明 

在 PCB-DESIGN 封装编辑器中状态栏显示坐标、格点及配置对应的功能按钮，方便快

捷操作。功能说明请参见表 6-19。 

表6-19 状态栏功能说明 

状态栏功能类型 功能说明 

显示画布中鼠标坐标 在画布中，单击任意一点，状态栏自动显示 X 轴坐

标和 Y 轴坐标。 

显示格点选择和配置 ⚫ 在栅格快捷图标前的栅格类型框

，可以选择设置好的

栅格格式类型。 

⚫ 单击栅格快捷图标 ，显示格点。再次单击，

不显示格点。 

⚫ 单击“Get”快捷打开“Find”窗口的 Pin。 

⚫ 单击“Offset”快捷设置偏移量。 

打开/关闭右侧窗口 
⚫ 单击快捷图标 ，打开层次窗口。再次单击快

捷图标 ，关闭层次窗口。 
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状态栏功能类型 功能说明 

⚫ 单击快捷图标 ，打开配层选择窗口。再次单

击快捷图标 ，关闭配层选择窗口。 

⚫ 单击快捷图标 ，打开配置窗口。再次单击快

捷图标 ，关闭配置窗口。 
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7 PCB-DESIGN 形状编辑器 

7.1  编辑器界面介绍 

7.2  菜单栏 

7.3  顶部工具栏 

7.4  右侧配置窗口 

7.5  底部操作命令窗口 

7.6  底部信息窗口 

7.7  底部状态栏 

7.1 编辑器界面介绍 

PCB-DESIGN 形状编辑器界面由菜单栏、工具栏、画布、配置窗口、操作命令窗口、

信息窗口、状态栏组成，如图 7-1 所示。 

编辑器各个部分的相关操作请参见表 7-1。 
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图7-1 编辑器界面 

 

 

表7-1 编辑器界面操作 

编辑器界面 使用方法 

菜单栏 菜单栏提供了编辑器常用的功能，关于菜单栏的具体操作请

参见 7.2 菜单栏。 

工具栏 工具栏提供了设置及显示菜单栏对应的功能按钮，方便快捷

操作，关于工具栏的具体操作请参见 7.3 顶部工具栏。 

画布 编辑器中，画布用于查看和绘制焊盘等操作。 

配置窗口 配置窗口提供了操作命令的所有配置功能，关于配置窗口的

具体操作请参见 7.4 右侧配置窗口。 

操作命令窗口 操作命令窗口提供输入命令操作，画布中的对象将直接执行

操作，关于操作命令窗口的具体操作请参见 7.5 底部操作命

令窗口。 

信息窗口 信息窗口提供了快速查看编辑器信息的功能，关于信息窗口

的具体操作请参见 7.6 底部信息窗口。 

状态栏 状态栏提供了编辑器中显示坐标、格点及配置功能按钮，方

便快捷操作，关于状态栏的具体操作请参见 7.7 底部状态

栏。 
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7.2 菜单栏 

7.2.1 文件菜单（File） 

7.2.1.1 新建焊盘封装（New） 

本章节为您介绍如何从形状编辑器中新建焊盘封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏中选择“File>New...”。 

步骤 3 在弹出提示窗口中，选择是否保存当前焊盘封装。 

⚫ 保存 

a. 单击“Yes”。 

b. 在弹窗中 Shape Name 后的输入框输入焊盘封装名称。 

c. 在 Database Name 后的下拉框选择存放的封装库。 

d. 单击“OK”。 

图7-2 保存当前焊盘封装 

 

 

⚫ 不保存 

单击“Cancel”。 

步骤 4 在弹出的“New”页面中，新建焊盘封装。 

1. 在 Shape Name 后的输入框输入新的焊盘封装名称。 

2. 在 Database Name 后的下拉框选择存放的封装库。 
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3. 单击“OK”。 

图7-3 新建焊盘封装 

 

 

步骤 5 新建完成后，系统自动打开焊盘封装。 

图7-4 打开封装示图 

 

 

 

⚫ 新建的焊盘封装编辑完成后需先保存到封装库中，才能在封装库打开。 

⚫ 保存路径不能有中文。 

----结束 

7.2.1.2 打开焊盘封装（Open） 

本章节为您介绍如何从形状编辑器中打开焊盘封装。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏中选择“File>Open...”。 

步骤 3 在弹出提示窗口中，选择是否保存当前焊盘封装。 

⚫ 保存 

a. 单击“Yes”。 

b. 在弹窗中 Shape Name 后的输入框输入焊盘封装名称。 

c. 在 Database Name 后的下拉框选择存放的封装库。 

d. 单击“OK”。 

图7-5 保存当前焊盘封装 

 

 

⚫ 不保存 

单击“No”。 

步骤 4 在弹出的“Open”页面中，打开焊盘封装。 

1. 单击封装库，在页面左上角 Pads 后的输入框输入焊盘封装名称，键盘按

“Enter”回车键。 

2. 在左侧封装列表中，系统自动显示封装名称。 

3. 单击封装名称，右侧会显示封装图形。 

4. 勾选 Show Rule Graph 前的方框，显示规则图形。 

5. 单击“OK”。 
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图7-6 打开封装示图 

 

 

----结束 

7.2.1.3 保存焊盘封装（Save） 

本章节为您介绍如何从形状编辑器中保存焊盘封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏中选择“File>Save”。 

步骤 3 在弹出窗口中，保存焊盘封装。 

1. 在 Shape Name 后的输入框输入封装名称。 

2. 在 Database Name 后的下拉框选择存放的封装库。 

3. 单击“OK”。 
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图7-7 保存焊盘封装 

 

 

----结束 

7.2.1.4 另存焊盘封装（Save As） 

本章节为您介绍如何从形状编辑器中另存焊盘封装。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏中选择“File>Save As...”。 

步骤 3 在弹出窗口中，另存焊盘封装。 

1. 在 Shape Name 后的输入框输入焊盘封装名称。 

2. 在 Database Name 后的下拉框选择存放的封装库。 

3. 单击“OK”。 

图7-8 另存焊盘封装 

 

 

----结束 
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7.2.1.5 导入结构图文件（Import DXF） 

本章节为您介绍如何导入结构图文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Import>DXF...”。 

步骤 3 在弹出的“Import  DXF”页面中，配置导入 DXF 参数。 

1. 单击 DXF file 输入框后的 ，选择需要导入的结构图文件（.dxf 文

件）。 

2. 在 Units 后的下拉框选择单位，可选择 MM 和 MILS。 

3. 勾选 DXF layer 前的方框，选择所有结构图层文件。 

4. 单击“Map”更新放置文件的配层。 

图7-9 导入结构图 

 

 

步骤 4 参数配置完成后，单击“Import”。 

步骤 5 结构图导入完成后，显示报告弹窗，查看报告后单击 关闭即可。 

----结束 
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7.2.1.6 导出结构图文件（Export DXF） 

本章节为您介绍如何导出结构图文件。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Export>DXF...”。 

步骤 3 在弹出的“Export DXF”页面中，配置导出参数。 

1. 在 DXF output file 后的输入框输入导出的文件名，一般默认为当前文件名（存放

路径和文件名称不能包含中文）。 

2. 在 Output Units 后的下拉框，选择单位“MM”或者“MILS”。 

3. 勾选全部的“Class”结构图层文件，单击“Map”更新“DXF layer”。 

图7-10 导出 DXF 文件 

 

 

步骤 4 配置完成后，单击“Export”导出文件。 

步骤 5 单击“View Path”查看结构图文件的存放路径，查看导出的文件。 
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----结束 

7.2.1.7 宏命令（Scripting） 

本章节为您介绍如何录制一个宏命令。宏命令可以快速的将您制作过程中所有的操作

命令转换成文本，方便下次使用。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Scripting”。 

步骤 3 在弹出的“Scripting”页面中，单击 选择录制脚本保存路径（存放路径和

文件名称不能包含中文），单击“Record”开始录制。 

图7-11 开始录制 

 

 

步骤 4 录制完成后，在菜单栏选择“File>Scripting”。 

步骤 5 在弹出的“Scripting”页面中，单击“Stop”，即可停止录制。 

图7-12 结束录制 
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步骤 6 打开录制脚本保存路径，查看录制脚本文件。录制后的脚本文件以 txt 格式保存。 

图7-13 宏命令文件 

 

 

----结束 

7.2.1.8 退出（Exit） 

本章节为您介绍如何退出形状编辑器工具。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“File>Exit”。 

步骤 3 在弹出的“Question”页面中，选择是否保存当前焊盘封装。 
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图7-14 保存提示窗口 

 

 

步骤 4 选择完成后，在弹出的“Question”页面中，单击“OK”退出形状编辑器。 

图7-15 退出提示窗口 

 

 

----结束 

7.2.2 编辑菜单（Edit） 

7.2.2.1 编辑基础操作 

本章节为您介绍在 PCB-DESIGN 形状编辑器中编辑焊盘和铜箔常用的快捷操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB-DESIGN 形状编辑器页面编辑常用快捷操作说明如表 7-2 所示。 
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表7-2 编辑常用快捷操作说明 

操作名称 操作步骤 

撤销

（Undo） 

在菜单栏单击“Edit>Undo”，可撤销最近在画布中对封装的改动操

作。 

重做

（Redo） 

在菜单栏单击“Edit>Redo”，可回到撤销动作前的状态。 

复制

（Copy） 

1. 在菜单栏单击“Edit>Copy”。 

2. 在画布中单选或者框选对象，自动复制所选对象，保存到剪切板等

待粘贴。 

粘贴

（Paste） 

与复制、剪切功能配合使用。 

1. 在画布中单选或者框选对象，复制或者剪切。 

2. 在菜单栏单击“Edit>Paste”，在画布中移动鼠标，左键单击确

定粘贴对象的位置，粘贴对象。 

移动

（Move） 

1. 在菜单栏单击“Edit>Move”。 

2. 在画布中单选或者框选对象，移动鼠标，左键单击确定移动对象的

位置。 

删除

（Delete） 

1. 在菜单栏单击“Edit>Delete”。 

2. 选中画布中要删除的对象，左键单击任意位置删除对象。 

旋转

（Rotate） 

1. 在菜单栏单击“Edit>Rotate”。 

2. 在编辑器右侧“Options”窗口，Angle 后的输入框输入旋转角

度。在画布中单选或者框选对象，移动鼠标旋转角度，左键单击确

定旋转对象的位置。 

 

----结束 

7.2.2.2 铜箔复制（Z-copy） 

本章节为您介绍在 PCB-DESIGN 形状编辑器中如何内缩和外延铜箔。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 
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步骤 2 在菜单栏选择“Edit>Z-copy”。 

步骤 3 在编辑器右侧“Options”窗口，配置拷贝参数，参数说明请参见表 7-3。 

图7-16 拷贝参数配置 

 

 

表7-3 拷贝参数说明表 

参数名称 说明 

Size 复制后对象大小，可选择 Contract(内缩)或

者 Expand(外延)。 

Offset 对象内缩和外延的值。 

 

步骤 4 在画布中选择复制的对象，系统自动显示复制后的图形，鼠标右键单击“Done”保

存。 

----结束 
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7.2.3 显示菜单（Display） 

7.2.3.1 封装文件缩放基础操作 

本章节为您介绍在编辑器中对封装文件缩放的基础操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB-DESIGN 形状编辑器页面常用封装文件缩放操作说明如表 7-4 所示。 

表7-4 封装文件缩放常用快捷操作说明 

操作名称 操作步骤 

适应窗口（Zoom Fit） 菜单栏选择“Display > Zoom Fit”，

或按快捷键 F2，画布中封装文件将以原

点为中心适应显示当前封装文件中的所

有对象。 

放大（Zoom In） 画布中封装文件将以鼠标为中心放大，

方便查看。封装文件放大，有如下两种

操作方式。 

⚫ 菜单栏选择“Display>Zoom In”，

或按快捷键 F11。 

⚫ 向前滑动鼠标滚轮。 

缩小（Zoom Out） 画布中封装文件将以鼠标为中心缩小。

封装文件缩小，有如下两种操作方式。 

⚫ 菜单栏选择“Display>Zoom 

Out”，或按快捷键 F12。 

⚫ 向后滑动鼠标滚轮。 

指定区域放大（Zoom Shape） 菜单栏选择“Display>Zoom 

Shape”，鼠标左键在画布中框出需要

放大的区域，松开鼠标左键，指定区域

将会被放大显示。 

 



PCB版图设计 

用户指南 7 PCB-DESIGN形状编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 609 

 

----结束 

7.2.3.2 查询（Info） 

本章节为您介绍如何在编辑器中查看对象属性。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Display > Info”。 

步骤 3 画布中单选或者框选对象，在弹出的“Show Info”页面中，显示全部对象的属性。 

图7-17 Info 属性页面 

 

 

----结束 

7.2.3.3 测量（Measure） 

本章节为您介绍如何测量画布中两对象之间的间距和铜箔宽度大小。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Display > Measure”。 

步骤 3 在画布中单击测量的起点，然后单击测量的终点，在弹出的“Measure”页面中，显

示测量对象的间距数据。 
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图7-18 显示测量数据页面 

 

 

----结束 

7.2.3.4 图层翻转显示（Flip Design） 

本章节为您介绍如何在编辑器中进行图层翻转显示操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在编辑器中图层翻转有三种方式。 

⚫ 支持菜单栏选择 

a. 在菜单栏选择“Display>Flip Design ”，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷键操作 

a. 给图层翻转设置快捷键，操作方法请参见 3.19.2 自定义配置临时快捷键。 
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b. 执行快捷键命令后，画布中自动显示翻转后的图层。 

c. 再执行一遍，恢复图层原始状态。 

⚫ 支持快捷命令搜索 

a. 在命令窗口下方“Type command here”栏输入“flip design”，按回车

键，画布中自动显示翻转后的图层。 

b. 再执行一遍，恢复图层原始状态。 

 

进入翻转状态后，右下角会有“Flip Design Mode”提示。 

----结束 

7.2.3.5 格点（Grids） 

本章节为您介绍编辑器中如何进行格点设置。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Display > Grids...”。 

步骤 3 在弹出的“Define Grid”页面中，选择格点类型。单击 Type 下的格点类型前的圆

圈，可选择 Place（器件），Trace（走线），Via（过孔），Other（其他）。 

步骤 4 单击 新增格点。 

步骤 5 在弹出的“Add Grid”页面中，在 GridName 后的输入框填写格点名称，单击

“OK”。 

步骤 6 选择新增的格点，修改格点间距、格点偏移量，单击“OK”。 
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图7-19 格点设置 

 

 

步骤 7 在编辑器底部的格点栏选择新增的格点，单击格点的快捷图标 打开格点，再次单

击关闭格点。 

图7-20 显示新增格点 

 

 

----结束 
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7.2.3.6 自定义工具栏（Customize Toolbar） 

本章节为您介绍如何自定义工具栏。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可增加或者删除一级菜单。 

⚫ 选择“Toolbar group”页签，在 Group Name 后的输入框输入菜单名称，单击

“Add”增加一级菜单。 

⚫ 选择“Toolbar group”页签，在左侧菜单列表中选择菜单，单击“Delete”删

除一级菜单。 

图7-21 一级菜单工具栏设置 

 

 

步骤 4 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Shape、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 
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3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 

6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 

图7-22 设置工具栏快捷图标 

 

 

----结束 

7.2.4 绘制菜单（Drawing） 

7.2.4.1 圆形（Circle） 

本章节为您介绍如何绘制圆形区域。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Circle ”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆形格点类型。 

格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

图7-23 圆形区域配置 

 

 

步骤 4 在画布中进入绘制圆形区域状态。 

1. 左键单击确定圆形区域中心点。 

2. 移动鼠标，左键单击确定圆形上任意一点，完成绘制。 

3. 圆形区域绘制完成，将保持绘制圆形状态，同时整个圆形被选中。也可右键单击

“Done”完成圆形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，在 Radius 后的输入框修改圆大小。 
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图7-24 绘制圆形区域 

 

 

 

⚫ 右键单击“Done”完成圆形区域绘制，保存并退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制圆形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制圆形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

7.2.4.2 矩形（Rectangle） 

本章节为您介绍如何绘制矩形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Rectangle”。 

步骤 3 在编辑器右侧“Options”窗口，配置矩形格点类型。 

格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图7-25 矩形区域配置 

 

 

步骤 4 在画布中进入绘制矩形区域状态。 

1. 左键单击确定矩形区域左上角坐标位置。 

2. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成绘制。 

3. 矩形区域绘制完成，将保持绘制矩形状态，同时整个矩形被选中。也可右键单击

“Done”完成矩形区域绘制，保存并退出绘制状态。 

4. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

a. 矩形长度：在 Width 后的输入框输入长度。 

b. 矩形宽度：在 Height 后的输入框输入宽度。 

c. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner、Round。 

d. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入框输

入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的输入框输

入倒角大小。 
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图7-26 绘制矩形区域 

 

 

 

⚫ 右键单击“Done”完成矩形区域绘制，保存并退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制矩形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制矩形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

7.2.4.3 多边形（Polygon） 

本章节为您介绍如何绘制多边形区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Polygon”。 

步骤 3 在编辑器右侧“Options”窗口，配置多边形格点类型和拐角线段类型。 

1. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 

2. 拐角线段类型：单击 Type 后的下拉框选择，可选择 Line、Line45、Line 

Orthogonal、Arc。 
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图7-27 多边形区域配置 

 

 

步骤 4 在画布中进入绘制多边形区域状态。 

1. 左键单击确定多边形区域一个顶点位置。 

2. 移动鼠标，左键单击确定另一个顶点，以此类推。 

3. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相连，

右键单击“Complete”，完成绘制。 

4. 多边形区域绘制完成，将保持绘制多边形状态，同时整个多边形被选中。也可右

键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 

图7-28 绘制多边形区域 
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⚫ 右键单击“Done”完成多边形区域绘制，保存并退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Oops”可退回落点。 

⚫ 绘制多边形区域过程中，右键单击“Cancel”可退出绘制状态。 

⚫ 绘制多边形区域过程中，右键单击“Toggle”可调整线段方向。 

⚫ 绘制多边形区域过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

7.2.4.4 修剪倒角（Trim） 

本章节为您介绍如何对铜箔进行修剪倒角。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Trim”。 

步骤 3 在编辑器右侧“Options”窗口，配置倒角的修剪方式和格点类型。 

1. 修剪方式：单击修剪方式前的圆圈，可选择 corner、round、polygon。 

2. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid、none。 
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图7-29 修剪倒角配置 

 

 

步骤 4 在画布中，根据修剪倒角方式类型，修剪倒角。 

⚫ 倒斜角 

a. 单击 corner 前的圆圈，在 corner 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 

图7-30 倒斜角示图 
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⚫ 倒圆角 

a. 单击 round 前的圆圈，在 round 后的输入框输入倒角大小。 

b. 在画布中框选需要倒角的地方，画布中系统自动显示倒角后的对象。 

图7-31 倒圆角示图 

 

 

⚫ 多边形修剪倒角 

a. 单击 polygon 前的圆圈，在 polygon 后的下拉框选择拐角线段类型，可选

择 Line、Line45、Line Orthogonal、Arc。 

b. 在画布中单击对象垂直线边沿。 

c. 移动鼠标，单击对象水平线边沿，剪切成功。 
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图7-32 多边形修剪倒角示图 

 

 

----结束 

7.2.4.5 复制粘贴（Create Detail） 

本章节为您介绍如何快速复制粘贴。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Create Detail”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数。 

1. 在 Scaling Factor 后的输入框输入放大倍数。 

2. 勾选 Filled pads 前的方框，填充焊盘。系统默认勾选。 
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图7-33 配置参数 

 

 

步骤 4 在画布中框选对象，对象将按配置的放大倍数复制并悬挂在鼠标上。 

步骤 5 在画布中单击任意位置放置，对象自动显示在画布中。 

图7-34 复制粘贴示图 

 

 

----结束 

7.2.4.6 圆形散热盘（Circle Flash） 

本章节为您介绍如何绘制圆形散热盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Circle Flash”。 

步骤 3 在编辑器右侧“Options”窗口，配置圆形散热盘参数。 
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1. 在 Inner diameter（ID）后的输入框输入内径。 

2. 在 Outer diameter（OD）后的输入框输入外径。 

3. 在 Spoke width（g）后的输入框输入开口宽度。 

4. 在 Number of spokes 后的下拉框选择开口个数。 

5. 在 Spoke angle 后的下拉框选择开口角度，可选择 0、30、45、60、90。 

6. 勾选 Add center dot 前的方框，选择添加中心点；取消勾选，则不选择添加。 

7. 在 Dot diameter（D）后的输入框输入中心点直径。 

8. 单击“Apply”，在画布中系统自动显示圆形散热盘。 

图7-35 配置圆形散热盘参数 

 

 

步骤 4 画布中焊盘编辑完成后，直接保存。具体操作请参见 7.2.1.3 保存焊盘封装

（Save）。 

----结束 
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7.2.4.7 椭圆形散热盘（Oval Slot Flash） 

本章节为您介绍如何绘制椭圆形散热盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Oval Slot Flash”。 

步骤 3 在编辑器右侧“Options”窗口，配置椭圆形散热盘参数。 

1. 在 Inner diameter width（ID2）后的输入框输入内径长度。 

2. 在 Inner diameter height（ID）后的输入框输入内径高度。 

3. 在 Outer diameter widtth（OD2）后的输入框输入外径长度。 

4. 在 Outer diameter height（OD）后的输入框输入外径高度。 

5. 在 Spoke width（g）后的输入框输入开口宽度。 

6. 在 Number of spokes 后的下拉框选择开口个数。 

7. 在 Spoke angle 后的下拉框选择开口角度，可选择 0、90。 

8. 勾选 Add center dot 前的方框，选择添加中心点；取消勾选，则不选择添加。 

9. 在 Dot diameter width（D2）后的输入框输入中心点长度。 

10. 在 Dot diameter height（D）后的输入框输入中心点高度。 

11. 单击“Apply”，在画布中系统自动显示椭圆形散热盘。 
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图7-36 配置椭圆形散热盘参数 

 

 

步骤 4 画布中焊盘编辑完成后，直接保存。具体操作请参见 7.2.1.3 保存焊盘封装

（Save）。 

----结束 

7.2.4.8 矩形散热盘（Rectangle Slot Flash） 

本章节为您介绍如何绘制矩形散热盘。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Drawing>Rectangle Slot Flash”。 

步骤 3 在编辑器右侧“Options”窗口，配置矩形散热盘参数。 
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1. 在 Inner diameter width（ID2）后的输入框输入内径长度。 

2. 在 Inner diameter height（ID）后的输入框输入内径高度。 

3. 在 Outer diameter widtth（OD2）后的输入框输入外径长度。 

4. 在 Outer diameter height（OD）后的输入框输入外径高度。 

5. 在 Spoke width（g）后的输入框输入开口宽度。 

6. 在 Number of spokes 后的下拉框选择开口个数。 

7. 在 Spoke angle 后的下拉框选择开口角度，可选择 0、90。 

8. 勾选 Add center dot 前的方框，选择添加中心点；取消勾选，则不选择添加。 

9. 在 Dot diameter width（D2）后的输入框输入中心点长度。 

10. 在 Dot diameter height（D）后的输入框输入中心点高度。 

11. 单击“Apply”，在画布中系统自动显示矩形散热盘。 

图7-37 配置矩形散热盘参数 
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步骤 4 画布中焊盘编辑完成后，直接保存。具体操作请参见 7.2.1.3 保存焊盘封装

（Save）。 

----结束 

7.2.5 铜箔编辑菜单（Shape） 

7.2.5.1 挖空铜箔（Cutout/Cavity） 

7.2.5.1.1 创建铜箔挖空区域（Create Cutout） 

本章节为您介绍如何创建铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Create Cutout”。 

步骤 3 在编辑器右侧“Options”窗口，配置格点类型、铜箔形状。 

1. 格点类型：单击 Shape grid 后的下拉框选择，可选择 current grid 、none。 

2. 铜箔形状：单击 Shapes 下选项前的圆圈，可选择 Rectangle（矩形）、Circle

（圆形）、Polygon（多边形）。 
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图7-38 创建铜箔挖空 

 

 

步骤 4 在画布中进入铜箔挖空状态，铜箔挖空形状有三种方式。 

⚫ 矩形 

a. 在编辑器右侧“Options”窗口，配置矩形倒角类型和大小。 

i. 倒角类型：单击倒角类型前的小圆圈，可选择 Corner（倒斜角）、

Round（倒圆角）。 

ii. 倒角大小：在左上角 后的输入框输入倒角大小，右上角 后的输入

框输入倒角大小，左下角 后的输入框输入倒角大小，右下角 后的

输入框输入倒角大小。 

b. 选择需要挖空的铜箔。 

c. 在铜箔上，左键单击确定矩形区域左上角坐标位置。 

d. 移动鼠标，左键单击确定矩形区域右下角坐标位置，完成挖空。 

e. 矩形区域挖空完成，将保持挖空矩形状态。也可右键单击“Done”完成矩形

区域挖空，保存并退出挖空状态。 
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图7-39 铜箔挖空矩形区域 

 

 

⚫ 圆形 

a. 选择需要挖空的铜箔。 

b. 在铜箔上，左键单击确定圆形区域中心点。 

c. 移动鼠标，左键单击确定圆形上任意一点，完成挖空。 

d. 圆形区域挖空完成，将保持挖空圆形状态。也可右键单击“Done”完成圆形

区域挖空，保存并退出挖空状态。 

图7-40 铜箔挖空圆形区域 

 

 

⚫ 多边形 

a. 选择需要挖空的铜箔。 

b. 在铜箔上，左键单击确定多边形区域一个顶点位置。 

c. 移动鼠标，左键单击确定另一个顶点，以此类推。 
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d. 再次单击左键确定多边形的最后一个顶点，首个顶点会和最末的顶点自动相

连，右键单击“Complete”，完成挖空。 

e. 多边形区域挖空完成，将保持挖空多边形状态。也可右键单击“Done”完成

多边形区域挖空，保存并退出挖空状态。 

图7-41 铜箔挖空多边形区域 

 

 

 

⚫ 右键单击“Done”完成挖空，保存并退出挖空状态。 

⚫ 挖空过程中，右键单击“Oops”可退回落点。 

⚫ 挖空过程中，右键单击“Cancel”可退出挖空状态。 

⚫ 挖空过程中，右键单击“Next”可继续下一步挖空。 

⚫ 挖空过程中，右键单击“Complete”完成挖空，并保持挖空状态。 

⚫ 挖空过程中，右键单击“Toggle”调整多边形边方向。 

⚫ 挖空过程中，右键单击“Snap Pick To”可选择特定位置落点。 

----结束 

7.2.5.1.2 删除铜箔挖空区域（Delete） 

本章节为您介绍如何删除铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Delete”。 
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步骤 3 在画布中，选择挖空的铜箔，单选或者框选要删除的挖空区域。 

步骤 4 单击画布中任意位置，删除挖空区域，保持挖空区域删除状态。 

步骤 5 右键单击“Done”完成删除挖空区域，保存并退出删除状态。 

图7-42 删除挖空区域前 

 

 

图7-43 删除挖空区域后 

 

 

----结束 

7.2.5.1.3 移动铜箔挖空区域（Move） 

本章节为您介绍如何移动铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Move”。 



PCB版图设计 

用户指南 7 PCB-DESIGN形状编辑器 

 

文档版本 01 (2024-09-06) 版权所有 © 深圳启云方科技有限公司 634 

 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要移动的挖空区域。 

步骤 4 单击鼠标左键，移动鼠标到指定位置后在单击鼠标左键，移动挖空区域并保持挖空区

域移动状态。 

步骤 5 右键单击“Done”完成移动挖空区域，保存并退出移动状态。 

图7-44 移动挖空铜箔前 

 

 

图7-45 移动挖空铜箔后 

 

 

----结束 

7.2.5.1.4 复制铜箔挖空区域（Copy） 

本章节为您介绍如何复制铜箔挖空区域。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Cutout/Cavity>Copy”。 

步骤 3 在画布中，选择挖空的铜箔，单选或者框选要复制的挖空区域。 
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步骤 4 单击鼠标左键，移动鼠标到指定位置后再单击鼠标左键粘贴挖空区域，复制挖空区域

并保持挖空区域复制状态。 

步骤 5 右键单击“Done”完成复制并粘贴挖空区域，保存并退出复制状态。 

图7-46 复制挖空铜箔前 

 

 

图7-47 复制挖空铜箔后 

 

 

----结束 

7.2.5.2 编辑铜箔（Select Shape or Void/Cavity） 

本章节为您介绍如何对铜箔进行编辑。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Select Shape or Void/Cavity”。 

步骤 3 在画布中，选择需要编辑的铜箔进行编辑操作，具体操作及鼠标右键辅助编辑操作请

参见表 7-5。 
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表7-5 铜箔编辑操作说明 

操作名称 操作步骤 

移动顶点（Move 

vertex） 

选择顶点，按住鼠标左键不放移动到目标位置释放鼠

标。 

添加顶点（Add 

vertex） 

按住 ctrl 键，鼠标左键单击在铜箔边沿线进行加点。 

删除顶点（Delete 

vertex） 

选择顶点，右键单击“Delete vertex”删除。 

保存并退出编辑状态

（Done） 

右键单击“Done”保存并退出编辑状态。 

退回落点（Oops） 右键单击“Oops”可退回落点。 

退出编辑状态

（Cancel） 

右键单击“Cancel”可退出编辑状态。 

下一步（Next） 右键单击“Next”完成当前编辑，继续下一步编辑状

态。 

切割铜箔（ Edit cut） 右键单击“Edit cut”可切割铜箔。 

复制到其他层（Copy to 

layers） 

右键单击“Copy to layers”，在弹窗中选择复制对象

放置的层，可将铜箔复制到其他层。 

选择特定位置落点

（Snap Pick To） 

右键单击“Snap Pick To”可选择特定位置落点。 

 

----结束 

7.2.5.3 两个重叠铜箔合并操作（Shape Operator） 

本章节为您介绍如何进行两个重叠铜箔的合并操作。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 
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步骤 2 在菜单栏选择“Shape>Shape Operator”。 

步骤 3 在编辑器右侧“Options”窗口，配置铜箔的操作方式。 

⚫ And：铜箔合并后，保留铜箔重叠部分，并简化为一个铜箔图形。 

⚫ Or：铜箔合并后，两个铜箔都保留，并简化为一个铜箔图形。 

⚫ Andnot：铜箔合并后，保留第一块铜箔没有和第二块铜箔重叠的部分，并简化为

一个铜箔图形。 

⚫ Xor：铜箔合并后，只删除铜箔重叠部分，其余铜箔部分保留。 

图7-48 铜箔操作方式配置 

 

 

步骤 4 在画布中，选择第一块铜箔，再选择第二块铜箔，显示合并后的铜箔。 

图7-49 铜箔合并操作 

 

 

 

两块铜箔必须有重叠部分，否则不能执行铜箔操作命令。 

----结束 
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7.2.5.4 合并同网络铜箔（Merge Shape） 

本章节为您介绍如何合并两个同网络铜箔。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Merge Shape”。 

步骤 3 在画布中，选择需要合并的第一个铜箔，再选择第二个铜箔。 

步骤 4 画布中自动显示合并后的铜箔。 

图7-50 合并后铜箔 

 

 

----结束 

7.2.5.5 线段闭合为封闭图形（Compose Shape） 

本章节为您介绍如何通过线段闭合为封闭的图形。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Shape>Compose Shape”。 

步骤 3 在编辑器右侧“Options”窗口，配置参数，选择是否倒角，参数说明请参见表 7-6。 
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图7-51 闭合图形操作配置 

 

 

表7-6 线段闭合为封闭的图形参数说明 

参数名称 说明 

Delete shape after compose 勾选 Delete shape after compose 前的方

框，可删除闭合后多余图形。取消勾选，则不

删除。 

Use auto gap 勾选 Use auto gap 前的方框，可自动闭合缺

口。取消勾选，则不自动闭合。 

Round corners 勾选 Round corners 前的方框，可倒角，并在

Radius 后的输入框输入倒角角度。取消勾选，

则不倒角。 

 

步骤 4 在画布中，框选线段，右键单击“Done”保存并退出转换状态。 
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图7-52 闭合封闭图形示例 

 

 

----结束 

7.2.6 工具菜单（Tools） 

7.2.6.1 修改设置（Settings） 

本章节为您介绍如何修改设置。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Tools>Settings...”。 

步骤 3 在弹出的“Setting”页面中，对工程（Project）、工具（Tool）、显示

（Display）、颜色（Color）、铜箔（Area）等设置进行修改。参数说明请参见表 7-

7。 
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图7-53 参数设置界面 

 

 

表7-7 设置参数说明 

类型 参数名称 说明 

Project 

Setting 

（工程设

置） 

General 

（常规操作） 

Console 命令栏相同前缀命令关联设

置。 

Library Connection 

Management 

（封装库连接） 

封装库配置远端公共库、本地库，配置

好封装库后才能导入网表。 

Tool 

Setting 

（工具设

置） 

Design Parameter 

（参数设置） 

设置使用单位、画布尺寸、画布偏置坐

标、原点坐标。 

Display 

（显示设

置） 

General 

（显示基本设

置） 

显示比例、格点自动跳转切换开关、鼠

标划过对象高亮/显示属性开关，高性能

模式开关等配置。 

Cursor 

（鼠标模式设

置） 

鼠标箭头，十字光标模式设置。 

Highlight 高亮设置（已禁用）。 
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类型 参数名称 说明 

（高亮设置） 

Color 

（颜色设

置） 

Display 

（显示颜色设

置） 

高亮、格点、飞线、DRC、钻孔、走

线、孔表、背景等颜色设置。 

Shape 

（铜箔高亮设

置） 

铜箔高亮设置，包括整板

（Brightness）、焊盘（Global 

transparency）、铜箔（Shapes 

transparency）的高亮设置，以及静态

动态铜箔样式，对象过滤器大小设置

等。 

Area 

（铜箔设

置） 

General 

（铜箔填充基本

设置） 

铜箔填充设置（Defer performing 

fill），不勾选即填充，反之不填充。以

及填充类型（动/静态铜箔）选择。 

Interactive 

（工具基本设

置） 

背钻最小起钻孔径，塞孔允许最小、最

大尺寸设置、最小叠层大小。 

 

步骤 4 设置完成后，单击“Apply”应用。 

步骤 5 单击“OK”保存设置。 

----结束 

7.2.7 窗口菜单（Windows） 

本章节为您介绍如何打开、关闭、显示和隐藏窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在 PCB-DESIGN 形状编辑器页面各个窗口的打开和关闭窗口操作说明如表 7-8 所示。 
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图7-54 打开/关闭窗口入口 

 

 

表7-8 窗口操作说明 

操作名称 操作步骤 

底部操作命令窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Console”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐

藏的窗口。 

底部信息窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Message”自动打开窗

口，取消勾选关闭窗口或者单击窗

口右上角的 关闭窗口。 

⚫ 显示/隐藏 
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操作名称 操作步骤 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏

的窗口。 

右侧配置窗口 ⚫ 打开/关闭 

1. 在菜单栏选择“Windows”。 

2. 勾选“Options”自动打开窗口，

取消勾选关闭窗口或者单击窗口右

上角的 关闭窗口。 

⚫ 显示/隐藏 

1. 单击窗口右上角的 隐藏窗口。

单击窗口底部 ，显示隐藏的窗

口。 

顶部工具栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Toolbar”自动打开工具栏，

取消勾选关闭工具栏。 

底部状态栏 1. 在菜单栏选择“Windows”。 

2. 勾选“Status bar”自动打开状态

栏，取消勾选关闭状态栏。 

重置窗口 1. 在菜单栏选择“Windows”。 

2. 勾选“Reset Default”重置所有隐藏

的窗口，恢复默认设置。 

 

 

在窗口关闭情况下，勾选窗口才能展示窗口。 

----结束 
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7.2.8 帮助菜单（Help） 

7.2.8.1 查看软件版本信息（About） 

在形状编辑器工具中可在“About”菜单查看软件版本信息。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Help>About” 。 

步骤 3 在弹出的“About”页面，查看软件版本信息。 

图7-55 About 页面 

 

 

步骤 4 查看完成后，单击“Close”关闭页面。 

----结束 

7.3 顶部工具栏 

7.3.1 工具栏打开与关闭 

本章节为您介绍如何在 PCB-DESIGN 形状编辑器中打开与关闭工具栏。工具栏提供了

设置及显示菜单栏对应的功能按钮，方便快捷操作。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Toolbar”自动打开工具栏，取消勾选关闭工具栏。 

----结束 

7.3.2 工具栏图标设置 

本章节为您介绍如何设置哪些图标显示在工具栏上。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Display > Customize Toolbar...”。 

步骤 3 在弹出的“Customize Toolbar”页面中，可设置工具栏快捷图标。 

1. 单击“Command”页签，在页面右侧一级菜单下拉框选择一级菜单，可选择

File、Edit、Drawing、Shape、Display、Tools。 

2. 在页面左侧单击 展开一级菜单下的子菜单。 

3. 勾选子菜单前的方框，单击 按钮，移动到页面右侧，增加子菜单快捷图标。 

4. 在页面右侧单击子菜单，调整子菜单的位置顺序。单击 按钮，可将子菜单向

下移动；单击 按钮，可将子菜单向上移动。 

5. 在页面右侧单击子菜单，单击 按钮，移动到页面左侧，删除子菜单快捷图

标。 

6. 单击“Apply”在工具栏自动生成快捷图标或者单击“OK”在工具栏自动生成快

捷图标并关闭窗口。 

7. 单击“Reset”可恢复原始设置。 
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图7-56 设置工具栏快捷图标 

 

 

步骤 4 鼠标左键长按并拖拽快捷图标前的 ，可以移动整排快捷图标的位置。 

图7-57 快捷图标示图 

 

 

----结束 

7.3.3 工具栏图标含义及功能 

文件菜单 

序号 图标 含义及功能 

1  新建焊盘封装 

2  打开焊盘封装 

3  保存焊盘封装 

4  另存焊盘封装 
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序号 图标 含义及功能 

5  结构图文件 

6  宏命令 

7  退出 

 

编辑菜单 

序号 图标 含义及功能 

1  撤销 

2  重做 

3  复制 

4  铜箔复制 

5  粘贴 

6  移动 

7  删除 

8 
 

旋转 

 

显示菜单 

序号 图标 含义及功能 

1  适应窗口 

2  放大 

3  缩小 

4  指定区域放大 

5  查询 
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序号 图标 含义及功能 

6  测量 

7  格点 

8  自定义工具栏 

 

绘制菜单 

序号 图标 含义及功能 

1  圆形 

2  矩形 

3  多边形 

4  修剪倒角 

5  圆形散热盘 

6  椭圆形散热盘 

7  矩形散热盘 

 

铜箔编辑菜单 

序号 图标 含义及功能 

1  创建铜箔挖空区域 

2  删除铜箔挖空区域 

3  移动铜箔挖空区域 

4  复制铜箔挖空区域 

5  编辑铜箔 

6  两个重叠铜箔合并操作 
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序号 图标 含义及功能 

7  合并同网络铜箔 

8  线段闭合为封闭图形 

 

工具菜单 

序号 图标 含义及功能 

1  设置 

 

7.4 右侧配置窗口 

7.4.1 配置窗口打开与关闭 

配置窗口也叫 Options 窗口，在绘制的过程中，在 Options 窗口可以给画布中的对象

操作进行配置。本章节为您介绍如何在 PCB-DESIGN 形状编辑器中打开与关闭配置窗

口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Options”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

7.4.2 配置窗口参数配置 

本章节为您介绍如何在配置窗口中为执行的菜单命令配置参数。 
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操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 当配置窗口处于显示状态时，执行菜单命令，右侧配置窗口会显示命令的配置信息。 

步骤 3 在右侧“Options”窗口中，根据需求配置命令的参数。 

步骤 4 在画布中执行操作命令。 

----结束 

 

编辑菜单的配置操作请参见 7.2.2 编辑菜单（Edit）。 

绘制菜单的配置操作请参见 7.2.4 绘制菜单（Drawing）。 

铜箔编辑菜单的配置操作请参见 7.2.5 铜箔编辑菜单（Shape）。 

7.5 底部操作命令窗口 

7.5.1 操作命令窗口打开与关闭 

操作命令窗口也叫 Console 窗口，可直接在窗口里输入命令，画布中的对象将直接执

行操作，使绘制操作更加便捷。本章节为您介绍如何在 PCB-DESIGN 形状编辑器中打

开与关闭操作命令窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Console”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

7.5.2 操作命令窗口指示 

本章节为您介绍如何在操作命令窗口中输入指示命令。 
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界面指示 

⚫ 在画布中，滚动鼠标滚轮，窗口界面会显示画布的比例大小。 

⚫ 在画布中，操作命令执行，窗口界面会显示具体操作步骤。 

⚫ 在窗口里输入命令，画布中的对象将直接执行操作。 

⚫ 支持快捷命令搜索，在窗口下方“Type command here”栏输入快捷键首字

母，显示所有有关首字母的快捷命令。 

常用操作 

在窗口命令输入框内输入操作命令，画布中对象立即执行操作命令。操作方法请参见

表 7-9。 

表7-9 命令窗口的常用操作指示 

操作名称 操作步骤 

命令窗口输入移动坐标 1. 在画布中，选择需要移动的对象。 

2. 在“Console”的命令窗口，输入坐

标，字母不区分大小写。 

⚫ 只移动 X 轴坐标：在命令输入框中

输入“X+空格键+X 轴移动坐标

值”并按回车键。 

⚫ 只移动 Y 轴坐标：在命令输入框中

输入“Y+空格键+Y 轴移动坐标

值”并按回车键。 

⚫ 只移动 X 和 Y 轴坐标：在命令输

入框中输入“X+空格键+X 轴移动

坐标值+空格键+Y+空格键+Y 轴

移动坐标值”并按回车键。 

命令窗口输入快捷键 “Console”的命令窗口，支持 alias 和

funckey 命令两种方式设置临时快捷

键。 

⚫ funckey 命令设置方法：在

“Console”命令窗口，在命令输入框

中输入“funckey+快捷键按键字母+

操作命令”并按回车键。设置快捷键
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操作名称 操作步骤 

完成后，键盘输入快捷键字母。 

⚫ alias 命令设置方法：在“Console”

命令窗口，在命令输入框中输入

“alias+快捷键按键字母+操作命令”

并按回车键。设置快捷键完成后，键

盘输入快捷键字母。 

 

7.6 底部信息窗口 

7.6.1 信息窗口打开与关闭 

信息窗口也叫 Message 窗口，可直接在窗口里查看信息。本章节为您介绍如何在

PCB-DESIGN 形状编辑器中打开与关闭信息窗口。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Message”自动打开窗口，取消勾选关闭窗口或者单击窗口右上角的 关闭窗

口。 

----结束 

7.6.2 信息窗口说明 

功能说明 

PCB-DESIGN 形状编辑器汇总信息会显示在窗口中，可在窗口查看提示的信息。 
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7.7 底部状态栏 

7.7.1 状态栏打开与关闭 

本章节为您介绍如何在 PCB-DESIGN 形状编辑器中打开与关闭状态栏。 

操作步骤 

步骤 1 在 PCB-DESIGN 安装目录下，双击“Shape Editor”打开 PCB 图形编辑器。 

步骤 2 在菜单栏选择“Windows”。 

步骤 3 勾选“Status bar”自动打开状态栏，取消勾选“Status bar”自动关闭状态栏。 

----结束 

7.7.2 状态栏功能说明 

在 PCB-DESIGN 形状编辑器中状态栏显示坐标、格点及配置对应的功能按钮，方便快

捷操作。功能说明请参见表 7-10。 

表7-10 状态栏功能说明 

状态栏功能类型 功能说明 

显示画布中鼠标坐标 在画布中，单击任意一点，状态栏自动显示 X 轴坐

标和 Y 轴坐标。 

显示格点选择和配置 ⚫ 在栅格快捷图标前的栅格类型框

，可以选择设置好的

栅格格式类型。 

⚫ 单击栅格快捷图标 ，显示格点。再次单击，

不显示格点。 

⚫ 单击“Offset”快捷设置偏移量。 

打开/关闭右侧窗口 
⚫ 单击快捷图标 ，打开配置窗口。再次单击快

捷图标 ，关闭配置窗口。 
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8 PCB-DESIGN 辅助工具 

8.1  TooLink 工具介绍 

8.2  TooLink 操作说明 

8.1 TooLink 工具介绍 

Toolink 是一个通信中转站，采用 Socket 协议，进行通信。连接上 toolink 的工具只

需要按照 toolink 的命令格式发送字符串，即可与 toolink 对接。 

该功能主要用于天枢协同。A 工具传消息到 toolink，toolink 再传消息给 B 工具，以

此实现 AB 工具的消息传递。 

8.2 TooLink 操作说明 

操作步骤 

步骤 1 通过 Auxitools 菜单下的 Easy Series 的 Enable/Close Banmo<->Tianshu 开启和关

闭 toolink。 

 

步骤 2 点击 Enable、Close 
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----结束 

8.3 调用 allegro 进行版图封装库 a 转 p 

本章节介绍如何调用 allegro 进行版图封装库 a 转 p。 

前提条件 

⚫ 已在编辑器左侧封装窗口存在封装库，如不存在，请先创建封装库，具体操作请

参见 4.2.1.1 创建封装库（New）。 

操作步骤 

步骤 1 点击 Auxitools 菜单下的 A2P Format Conversion，在弹窗中，选择 allegro.exe 的

路径与待转换的 brd 文件路径 
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步骤 2 点击【OK】转换成功会自动保存转换得到的 txt 文件 

 

步骤 3 可将导出的 txt 文件导入版图工具 
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----结束 

 


